Erreurs SQL

Ici c'est moi qui vous informe de la vie du site et du forum.

Modérateurs : Papy.G, fneck, Carl

__sam__
Messages : 3943
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Erreurs SQL

Message par __sam__ » 06 avr. 2016 11:47

Est-ce lié à une forte affluence sur le forum ? Il ya quand même 14 "invités" sur le forum en ce moment même. Ca me semble très haut par rapport aux 2-3 habituels. As tu le moyen de savoir si les temps de réponses sont corrélés aux nombre d'invités présents simultanément ?
Samuel.
Amiga 500+GVP530(MMU/FPU) (hs), A1200(030@50mhz/fpu/64mb/cf 8go), R-Pi, TO9, TO8D, TO8.
New Teo 1.8.4 8)

Avatar du membre
Papy.G
Modérateur
Messages : 1721
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Erreurs SQL

Message par Papy.G » 06 avr. 2016 12:37

A moins que parmi les invités, il y ait des bots anonymes qui génèrent un nombre de hits anormalement élevé, il n'y a aucune raison qu'une vingtaine d'utilisateurs mettent le serveur à genous:
"Le record du nombre d’utilisateurs en ligne est de 213, le 09 Mar 2016 19:00"

Il faudrait avoir un graphique du nombre de requêtes pour mettre en perspective avec les temps de réponses.

A moins que le serveur SQL soit partagé entre plusieurs sites et que les autres aient une affluence importante.
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Daniel
Messages : 10206
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Erreurs SQL

Message par Daniel » 06 avr. 2016 14:02

Aujourd'hui ça commence à devenir pénible : les perturbations durent depuis maintenant au moins cinq heures, alors que les jours précédents ce n'était jamais plus d'une heure.
Daniel
L'obstacle augmente mon ardeur.

__sam__
Messages : 3943
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Erreurs SQL

Message par __sam__ » 06 avr. 2016 14:08

Toujours 11 invités. Je me demande combien de trafic font ces 11 invités. Si ce sont des bots qui aspirent le site, ca peut probablement vite saturer la base de donnée sous-jacente.
Samuel.
Amiga 500+GVP530(MMU/FPU) (hs), A1200(030@50mhz/fpu/64mb/cf 8go), R-Pi, TO9, TO8D, TO8.
New Teo 1.8.4 8)

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: Erreurs SQL

Message par Xavier » 06 avr. 2016 14:23

Oui, la connexion ce matin (5h) a été pénible...
:(

Avatar du membre
fneck
Site Admin
Messages : 11947
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Erreurs SQL

Message par fneck » 06 avr. 2016 19:21

Je n'ai à l'heure actuelle pas de réponse d'OVH à mon message, il semble cependant que depuis 14h00 le problème soit réglé:
Image

Globalement sur la semaine il y a eu de fortes perturbations le 2/04 dans la matinée et depuis hier après-midi jusqu'à aujourd'hui 14h00. Plus quelques parasites à droite et à gauche chaque jour.

Le forum n'est pas sur un serveur dédié, donc il est partagé avec xxx autres clients. Mais soyez rassurés ce ne sont pas les requêtes issues du site ni les 20 invités qui plantent le serveur :?

Un zoom sur la journée:
Image

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: Erreurs SQL

Message par Xavier » 06 avr. 2016 19:53

Oui, bon... à 3 heure du mat. c'est moi ... j'ai rafraichi la page plein de fois... à 4 heure je suis allez faire PiPi, et j'ai recommencé...
:oops:

Avatar du membre
Rhod
Messages : 10695
Enregistré le : 09 avr. 2007 09:54
Localisation : Orléans
Contact :

Re: Erreurs SQL

Message par Rhod » 06 avr. 2016 19:57

Ce matin a 10h43 , forum était out... je n'ai pas ré-essayé dans la journée.

__sam__
Messages : 3943
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Erreurs SQL

Message par __sam__ » 07 avr. 2016 00:15

Ce soir un gros robot russe vient de faire du flood massif en postant dans pleins de sujets. Si ca se trouve OVH a subit ce genre d'attaque toutes la journée sur ses serveurs PHP.
Samuel.
Amiga 500+GVP530(MMU/FPU) (hs), A1200(030@50mhz/fpu/64mb/cf 8go), R-Pi, TO9, TO8D, TO8.
New Teo 1.8.4 8)

Avatar du membre
Papy.G
Modérateur
Messages : 1721
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Erreurs SQL

Message par Papy.G » 07 avr. 2016 01:09

Merci Sam pour ce signalement, quarante-huit messages à effacer, le salopiaud! :shock:
Comme dirait xavier, la permanence de nuit veille. :mrgreen:
Vu l'ampleur des blocages, je m'attendais à plus de nouveaux "membres".
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
claudounet
Messages : 1041
Enregistré le : 15 juil. 2009 21:21
Localisation : Dublin 6 (IRL) - Vichy (03)
Contact :

Re: Erreurs SQL

Message par claudounet » 07 avr. 2016 15:54

Perso, je n'ai pas de problemes, mais peut-être que je ne viens pas assez.

Pour les injections, n'y a t-il pas de captcha (ou solution equivalentes) pour empecher les robots au moment de l'inscription?

Ceci dit, je me pose aussi la question depuis longtemps de visiteurs qui ont des connections lentes. En effet, le serveur met plus de temps et peine a retourner le contenu de la page en un temps correct. Plus il y a de connections lentes, plus cela perturbe le serveur. Et des connections lentes, hors methodes d'attaques il y en a. Entre le wifi et l'internet mobile, c'est pas forcement la panacee. Je viens de trouver un blog qui en parle; https://blog.qualys.com/securitylabs/20 ... tp-attacks.
Claude

Retro'rdinateurs http://www.retrordinateurs.com/

Markerror
Messages : 1255
Enregistré le : 31 oct. 2011 19:21
Localisation : Orléans
Contact :

Re: Erreurs SQL

Message par Markerror » 15 mars 2018 08:15

Bonjour,

Depuis hier, lorsque je poste un message, j'ai systématiquement un erreur SQL à la première tentative.

__sam__
Messages : 3943
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Erreurs SQL

Message par __sam__ » 15 mars 2018 10:12

La lecture se passe toujours bien pour moi, mais l'envoi plante. Ceci explique sans doute pourquoi le site system-cfg marche bien (on y lit bien plus qu'on y écrit) que le forum.
Samuel.
Amiga 500+GVP530(MMU/FPU) (hs), A1200(030@50mhz/fpu/64mb/cf 8go), R-Pi, TO9, TO8D, TO8.
New Teo 1.8.4 8)

Daniel
Messages : 10206
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Erreurs SQL

Message par Daniel » 15 mars 2018 11:04

Exactement pareil depuis trois jours :
- En lecture aucun problème (sauf hier matin, voir l'autre fil de discussion).
- En envoyant un post erreur SQL au moins neuf fois sur dix. Par contre le post est correctement enregistré dans la base de données.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10206
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Erreurs SQL

Message par Daniel » 16 mars 2018 08:29

Hier en fin d'après midi il y avait un peu moins d'erreurs SQL, mais les temps de réponses étaient à la limite du supportable.
Ce matin ça recommence, comme chaque matin depuis plusieurs semaines.
Erreur générale
SQL ERROR [ mysql4 ]
Lost connection to MySQL server during query [2013]
Une erreur SQL est arrivée en chargeant cette page. Contactez l’administrateur du forum si ce problème persiste.
Contactez l’administrateur du forum ou le webmaster : webmaster@system-cfg.com
Daniel
L'obstacle augmente mon ardeur.

Répondre