Projet Apple Lisa 1

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Répondre
petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Projet Apple Lisa 1

Message par petitjd » 17 sept. 2015 11:35

Aujourd'hui début des tests des cartes du Lisa 1, dans la mesure des essais possibles vis à vis du matériel dont je dispose actuellement.
Les essais sont plutôt rassurants:
Je dispose pour mes tests d'un Lisa 2/10 avec alimentation 220v.
Dans un premier temps, j'ai effectué le test le plus simple, celui des rams du Lisa 1. Le Lisa 2/10 a correctement passé le test initial de la ram et a booté sur Macworks sans encombre. On peut donc en conclure que les rams fournies avec le Lisa 1 fonctionnent correctement.
Ensuite, ca se gate un peu pour la carte CPU du Lisa 1 en ROM C. Lors du démarrage du Lisa 2/10 avec la carte CPU du Lisa 1 en rom C, l'ecran du Lisa affiche n'importe quoi et deux bips lo, lo se font entendre.
Deux bips lo, lo signifient un problème de mémoire. Bizarre me dis-je, je viens de les tester, elles fonctionnent!
Je décide donc de retirer une RAM, celle située dans l'emplacement MEM 2. Là le Lisa 2/10 démarre, affiche un écran cohérant sans afficher la révision de la ROM dans le coin supérieur droit de l'écran puis affiche le sablier comme si le Lisa tentait de booter sur un lecteur Twiggy.
J'ai également fais l'essai avec l'autre RAM dans l'emplacement MEM 1, le Lisa démarre de la même manière.
À noter que si on retire le clavier, la tonalité des bips change entre la rom de la carte cpu 3A et la rom de la carte cpu C.
J'en déduis timidement que la carte CPU du Lisa 1 semble fonctionner.
Je ne peux cependant pas aller plus loin pour le moment dans les essais car je ne pense pas qu'il soit conseillé d'insérer une carte I/O de Lisa 1 dans un fond de panier de Lisa 2/10.
Je pense que le cablage électrique et données entre un Lisa 1, ou 2/5 est également différent de celui d'un Lisa 2/10 concernant la carte fond de panier, donc je pense que pour poursuivre les essais sans Lisa 2 il me faudra investir dans la cablerie d'un Lisa 2 et utiliser la sortie video de la carte fond de panier.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 17 sept. 2015 12:04

si ta carte cpu de 2/10 est en 3A alors tu dois avoir le screen modification kit (avec la prom video prévue pour le mode macintosh) et donc des réglages sur l'écran (potentiomètres) prévus pour ce mode. Lors de l'installation de la carte CPU de lisa1 tu dois reprendre ces réglages pour stabiliser l'image, et potentiellement retirer une bobine:
http://lisafaq.sunder.net/single.html#l ... reflection
potentiellement uniquement car mon 2/10 nativement en 3A n'avait pas cette bobine mais juste un réglage de potentiomètre (d'origine et bloqué dans un vernis).

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Projet Apple Lisa 1

Message par petitjd » 17 sept. 2015 16:57

Bien vu Gilles, l'écran était décalé vers la droite, la référence de la ROM était donc invisible. Ce soir je modifierai le réglage horizontal pour vérifier la version de la ROM.

Voici quelques photos des cartes du Lisa 1, pour comparaison, voici le lien du Lisa 1 d'Alker33:
http://vi.raptor.ebaydesc.com/ws/eBayIS ... 9060307182

les premières photos sont des photos des cartes non traitées.
La question que je me pose, c'est est-ce que je dois retirer le résiduel d'attaque verdâtre au niveau des pistes de la carte I/O, même si ce résiduel est neutralisé par le KF. Le vernis sur les pistes attaquées a sauté, mais le contact est encore bon. J'ai peur de le rompre si je retire la couche verdâtre.
La ROM twiggy d'origine (40) de la carte I/O a été remplacée par la rom A8, il y a des traces de tournevis sur le socket.
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_01.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_02.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_03.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_04.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_05.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_06.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_07.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_08.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_09.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_10.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_11.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_12.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_13.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_14.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_15.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_16.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_17.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_18.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_19.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_20.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_21.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_22.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_23.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_24.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_25.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_26.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_27.JPG
Image
Lien HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_28.JPG
Modifié en dernier par petitjd le 17 sept. 2015 20:19, modifié 1 fois.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 17 sept. 2015 17:34

D'apres l'etiquette je suppose que tu as des roms cpu H donc les dernieres pour un lisa 1 converti en 2. Pour la rom io je suppose que c'est 88? Mais d'autres versions sont possibles

[edit] plutot une a8 pour la carte io
Modifié en dernier par gilles le 17 sept. 2015 17:42, modifié 1 fois.

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Projet Apple Lisa 1

Message par petitjd » 17 sept. 2015 17:41

Non non Gilles, regarde bien l'étiquette des roms CPU:
Le H est pour rom "H"igh. Il y a bien écrit rev C à coté.
Sur l'étiquette de la rom low, on ne voit pas bien sur la photo, mais sur l'étiquette, le dernier caractère est bien un C.
La rom de la carte i/o a été modifiée comme je le disais, il y a des traces de tournevis sur le socket de la rom.

Ce soir je ferai un essai de calage de l'écran pour confirmer ou infirmer qu'on est en rom c.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Projet Apple Lisa 1

Message par petitjd » 17 sept. 2015 19:14

Voici le verdict, après calage horizontal de l'écran, il n'y a pas d'identification de la ROM ni CPU ni I/O.
Si c'était une ROM H, il se serait affiché H/88.

Image
HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_29.JPG

Après les tests, le Lisa essaye de booter directement sur quelque chose, je suppose un lecteur Twiggy qu'il ne peut pas trouver.

Image
HR: http://nanoreseau.net/system-cfg/lisa1/HR/IMG_30.JPG
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 17 sept. 2015 21:14

Effectivement c'est donc vraisemblablement une C, à ma connaissance il n'y a pas de dump dispo en téléchargement de ce jeu de rom.
La rom IO devrait être une 40 avec la revC.
Sur une H la lettre s'affiche assez tôt dans les tests. La version de rom IO s'affiche plus tard.
Avec le clavier il y a un moyen d'aller voir la version de la rom io (en activant le moniteur et en allant lire en xC018 de l'espace IO (généralement en xFCC018)

{edit}
en xFCC031 en fait (c'est x18 en espace d'adressage 16 bits, il faut doubler pour l'adresse vue du 68000

Apple-S pour passer en mode moniteur (fonctionne sur certains menus, pas sur d'autres)
Modifié en dernier par gilles le 17 sept. 2015 21:51, modifié 1 fois.

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Projet Apple Lisa 1

Message par petitjd » 17 sept. 2015 21:27

Ici il semble y avoir un dump de la rev C. Je ne sais pas s'il fonctionne.
http://adam.trideja.com/Apple%20Compute ... Lisa1Roms/

Il faut que je change les pads de mon clavier et que je remplace le condensateur cassé C19 sur la carte I/O. Je ne sais pas quel est la valeur de ce condensateur, je n'ai pas trouvé le schéma de la carte I/O rev J.

Aller j'ai encore un peu de travail mais on va y arriver à démarrer ce petit Lisa 1 :D

J'ai remporté la carte CPU en ROM D, mais il va falloir attendre un peu avant qu'elle arrive.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 17 sept. 2015 22:06

selon moi le dump que tu as trouvé est correct (il est fonctionnel avec mon émulateur après conversion du format hex intel vers un format bin).

[edit]
il semble possible de booter un profile installé avec LOS2.02 avec cette ROM (sous émulateur, info à prendre au conditionnel donc)

Avatar du membre
laurel
Messages : 1464
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: Projet Apple Lisa 1

Message par laurel » 17 sept. 2015 23:57

C'est le même jeu de carte que j'ai échangé avec Jérôme il y a quelques années. Avec le CPU ceramique.
Les révisions sont toutefois un peu plus récentes : H pour la carte mère et N pour le CPU, tamponnée 84 39.
La cpu fonctionne, mais les roms ont été remplacées par des H
la ram est HS et la I/o HS aussi et très attaquées avec une rom 341-0290 rev B.
Je n'ai pas pu tester la carte mère car je n'ai pas le câblage adapté.

http://www.ebay.co.uk/itm/Apple-Lisa-1- ... 0712081062
On en a un chacun ici :) ... mais c'est un peu onéreux...

Tu n'enlèves pas les batteries?
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 18 sept. 2015 08:50

pour info les images disque de LOS 1 (twiggy) sont dispo sur le web...
je suis en train d'ajouter le support de la lecture des images twiggy à mon emu, cela permettrait d'installer vers une image de profile sous émulation si tout se passe bien.
Actuellement lisa monitor 12 boote (avec une image floppy de twiggy).

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Projet Apple Lisa 1

Message par petitjd » 18 sept. 2015 09:29

Voici les liens des images:
http://bitsavers.trailing-edge.com/bits ... sa/twiggy/
http://bitsavers.trailing-edge.com/bits ... kshop_1.0/

@Gilles: J'ai essayé de convertir les images ROM C avec hex2bin (hex2bin -b XXX.HEX), qui me créent bien un fichier .bin par image.
Je place ces images et les renomment en booth.hi et booth.lo dans le dossier bios de IDLE, je lance IDLE, une fenêtre d'un debugger apparait, je ne sais pas quoi faire à ce stade pour tenter un boot du Lisa. Ai-je manqué quelque chose?

Super pour la mise en place de l'émulation des Twiggy :D
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 18 sept. 2015 10:00

il y a d'affreux patch en dur de la rom H. il faut les retirer pour que ça marche bien (le test auto va planter par contre car le SCC n'est que partiellement émulé).


Avatar du membre
gilles
Messages : 1632
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Projet Apple Lisa 1

Message par gilles » 19 sept. 2015 01:43

Les images twiggy de bitsavers.org semblent correctes pour le système. Mais sont à vérifier pour les outils (remonte des erreurs mais difficile de savoir si c'est l'ému ou l'image disque qui pose problème).
Le code source de l'ému modifié est publié sur sourceforge, testé sur linux ubuntu uniquement (mais toute plateforme allegro4 devrait convenir).

Image

Le systeme en ROM C doit pouvoir booter sur le profile mais il doit avoir besoin que la carte IO sache gérer 2 lecteurs, pendant le boot pas mal de commandes disque sont lancées, et cela bloque si on simule le comportement de la rom A8

Répondre