[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 16 juin 2018 19:06

Code : Tout sélectionner

Machine  | SDDRIVE | Lecture | Ecriture | Reset | Commentaires          
---------|---------|---------|----------|-------|------------------------------------------------------
T9000    | Aucune  |         |         `|       | Pas d'extension 16ko
TO7/70   | V1      | Ok      |          | Non   | Impossible d'essayer l'ecriture
         |         |         |          |       | Le reset plante systématiquement
         | V2      | Ok      |          | Ok    | Ecriture impossible car Disk DOS impossible à charger
MO5 50001| V1      | Ok      | Ok       | Ok    |
         | V2      | Non     |          |       | Test à refaire sur une autre machine 50.001
MO5 Meca | V1      | Non     |          |       | 
         | V2      | Ok      | Ok       | Ok    |
MO6NR    | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC128
         |         |         |          |       | Taper CLEAR,&H4FFF:EXEC&HA025
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment
TO8      | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC512
         |         |         |          |       | Taper CLEAR,&H8FFF:EXEC&HE025
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment
TO8D     | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC512 ou 1.0
         |         |         |          |       | Taper POKE&HE7E7,&HD4:EXEC&HE025
         |         |         |          |       | Après Disk chargé taper EXEC&HE007    
         |         |         |          |       | Le reset renvoie 3 erreurs 2 et bloque le retour au BASIC
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment sauf
         |         |         |          |       | Le reset bloque le retour au BASIC directement
---------|---------|---------|----------|-------|------------------------------------------------------        
Je complèterai ce post avec d'autres tests mais déjà nous avons un bon comparatif entre les deux versions V1 et V2 de SDDRIVE ;)

[edit]

Code : Tout sélectionner

Machine  | SDDRIVE | Lecture | Ecriture | Reset | Commentaires          
---------|---------|---------|----------|-------|------------------------------------------------------
MO5 50001| V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC1.0 sur les deux UC test et contrôle 
         |         |         |          |       | Taper CLEAR,&H4FFF:EXEC&HA025
         |         |         |          |       | Après Disk chargé taper EXEC&HA007 
         | V2      | Ok      | Ok       | Ok    |
TO7/70   | V1      | Non     |          |       | ?IO Error in 0
         |         |         |          |       | Le reset ne plante plus
         | V2      | Ok      | Ok       |       | Erreur ?NE in 0 après chargement du DOS
         |         |         |          |       | DOS bien présent
         |         |         |          |       | Le reset ne retourne pas au DOS
---------|---------|---------|----------|-------|------------------------------------------------------        
Modifié en dernier par jasz le 16 juin 2018 21:37, modifié 5 fois.

gti
Messages : 28
Enregistré le : 20 oct. 2013 09:09

Re: [Thomson] SDDRIVE

Message par gti » 16 juin 2018 19:47

Bonsoir Daniel, mon adresse est bien la même. Désolé de ne pas avoir répondu avant. Je ne pouvais pas avant. J ai bien lu les conditions mais je payerais la totalité de tes frais, c est normal donc n hésite pas à me donner le total tout frais. Des réception, je consacrerais une partie de mes soirée aux essais.

Cordialement

Guillaume

Daniel
Messages : 10326
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 juin 2018 20:25

@gti : Nous ferons le point sur tous les sujets à mon retour de vacances, le 2 juillet.

@jasz : Le tableau des résultats n'est pas facile à exploiter, car il y a des commentaires qui pourraient être pris pour des erreurs par un lecteur non attentif, alors que c'est parfaitement normal et explicable. Par exemple il est normal que le système ne fonctionne pas si on ne respecte pas la procédure de lancement décrite dans la documentation. Il est normal que le menu SDDRIVE ne s'affiche pas directement en Basic 128 ou 512. Il est normal que les démonstrations de streaming audio et vidéo, ainsi que certains programmes commerciaux, ne puissent pas être interrompus par le bouton reset. C'est pareil avec de vraies disquettes.
Pour le TO7/70 peux-tu préciser pourquoi le DOS est impossible à charger ? Quelle cartouche MEMO7 utilises-tu ? Quelle commande as-tu tapée, et quel fichier .sd as-tu utilisé ?

@tous les testeurs : L'objectif des tests est de vérifier que le matériel fonctionne bien. Il faut chercher à mettre en évidence d'éventuelles erreurs d'accès à la carte SD. Les incompatibilités logicielles entre les différents Basic, le DOS, les jeux commerciaux etc. sont un autre problème, intéressant certes, mais il ne faut pas le mélanger avec la validation du schéma du contrôleur. Nous discuterons des questions soft plus tard.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 16 juin 2018 21:00

Daniel a écrit :
16 juin 2018 20:25
Il est normal que le menu SDDRIVE ne s'affiche pas directement en Basic 128 ou 512. Il est normal que les démonstrations de streaming audio et vidéo, ainsi que certains programmes commerciaux, ne puissent pas être interrompus par le bouton reset.
Je donne simplement une procédure simplifiée dans certains cas et des commentaires dans d'autres. Ce ne sont pas des critiques ni des conclusions ;) Maintenant si tu préfères "ça marche", "ça marche pas", c'est à dire que l'écran SDDRIVE s'affiche, ouais... bon... mais, je ne voie pas trop l'utilité car ton interface doit pourvoir servir en entrée comme en sortie... Qui à fait les tests en sortie? Levez les doigts bien haut que je puisse compter :mrgreen:
Les reset tests ont tous étaient fait à partir du DOS fournie sur la microSD...

Je vais ressortir mon TO7/70 pour un autre test. Pour info j'utilise le BASIC1.0 :roll:

Le chargement du DOS donne une ?NE error in 0, je n'avais pas fait le DIR mais apparemment le DOS est chargé car je voie le programme de test en écriture. Cependant, le reset vire le DOS. Un DIR me donne une ?ND error contrairement aux autres machines testées. Je vais modifier mon précédent post.

Daniel
Messages : 10326
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 juin 2018 22:12

Le problème est qu'il est difficile de savoir si ces tests ont détecté ou pas des dysfonctionnements. Quand tu écris "Les reset tests ont tous été faits à partir du DOS fourni sur la microSD..." et "Le reset plante systématiquement", je ne comprends pas ce que ça signifie. Je ne sais pas dire si c'est le comportement normal, ou si tu as détecté une anomalie de fonctionnement du contrôleur.

Il faut donner le détail des opérations effectuées, en précisant bien la configuration de l'ordinateur et les fichiers .sd utilisé. Si le résultat n'est pas celui attendu, alors SDDRIVE est fautif. On ne cherche pas à lister le comportement du contrôleur dans chaque cas de figure, mais à détecter d'éventuels comportements anormaux provoqués par les glitches, les différences de délais de propagation, les interférences, les parasites, les rebonds aux extrémités du bus, les imperfections des composants, etc. Bref à évaluer le fonctionnement du matériel, pas du logiciel ni de l'opérateur.

Un exemple, que nous avons déjà évoqué dans ce fil de discussion :
L'erreur ? NE error in 0 se produit quand on cherche à lancer le programme AUTO.BAT et que le fichier AUTO.BAT n'existe pas. C'est une erreur parfaitement normale, on aurait exactement la même avec une vraie disquette. Elle ne m'intéresse pas du tout, car elle n'a aucun rapport avec la nouvelle version de SDDRIVE.

Une seule chose m'intéresse : la nouvelle version a-t-elle corrigé ou pas les problèmes électroniques constatés avec la précédente ?
Les 30 tests effectués sur mes ordinateurs n'ont détecté aucun problème, je voudrais simplement avoir la confirmation avec un plus grand nombre de testeurs et d'ordinateurs.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Silou78
Messages : 177
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: [Thomson] SDDRIVE

Message par Silou78 » 17 juin 2018 00:22

Voici le résultat des tests sur mes machines.
Pour chaque machine plusieurs tests sont effectués avec des démos, et des jeux.

@jasz : je ne vois pas spécialement l'intérêt de faire des tests en écriture car de toute façon même en lecture, MISO (entrée) et MOSI (sortie) sont utilisés par le protocole de communication. L'écriture sur la SD n'est ensuite que de la tambouille interne à l'adaptateur µSD suivant la commande que SDDRIVE lui a envoyée. Donc à moins d'un adapteur ou une carte µSD défaillante, ça doit fonctionner (mais c'est vrai qu'un test en plus permet d'en être sûr et certain).

TO8D n°1 : Fonctionnement OK (connexion directe, nappe 5cm, nappe 15cm)
TO8D n°2 : Fonctionnement OK (nappe 15cm)
MO6 n°1 : Fonctionnement OK (nappe 15cm)
MO6 n°2 : Fonctionnement OK (nappe 5cm) - Avec la nappe 15cm, le menu SDDRIVE ne se lance pas à chaque fois.
TO8 : Fonctionnement OK (nappe 15cm)
TO9+ : Fonctionnement OK (nappe 15cm)
TO7/70 : Fonctionnement OK (nappe 15cm) - Testé avec cartouche Basic 1.0 et Basic 128.
MO5 : Fonctionnement OK (nappe 15cm)

Donc le nouveau schéma fonctionne bien mieux que l'ancien. La longueur de la nappe de 15cm reste problématique pour une de mes machines.
Il reste donc important de minimiser la longueur de la connexion du SDDRIVE avec le connecteur d'extension de l'ordinateur pour garantir un fonctionnement proche de 100%.
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 17 juin 2018 07:05

Daniel a écrit :
16 juin 2018 22:12
Une seule chose m'intéresse : la nouvelle version a-t-elle corrigé ou pas les problèmes électroniques constatés avec la précédente ?
Les 30 tests effectués sur mes ordinateurs n'ont détecté aucun problème, je voudrais simplement avoir la confirmation avec un plus grand nombre de testeurs et d'ordinateurs.
Ok! Je ferai de nouveaux tests avec d'autres machines dans la journée. Mais on peut avancer sans trop se tromper que la V2 de SDDRIVE fonctionne mieux que son prédécesseur V1 donc le comportement sur certaines machines était aléatoire... Pour revenir à l'ancienne version de SDDRIVE que je nomme V1, grâce à cette série de test, j'ai réussi à le domestiquer et fonctionne à présent sur presque toutes les machines ;)

Daniel
Messages : 10326
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 17 juin 2018 08:27

Voici une procédure de test simplifiée permettant de déterminer si l'électronique de la nouvelle version fonctionne :
- Exécuter la procédure indiquée au paragraphe "Sélection de la disquette au démarrage de l'ordinateur" de la documentation.
- Le menu SDDDRIVE s'affiche : c'est bon. Le menu SDDRIVE ne s'affiche pas : il y a un problème.

Accessoirement, pour vérifier le bon fonctionnement dans le temps, on peut lancer une démonstration (cat, imagine ou bach) pendant quelques minutes pour s'assurer que le programme s'exécute normalement.

Les tests de Silou78 confirment exactement ce que j'ai constaté avec mes machines.
En simplifiant à l'extrême on peut dire qu'il y avait deux problèmes avec la première version : les glitches et le bus.
Théoriquement le nouveau schéma évite les glitches, la suppression ou le raccourcissement de la nappe supprime les problèmes de bus.
Les tests en cours ont pour but de valider cette hypothèse. Sinon il faudra chercher d'autres causes de dysfonctionnement.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 17 juin 2018 08:43

J'avais oublié de préciser que les tests comprenaient imagine et cat fournis avec le microSD et fonctionnent sur pratiquement toutes les machines. Le DOS ne me servant que pour l'écriture ;) Aujourd'hui, comme dit plus haut, je vais faire d'autres essais mais avec d'autres fichiers .sd

Avatar du membre
irios
Messages : 3157
Enregistré le : 04 nov. 2007 19:47
Localisation : Rochefort du Gard (30)
Contact :

Re: [Thomson] SDDRIVE

Message par irios » 17 juin 2018 10:46

Mes tests :
-J'ai du remplacer la carte µSD expédiée avec l'interface car elle ne fonctionne pas. Elle n'est pas vue quelque soit le système utilisé pour réaliser un formatage de bas niveau.

-MO5 gomme : OK
-MO5 clavier : OK
-MO6 : OK
-TO8D : OK

Cependant, ave le TO8D, j'ai remarqué avec le jeu brain power, en utilisant le basic 1 avec les commandes POKE &HE7E7, &HD4 EXEC &HE025, la page d'accueil du jeu reste bloquée. En revanche en faisant les commandes POKE &HE7E7, &HD4 EXEC &HE007 le jeu fonctionne. Sous basic 512, quelques soient les commandes la page d'accueil est figée, soit il y a la liste des instructions basic.
Modifié en dernier par irios le 17 juin 2018 19:09, modifié 2 fois.
http://irioslabs.over-blog.com/

La connaissance ne vaut que si elle est partagée par tout le monde.
I2C

Avatar du membre
Carl
Modérateur
Messages : 10026
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 17 juin 2018 11:40

Aucun dysfonctionnement sur les machines que j'ai testé....

ps : Irios, je n'ai utilisé que cette commande : POKE &HE7E7, &HD4 EXEC &HE007 pour le TO8D & T09+

Carl

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 17 juin 2018 18:32

Bien! J'ai changé les bécanes et testé la V2 exclusivement sur une dizaine de jeux pour TO8/D
- Prohibition Ok
- Arkanoid Ok
- Les passagers du vent 1 & 2 Ok
- Bob winner Ok
- Le temple de quautli Ok
- L'aigle d'or Ok
- L'arche du capitaine blood ok
- Kandy cruch java Ok 8)
- Bob morane science fiction ok
- Mack 3 ok
- Space racer ok

Par contre la marque jaune ne fonctionne pas. Je ne sais pas si c'est un problème de conversion du FD vers le SD (avec FD2SD) mais ça patine un max sur 8 et 8D. Quelqu'un peut vérifier?

Sur MO et TO7/70 il y a moins de jeux sur D7 donc il y aura moins de possibilité de contrôle. Mais les stream fonctionnaient bien il n'y a donc pas de raison ;)

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 17 juin 2018 18:53

irios a écrit :
17 juin 2018 10:46
En revanche en faisant les commandes POKE &HE7E7, &HD4 EXEC &HE007 le jeu fonctionne.
Suite à mes différents tests sur 8 et 8D je peux certifier que POKE &HE7E7, &HD4 EXEC &HE007 ne lance pas le jeu pour une simple et bonne raison; la D7 n'est pas chargée.
Le POKE &HE7E7, &HD4 désactive le lecteur interne
et le EXEC &HE007 exécute le boot secteur à défaut le menu SDDRIVE.
Mais comment faire si ta D7 n'est pas sélectionnée et qui te dit qu'il ne faut pas un RUN"AUTO.BAT" n'est pas Carl ;)

Avatar du membre
Carl
Modérateur
Messages : 10026
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 17 juin 2018 19:18

Jasz,
sur mon TO8D avec la commande POKE &HE7E7, &HD4 EXEC &HE007 en basic 1.0, le jeu se lance sans problème par contre il bug à l'écran d'intro en basic 512...

Carl

jasz
Messages : 362
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 17 juin 2018 20:38

Carl,
Tu peux me donner les titres communs aux miens que je fasse l'essai sur mes 8D...
En tout cas sur 8 c'est impossible...
Sur une bonne majorité de jeux testés ce jour la commande RUN"AUTO.BAT lance le jeu comme l'aigle d'or ou le temple de quauhtli

[edit]
Je viens de vérifier les commandes POKE&HE7E7,&HD4:EXEC&HE007 ne lancent pas un jeu mais le sélecteur SDDRIVE sddrive.sel

[edit]
La marque jaune ne fonctionne pas sous le format .sd car elle boote sur le lecteur interne malgré sa désactivation :shock: Pour info la marque jaune se lance par RUN"AUTO.BAT :mrgreen:

Répondre