[MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Papy.G, fneck, Carl

Répondre
hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

[MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 06 janv. 2018 21:49

J'ai acheté un deuxième convertisseur Péritel vers HDMI pour pouvoir le modifier. Pourquoi ? j'ai un Atari 520 STE que je peux connecter à mon poste de télévision SHARP via le péritel mais il a un soucis de synchronisation à cause de la commutation rapide dont la broche est connectée sur le signal HSYNC de l'Atari. Ce problème est connu et il existe une réponse : http://fr.meric.free.fr/Articles/articl ... lat.html#1.

L'idée est de se servir de ce convertisseur pour fournir la commutation rapide avec le voltage qui va bien pour que la télé reçoive bien en RGBS.

L'idée est d'autant plus séduisante que je pourrais me faire un cable péritel pour le MZ-700 (voire pour le MZ-800) qui aura la même problématique de ne pas pouvoir fournir le bon signal pour la commutation rapide en RGBS. Si ce convertisseur fait le boulot à la place, je pourrais utiliser ce convertisseur aussi bien pour l'Atari 520 STE que pour le MZ-700 en ne se souciant pas des signaux de commutation rapide et lente (cette dernière peut être ignorée en forcant la télé à 4/3).

Mais il y a un hic et vu que je ne suis pas électronicien, je me tourne vers vous pour me guider proprement. Le circuit du convertisseur a évidemment changé depuis la dernière mise-à-jour du tutoriel que j'ai cité en lien. Le lien stipule qu'il faut couper une trace entre la broche de commutation rapide et la première résistance à 75 Ohm branchée sur la masse en parallèle . Juste après cette résistance il y a une diode ZD1 où on doit ajouter un fil branché à une source de 5V avec une résistance de 100 Ohm en série. Or cette diode n'est plus !

J'ai donc cherché à suivre la trace : elle passe bien par cette même résistance 75 Ohm branchée sur la masse en parallèle. Donc j'imagine que je n'ai qu'à couper la trace avant. Cependant, sur l'autre branche en parallèle, il n'y a plus de diode et la trace continue directe jusqu'à une patte de la grosse puce de traitement.

Question : est-il possible que la diode ait été supprimée parce que la grosse puce est capable de gérer l'équivalence d'une diode à sa patte ? et donc, je n'aurais qu'à placer un fil avec une résistance 100 Ohm en série entre un point de la trace le plus près de la patte et une source 5V (connecteur J7 nu qui a un pad carré de 5V).

Passons aux photos pour illustrer.

Le circuit ne présentant pas de diode avec la trace non dessinée :
WIN_20180106_20_34_21_Pro.jpg
WIN_20180106_20_34_21_Pro.jpg (342.96 Kio) Vu 143 fois

Le circuit avec la trace déssinée en rouge :
WIN_20180106_20_34_21_Pro_RedTrace.jpg
WIN_20180106_20_34_21_Pro_RedTrace.jpg (402.93 Kio) Vu 143 fois
Et enfin le fil vert avec la résistante 100 Ohm en bleu connecté aux points rouges :
WIN_20180106_21_36_14_Pro.jpg
WIN_20180106_21_36_14_Pro.jpg (407.94 Kio) Vu 143 fois
Les photos ne sont pas très bonnes car elles sont prise avec un endoscope :
IMG_20180106_215115.jpg
IMG_20180106_215115.jpg (738.42 Kio) Vu 141 fois
Qu'en pensez-vous ? je rappelle que je ne suis pas électronicien mais informaticien donc soyez indulgent avec mes bétises.

Fool-DupleX
Messages : 883
Enregistré le : 06 avr. 2009 12:07

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par Fool-DupleX » 06 janv. 2018 23:21

On va dire que je suis tebé, mais je ne comprends pas très bien le tuto en question, ni pourquoi il y a cette diode zener sur le chemin, ni pourquoi la résistance de 75 ohms semble montée en parallèle sur le signal alors qu'en principe la correction d'impédance se fait en série. Et ce n'est pas en mettant une résistance de 100 ohms sur du 5V qu'on obtient du 3V. J'ai l'impression que grâce à la résistance de 75 en parallèle déjà présente, la résistance de 100 permet de réaliser un pont qui produit une tension de 2.15V, ce qui fait l'affaire. C'est plutôt mal expliqué.

Cela étant dit, il me semble que la solution au problème est de fournir une tension continue entre 1V et 3V sur la broche de ta grosse puce. couper la ligne 16 et brancher directement la broche avec un fil sur un régulateur 3.3, 2.5 ou 1.8 qui traine dans le coin devrait faire l'affaire, le 2.5 étant idéal. Par exemple, sur ta photo, U2 est un régulateur, il serait intéressant de mesurer les tensions à ses bornes par rapport à la masse.

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 00:32

Oui le tuto n'est pas très clair car il ne dit pas qu'il se passe après la diode. En tout cas, sur mon circuit, il n'y rien après la résistance 74 Ohm. Après avoir lu ton message, je me suis rappelé que ce doit être en fait une tentative de division de voltage qui ressemble beaucoup à ça :
voltage-divider-schematic.png
voltage-divider-schematic.png (1.91 Kio) Vu 121 fois
avec VIN = 5V, R1 = 100 Ohm et R2 = 75 Ohm.

Ok, je fais le calcul avec la formule suivante :
resistor-divider-equation.jpg
resistor-divider-equation.jpg (8.46 Kio) Vu 121 fois
Donc VOUT = 5V * (75 / (100 + 75)) = 2,15V.

Ok, tant qu'on reste entre 0,3V et 3V, on est en RGBS et c'est le cas.

Donc tu me conseillerais de voir plutôt les régulateurs ? le U2 est un peu trop petit et je me vois mal faire une soudure sur une des pattes (laquelle d'ailleurs ?). Il y a le U3 qui semble délivrer du 3,3V (on sort de le spec) et U4 qui semble délivrer du 1,8V qui devrait suffire, non ?
IMG_20180107_001714.jpg
IMG_20180107_001714.jpg (1.05 Mio) Vu 121 fois
Je vais tester leurs tensions demain quand je saurais quelle patte fournit la tension demandée.

Avatar du membre
fneck
Site Admin
Messages : 11681
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par fneck » 07 janv. 2018 09:58

hlide a écrit :
07 janv. 2018 00:32
je me suis rappelé que ce doit être en fait une tentative de division de voltage qui ressemble beaucoup à ça (...) avec VIN = 5V, R1 = 100 Ohm et R2 = 75 Ohm (...)
Attention en faisant ce calcul à ne pas ommettre la résistance d'entrée du montage suiveur (R équivalente connectée sur Vout) que j'appellerai ici R3 et schématiquement branchée en parallèle de R2

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 10:33

Si par R3, tu fais allusion à une résistance virtuelle se trouvant dans la grosse puce en passant par la patte concernée, on s'en fiche un peu, non ? la grosse puce en fait ce qu'elle veut du moment qu'on lui fournit en entrée quelque chose entre 0,3V et 3V pour qu'elle reconnaisse un RGBS.
Modifié en dernier par hlide le 07 janv. 2018 10:56, modifié 2 fois.

Avatar du membre
fneck
Site Admin
Messages : 11681
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par fneck » 07 janv. 2018 10:51

hlide a écrit :
07 janv. 2018 10:33
Si par R3, tu fais allusion à une résistance virtuelle se trouvant dans la grosse puce en passant par la patte concernée, on s'en fiche un peu, non ?
Tout dépend de sa valeur. Si elle fait 100k alors oui elle devient négligeable mais si elle fait une 100aine d'ohms il faudra la prendre en compte dans le calcul.

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 10:56

Une fois de plus - les cours d'électronique datant pour moi - si je connecte directement une tension de régulateur au point VOUT (cercle rouge dessiné sur la photo montrant les régulateurs), c'est comme si j'avais une résistance 0 Ohm ? avec VOUT = VIN * R2 / (R2 + 0) = 1,8 V si j'utilise U4 pour obtenir un VIN = 1,8 V ?

Ou alors je coupe la trace APRES la résistance 75 Ohm et non avant de façon à casser cette branche connectée à la masse et faire passer directement la tension de U4 (1,8 V) sur le point VOUT ?

Actuellement, sans modification, j'ai au point VIN la tension délivrée à la broche 16 du SCART (commutation rapide), j'ai une résistance R2 de 75 Ohm branchée sur la masse et une branche parallèle qui va directement sur une patte de la grosse puce (donc une résistance virtuelle R1 de 0 Ohm, je présume).

Si je coupe la trace entre la broche 16 du SCART et la résistance 75 Ohm, je dois fournir une tension équivalente à la place de la broche 16 :

1) option 1, celle donnée par le tutoriel : créer un branche avec une résistance R1 à 100 Ohm depuis une source 5V en utilisant une division de tension pour obtenir du 2,15 V au point VOUT.

2) option 2, lier la sortie 1,8 V de U4 directement au point VOUT avec la branche parallèle de 75 Ohm. Est-ce un montage "safe" ?

Si je coupe la trace entre la résistance 75 Ohm et le point VOUT (ce qui revient à se débarrasser de la résistance 75 Ohm) :

3) option 3, lier la sortie 1,8 V de U4 directement au point VOUT sans la branche parallèle de 75 Ohm. Est-ce un montage "safe" ?

Quelle est l'option la plus sensée ?

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 11:41

J'ai mesuré la tension aux sorties des régulateurs, à la broche 16 du SCART (test avec un AMIGA 600 branché via un péritel uniquement broché en RGBS) et au point VOUT :

- U2 : 0,6 V
- U3 : 3,3 V
- U4 : 1,8 V
- SCART #16 : 1,4 V - tension prise entre SCART #16 (BLANK) et #18 (BLANKGND) quand la péritel est branchée au connecteur et juste un peu moins si péritel non branché.
- VOUT : 1,4 V

Et c'est nickel sur mon téléviseur SHARP comme sortie. Donc piquer du 1,8 sur le régulateur U4 devrait faire l'affaire, non ?

Avatar du membre
fneck
Site Admin
Messages : 11681
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par fneck » 07 janv. 2018 11:52

Oui, si en réel ça fonctionne bien, fait comme cela 8)

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 14:17

Bon, j'ai choisi l'option 2 :

- couper la trace entre la broche 16 du SCART (commutation rapide) et le point de raccordement entre deux branches dont l'une a une résistance 75 Ohm branchée à la masse.
- relier la sortie 1,8 V du régulateur U4 vers le point de raccordement des deux branches.

Pourquoi l'option 2 ? j'ai noté qu'il y avait deux pads juste au-dessus de la résistance 75 Ohm et une trace qui raccordait les deux pads. Si je veux pouvoir revenir à l'origine, il me suffirait de raccorder ces deux pads et de retirer le fil.
/---
IMG_20180107_122256.jpg
IMG_20180107_122256.jpg (1.39 Mio) Vu 75 fois
\---

On coupe la trace entre les deux pads A et B:
/---
IMG_20180107_123332.jpg
IMG_20180107_123332.jpg (1.43 Mio) Vu 75 fois
\---

Et on place un fil conducteur entre le pad A et le pad 2 du régulateur U4:
/---
IMG_20180107_131631.jpg
IMG_20180107_131631.jpg (1.04 Mio) Vu 75 fois
\---

J'ai bien vérifié que le courant ne passait plus entre les pads A et B avant et après de placer le fil.

J'ai retesté avec l'Amiga 600 et j'ai bien du 1,8 V au VOUT. En revanche, j'ai presque du 12 V sur la broche 16 du SCART alors qu'il était à 1,4 V avant. Je ne sais pas quoi en penser. C'est grave, docteur ?

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 14:48

Et ça fonctionne sur l'Atari, je n'ai plus de décalage intempestif de l'image sur l'écran quelque soit les modes de l'écran (4/3, 16/9, zoom1, zoom2 ou point to point - affichage "point to point" ici, c'est-à-dire un pixel de résolution source égale un pixel de l'écran).
IMG_20180107_143903_HDR.jpg
IMG_20180107_143903_HDR.jpg (1.37 Mio) Vu 74 fois

Fool-DupleX
Messages : 883
Enregistré le : 06 avr. 2009 12:07

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par Fool-DupleX » 07 janv. 2018 20:46

En revanche, j'ai presque du 12 V sur la broche 16 du SCART alors qu'il était à 1,4 V avant. Je ne sais pas quoi en penser. C'est grave, docteur ?
On s'en ventile les rouflaquettes. Par contre, tu consommes inutilement 24 mA avec ta résistance 75 ohms. Mais c'est pas bien grave.

hlide
Messages : 114
Enregistré le : 29 nov. 2017 10:23

Re: [MZ-700/800, ATARI 520 STE] Modification d'un convertisseur Péritel vers HDMI

Message par hlide » 07 janv. 2018 22:01

Merci Fool-DupleX pour la suggestion du régulateur. C'était la seule option qui me permettait de faire des soudures "faciles" d'un fil très fin sur des pads existants et de pouvoir revenir en arrière si nécessaire. Donc je vais accepter ce gaspillage de 24 mA, car ce n'est pas comme si je faisais tourner mon Atari 520 STE 24h/24.

Répondre