Restauration Amiga 2000

A partir de maintenant la course à l'armement est lancée.

Modérateurs : Carl, Papy.G, fneck

Arthur
Messages : 8
Enregistré le : 27 janv. 2016 15:39
Localisation : Seine et Marne

Restauration Amiga 2000

Message par Arthur » 27 janv. 2016 18:34

Bonjour,

Adolescent, je rêvais d'avoir un Amiga 2000, alors lorsqu'au boulot on m'en a proposé un (gratis !) j'ai sauté sur l'occasion.
On m'avait bien prévenu qu'il ne fonctionnait pas, mais je me suis dis (naïvement), que c’était un bête fusible ou un composant à rechausser sur son support.
Alors imaginez ma déception lorsque j'ai découvert la carte mère rongée par l'acide de la batterie ...
j'ai pris de l’alcool, une ville brosse à dent et j'ai gratté le plus gros
Les dégâts semblent très importants du moins à mes yeux : mes connaissances en électronique sont limitées au pont de diode et au filtre passe bas.
J'ai testé les résistances et condos, ils sont tous bons à changer.
j'ai fais quelques tests de continuité et il me semble que j'ai pas mal de pistes coupées
A moins que les contacts sur lesquels je m'appuie sont encore trop corrodés.
Je pense que le support du M68K est à changer aussi (le proc, lui, est plutôt propre)
bref, c'est pas la joie, mais malgré mes faibles compétences, j'ai décidé de lui rendre vie.

Et c'est là que j'ai besoin de vous : au vu de la photo jointe,
pensez vous qu'une restauration est encore possible ?
comment s'y prendre pour nettoyer mieux encore ?
je pense que je peux ponter les pistes coupées par du fil, au verso de la carte - y aurait il une meilleure solution ?
tout conseil sera bien évidement le bien venu

D'avance merci
Fichiers joints
dégâts.JPG
putain de varta
dégâts.JPG (259.71 Kio) Vu 2242 fois

Daniel
Messages : 10323
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Restauration Amiga 2000

Message par Daniel » 27 janv. 2016 19:06

Les dégâts ne semblent pas catastrophiques.

Pour commencer un bon nettoyage avec un produit de vaisselle appliqué au pinceau souple neutraliserait l'éventuelle acidité résiduelle. A faire suivre d'un bon rinçage. Les pistes larges ne semblent pas coupées. Il faut contrôler les autres à l'ohmmètre, mais pour que les mesures soient significatives les points de contact doivent être désoxydés, avec un produit spécial du type KF pour contacts. Si l'oxydation est trop importante on peut aussi gratter très légèrement avec une lame métallique.

Pour réparer une piste coupée le plus simple est de la gratter pour enlever le vernis et l'éventuelle oxydation, et de souder par-dessus un fil conducteur très fin pour remplacer la partie manquante.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: Restauration Amiga 2000

Message par Xavier » 27 janv. 2016 19:20

Salut Arthur,
:shock:

Tu l'as trouvé sur la plage?

Un strap ou deux en cas de rayures, usure mécanique ou problème localisé (fissure...
Mais, là...
Même, si tu arrives à le faire fonctionner... avec une 50ène de fils volants...
Le circuit est tellement rongé, que les pistes fragilisée en épaisseur, feront fusible et claqueront les une après les autres.

MAIS...
Si tu demandes des conseils, je ne te dirai pas "POUBELLE!"

Donc, il faut que tu la restores pour le plaisir... de l'ouvrage.

Cherche des photos haute résolution du PCB côté composant et cuivre.
Prévoie des pises autocollantes, vernis conducteur et un nettoyage complet de la carte.
Changement des composants passifs, condos et remplacement des supports CI.
Pour cela, il faudra TOUT démonter, en t'équipant d'un matériel d'électronique à la hauteur (pompe à dessouder...).

C'est un gros chantier, cela prendra du temps, et le résultat n'est pas certain.
Un bon passe-temps, mais qui demande une discipline rigoureuse.
Cette machine est bien documentée, et il sera facile de trouver des documents techniques et schémas...
(Prévoie quand même l'achat d'une carte en pièce détachée si l'ouvrage te fait peur!)
Donc, c'est jouable.
Les dégâts ne semblent pas catastrophiques.
Pour une machine qui a pris l'eau ???
Je ne doute pas que Daniel puisse restaurer des machines remontées de l'épave du "Titanic", mais je te trouve très optimiste!
Les pistes sont rongées sous le verni !!!

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Restauration Amiga 2000

Message par petitjd » 27 janv. 2016 21:24

Les pistes sont bouffées par l'oxydation, surtout autours de R1888 et en dessous à gauche du 68000.
Ca semble assez complexe à restaurer, ca ressemble à un de mes Lisa en moins pire.

@Xavier: correction, Daniel serait capable de restaurer le Titanic!
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Restauration Amiga 2000

Message par fneck » 27 janv. 2016 21:27

On ne voit pas forcément bien sur la photo, mais je crains que Xavier ait raison, il me semble également qu'il y a beaucoup de pistes coupées pour pronostiquer un résultat positif :(

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Restauration Amiga 2000

Message par petitjd » 27 janv. 2016 21:56

Je viens de m'apercevoir que mon iPhone permet de voir la partie droite de la photo qu'on ne voit pas sur pc, du moins sur le mien.
Si pour vous la partie droite s'arrête au 68000, copiez l'image et coller la dans paint pour comprendre le problème autours de R1888 situé à droite du 68000.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Restauration Amiga 2000

Message par fneck » 27 janv. 2016 22:00

petitjd a écrit :(...) la partie droite de la photo qu'on ne voit pas sur pc, du moins sur le mien.
Avec un navigateur comme Firefox, tu cliques bouton droit sur la photo et "afficher image" pour la voir en totalité.

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Restauration Amiga 2000

Message par petitjd » 27 janv. 2016 22:02

FireQuoi??? :mrgreen: :wink:
Je n'utilise qu'IE sur PC et sous IE, "Afficher l'image" est grisé ici.
En double cliquant, l'image se cale à la hauteur maximale, mais pas à la largeur maximale.
En double cliquant à nouveau, les ascenseurs horizontaux et verticaux apparaissent permettant de scroller l'image vers la droite.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
Papy.G
Modérateur
Messages : 1729
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Restauration Amiga 2000

Message par Papy.G » 27 janv. 2016 22:36

Aucun problème d'affichage, ni sur Safari, ni sur Nokia (Ex-Netscape), par contre, c'est assez vilain, la façon dont l'image déborde du "plan", malgré la disponibilité des ascenseurs dans les deux directions. :roll:

Pour en revenir au sujet, ça me rappelle une cartouche de gameboy, qui a subit les mêmes dégâts, et que j'ai mis de côté, des fois que j'aurais un jour la folie d'essayer de sauver. Il y a beaucoup moins de pistes, mais moins de place aussi. Ici, j'aurais tendance à dire que ça doit être faisable, dans la mesure où l'encombrement et le temps passé n'est pas une contrainte, mais ça va ressembler à un plat de spaghettis à la fin. :mrgreen:
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: Restauration Amiga 2000

Message par Xavier » 27 janv. 2016 23:03

:shock:
pistes.JPG
pistes.JPG (41.37 Kio) Vu 2174 fois
Le Minautore, superbe jeu !
Mais, vu d'avion, il faudra réinventer des pistes...

Arthur
Messages : 8
Enregistré le : 27 janv. 2016 15:39
Localisation : Seine et Marne

Re: Restauration Amiga 2000

Message par Arthur » 28 janv. 2016 09:58

Merci pour toutes vos réponses.
Navré pour le format de la photo... une rotation à 90° aurait peut être mieux convenue
Si je résume, c'est pas impossible, mais je vais en baver, ça va pas se faire en une journée.
ça me va, de toutes façons, j'ai rien à perdre à essayer - ça m’intéresse et il faut bien se faire la main sur qqch.

Je pense que Petitjd et Xavier ont bien ciblé la partie la plus délicate.
je vous joint une photo de détail.

Je vais donc commencer par prendre plus de photos, sous différents angles
Trouver le plus de doc possible concernant cette carte (rev.6)
Dessouder les composants, les supports du PROC et de la ROM
Nettoyer au mieux, gratter, utiliser du K2 de chez KF (si j'ai bien compris) et tester les pistes les unes après les autres.
J'aviserais alors si quelques patches font l'affaire ou s'il faut comme Daniel de suggère remplacer les pistes abimées.

je vais y aller doucement, quand le temps me le permettra mais je vous tiendrais au courant, et reviendrais très certainement vers vous pour d'autres conseils.
Fichiers joints
dégâts - détails.JPG
c'est mal barré
dégâts - détails.JPG (247.25 Kio) Vu 2144 fois

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: Restauration Amiga 2000

Message par Xavier » 28 janv. 2016 11:11

Salut!
Purée... belle photo, perso j'arrive pas a faire des macros de cette qualité.
Donc, comme toujours Daniel avec son excès d'optimisme avait raison.

Les pistes sont toujours là !!!
Mais, le problème est peut être plus simple.

Tu as des soudures sèches. (en bas à gauche, sur un réseau de résistance RP900, face cuivre!)
Avant de tout recâbler, vérifie une à une les soudures (des deux côtés), car la panne vient peut-être de là.

Nettoie le PCB comme le disait Daniel, ça te permettra d'enlever les traces de saletés qui couvre les pistes.
N'insiste pas sur les soudures, et ajoute de la soudure étain avec fondant pour ne pas décoller les pistes...

Garde à l'esprit que souder sur de l'étain oxydé est très difficile... tu peux utiliser de l'ammoniaque comme fondant, mais prévoie un ventilo. pour éviter les gros délires....

Les soudures ont une apparence "vibrées" (ternes), donc une refonte ne serait pas de trop.
Par contre, pour la soudure sèche, tu limes la patte pour faire accroche l'étain, puis tu chauffes la patte et non la pastille du PCB... sauf pour les ponts de couche (sans composants) qui demande une chauffe un peut plus soutenue.

Evite la pompe à dessouder pour les ponts, car sur certaines cartes (pcb 2 faces), ce ne sont pas des pastilles rivetées, mais des rouleaux de cuivres qui ont la fâcheuse tendance d'être aspirées par la pompe, si c'est le cas, un petit bout de cuivre doit être placé pour établir le pontage des couches.

Donc, soudures,KF sur connecteurs/supports ROM et ?RAM? , puis essais.
En cas de dysfonctionnement lors des test, tu pourras mieux cibler la panne (ROM/RAM/clavier...)

Vàla...
Bon courage, mais cette photo est plutôt rassurante!

Avatar du membre
irios
Messages : 3157
Enregistré le : 04 nov. 2007 19:47
Localisation : Rochefort du Gard (30)
Contact :

Re: Restauration Amiga 2000

Message par irios » 28 janv. 2016 16:52

Salut,

J'ai fait une réparation d'un Amiga 2000 ayant ces problèmes. Tu as la description des actions qui ont été faites pour réparer la carte sur mon blog : http://irioslabs.over-blog.com/

Bonne restauration. :wink:
http://irioslabs.over-blog.com/

La connaissance ne vaut que si elle est partagée par tout le monde.
I2C

Arthur
Messages : 8
Enregistré le : 27 janv. 2016 15:39
Localisation : Seine et Marne

Re: Restauration Amiga 2000

Message par Arthur » 28 janv. 2016 18:26

Bonsoir,

Bien vu, Xavier, pour soudures sèches - par contre, il n'y a pas de réseau de résistance en RP900, ni en RP901 d'ailleurs
J'ai cherché d'autres photos sur le net et en effet, certaines cartes les ont, d'autre pas...
Cependant, des pistes passent au travers sur les deux faces, donc je vais suivre ton conseil et les refaire.

Merci Irios pour le lien - j'avais fini par trouvé les mêmes schémas - bien utiles !
Je vois que tu as remplacé la pile rechargeable d'origine par une pile bouton ... c'est pas risqué ça ?
je me suis inspiré de ta photo avec la carte dirigée vers une source de lumière pour faire une "radio" et vérifier l'état des pistes.

j'ai sorti le proc et a rom de leurs supports - les deux sont saufs.
de visu, le support de la rom semble encore bon - sur celui du proc, trois pattes sont parties en poussière.

je vais faire un inventaire des passifs à changer et passer commande - des conseils pour les fournisseur ? (je ne connais que conrad)
Fichiers joints
radio.JPG
radio
radio.JPG (218.6 Kio) Vu 2105 fois

Arthur
Messages : 8
Enregistré le : 27 janv. 2016 15:39
Localisation : Seine et Marne

Re: Restauration Amiga 2000

Message par Arthur » 05 févr. 2016 18:01

ça avance ... lentement mais surement.
j'ai reçu ma commande, vérifié que j'avais bien tout ce qu'il me fallait avant de commencer à dessouder
j'ai viré quelques condensateurs et le support du processeur.
j'ai testé un max de pistes; toutes sont bonnes - ouf
le nouveau support de proc n'est pas identique à l'original - faut croire qu'en 64 broches ça ne se fait plus
ça me chagrine, j'aurais voulu une restauration, je vais me contenter d'une réparation.
sur la photo, il est juste inséré, il me faut maintenant le souder et y aura plus qu'à tester.
Fichiers joints
nouveau support.JPG
nouveau support.JPG (70.24 Kio) Vu 2020 fois
grand vide.JPG
grand vide.JPG (84.14 Kio) Vu 2020 fois

Répondre