[Logabax] Restauration Persona 1600

Pour tout ce qui touche au PC d'IBM et ses nombreux descendants. Attention tout de même, au delà de quelques MHz la discussion devient vite hors sujet.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
Fredo
Messages : 36
Enregistré le : 22 janv. 2008 19:51
Localisation : 91250 - St Germain les Corbeil
Contact :

Re: [Logabax] Restauration Persona 1600

Message par Fredo » 09 oct. 2012 09:26

Bonjour

Tu trouveras toutes les infos sur http://logabax.free.fr
Page Documents/Personna 1600

cdlt
Fred

Fabrice Montupet

Re: [Logabax] Restauration Persona 1600

Message par Fabrice Montupet » 09 oct. 2012 10:52

clearscreen a écrit :est ce qu'un membre du forum aurais une doc en pdf - la partie dip switch et alim me serait tres utile.
J'ai créé une page entièrement dédiée au Persona 1600 contenant documents techniques, schémas, configuration des SW, ROMs, etc. , ici: http://www.ti99.com/exelvision/website/ ... rsona-1600
have fun! :)

fabu
Messages : 927
Enregistré le : 11 avr. 2007 13:03
Localisation : Aveyron

Re: [Logabax] Restauration Persona 1600

Message par fabu » 09 oct. 2012 11:05

Merci Fabrice. C'est très bien présenté !

Fabrice Montupet

Re: [Logabax] Restauration Persona 1600

Message par Fabrice Montupet » 09 oct. 2012 11:14

Merci! J'ai pris beaucoup de plaisir à réaliser cette page, et si cette dernière rend service à des possesseurs de 1600, je suis comblé :)

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 09 oct. 2012 15:52

un grand merci a tous.
allez je me retrousse les manches.

ludovic.

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 09 oct. 2012 17:29

Bonjour
alors je ne sais pas ce qui s'est passe mais l'alim debite correctement. et j'ai donc pas trop mal soude mon varta nimh 3,6 v 70 mAh

toutes les tensions sont ok
cela devait être un faux contact (?)

par contre je bute sur un truc
j'ai enleve la carte d'extension ram

sur la banque 0 j'ai 18 puces 8532rs013 d4164c-3
et sur la 1 j'ai 18 mb8264a-12 8505 m63 ou m66

je consulte la doc et le groupe 0 des dips gere la config ram
1 2 3 4 = off on off off

d'ailleurs et il est ecrit que certaines cm voient leurs blocs inverses. . . je suis perdu :)

et changeant de conf je reste toujours a 128 voire je shunte la video

a votre avis je me plante ou ?

physiquement sur la cm j'ai 128 ?
l'inversion des switches ?
pour moi le point blanc marque le on et le 1 commence bien a gauche non ?

ci joint une photo de l'implantation des dips et des banques

merci de tous vos conseils

ludovic.
2012-10-09 17.19.20.jpg
2012-10-09 17.19.20.jpg (112.16 Kio) Vu 2577 fois
Fichiers joints
2012-10-09 17.25.31-1.jpg
2012-10-09 17.25.31-1.jpg (77.06 Kio) Vu 2577 fois

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Logabax] Restauration Persona 1600

Message par fneck » 09 oct. 2012 21:08

clearscreen a écrit :physiquement sur la cm j'ai 128 ?
l'inversion des switches ?
pour moi le point blanc marque le on et le 1 commence bien a gauche non ?
Non, tu as 256Ko sur la carte mère (2 banques de 128Ko).
Pour les switchs, tout est marqué dessus, tu vois le "ON" du coté fermé et les chiffres de 1 à 8 du coté ouvert (donc le 1 est à gauche en regardant de face, sur ta photo ci-dessus à l'envers par rapport à la sérigraphie des puces le 1 est à droite)

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 10 oct. 2012 01:28

Bonsoir,
sur la ram je n'ai pas ete trop stupide car apres avoir regarde les datasheets des puces j'avais buen des 64kbit

Par contre sur les dips je nage.
il semble que le bloc soit inverse par rapport a la doc de naintenance. bon soit et la doc previent que cela peut être le cas.

Si je suis ce que tu me dis , par rapport a ma photo : si la doc dit que le premier doit être "on" je le bascule donc le switch sur le point blanc ou sur le chiffre 1

comme ceci (les crochets materialisent la tete orange du dip)

ON

[] o
1

si tu est d'accord avec cela j'ai essaye toutes les combinaisons et je reste a 128ko
voire la video degage ( bizarre non ? )

ceci dit il semble qu'avec le 1·36 la ram est plus sympa a gerer.

bonne nuit et desole si j'insiste trop lourdement sur les switchs.
ludovic.

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Logabax] Restauration Persona 1600

Message par fneck » 10 oct. 2012 09:45

clearscreen a écrit :si la doc dit que le premier doit être "on" je le bascule donc le switch sur le point blanc ou sur le chiffre 1
La position 1 est du coté du repère "ON" sur le Dip-Switch (ou encore de la marque BECKMANN dans ton cas précis).
Sur ta photo ci-dessus, les 4 premiers contacts du switch 0 pour configurer la mémoire sont positionnés actuellement comme ceci:

ON ON OFF ON soit selon la doc 512K dont 256 sur carte mère.

Image

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 10 oct. 2012 12:25

Merci baucoup fabien.
je vais reessayer les positions 128 et 256 kb ce soir.

je vais changer la led aussi ( par quel modele tu as remplace la tienne ?)

ludovic.

ps : au fait merci ( ça fait 2 fois :-) car c'est grace a tes posts que j'ai change les accus nicad sur mon epson avant qu'ils ne coulent.

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Logabax] Restauration Persona 1600

Message par fneck » 10 oct. 2012 19:20

Pour la LED j'ai dû simplement prendre ce que j'avais en stock, ça n'a pas une grosse importance si tu restes dans les classiques rouge ou verte.

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 11 oct. 2012 00:48

Merci !
ce soir j'ai completement nettoye le fdd et le hdd autant que possible
2012-10-10 21.25.31.jpg
2012-10-10 21.25.31.jpg (195.77 Kio) Vu 2511 fois
2012-10-10 20.38.55.jpg
2012-10-10 20.38.55.jpg (160.67 Kio) Vu 2511 fois
demain je remonte l'ensemble.

:P

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 12 oct. 2012 00:59

vous allez rire . . . ou pas.

j'ai remonté le tout et apres m'être battu pour faire reconnaitre le disque dur : tout marche sauf la ram ou il n'y a que 128kb de reconnu sur les 256 kb

j'ai des erreurs sur une puce ou j'ai calcule la localisation en B2 avec vos docs mais cela ne se produit pas toujours.

Bref, piqué au vif, là dessus j'installe une autre cm que j'ai aussi recupéré et bonheur, il semble que j'ai 128 kb en bank 0 et 512 kb en banque 1 ( du mt 1257-15 )
et génial : la led marche sur celle ci.

eh bien je n'ai que 512 kb et non 640kb et là pas possible de se vautrer sur les dips c'est 128kb + 256kb avec chips de 256
off on off off pour 1 2 3 4

et pire, le disque dur n'est plus détécte.

une idee ? ( à part me dire de mettre les chips de 256 sur la cm qui detecte le disque et de souder une led :-P

le bonsoir a tout le monde
ludovic

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Logabax] Restauration Persona 1600

Message par fneck » 13 oct. 2012 08:10

Il y a une piste qu'il faudrait peut être approfondir, sur le bout de doc que j'ai posté ci-dessus, on ne trouve pas de configuration avec 640 Ko directement sur la carte mère. Je ne dis pas que c'est pas possible mais il y sans doute une histoire de révision de CM et de version du BIOS.

Cette doc Olivetti donne quelques indications sur les différentes cartes mères http://system-cfg.com/files/olivetti_M24-M21.pdf

clearscreen
Messages : 71
Enregistré le : 05 juin 2011 02:39

Re: [Logabax] Restauration Persona 1600

Message par clearscreen » 13 oct. 2012 21:47

Bonsoir,
C'est une doc très intéressante.

Il apparait effectivement que le 1.36 augmente l'efficacité de la gestion ram et des banques , combiné au pl90

j'ai donc consideré que ma carte etait parfaitement fonctionnelle avec une led qui marche en prime.

j'ai donc acheté et soudé un varta 3,6v 80mAh - et ça marche super.

Maintenant le disque est toujours "not present"

est ce que cela vient :
du controleur
du disque
de la puce sur la cm ?

le disque tourne, le moteur de deplacement fait son test, la led s'allume 10 sec puis a l'extinction apparaît "not present"

est ce qu'un membre du forum a déjà eu a traiter ce genre de soucis ?
a bientôt

ludovic
2012-10-13 22.01.54.jpg
2012-10-13 22.01.54.jpg (85.42 Kio) Vu 2445 fois

Répondre