Un automate industriel?

Si vous n'avez pas trouvé de catégorie correspondante ci-dessus, regroupe les discussions plus générales et à l'occasion peut aussi abriter un fil sur les vieilles consoles de jeux.

Modérateurs : Carl, Papy.G, fneck

Répondre
Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Un automate industriel?

Message par Lesarthois » 19 juin 2016 15:52

J'ai eu l'occasion pendant une mission d'intérim de mettre la main sur un automate, ou peut-être d'ailleurs juste une partie?

Malheureusement le collègue avec qui je me trouvais à ce moment n'avait aucune idée de ce que c'était et je n'ai pas pu trouver d'informations avant la fin de mission :?

Je ne suis pas aidé car l'engin ne porte absolument aucune marque, aucun nom, aucune indication, en dehors du mot "Sinergie" sur la façade, et le fait qu'il semble avoir été fait en France, avec beaucoup de travail manuel.
boitier 1.jpg
boitier 1.jpg (297.77 Kio) Vu 1606 fois
Un boîtier bien "vide"
boitier 2.jpg
boitier 2.jpg (284.27 Kio) Vu 1606 fois
Les cartes, remises en place (elles étaient en vrac, sûrement enlevées lors du démontage et du transport)
boitier 7.jpg
boitier 7.jpg (285.12 Kio) Vu 1606 fois
La carte qui me semble être celle du "cerveau" de la machine.

Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Re: Un automate industriel?

Message par Lesarthois » 19 juin 2016 15:56

Zut, limite de 3 photos... les autres photos des cartes ici, moins la carte d'alimentation :
boitier 4.jpg
boitier 4.jpg (294.18 Kio) Vu 1605 fois
La carte qui communique avec le boîtier "Télécom"


Deux cartes I/O, certainement :
boitier 6.jpg
boitier 6.jpg (290.61 Kio) Vu 1605 fois
boitier 5.jpg
boitier 5.jpg (294.13 Kio) Vu 1605 fois

Avatar du membre
frodon69
Messages : 2451
Enregistré le : 24 juin 2007 10:55
Localisation : Lyon

Re: Un automate industriel?

Message par frodon69 » 19 juin 2016 22:53

La prise téléphonique pourrait laisser penser que ça se programme avec un minitel ?
Frodon69

Avatar du membre
Papy.G
Modérateur
Messages : 1729
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Un automate industriel?

Message par Papy.G » 19 juin 2016 22:56

Ca a rapport avec la ligne téléphonique, un système d'alarme, par exemple. :o

On reconnaît facilement le processeur, MC6809P, la RTC ICM7170, un ACIA UM6551, un PIA MC6821P, trois timers programmables EF6840P, 3x32kO de Sram (peut-être alimentée pour sauvegarde), 2x32kO de Rom.

Tout ce petit monde étant sur support, si tu ne fais rien du truc en l'état, ça fait toujours une bonne base pour monter un Tavernier ou un truc dans le genre. :mrgreen:

Attention au condo explosé à côté du RTC. :?
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Re: Un automate industriel?

Message par Lesarthois » 19 juin 2016 23:43

En effet, certains de ces automates se programmaient par Minitel, (les anciens Sofrel) mais aucune idée pour celui-ci.
Et vu son état, le condensateur, mais aussi du vert-de-gris sur certaines pistes, il nécessite une bonne révision avant d'être rebranché.

Pour la ligne téléphonique, je pense qu'ils s'agissait surtout d'envoi de données, et de permettre la consultation à distance (compagnie des eaux, ces genre d'automate peut se trouver dans un château d'eau, une pompe de relevage, un quelconque réservoir/site isolé).
Le condo et l'âge de l'engin expliquent surement la mise au rebut.

En tout cas merci pour les précisions sur les différents composants ;) Ce n'est pas encore trop mon rayon.

Pour la SRAM, il y a bien cette pile de sauvegarde, et en effet elle pourrait bien stocker des paramètres à régler, voire tout le programme de surveillance (chez Sofrel, ils se programment ainsi, on les commande avec un domaine précisé, eau, assainissement, etc, et on ajoute ensuite les détails : sondes, contacts, etc...).
Une pile serait bien indispensable, vu la propension des sites à disjoncter (château d'eau = humidité + point haut = la foudre adore les installations). Aujourd'hui les réglages sont sur mémoire flash et les postes "sensibles" ont une batterie.

Avatar du membre
Papy.G
Modérateur
Messages : 1729
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Un automate industriel?

Message par Papy.G » 20 juin 2016 19:50

Habituellement, la programmation à l'aide d'un minitel se fait via la prise série en local, mais il se peut que la centrale s'administre par minitel distant, voir même local, si c'est le sens du commutateur local/P&T.

Pour les composants, je n'ai aucun mérite, on les trouve couramment dans les vieux ordinateurs, et dans les discussions ici, et pour les autres, il y a des bases de données de documentations en ligne qui permettent facilement de savoir ce que c'est.

Si tu les remets en marche, j'espère que seuls des paramètres sont sauvegardés en SRam.
Il faudra peut-être un minitel 1b au moins pour contrôler l'interface du bidule. ;)
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Re: Un automate industriel?

Message par Lesarthois » 20 juin 2016 20:50

Ca devrait se trouver dans les brocs facilement :D
Je n'ai pas de minitel 1B, juste une pyramide.

Il faudra essayer pour le Minitel, je sais que certains se connectaient sur les Sofrel ancienne série sur une prise en T classique avec leur Minitel.

Pour les composants je suis capable de lire les refs, mais bon pour le coup j'ai loupé le processeur.

Les deux puces avec une étiquette dessus ne sont-elle pas des EPROM? Si c'est le cas, on peut espérer qu'il reste le programme de base dessus.

Je verrais ça en fin de semaine, pour le moment je suis trop occupé :D c'est pas comme si cet automate allait se sauver de toutes façons. Mais ce serait sympathique de le mettre en route. Ca fait aussi partie du patrimoine électronique. C'est dommage d'ailleurs, j'ai dû louper à deux semaines près la mise au rebut d'un Télémécanique TSX7, une machine bien connue celle-là...

Avatar du membre
Papy.G
Modérateur
Messages : 1729
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: Un automate industriel?

Message par Papy.G » 20 juin 2016 21:05

Si ta "Pyramide" est un Magis (avec lecteur de carte) :lol: , ça le fait, c'est plus récent que M1b.

Tu verras, avec un peu d'habitude, tu arriveras à repérer les références, et à les différencier des datecodes. :mrgreen:

Tu as bien vu pour les eproms (la ref. commençant par 27 indique ce type de composant), c'est les 2x32kO de Rom dont j'ai parlé. :wink:

Je serais curieux de savoir ce qui anime les automates de la grande famille des TSX7, malgré que j'en ai vu pas mal (et même de la famille des TSX1), je n'en ai jamais ouvert. :cry:

Par ailleurs, je n'y connais pas assez, mais peut-être la machine est basée sur un bus standard que d'autres sauront identifier le cas échéant, et alors il sera possible de faire autre chose de ce matériel sans le modifier énormément.
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
Totor le Butor
Messages : 1385
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: Un automate industriel?

Message par Totor le Butor » 20 juin 2016 21:09

Tu dois pouvoir prendre la main sur le système en connectant un PC avec Hyperterminal sur la prise série.

Par contre méfiance sur le câblage de la prise série car on voit bien sur la photo sur la broche 10 de la prise série une piste plus grosse qui peut être du 5 ou 12v peut être pour alimenter le modem (la 7 et la 9 sont à la masse).

Tu peux essayer en câblant simplement les broches 2, 3 et 7 (Tx, Rx et masse) mais, plus vraisemblablement il te faudra câbler aussi les RTS,CTS (controle de flux de la liaison série)et DSR,DTR (contrôle de la liaison modem distante). Pour le câblage Google est ton ami :wink: .

Essaye en 300 et 1200 bauds en 8 bits un stop et sans parité, ce sont les paramètres habituels pour ce type de liaison.

Le modem ne serait pas un Digitelec par hasard ?
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Re: Un automate industriel?

Message par Lesarthois » 20 juin 2016 21:29

Oui, c'est un Digitelec. J'ai tenté une photo mais elle n'est pas bonne, trop floue, donc non incluse.

Google est mon ami, en effet, mais s'il n'y avait ne serait-ce qu'une marque sur ce boîtier, je saurais ou regarder :D
Mais Sinergie ne renvoie à rien, évidemment, et la mention CGE 1200 notée à la main non plus.

Avatar du membre
Totor le Butor
Messages : 1385
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: Un automate industriel?

Message par Totor le Butor » 20 juin 2016 22:05

A mon avis tu ne trouveras rien sauf mega coup de chance car la fabrication semble quasi artisanale même si elle très propre. Pour Google je parlais uniquement du câblage d'une prise série.

Si tu peux mettre la main sur un programmeur d'Eprom il serait intéressant de la lire l'Eprom de gauche intitulée CGE 2100 TEXTE, elle pourrait contenir ...du texte affiché lors de la communication.

A propos, il y a aussi un convertisseur analogique/digital 8 canaux ce qui veut dire que ton bidule peut surveiller 8 dispositifs analogiques genre température, pression, niveau d'eau, vitesse du vent etc...
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Lesarthois
Messages : 131
Enregistré le : 13 mai 2016 22:21

Re: Un automate industriel?

Message par Lesarthois » 20 juin 2016 22:22

Oui, vu qu'il y a une plaque fabricant mais vide, ça ressemble à du fait maison. Ce qui explique aussi que les quelques personnes que j'ai pu interroger ne sachent rien de ce boîtier.

pour les entrées, comme il vient d'une entreprise de distribution d'eau, ce boitier surveillait certainement des paramètres liés à l'eau. Et vu l'état extérieur, il était probablement dans une station, ce qui expliquerait la présence de 8 entrées analogiques.

En général dans un château d'eau on se contente d'un niveau haut/niveau bas + alerte marnage (on touche le fond :D) donc 4 entrées numériques suffisent.
De plus en plus vu la taille des automates/boîtiers communicants on met une sonde au lieu des poires mais ce n'est pas encore généralisé.

En revanche sur une station de production d'eau potable, ou une station d'épuration (d'après ce que j'ai vu dans d'autres entreprises, l'épuration est plus automatisée... Les contrôles sont aussi stricts, mais l'impact sur l'image de la société est moins important si on rejette de l'eau sale que si on fait boire de l'eau contaminée :D ) du coup on peut trouver plusieurs sondes de niveau pour les différents bassins, la pression en effet même si c'est rare... Pour une station d'eau potable, des sondes de turbidité et de PH, mais je ne saurais pas dire s'il y en avait déjà il y a 20 ans.

Pour les EPROM, malheureusement je n'ai rien de tout ça chez moi... Je suis plus un "mécano de l'électronique" :mrgreen:

Répondre