Plan récup Amiga 500

Pour épater ses petits camarades en présentant sa dernière merdouille ou son super bon plan.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
fneck
Site Admin
Messages : 12018
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Plan récup Amiga 500

Message par fneck » 05 déc. 2016 10:13

Falkor a écrit :Quelle est la fonction de cette pièce en plastique ? Au bout du bras à gauche, un doigt vient frotter sur le coté de la disquette lors de l’insertion/retrait
Je pense qu'il s'agit du mécanisme d'ouverture de la trappe métallique de la disquette.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 05 déc. 2016 10:35

Nan, l'ouverture de la trappe est réalisée par la pièce métallique en forme de "L" juste en dessous (qui pivote). Là la pièce en plastique dont je parle possède juste un petit doigt qui vient presser sur le coté de la disquette.

Bon dans tout les cas je ne vais pas chercher à me prendre la tête avec le lecteur, j'ai l'intention de mettre un gotek à la place. Tout est expliqué ici. :)

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 déc. 2016 09:20

Bon, hier soir c'était première mise sous tension ! :)

Vérification des tensions de l'alim à vide. Je n'avais pas pile poil 12, -12 et 5V, mais j'étais à ±1V. (mesure à vide, donc je me dit que c'est dans les normes).

Branchement d'une télé sur la sortie composite (noir et blanc) et branchement du clavier uniquement. Démarrage. J'ai une succession d'écrans gris de plus en plus clairs (il me semble qu'à chaque écran correspond une étape de test ?), mais le système fige sur un écran blanc.

Bon je me dit qu'il ne doit pas aimer l'absence du lecteur de disquettes. Je le branche, mise sous tension et hop ! Écran du kickstart ! (V1.3). En noir et blanc forcément (je n'ai pas encore reçu le matériel pour me fabriquer le câble péritel couleur :mrgreen: ).

Bon par contre le lecteur de disquette n'a pas réagi du tout, même avec une disquette (DD je précise) à l'intérieur :( . Aucun bruit ni mise en rotation du disque. Je n'ai pas vérifié si les tensions arrivaient correctement (après l'amiga semble le détecter car sans lui il ne bootait pas) mais il est sans doute bien malade. Bon pas si grave, je suis en attente de la réception d'un gotek.

Je n'ai pas testé le clavier encore...

A suivre !!
Fichiers joints
DSC_2758.jpg
DSC_2758.jpg (72.56 Kio) Vu 1108 fois

__sam__
Messages : 3991
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Plan récup Amiga 500

Message par __sam__ » 07 déc. 2016 09:40

oui les gris correspondent aux différents tests par la ROM. Voici la liste de ce qu'il se passe au boot:
1. Clear all chips of old data
2. Disable DMA and interrupts during the test.
3. Clear the screen.
4. Check the hardware ....checks to see if 68000 is functioning.
5. Change screen color.
6. Do a checksum test on all ROMS.
7. Change screen color.
8. Beginning of system startup.
9. Check RAM at $C0000,and move SYSBASE there
10. Test All CHIP RAM.
11. Change screen color.
12. Check that software is coming in ok.
13. Change screen color.
14. Setup CHIP RAM to receive data.
15. Link the libraries
16. Check for additional memory and link it
17. Turn the DMA and interrupts back on.
18. Start a default task.
19. Check for 68010,68020, and or 68881.
20. Check to see if thee is an exception ...processor error
21. If so do a system reset.
(http://www.amicue.org/TechStuff/amigaboot.html)
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 09 déc. 2016 17:58

Super merci !

Je viens de remonter la bête. Je me suis juste fait avoir sur la mise en place du blindage : obligation de brancher la nappe du lecteur de disquettes et son alim. :-P

Souci toutefois que je n'avais pas remarqué avant le démontage : l'unité centrale est extrêmement bancale ! L'un des pieds est 3 mm plus haut que les autres. Je ne pense pas m'être trompé lors du remontage... Tout semble clipsé comme il faut.

J'avais nettoyé les plastiques à l'eau chaude, mais pas bouillante non plus. Vous pensez que le problème pourrait venir de là ? Une déformation ?

Une idée pour le redresser ? Je peux mettre quelques livres dessus en attendant... ! ;-)

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 14:09

Bon j'ai un souci avec l'émulateur gotek. :-(

J'ai flashé l'appareil avec la dernière version du firmware suivant cette méthode : https://cortexamigafloppydrive.wordpress.com/

Puis j'ai installé le lecteur en lieu et place du lecteur de disquette physique de mon a500.

Je place à la racine d'une clé USB le fichier adf nécessaire au boot, et j'ajoute quelques fichiers adf en plus.

Mise en route : rien ne se passe. Le lecteur affiche bien "000", et une action sur les touches plus ou moins provoquent l'affichage de petits tirets (je pense que c'est dû au fait que les autres slots n'ont pas été affectés.)

Sur l'écran je n'ai rien d'autre que l'affichage de la disquette du kickstart.

Le voyant vert du "drive" reste allumé en permanence. J'ai tenté plusieurs marques de clés USB, même résultat.

J'ai la désagréable impression qu'il ne détecte pas le lecteur de disquettes... Quoique, un boot avec le lecteur débranché fait planter le boot, on reste sur un écran gris.

J'ai également une grosse incertitude sur le sens de branchement de la nappe... Le trait rouge, c'est pour indiquer le fil "1" ?

Une idée ? Quelqu'un possède-il un amiga avec un gotek ?

Merci ! ;-)

Daniel
Messages : 10326
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Plan récup Amiga 500

Message par Daniel » 07 janv. 2017 15:35

Falkor a écrit :Le voyant vert du "drive" reste allumé en permanence.
C'est le coup classique quand la nappe est à l'envers.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 17:17

Le gotek reste également complètement inerte nappe branchée dans l'autre sens.

Par contre, le lecteur de disquettes physique qui pour l'instant n'avait jamais donné signe de vie à un autre comportement si nappe inversée : au boot la led du drive est éteinte, cette dernière s'allume si on introduit une disquette.

Le disque ne tourne jamais. J'entends également vers la tête un "tic ... tic" environ une fois par seconde quand le lecteur est vide !

Et l'image de la disquette du kickstart disparaît quand on introduit une disquette !
Le bruit également. Et le voyant passe au vert fixe.

Il y a un risque d'esquinter un contrôleur ou un lecteur en branchant une nappe à l'envers ? :-(

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 17:29

Je viens de rouvrir le capot du lecteur de disquette.

C'est bien la tête qui translate de 1 mm environ, puis une seconde après recule d'autant, puis recommence.

Ce mouvement s'arrête quand on introduit une disquette. (Et le voyant drive reste vert fixe )

Ce comportement est-il... normal ? :-S

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 17:55

Bon, j'ai considéré que ce sens était le bon, j'ai réinstallé le gotek.

Mise en route, après quelques minutes d'écran blanc j'ai eu cet étrange message :
DSC_2855-1.jpg
DSC_2855-1.jpg (41.63 Kio) Vu 1004 fois
Un clic sur la souris n'ayant rien résolu, je reboote, mais je n'ai plus jamais revu ce message.

À votre avis, ce message vient de l'amiga ou du gotek ???

Merci de vos lumières... ! Je comprends de moins en moins bien... :-(

Daniel
Messages : 10326
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Plan récup Amiga 500

Message par Daniel » 07 janv. 2017 18:05

Guru Meditation, c'est l'une des expressions favorite de l'Amiga, pas du Gotek :wink:
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 18:29

Aïe... Mon amiga aurait-il un grave problème... ?

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Plan récup Amiga 500

Message par petitjd » 07 janv. 2017 18:43

En l'occurrence c'est une erreur d'adresse.
Il y a quelque chose qui ne lui revient pas à 3342.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 janv. 2017 19:06

Je peux certainement regarder la memory map pour déterminer l'origine ?

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Plan récup Amiga 500

Message par petitjd » 07 janv. 2017 19:21

PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Répondre