Plan récup Amiga 500

Pour épater ses petits camarades en présentant sa dernière merdouille ou son super bon plan.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 10 févr. 2017 13:51

Suite de l'aventure...

J'ai pu récupérer un autre A500 grâce à ENMM (merci à lui !! :) ).

Ouverture et prélèvement du lecteur de disquettes. Nettoyage des têtes à l'alcool. Installation dans le premier A500. Mise sous tension : j'ai bien le "clac clac" habituel. Introduction d'une disquette (HD) vierge pour faire un test, youpi mise en rotation du disque.

Introduction d'une disquette de workbench. Ça mouline ! Après quelques secondes, j'ai toutefois un écran avec une fenêtre affichant un read error. Depuis, impossible de le faire rebooter, j'ai certainement tué la seule disquette bootable que j'avais. :cry:

L'introduction d'une disquette dans le nouveau lecteur fait bien cesser le clac clac et met le disque en rotation, mais rien d'autre.

Retenté un nettoyage de tête, sans succès. Une idée de quoi tenter d'autre ?

Les hypothèses sont :
-j'ai tué la disquette de workbench
-le lecteur de D7 est lui aussi HS
-la CM est HS

Je ne penche pas pour la dernière option. J'ai quand même eu une fenêtre graphique digne de ce nom.

Pour le gotek, il a probablement grillé lors du branchement à l'envers de la nappe. J'attends son remplaçant.

Est-il possible qu'une carte mère puisse griller en série des lecteurs ? L'alimentation (5v et 12v) sont correctes sur le connecteur du lecteur.

Mica60
Messages : 189
Enregistré le : 20 avr. 2016 00:28

Re: Plan récup Amiga 500

Message par Mica60 » 10 févr. 2017 16:10

Cause possible, la disquette de boot que tu as utilisé est HS, celle-ci a mal vieilli et le disque a durcis.

Lorsque tu la mets dans ton lecteur elle fait du bruit suite au frottement du disque qui est devenu rigide et
cela encrasse la tête de lecture.

Tu as eu le bon réflexe, nettoyer la tête de lecture de nouveau ( celle-ci doit être nickel, reflet parfait a contre jour ).

Malheureusement, ta disquette de boot est inutilisable :( (direction poubelle pour ne pas te faire avoir une nouvelle fois et devoir nettoyer de nouveau ta tête de lecture) , mais je pense que tu peux en recréer une avec un PC équipé d'un lecteur de disquette et d'un OS windows XP ou inférieur, grâce notamment à l'utilitaire Omniflop.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 24 févr. 2017 09:40

Recu hier le nouveau gotek. Flashage et installation dans l'A500 en faisant attention au sens de la nappe. Echec. Toujours le même comportement : j'ai bien la led d'activité du lecteur qui s'allume, mais elle reste fixe.

J'ai décidément pas de chance avec le matériel 16 bits :cry:

__sam__
Messages : 3991
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Plan récup Amiga 500

Message par __sam__ » 24 févr. 2017 11:15

Le CIA qui pilote le lecteur de D7 ne serait-il pas mort ? (ou mal enfoncé)
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 24 févr. 2017 11:22

Parmi les tests que j'ai pu effectuer, j'ai eu un demi boot du workbench avec un vrai lecteur de disquettes qui a dû tuer la seule disquette de workbench que j'avais (apparition d'une fenêtre du CLI et message read error, retry cancel). Ça me laisse à penser que le contrôleur fonctionne...?

J'ai un second A500 qui ne boote pas (pour l'instant) qui me permettra de faire des permutations de composants. Mais pas trop le temps de me lancer dans de la grosse chirurgie.

J'avais testé la nappe qui me paraissait correcte. Je vais quand même voir si je n'arrive pas à en trouver une autre pour faire un autre essai.

Le 12 et 5v sont corrects. (mesure effectuée au niveau du connecteur du lecteur de D7)

Avatar du membre
farvardin
Messages : 356
Enregistré le : 27 déc. 2014 16:07
Contact :

Re: Plan récup Amiga 500

Message par farvardin » 24 févr. 2017 22:37

je ne peux pas trop t'aider pour le problème avec l'Amiga, par contre pour le premier gotek, ça m'étonnerait qu'un branchement de la nappe à l'envers ait pu le griller. Ça fait quoi si tu reflashes le lecteur ? D'autre part si j'ai bien compris tu as utilisé le firmware cortex. Si tu essayer de flasher le HxC, tu pourras essayer ce lecteur sur d'autres machines (plus robustes qu'un fragile Amiga :mrgreen: ), genre Atari ST, pour tester son état.

D'ailleurs (avec le firmware HxC), j'ai essayé plusieurs fois les divers sens de nappe parce que cela ne fonctionnait pas au début, j'ai mis également trop de tensions dans le gotek, et malgré tous ces mauvais traitements, il fonctionne encore correctement une fois que j'ai trouvé le bon sens (j'ai eu de la chance pour le survoltage, c'est la clé usb qui a tout pris).

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 27 févr. 2017 10:49

farvardin a écrit :Ça fait quoi si tu reflashes le lecteur ?
Le gotek reste complètement inerte si branchement d'une alim. Pas de led ni affichage sur les 7 segments. Je n'ai pas cherché à tracer les alims pour savoir si les composants sont bien alimentés.
farvardin a écrit : D'autre part si j'ai bien compris tu as utilisé le firmware cortex. Si tu essayer de flasher le HxC, tu pourras essayer ce lecteur sur d'autres machines (plus robustes qu'un fragile Amiga :mrgreen: ), genre Atari ST, pour tester son état.
C'est prévu !! Coté atari justement, il faut formater la clé usb avec l'utilitaire gotek ? (création de X partitions). Comment ça fonctionne exactement ? Sur Amiga tu as juste à déposer tes fichiers images ADF et un fichier SELECTOR maoitre, et c'est tout.

J'ai plié les amigas en vue de mon déménagement imminent, je vais voir si j'ai le temps de m'occuper de flasher le HxC pour mon ST.
Et j'ai d'autres machines qui arrivent en principe cette semaine.... :)

Avatar du membre
farvardin
Messages : 356
Enregistré le : 27 déc. 2014 16:07
Contact :

Re: Plan récup Amiga 500

Message par farvardin » 27 févr. 2017 21:43

il y a plusieurs modes de fonctionnement. En gros le plus pratique c'est d'envoyer des images disquettes sur des "slots" virtuels (à préparer avec l'utilitaire), ensuite tu changes de slot avec les boutons du gotek (et les numéros associés), comme si tu changeais de disquette. Il y en aurait un autre (que je n'ai pas testé) où tu n'as qu'un slot mais tu peux copier les fichiers sur la clef comme si c'était une disquette, sans passer par l'utilitaire.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 mars 2017 13:25

Flashé le Gotek avec le firmware, c'est plus simple que je ne le pensais. L'opération à fonctionné du premier coup. Tests ce soir sur le ST quand j'aurais préparé la clé USB.
farvardin a écrit :En gros le plus pratique c'est d'envoyer des images disquettes sur des "slots" virtuels (à préparer avec l'utilitaire)
Cet utilitaire, c'est celui fourni avec le gotek ? Rien ne semble fourni pour le HxC...?

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 07 mars 2017 17:42

Bon décidément les 16 bits ne me réussissent pas... :-(

Le gotek fraîchement flashé n'est pas reconnu par le St... Je reste sur un écran blanc, pas de bureau. Attention, sans clé USB. Cette dernière n'étant pas encore formatée. J'espère que c'est ça...

Après j'imagine mal que le système refuse de booter sans clé... ?

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 08 mars 2017 08:18

Bon je retire ce que j'ai dit dans le message précédent. Une bonne lecture des manuels m'a permis de correctement configurer l'ensemble. Bon pour ma défense je peux dire que c'est quand même mal expliqué, il faut aller chercher plein de fichiers readme un peu partout, et d'abord faire une mise à jour du HxC avant de préparer la clé pour la machine concernée. Et là encore, il faut un utilitaire de conversion pour préparer les images disquettes dans mon cas du St.

Mais ça fonctionne ! :)
DSC_3087.jpg
Démo !!
DSC_3087.jpg (99.12 Kio) Vu 1053 fois
Du coup ça m'a motivé à ressortir mon A500 de son carton pour faire un essai...!

__sam__
Messages : 3991
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Plan récup Amiga 500

Message par __sam__ » 08 mars 2017 08:29

Monkey Island est N&B sur ST ? :shock:
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 08 mars 2017 08:51

__sam__ a écrit :Monkey Island est N&B sur ST ? :shock:
Non, c'est uniquement mon écran ! :) (Un SM125)

Je pense investir dans le câble couleur, d'autant plus que j'ai un autre ST qui va arriver.

Avatar du membre
farvardin
Messages : 356
Enregistré le : 27 déc. 2014 16:07
Contact :

Re: Plan récup Amiga 500

Message par farvardin » 08 mars 2017 23:34

bravo !
oui, le site est compliqué et un peu fouilli. L'utilitaire hxc permet de créer et gérer ces slots, mais je pense que tu as déjà tout trouvé.

Avatar du membre
Falkor
Messages : 597
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Plan récup Amiga 500

Message par Falkor » 09 mars 2017 08:44

Bon, je ne cache pas une certaine émotion, j'ai ENFIN réussi à ressusciter mon A500. :)

Conforté dans l'idée que le gotek fonctionne grâce à mes essais sur le St, j'ai réinstallé ce dernier dans l'A500. Comportement similaire à d'habitude : voyant d'activité disque vert fixe, et écran blanc statique. (nappe branchée dans le bon sens :mrgreen: ).

Démontage des blindages, ré-appui sur les circuits et les différents connecteurs pour tenter de faire évoluer le comportement. Aie, après un redémarrage, plus d'activité sur le lecteur. (Voyant ne s'allume plus). Mais preuve que quelque chose ne va pas à ce niveau.

J'ai fini par retirer le CI de ROM que je n'avais pas pu retirer lors du premier démontage (mal situé et mal outillé, je ne l'avais pas retiré). Avec infinies précautions, j'arrive à le retirer (non sans malheureusement tordre quelques pattes.) Grattage et redressage des pattes, réinsertion dans le support. Mise en route : le voyant d'activité se met à clignoter. Allumage de l'écran, youpi j'ai enfin accès au menu de sélection des images. Un petit reboot après réglage des slots, victoire, il démarre !

Bon seuls bémols : mon câble couleur péritel ne fonctionne pas. (Utilisation de la sortie composite N&B pour le moment) et certaines touches du clavier ne répondent pas, je suis bon pour le redémonter (je voulais faire dire des trucs au "Say" du workbench). Son nickel toutefois, j'ai tout de suite retrouvé la joie de rejouer à mes anciens jeux. Sur émulateur, ça n'a pas la même saveur. :)

Merci à tous pour vos conseils en tout cas, il me reste encore un petit peu de boulot sur cette machine, mais au moins elle démarre !
Sans parler de l'adaptation mécanique du gotek dans la machine qu'il va falloir étudier. On trouve plein d'exemples sur le net, chacun ayant ses avantages et défauts (modifications du gotek ou des capots des machines.). En tout cas, je note d'investir dans un outil permettant l'extraction des CIs sur support. Le double tournevis plat ayant pour le coup montré ses limites.

A suivre...!

Répondre