494 résultats trouvés

par joaopa
16 mai 2020 08:24
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

0 signifie de face?
par joaopa
16 mai 2020 07:29
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

A quoi correspondent les diverses valeurs de D?

En outre, pouvez-vous tester les déplacements du joueurs (creusage, changement de tableau, rejouer, compteurs..... la totale quoi) :roll: Ce serait encore mieux si c'était sur un VRAI VG5000.
test.zip
(25.96 Kio) Téléchargé 8 fois
Le listing:
RUNNER.LST.zip
(28.3 Kio) Téléchargé 8 fois
par joaopa
16 mai 2020 05:14
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

@Guillaume: As-tu eu le temps de programmer le mode CHASE? une autre question: pourquoi quand stickx est actionné vers la droite (ligne 500), il y a un test pour D (D=0 ou D=2) et il y en n'a pas pour stickx actionné vers la gauche? Encore un bug: en position initiale, creusez un trou en dessous. To...
par joaopa
15 mai 2020 23:04
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

En ligne 571, il y a un goto. Comment fait-on pour atteindre la ligne suivante (ligne 585)?
par joaopa
15 mai 2020 21:59
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

La ligne 585 se termine par un return. A quel gosub correspond-il? Ne s'agit-il pas d'un GOTO? Et si oui GOTO quelle ligne?
par joaopa
15 mai 2020 19:38
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

@Xavier: As-tu modifié les tableaux de Guillaume. Dans le tableau 2, je peux monter entre les échelles (celles tout à droite) avec ton fichier. Avec le fichier de Guillaume, on ne peut pas. EDIT: Après avoir compris le tableau, je pense qu'il y a un bug dans ton code Xavier (et dans le mien aussi :m...
par joaopa
15 mai 2020 05:52
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

Quelqu'un peut-il confirmer que le dernier caractère définissant le tableau est Z (ascii=90), le premier du deuxième tableau est % (ascii=37)?
par joaopa
14 mai 2020 21:56
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

Il y a un bug dans la version BASIC de Lode Runner ligne 573 Si on touche un ennemi alors que celui ci est en sa position initiale alors il n'est pas réaffiché puisque ses coordonnes sont ses originales et celle du joueur. La ligne 573 devrait être en 568. Je m'en suis rendu compte, puisque pour l'i...
par joaopa
13 mai 2020 19:01
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

justement la dernière ligne est cassable.
par joaopa
13 mai 2020 18:44
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

J'ai testé avec le programme BASIC. La dernière ligne de briques est creusable. Bug?
Par contre on ne peut aller dans la ligne jaune.
par joaopa
12 mai 2020 22:02
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

Bonsoir, quelqu'un pourrait-il essayer ce test sur un VRAI VG5000? Le test est simple: il s'agit de savoir s'il se passe des trucs tordus sur les bords du tableau . Une fois que vous êtes sur l'échelle tout à doite, tapez frénétiquement sur la touche droite. Voyez-vous le joueur disparaître et faire...
par joaopa
09 mai 2020 23:57
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

En assembleur la difference est énorme!! Voir mes galères dans les messges précédents :roll:
par joaopa
09 mai 2020 19:56
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

Il y a une colonne 0 en BASIC. On compte de 0 en 39. Si on commence en 0 (ce qui est permis), le basic fait en plus un delim.
par joaopa
09 mai 2020 18:19
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

@Guillaume: Peux-tu confirmer que dans les lignes 142 et 143, CURSORX=30 devrait être CURSORX=31?
par joaopa
09 mai 2020 18:11
Forum : Développements actuels
Sujet : [VG5000] Lode Runner
Réponses : 225
Vues : 4153

Re: [VG5000] Lode Runner

Ouf!! Enfin. Formellement, j'avais résolu le problème dès le message où j'expliquais le remplissage des registres de l'EF9345. Le probleme des briques et du message LODE RUNNER étaient du au problème du CURSORX=30 qui devrait être CURSORX=31.

En tous cas, merci Carl pour les tests et ta patience