Panne Lecteur K7 Thomson MO5 [Résolu]

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Panne Lecteur K7 Thomson MO5 [Résolu]

Message par btr » 11 sept. 2018 00:19

Bonjour à tous,

(Vous pouvez passer ce paragraphe)
Sur les doigts d'une main, je pourrais compter le nombre de fois que j'ai du toucher à un MO5 dans ma jeunesse. Mais peu importe, je n'avais pas de préférence, tant que je pouvais taper au clavier d'un ordi, j'étais aux anges (TI-99/4A, cpc, amiga etc.).
Cependant le MO5 est peut-être le 1er ordinateur que j'ai pu approcher sans en avoir un super souvenir. Pour mieux comprendre l'expérience que j'avais peut-être raté (en bon ou mauvais), j'ai fait l'acquisition il y a plus 15 ans de quelques pièces que je viens à peine de déballer (MO5 classique, clavier mou et platini).

(Celui-ci aussi)
Malheureusement tout n'est pas fonctionnel. Je n'ai aucun problème pour démonter les appareils, par contre niveau électronique, je dois avoir des branchements manquant dans mon cerveau, je n'y comprends rien, mais vraiment rien, j'ai honte. Dans un moment de folie j'ai acheté un multimètre et... voilà ! Eh oh, ça va hein ? j'ai quand même "réparé" un platini, seules quelques touches fonctionnaient. Bon il suffisait d'insérer correctement les nappes, mais c'est réparé !

(Enfin, Le problème)
Bref, maintenant que j'ai un MO5 fonctionnel, je prends confiance et je branche le lecteur k7. Play, rembobinage, tout est ok. Allez un RUN" : "Searching" jusqu'à la fin de la k7. P'tin c'est quoi ce voyant rouge allumé ?. Je suis tombé par hasard sur votre forum et un topic que je ne retrouve plus qui relatait le même problème. Il s'agissait d'un pb mécanique, une sorte de levier mal monté. Du coup j'ai peut-être effacé le peu de k7 que j'avais car le voyant correspond au mode enregistrement :( . J'ai remis en place le levier associé à la touche rec. Coté mécanique tout à l'air Ok.
C'est maintenant que ça se corse. Depuis la "réparation", je n'ai plus le voyant rouge mais plus rien ne tourne, même à vide. La courroie semble correcte. Le lecteur semble alimenté, j'entends l'alim ronronner.
J'ai testé avec un autre lecteur, pas de chance, j'ai le même pb.
Si je branche le lecteur qu MO5 j'ai forcément un error 60.

C'est là que j'ai besoin de vous et de vos connaissances. J'aimerais bien comprendre un peu et pouvoir remettre en l'état tout ce matériel. (j'ai aussi un MO5 qui me fait un écran jaune au démarrage, mais ne mélangeons pas tout).

Si y il a besoin de mesurer quoique ce soit avec le multimètre, je suis chaud bouillant, mais attention, niveau -5 en matière d'éléctro, va falloir être précis, photos/schéma/vidéo fortement conseillées si possible.

Merci d'avance.
Modifié en dernier par btr le 08 oct. 2018 19:55, modifié 1 fois.

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 11 sept. 2018 09:23

J'ai très peur pour le contenu de la cassette. Avec le voyant rouge allumé, elle a du être effacée.

L'erreur 60 indique qu'il n'y a pas la tension prévue sur la broche "data in" du MO5. Si en plus rien ne tourne et aucun voyant ne s'allume, c'est probablement un problème d'alimentation : soit un fil dessoudé, soit un mauvais contact, soit une panne plus grave.

Pour le diagnostic un simple voltmètre suffit. Commencer par mesurer à la sortie du transformateur (17,5 V alternatif), à l'entrée du régulateur 7812 (17V continu), à la sortie du régulateur (12V continu). Il y a de fortes chances que le problème soit à ce niveau, sinon il faudra chercher plus loin sur le circuit imprimé. A priori ce n'est pas grave et facile à réparer.

Image

Une remarque en passant : si le levier de commande du commutateur était sorti de son logement, c'est parce que le magnétophone a été démonté et mal remonté. Et s'il a été démonté, c'est qu'il avait des problèmes. Donc, même en réparant l'alimentation, ça ne suffira pas. Il faudra certainement chercher et réparer la panne originale. Tous ces problèmes mécaniques et électroniques, sans compter les temps de chargement très longs, poussent la plupart des utilisateurs à délaisser les lecteurs de cassettes au profit d'autres périphériques plus fiables et plus rapides.
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 12 sept. 2018 01:30

Merci beaucoup pour votre aide.

J'ai peur aussi pour les K7, je verrai quand tout fonctionnera :)

Sinon bravo pour le diagnostic. Effectivement y avait un fil dessoudé, celui qui part de l'alim vers la carte.
20180911_224328.jpg
20180911_224328.jpg (104.54 Kio) Vu 317 fois
J'ai du dessoudé l'autre pour pouvoir dénudé correctement les 2 fils avant de les ressouder. J'ai un peu galéré pour passer les fils dans les trous. Manque d'expérience. Du coup j'ai repercé les trous avec une aiguille tout en faisant fondre l'étain de l'autre coté. A partir de là c'était plus simple car je pouvais passer les fils à travers le circuit.
Je remonte le lecteur, je branche... rien ! J'ouvre à nouveau, P***n ! c'est maintenant du coté de l'alim que ça s'est dessoudé. Je ressoude (là aussi il faut retirer les anciennes soudures et refaire le trou pour faciliter le passage des fils qui sont très fins), je rebranche et là 8) 8) 8) ça tourne ! play, av rap, rec avec le voyant, tout semble nickel.

Bon là il se fait tard, madame n'est pas contente, j'ai foutu le bordel dans la maison pour retrouver mon fer à souder du lycée. Demain je check le lecteur avec le MO5 (j'espère que ça va fonctionner !).

Encore merci.

Il est vrai que je ne vais pas me servir beaucoup du lecteur, mais au moins juste pour tester les 2-3 k7 en ma possession et vivre l'expérience. Et puis ça me fait plaisir d'avoir du matos qui fonctionne et que j'ai (peut-être) pu réparer.
J'ai vu que vous aviez créé le SDDRIVE, c'est excellent. J'en commanderai sûrement un. Je suis impressionné par autant de maitrise hardware que software. Bravo !

Pour mon deuxième lecteur, pas de fil débranché. Je vais donc essayer la mesure à la sortie du transformateur mais je posterai une photo pour être sûr de savoir où placer les pointes de touche.
D'ailleurs, avec le multimètre, je dois me positionner en volt continu ou alternatif (comme on a du alternatif en entrée et du continu en sortie ???) ? (Ouais, j'en suis à ce niveau...)

@+
Modifié en dernier par btr le 13 sept. 2018 22:37, modifié 1 fois.

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 12 sept. 2018 07:59

A la sortie du transformateur, il faut mettre le multimètre en mode Voltmètre alternatif (calibre entre 20V et 200V, selon le type de multimètre).
Pour toutes les autres mesures en aval (après le pont de diodes), mode Voltmètre continu (calibre 20V).
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 13 sept. 2018 22:43

Pour info, le 1er lecteur fonctionne parfaitement. J'ai pu charger et jouer à Numéro 10 ainsi qu'à Meurtre à grande vitesse.

Par contre, j'ai perdu Super Tennis et Karaté :( à cause problème du levier qui était mal remonté.

Je vais vais essayer vos reco pour le deuxième lecteur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 14 sept. 2018 00:26

Daniel a écrit :
12 sept. 2018 07:59
A la sortie du transformateur, il faut mettre le multimètre en mode Voltmètre alternatif (calibre entre 20V et 200V, selon le type de multimètre).
Pour toutes les autres mesures en aval (après le pont de diodes), mode Voltmètre continu (calibre 20V).
J'ai mesuré à la sortie du transfo, est-ce que j'étais bon pour le placement des pointes de touche ?
20180914_000745.jpg
20180914_000745.jpg (295.27 Kio) Vu 308 fois
20180914_000721.jpg
20180914_000721.jpg (240.38 Kio) Vu 308 fois
Si c'est ok, j'avais du 2,5 V, donc on est loin du 17,5 V attendu.
Le transfo était super chaud. Juste le temps de prendre les mesures, même pas 5min, je veux bien que ça chauffe mais là, je ne sais pas si c'est normal.

Pour la deuxième mesure, après le pont de diodes, je ne suis pas vraiment sûr :
20180914_000816.jpg
20180914_000816.jpg (604.67 Kio) Vu 308 fois
Là, j'avais 0 V. Je suppose que c'est normal vu ce que j'avais en sortie du transfo.

J'ai démonté le transfo, à vu d’œil il est nickel. Soudures, bobines propres.
Est-ce possible qu'il soit "grillé" ? il est possible de le remplacer ?

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 14 sept. 2018 08:02

Ces mesures montrent un court-circuit, soit dans le circuit d'alimentation, soit plus loin dans l'électronique du lecteur.
Première précaution : ne plus rebrancher le lecteur tant que la cause du court-circuit n'est pas identifiée, pour ne pas risquer d'abîmer d'autres composants (en particulier le transformateur, le pont de diodes et le régulateur).

Une première inspection visuelle permet de détecter un éventuel contact entre deux pistes du circuit (par exemple un pont de soudure).

Ensuite il faut procéder méthodiquement, en testant un par un les composants susceptibles de provoquer le court-circuit. Pour cela il faut mettre le multimètre en position ohmmètre, calibre 2000 ou 20K. Commencer par mesurer la résistance aux bornes du composant sans le dessouder :
- Chacune des quatre diodes du pont de diode (dans un sens, puis dans l'autre en inversant les pointes de touche).
- Le régulateur 7812 entre les broches 1 et 2, puis entre les broches 3 et 2 (pointe de touche noire sur la broche 2).
- Le régulateur 7812 entre les broches 1 et 3 (pointe de touche noire sur la broche 3).

Selon les résultats de ces mesures on verra pour la suite...
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 16 sept. 2018 21:42

Hello,
- Pour les 4 diodes avec le calibre "diode" du multimètre j'ai des valeurs entre .630 et .660 (COM sur la cathode, idem si j'inverse). D'ailleurs à quoi correspondent ces valeurs ?
Avec le calibre sur 2K, 20K, j'ai tjrs 1. Sur 200k là j'obtiens des valeurs qui montent entre .170 et .190 puis reviens à 1. (C'est normal ça non ?) Si j'inverse ça va de .120 à .140. Mais ça change à chaque mesure.
20180916_212104.jpg
20180916_212104.jpg (248.78 Kio) Vu 261 fois

- Pour régulateur 7812 (celui positionné verticalement et collé à une sorte de radiateur non ? visuellement il à l'air propre), si je ne me trompe pas la broche 1 est celle en sortie de la diode du pont de diode, la 2, celle du milieu (la cathode ?) et ensuite la 3 :

- entre les broches 1 et 2 (pointe de touche noire sur la broche 2 au milieu) : calibre diode -> .001, calibre 20k : 0.01 (il est là le pb non ?)
20180916_211814.jpg
20180916_211814.jpg (362.17 Kio) Vu 261 fois

- Pour régulateur 7812 entre les broches 3 et 2 (pointe de touche noire sur la broche 2 au milieu) : calibre diode -> .701, calibre 20k : 2.29
20180916_211853.jpg
20180916_211853.jpg (447.43 Kio) Vu 261 fois

- Pour régulateur 7812 entre les broches 1 et 3 (pointe de touche noire sur la broche 3) : calibre diode -> .670, calibre 20k : 2.29
20180916_211917.jpg
20180916_211917.jpg (460.03 Kio) Vu 261 fois
Qu'en pensez-vous ?

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 17 sept. 2018 08:22

Il n'est pas toujours possible de contrôler des composants sans les dessouder, car les autres éléments du circuit perturbent les mesures. C'est le cas, en particulier, pour les diodes, à cause du condensateur de filtrage qui se charge ou se décharge selon le sens de branchement du multimètre. C'est ce qui explique les mesures fluctuantes. L'essentiel est de ne pas trouver une résistance nulle, signe d'une diode en court-circuit.

L'information importante est la résistance presque nulle entre les broches 1 et 2 du régulateur. Soit il y a un court-circuit avant le régulateur, soit le régulateur lui-même est en court-circuit. Cette deuxième hypothèse est de loin la plus probable. Sinon il faudra contrôler le condensateur.

L'étape suivante consiste à enlever le régulateur pour refaire la mesure hors-circuit entre les broches 1 et 2. Si elle confirme le court-circuit le régulateur est défectueux, il suffit de le changer, c'est très simple et pas cher. Compte tenu du faible coût du 7812 (0,22€ chez Conrad) et de sa forte probabilité de panne, il est plus simple de ne pas le dessouder (pour ne pas abîmer le circuit imprimé) et de couper les pattes. Ensuite il sera beaucoup plus facile de déboucher les trois trous un par un pour souder son remplaçant.

Après avoir enlevé le 7812 il faut refaire la mesure entre les points 3 et 2 pour s'assurer qu'il n'y a pas de problème en aval. Si on trouve encore 2,29K, c'est bon. Ensuite il faut rebrancher le magnétophone et mesurer la tension entre 1 et 2 (voltmètre continu, calibre 20V, pointe noire sur le 2), pour s'assurer qu'il n'y a pas de problème en amont. C'est important, car si le 7812 a été détruit à cause d'un autre défaut on risque de détruire son remplaçant de la même manière.
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 17 sept. 2018 22:29

OK,

J'ai eu peur que le 7812 soit "coller" au radiateur mais après avoir enlever l'anneau de maintient, il n'y a que de la pâte thermique. Par contre je ne suis pas équipé pour couper les pattes. Va falloir que j'aille me procurer une pince coupante pour électro. Je vais voir ça dans la semaine, je ne laisse pas tomber ;)

Le condensateur de filtrage, c'est le cylindre jaune (en bas sur la photo), c'est bien ça ?
20180917_221759.jpg
20180917_221759.jpg (593.13 Kio) Vu 218 fois

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 18 sept. 2018 10:11

Oui, le condensateur de filtrage est le cylindre jaune dans l'angle de la carte. Il est peu probable qu'il soit en court-circuit, mais ce n'est pas totalement exclu. Même s'il n'est pas en panne il serait bon de le remplacer par un neuf, de même capacité (470 µF) et de tension de service égale ou supérieure (25V ou 50V). En effet les condensateurs électrolytiques perdent un peu de leur capacité avec l'âge.

On doit pouvoir couper les pattes du 7812 sans pinces coupantes, en les pliant plusieurs fois dans un sens et dans l'autre. Si tu as l'occasion de passer dans un magasin d'électronique, tu peux déjà acheter un ou deux 7812 et un ou deux condensateurs, ils seront certainement utiles plus tard. Idéalement il faudrait aussi un peu de pâte thermique, mais à défaut on peut probablement s'en passer.
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 19 sept. 2018 22:42

Alors, je suis passé dans un magasin d'électronique et je suis maintenant équipé d'une pince coupante qui va bien et quelques outils pour retirer des CMS, faire levier, déboucher les trous etc.

J'ai pris un nouveau 7812 mais je n'ai pas pensé au condensateur, j'ai vu votre message trop tard. J'ai pensé à la pâte thermique mais comme il en reste sur le radiateur, je me suis dis que ce n'était peut-être pas si utile.

Par contre, quand je refais les mesures sur le 7812 suspect hors circuit, j'obtiens :
- 3.54 (calibre 20k) sur entre la broche 3 et 2 (sur circuit j'avais 2.29)
- Rien (1) sur la 1 et 2,
- Rien sur la 1 et 3 (sur circuit j'avais 2.29)

Ce qui peut confirmer donc qu'il est HS.

Par contre quand je fais les mêmes mesures sur le 7812 remplaçant hors circuit, j'obtiens :
- 11.99 (calibre 20k) sur entre la broche 3 et 2
- Rien (1) sur la 1 et 2,
- Rien sur la 1 et 3

Du coup, 2 questions :

1. est-ce normal que sur le nouveau j'ai 12 alors que sur l'ancien j'ai 3.54 ?
2. est-il possible qu'il soit aussi défectueux, ou alors je me trompe dans la façon de mesurer depuis le début ?

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 20 sept. 2018 08:24

D'un composant à l'autre les caractéristiques peuvent être différentes et les mesures de résistance à vide ne sont pas forcément significatives. Ce qui compte pour un régulateur, ce sont les tensions mesurées pendant le fonctionnement.

Quand l'ohmmètre n'indique pas la résistance sur un calibre donné, il faut passer au calibre supérieur pour obtenir la bonne valeur. Mais peu importe, les mesures effectuées montrent clairement un point important pour le 7812 :
- En circuit la résistance entre 1 et 2 est très faible (0.01K).
- Hors circuit la résistance entre 1 et 2 est très grande (>20K).

Ce qui veut dire que le court-circuit suspecté n'est pas dans le 7812, mais en amont. Il faut le trouver.

1) Mesurer la résistance sur le circuit imprimé, sans le 7812, entre les pistes où étaient connectées les broches 1 et 2
On doit trouver 0.01K, ce qui confirme le court-circuit en amont. Sinon c'est incompréhensible, sauf erreur de mesure.

2) Dessouder le condensateur de 470µF. Mesurer à nouveau entre les mêmes pistes.
S'il y a plus de 1K le condensateur est en court-circuit. Sinon il faut chercher autre chose (nous verrons plus tard).

J'ai un petit doute sur les mesures, à cause du condensateur. La mesure de 0.01K est-elle stable pendant plusieurs secondes ? Quand on mesure la résistance d'un condensateur, elle est nulle au début et augmente ensuite jusqu'à l'infini. Si 0.01K a été mesuré moins d'une seconde, c'est normal. Par contre si la mesure reste à 0.01K pendant une minute, c'est bien la preuve d'un court-circuit.
Daniel
L'obstacle augmente mon ardeur.

btr
Messages : 23
Enregistré le : 10 sept. 2018 23:28

Re: Panne Lecteur K7 Thomson MO5

Message par btr » 21 sept. 2018 00:28

Pour info, hors circuit (calibre diode), sur le composant suspect j'obtiens :
- sur 2 et 3 : .845 (stable)
- sur 1 et 2 : 1.884 (1s) mais repasse à 1

Sur le nouveau composant ça reste à 1 tout le temps.

Quelle différence entre le calibre diode et ohm ? quand utiliser l'un ou l'autre ?


1) sur le circuit broche 1 et 2 (calibre 20k) : ça par sur des valeurs négatives puis tombe rapidement à 0.01 et 0
sur 2 et 3 j'ai du 6.53

2) j'ai dessouder le condensateur de 470µF. Mesure :
- sur 2 et 3 j'ai du 6.53
- sur 1 et 2 j'ai 1 (peut importe le calibre)

La mesure 0.01K était stable, même comportement qu'avec le circuit sans le 7812. La valeur restait à 0.01K

Daniel
Messages : 10834
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne Lecteur K7 Thomson MO5

Message par Daniel » 21 sept. 2018 10:35

Pour le régulateur 7812 je ne sais pas quoi dire, les mesures semblent incohérentes. A priori il vaut mieux l'abandonner et utiliser le neuf.

Je résume le point important : après avoir enlevé le régulateur, sur le circuit imprimé entre les points 1 et 2 :
- Avec le condensateur soudé, la résistance est 0.01K ou 0K après stabilisation.
- Après avoir enlevé le condensateur la résistance est infinie

Donc le condensateur est en court-circuit. Pour le confirmer il suffit de mesurer la résistance entre les deux pattes du condensateur démonté.

D'autre part la mesure de 6.53K entre les points 3 et 2 est normale, il n'y a pas de court-circuit sur la carte en aval du régulateur. Avec un condensateur neuf et un régulateur neuf le magnétophone fonctionnera.

Pour être bien sûr que les diodes fonctionnent, il y a encore une mesure à faire avant de souder les deux nouveaux composants :
- Mettre sous tension le magnétophone
- Mesurer la tension entre les points 1 et 2 du circuit imprimé (voltmètre calibre 20V continus). Si ça dépasse 20V passer au calibre supérieur.
Daniel
L'obstacle augmente mon ardeur.

Répondre