[Apple IIe] remise en route

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Papy.G, fneck, Carl

Répondre
Patrick
Messages : 1426
Enregistré le : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

[Apple IIe] remise en route

Message par Patrick » 17 sept. 2019 17:30

J'ai acheté mon premier Apple IIe pour la somme hautement improbable de 2 € au marché aux puces de Clermont-Ferrand. Le lot comprenait l'unité centrale, deux lecteurs Disk ][ et une ImageWriter.
Evidemment, arrivé chez moi, l'ordinateur ne fonctionnait pas :
Image

C'était il y a plus de 10 ans.
Entre temps, j'ai récupéré un deuxième Apple IIe qui lui fonctionnait parfaitement.
Régulièrement, je revenais à ce problème, je me suis documenté et j'étais pratiquement sûr que comme dans bien des cas, c'était un problème de composant mémoire. Vous allez voir que je me trompais.

Sur cette photographie de la carte mère, il est visible que les composants mémoires, positions F3 à F9, sont installés sur des supports :
Image

J'ai donc remplacé tous les composants mémoire par de nouveaux. Sans succès, le problème reste entier.
Dans ce cas, je décide d'appliquer la technique Bad Chips: Exchanging the chips.
J'échange les composants entre l'Apple IIe qui fonctionne et celui qui ne fonctionne pas. J'échange successivement le CPU, la ROM CD et la ROM EF, sans résultat. Là je me dis que cette machine va encore rester quelques dizaines d'année sans fonctionner.
J'examine encore la carte mère et je vois qu'il est possible d'échanger deux autres circuits spécialisés, MMU et IOU. MMU, ça me parle, ça pourrait être ça, un problème d'adressage, je commence donc par celui-ci et j'ai enfin un résultat : le IIe qui ne fonctionnait pas fonctionne et celui qui fonctionnait ne fonctionne plus (c'est pas le but recherché, je sais, mais c'est un début). Je confirme rapidement en lançant un auto-diagnostic (Ctrl+Pomme pleine+Reset) , qui se termine avec succès sur le message KERNEL OK. J'ai enfin trouvé le coupable :D.
Je précise que j'ai fait toutes ces tentatives en retirant les cartes d'extension (Apple II parallel Interface, Apple II Extended 80-Column Text Card et Disk ][ Interface Card). Je recommence le diagnostic avec toutes ces cartes, le résultat est identique, KERNEL OK.
Il faut donc je parte à la chasse au MMU. Pas facile, j'ai même passé un message ici et sur Silicium, sans succès.
Le circuit est référencé sur certains sites, mais jamais en stock.
Je m'inscris également sur le forum AppleFritter mais le seul conseil qui m'est donné et d'acheter une carte mère pour prélever le MMU (en aéronautique, c'est du cannibalisme). C'est sûr qu'aux USA la carte mère d'Apple IIe se trouve à $25 mais en France, ce n'est pas le même tarif.
J'ai finalement trouvé le composant sur le site Vintage Apple. Un peu cher pour un composant, 24 € port compris, mais au prix de l'Apple IIe, c'est valable. Et puis au final, cet Apple IIe me revient à 26 €. C'est pas si mal :lol: !
Le composant a mis quelques jours pour venir de Suède, mais après installation, mon IIe est enfin réparé.
Les Disk ][ fonctionnent également parfaitement.
Pour conclure, l'échange de composant, déjà mis en oeuvre dans la réparation de mon Commodore Plus/4, m'a encore permis de trouver la cause d'une panne. Ceci est facilité par le fait que mon Apple IIe est une version B avec tous les composants sur support. Situation idéale. Par exemple, mon deuxième Apple IIe, celui qui m'a servi de source et de référence, n'a plus que les composants principaux montés sur support.
Et alors, les ordinateurs plus récents, n'en parlons même pas.
Dans le prochain épisode, je vous parle de l'amélioration de mon deuxième Apple IIe et des conséquences qui en découlent.
Modifié en dernier par Patrick le 17 sept. 2019 20:54, modifié 1 fois.
Patrick

jvernet
Messages : 1711
Enregistré le : 12 avr. 2007 10:59
Localisation : France 69

Re: [Apple IIe] remise en route

Message par jvernet » 17 sept. 2019 20:50

Super !

J'ai une carte mère de //e en rab qui me sert justement de spare. J'ai déja piqué les ROM, la CPU...

Glonx
Messages : 9
Enregistré le : 15 mars 2019 09:49
Localisation : 76

Re: [Apple IIe] remise en route

Message par Glonx » 18 sept. 2019 08:54

Bonjour,

Super, bien content que tu ais réussi !
Cela me rappelle le dépannage de ma carte Chat Mauve.
Je suis déjà très intéressé par ton retour sur ton Apple IIe amélioré (j'ai "enhancé" le mien).

Avatar du membre
Stigma
Messages : 52
Enregistré le : 05 févr. 2010 16:38
Localisation : Le Portel
Contact :

Re: [Apple IIe] remise en route

Message par Stigma » 29 sept. 2019 11:52

Glonx a écrit :
18 sept. 2019 08:54
Cela me rappelle le dépannage de ma carte Chat Mauve.
Je n'ai jamais réussi à en dégoter une, ou alors à des prix prohibitifs :evil:
Si tu es incinéré, ce sera ta dernière cuite.
Si tu es enterré, tu as encore une chance d'avoir un dernier ver dans le nez.

Avatar du membre
Ghost59
Messages : 703
Enregistré le : 12 déc. 2007 18:01
Localisation : Flandre

Re: [Apple IIe] remise en route

Message par Ghost59 » 02 oct. 2019 19:50

excellent ! :)
Philippe.

Répondre