[RESOLU] ZX81 super modifé n'affiche rien à l'écran

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
bubulemaster
Messages : 279
Enregistré le : 01 juil. 2014 13:48
Localisation : Nantes
Contact :

[RESOLU] ZX81 super modifé n'affiche rien à l'écran

Message par bubulemaster » 03 mars 2015 07:57

Bonjour,

j'ai récupérer vendredi dernier un ZX81 pour mon plus grand bonheur.

Après l'exploit de la poste, je l'ai branché et rien à l'écran. Et zut !

J'ai donc vérifié l'alimentation 9V, qui a vide me délivre du 15,4V soit plus que 9 *racine de 2 (=12,73) mais rien d'alarmant.

J'ai donc ouvert le boitier et je constate que le ZX81 a été légèrement modifié :lol: (voir les photos : http://www.openjill.org/oldies/zx81/).

La question est déjà, qui connait ce type de hack ?
Car la mémoire RAM est remplacée mais la sortie écran aussi et peut être d'autres choses.

Avez-vous des conseils pour investiguer cette machine mutante ?

Merci
Modifié en dernier par bubulemaster le 01 juil. 2015 12:15, modifié 1 fois.
Le 80286 et suivant sont des processeurs beaucoup trop évolués qui n'auraient jamais dû être inventés :-).

Avatar du membre
LeGrapyl
Messages : 1182
Enregistré le : 15 déc. 2013 23:38
Localisation : 71 mais parfois 34...

Re: ZX81 super modifé n'affiche rien à l'écran

Message par LeGrapyl » 03 mars 2015 09:27

Cyber-Papy ou Xavier ? Au fait quelqu'un a des nouvelles de Cyper-Papy ?

[EDIT]ça semble être une extension mémoire... puisqu'il semble être sur l'IC4 (vu sur le site de Xavier Mémoire (1kO) : IC4 = 2x MCM21L14 (Suivant les modèles cf. Références mémoire du tableau)[/EDIT]
Tom la Riboulle, l'homme qui roule en boule !

Avatar du membre
PowerON
Messages : 142
Enregistré le : 09 juin 2014 12:54
Localisation : Nord

Re: ZX81 super modifé n'affiche rien à l'écran

Message par PowerON » 03 mars 2015 10:10

Bonjour à tous,

Belle modification en effet.

Bizarrement, les 2 Ram 2114 sont quand même présentent à leur emplacement.
Pour faire une extension 2 k il suffisait d'utiliser une Ram Statique type 4802 (en remplacement des 2 ram 2114)

Il y a aussi une bidouille sur l'entrée du modulateur UHF.
Modification pour utiliser en mode SECAM.
Peur être la version inverseur vidéo ?
Cela expliquerait la carte additionnelle (mais il devrait y avoir un inverseur quelque part)

Il y avait aussi un montage pour ajouter un buzzer au clavier.
Cette carte est peut être un mix de tout ?

Peut on voir le coté composant de cette carte additionnelle ?
Elle doit pouvoir se retirer du support avec de la précaution.

PS : il semble que la nappe clavier a bien dégustée.
On y voit des coupures au niveau de la pliure si mes yeux ne me trahissent pas.

A plus.

Avatar du membre
claudounet
Messages : 1072
Enregistré le : 15 juil. 2009 21:21
Localisation : Dublin 6 (IRL) - Vichy (03)
Contact :

Re: ZX81 super modifé n'affiche rien à l'écran

Message par claudounet » 03 mars 2015 14:08

Pour l'inverseur video, il fallait juste un transistor à l'entrée du modulateur. Le montage me parait trop compliqué.
Pour le mode secam, il faut un autre modulateur.
J'ai pensé a une carte couleur, mais il n'y a pas de sortie peritel.

Il est vrai que si on pouvait voir les composants, ca serait plus pratique.
Et il s'agit d'une carte fabrication artisanale. Donc sans doute un montage decrit dans Radio-Plan. Ce n'est pas le look des cartes d'Elektor.
Pour l'alim, il y a un 7805 (de memoire) qui régule. Vu la sortie élevée de l'alim (c'est normal), il faut un bon radiateur pour evacuer l'excédent de chaleur.
Après, tu dis que tu n'as rien sur la télé: même pas un ecran noir vers le canal 36? Tu as une vieille télé?
Claude

Retro'rdinateurs http://www.retrordinateurs.com/

Avatar du membre
bubulemaster
Messages : 279
Enregistré le : 01 juil. 2014 13:48
Localisation : Nantes
Contact :

Re: ZX81 super modifé n'affiche rien à l'écran

Message par bubulemaster » 03 mars 2015 14:21

Ok, je vais essayer.

Mais ça me fait un peu peur pou essayer de dépanner tout ça :?

J'irais peut-être plus vite à en acheter un autre :lol:
Le 80286 et suivant sont des processeurs beaucoup trop évolués qui n'auraient jamais dû être inventés :-).

Avatar du membre
LeGrapyl
Messages : 1182
Enregistré le : 15 déc. 2013 23:38
Localisation : 71 mais parfois 34...

Re: ZX81 super modifé n'affiche rien à l'écran

Message par LeGrapyl » 03 mars 2015 14:35

Tu le revends ou l'échanges ? :wink:
Tom la Riboulle, l'homme qui roule en boule !

Avatar du membre
bubulemaster
Messages : 279
Enregistré le : 01 juil. 2014 13:48
Localisation : Nantes
Contact :

Re: ZX81 super modifé n'affiche rien à l'écran

Message par bubulemaster » 03 mars 2015 16:06

Hé, hé, non, je le garde :D

Je vais essayer de le réparer quand même :wink:
Le 80286 et suivant sont des processeurs beaucoup trop évolués qui n'auraient jamais dû être inventés :-).

Avatar du membre
LeGrapyl
Messages : 1182
Enregistré le : 15 déc. 2013 23:38
Localisation : 71 mais parfois 34...

Re: ZX81 super modifé n'affiche rien à l'écran

Message par LeGrapyl » 03 mars 2015 16:59

:twisted: ACHHHHH ! Raté :lol:
Tom la Riboulle, l'homme qui roule en boule !

Avatar du membre
PowerON
Messages : 142
Enregistré le : 09 juin 2014 12:54
Localisation : Nord

Re: ZX81 super modifé n'affiche rien à l'écran

Message par PowerON » 03 mars 2015 17:08

Bonjour,

Pour l'inverseur vidéo il fallait plus qu'un simple transistor :wink:

Je parle d'inversion vidéo (curseur blanc sur fond noir) , pas d'inversion du signal vidéo pour le faire sortir pour TV Secam.
Comme le montage ajouté à l'entrée des modulateurs UHF sur Oric pour sortir sur TV.

On remarque qu'il y a 2 ajustables sur cette carte (comme sur le montage inverseur vidéo paru dans Microsystème)
Montage du N° 22 (74LS14, 74LS03 ou LS01, 2N2369, 2 ajustables 1kohm et quelques résistances et condensateurs)
Coïncidence :?:

Une photo, une photo bubulemaster SVP :)

Avatar du membre
claudounet
Messages : 1072
Enregistré le : 15 juil. 2009 21:21
Localisation : Dublin 6 (IRL) - Vichy (03)
Contact :

Re: ZX81 super modifé n'affiche rien à l'écran

Message par claudounet » 03 mars 2015 17:24

tu as raison, mea culpa. Avec l'age... C'est le montage que j'avais bricolé sur mon Oric.
Claude

Retro'rdinateurs http://www.retrordinateurs.com/

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: ZX81 super modifé n'affiche rien à l'écran

Message par Xavier » 03 mars 2015 18:52

Salut,
Ce montage m'est inconnu, mais ses connections impliquent forcement une modification du signal vidéo en entrée du modulateur.
Surement une modification pour une haute résolution en WRX ou un conformateur de sauvegarde/affichage vidéo.
Cela n'explique pas le problème d'écran, car la carte fille semble être greffée sur une carte de ZX81 intacte.
Il est toujours possible que le ULA soit mort, je miserai plus sur un mauvais contact.
Il est préférable de faire les essais sans ram sur l'extension... puis avec si celle si ne fonctionne pas.
Sinon, le recensement des connections peut donner une idée de son utilisation...
Le schéma français est ici: http://fetrmartin.free.fr/ZX81/schema_ZX81_Fr.gif

Avatar du membre
bubulemaster
Messages : 279
Enregistré le : 01 juil. 2014 13:48
Localisation : Nantes
Contact :

Re: ZX81 super modifé n'affiche rien à l'écran

Message par bubulemaster » 03 mars 2015 20:25

Wouah merci à tou.

Je ne pensais as avoir récupéré un modèle si intrigant.

J'ai fait des photos ratées du montage. Image zx81_carte_hack_memoire

Il faut que je dessoude des fils passés dans les résistances qui empêche le démontage de la carte. :roll:
PowerON a écrit : PS : il semble que la nappe clavier a bien dégustée.
On y voit des coupures au niveau de la pliure si mes yeux ne me trahissent pas.
Oui la nappe est coupée. Doit y avoir moyen de réparer ça aussi.
claudounet a écrit :Après, tu dis que tu n'as rien sur la télé: même pas un ecran noir vers le canal 36? Tu as une vieille télé?
Je sens que je vais dire une bêtise. La sortie vidéo ne se branche pas sur l'entrée vidéo (prise jaune) type RCA ?
Le 80286 et suivant sont des processeurs beaucoup trop évolués qui n'auraient jamais dû être inventés :-).

Marcopolo

Re: ZX81 super modifé n'affiche rien à l'écran

Message par Marcopolo » 03 mars 2015 21:02

bubulemaster a écrit :Je sens que je vais dire une bêtise. La sortie vidéo ne se branche pas sur l'entrée vidéo (prise jaune) type RCA ?
Oui et non

Marcopolo

Re: ZX81 super modifé n'affiche rien à l'écran

Message par Marcopolo » 03 mars 2015 21:03

LeGrapyl a écrit ::twisted: ACHHHHH ! Raté :lol:
J'ai un ZX81 qui fonctionne à vendre + un en panne.

Avatar du membre
LeGrapyl
Messages : 1182
Enregistré le : 15 déc. 2013 23:38
Localisation : 71 mais parfois 34...

Re: ZX81 super modifé n'affiche rien à l'écran

Message par LeGrapyl » 03 mars 2015 21:30

bubulemaster a écrit :Je sens que je vais dire une bêtise. La sortie vidéo ne se branche pas sur l'entrée vidéo (prise jaune) type RCA ?
Sur le modèle non modifié, il se branche sur l'entrée antenne de ton téléviseur canal 36... Comme le tiens semble l'avoir été, il doit pouvoir gérer la composite...
Marcopolo a écrit :J'ai un ZX81 qui fonctionne à vendre + un en panne.
Tu as une idée de la gravité de la panne ? je voulais en avoir un pour le modifier, donc en état de marche ou en panne ça ne me dérange pas si c'est réparable sans avoir à tout changer ; l'un des deux a le clavier mécanique. Maintenant tout dépend à quel point ça va gréver mon budget pour acquérir un Goupil 3 :wink:
Tom la Riboulle, l'homme qui roule en boule !

Répondre