[TRS-80] La suite - Le boitier d'extension

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
gleike
Messages : 813
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [TRS-80] La suite - Le boitier d'extension

Message par gleike » 13 mars 2015 11:45

Pour que ça soit plus clair, as tu vu ma réponse a ton précédent post dans la rubrique RECHERCHES
ICI -->http://forum.system-cfg.com/viewtopic.p ... 134#p99377

Avatar du membre
fneck
Site Admin
Messages : 13909
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [TRS-80] La suite - Le boitier d'extension

Message par fneck » 14 mars 2015 10:07

Concernant le câble pour lecteur de disquettes, tu peux aller plus loin en y ajoutant d'autres connecteurs pour lecteurs 5"1/4 ou 3"1/2. Ainsi tu auras un câble quasi-universel sur lequel tu pourras raccorder à peu près n'importe quoi, y compris un HxC. Voila le mien :

Image

A noter que si tu ne veux pas perdre trop de longueur du câble, tu peux dé-twister les 10 fils correspondants, visible ici en regardant bien :

Image

Attention pour les connecteurs, il y a un repère (souvent un petit triangle) dessus qui correspond au fil de couleur de la nappe. Sinon ce n'est pas simple non plus à bien sertir, pour ma part j'utilise un petit étau pour bien appuyer parallèlement.

Avatar du membre
Papy.G
Modérateur
Messages : 2384
Enregistré le : 10 juin 2014 13:40
Localisation : Haute-Garonne/Gers

Re: [TRS-80] La suite - Le boitier d'extension

Message par Papy.G » 14 mars 2015 11:08

Pour sertir les connecteurs à harpons, je les coince dans une porte, côté charnière, ça garanti de bien avancer droit.

Par contre, est-il indispensable d'enlever des broches, comme dans le câble d'origine?
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
gleike
Messages : 813
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [TRS-80] La suite - Le boitier d'extension

Message par gleike » 14 mars 2015 11:15

Non, il ne faut surtout pas enlever de broches.
Les broches en moins sur le câble d'origine servaient a la sélection du drive, la sélection se fait ici par jumper.

Avatar du membre
fneck
Site Admin
Messages : 13909
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [TRS-80] La suite - Le boitier d'extension

Message par fneck » 14 mars 2015 12:35

Papy.G a écrit : est-il indispensable d'enlever des broches, comme dans le câble d'origine?
Alors je serais moins catégorique que Gleike. Effectivement il a raison, il n'y a pas besoin d'enlever des broches dans 99% des cas, sauf...

Parce qu'il y a toujours un cas particulier, donc sauf si tu utilises des lecteurs originaux Tandy, car ceux-ci peuvent avoir tous les jumpers de sélection de drive court-circuités, voir photo (au-dessus de la sérigraphie 1, 2, 3 et 4) :

Image

C'est ce que j'avais par exemple sur un Model III et je peux vous dire que j'ai cherché un moment pourquoi ça ne fonctionnait pas avec mon câble. :?

Dans ce cas soit il faut utiliser un câble avec des pinoches retirées, soit il faut masquer les pistes du circuit imprimé du lecteur avec par exemple du ruban adhésif.

Donc attention si un jour tu utilises des lecteurs d'origines.

Pour info voici un câble original sur lequel on peut voir les connexions coupées :

Image

Avatar du membre
gleike
Messages : 813
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [TRS-80] La suite - Le boitier d'extension

Message par gleike » 14 mars 2015 18:39

Effectivement Fabien, je faisais référence a l'usage exclusif de drives 3.5.

Avatar du membre
meridian
Messages : 741
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [TRS-80] La suite - Le boitier d'extension

Message par meridian » 14 mars 2015 18:58

Hello,
j'ai récupéré une nappe d'un ancien 5.1/4, elle n'est pas en super état mais la partie non twistée est ok Je pense la couper à la hauteur du second connecteur Plat qui du coup se retrouvera en début de nappe et insérer le connecteur 3.5 qui était sur la partie twistée de l'autre coté de la nappe.
Ce qui fera

5--3-----3--3

5 pour plat (5.1/4")
3 pour 3.5"
Le premier 3 ne me servira à rien, trop près du connecteur plat.

Sinon encore une question :oops:

J'ai un lecteur MPF920 de Sony, mais je ne trouve pas les jumpers de sélection, donc je coupe les pistes ?

Avatar du membre
fneck
Site Admin
Messages : 13909
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [TRS-80] La suite - Le boitier d'extension

Message par fneck » 14 mars 2015 19:45

Il y a des lecteurs 3"1/2 qui n'ont effectivement pas de cavalier mais généralement tu peux trouver un point de soudure qui fait cette fonction. S'il n'y a rien de plus sur ce lecteur tu ne pourras pas l'utiliser simplement car pour un PC il est configuré par défaut en lecteur 1 alors que dans le TRS-80 il te le faut en 0.

Retirer les broches ne servira à rien car en face du lecteur 0 sur le câble tu n'auras pas de lecteur physique. Il te faudrait éventuellement croiser les fils des lecteurs 0 et 1 sur ton câble mais ce n'est pas terrible comme solution.

Avatar du membre
meridian
Messages : 741
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [TRS-80] La suite - Le boitier d'extension

Message par meridian » 14 mars 2015 21:51

bon je sais quoi chercher maintenant
http://freaknet.org/asbesto/roba/diskettes-jumpers.pdf

Avatar du membre
meridian
Messages : 741
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [TRS-80] La suite - Le boitier d'extension

Message par meridian » 14 mars 2015 22:38

rah ça y est j'en ai un qui semble bon et le jumper qui va bien :D

http://tizeta2.altervista.org/amiga/tut ... 920-e.html

Avatar du membre
gleike
Messages : 813
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [TRS-80] La suite - Le boitier d'extension

Message par gleike » 15 mars 2015 18:20

Attention, sur cette image la modification est fausse.
http://tizeta2.altervista.org/amiga/tut ... 920-e.html
Il ne faut pas faire la liaison en rouge, sinon DS0 et DS1 vont être sélectionnés en même temps,
mais déplacer le CMS JC31 en JC30.
Comme sur cette image.
http://www.pitsch.de/stuff/amiga/tepe/sonympf920e.jpg
Modifié en dernier par gleike le 16 mars 2015 15:11, modifié 2 fois.

Avatar du membre
meridian
Messages : 741
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [TRS-80] La suite - Le boitier d'extension

Message par meridian » 15 mars 2015 19:01

Merciiii, j'avais fait la modif

je vais refaire la modif comme sur cette photo :D

Avatar du membre
fneck
Site Admin
Messages : 13909
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [TRS-80] La suite - Le boitier d'extension

Message par fneck » 15 mars 2015 19:05

Bien vu Gleike :)

Si tu ne te sens pas de ressouder le SMS de JC31 en JC30, tu peux aussi le déposer puis faire la liaison entre les trous des S0 et S1. Mais ce n'est guère plus gros.

Avatar du membre
meridian
Messages : 741
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [TRS-80] La suite - Le boitier d'extension

Message par meridian » 22 mars 2015 11:14

Hello,

Bon ça avance doucement au rythme de mon temps de libre ^^

J'ai préparé le lecteur de disquette, mais pas trouvé un assez vieux pc pour créer des disquettes.
J'ai donc utilisé une HxC récupéré dans un Amiga que je viens rentrer.

Ça fonctionne à peut près, j'ai réussi à booter sur du NewDos, mais pas du Ldos 351, ce dernier se plante après la saisie de l'heure.

Le Newdos a l'air de fonctionner hormis les caractères étranges sur l'écran de démarrage.
NewDos-1.jpg
NewDos-1.jpg (55.45 Kio) Vu 1861 fois
le dir 0 fonctionne
NewDos-2.jpg
NewDos-2.jpg (52.06 Kio) Vu 1861 fois
A suivre...

Avatar du membre
gleike
Messages : 813
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [TRS-80] La suite - Le boitier d'extension

Message par gleike » 23 mars 2015 10:22

Tu as peut être, un problème de RAM, je te conseille de télécharger ce programme.
http://www.planetemu.net/rom/tandy-radi ... mbaugh-cmd

Il permet de faire un test mémoire du TRS-80 model 1, assez complet.

Répondre