Thomson MO5 N

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

Spoutnik
Messages : 153
Enregistré le : 12 déc. 2016 23:41
Localisation : Landes (40)

Thomson MO5 N

Message par Spoutnik » 21 déc. 2016 14:17

J'ai récupéré un Mo5 à clavier mécanique gracieusement qui a pris la poussière pendant des années dans un recoin de grenier (d'ailleurs couplé avec un lecteur cassette blanc Mo5 E bizarre). Avant de vouloir mettre la bestiole en route j'ai ouvert pour nettoyer et voir si la carte mère n'avait pas trop une sale tête. La tête bizarre c'est moi qui l'ai eu en voyant une carte mère totalement épurée à côté des photos que j'ai pu voir sur ce site!

Voyez plutôt :

Image

Mo5 CMS Kézako ? Les deux puces avec les pastilles bleue et rouge sont des intel D27256-4 U6031945 S.

S'agit il d'une version différente de la série normale ?

Dernière question je ne possède pas l'alimentation d'origine, je n'ai qu'un transformateur universel qui délivre au plus 12V et 500mA. Pensez vous que ça sera suffisant pour faire un test après nettoyage (j'ai déjà vu pour la polarité qu'il fallait du + sur l'extérieur de la prise jack et ça c'est ok) ?

Merci d'avance.
Modifié en dernier par Spoutnik le 04 janv. 2017 20:55, modifié 1 fois.

Avatar du membre
fneck
Site Admin
Messages : 12114
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Question MO5 CMS

Message par fneck » 21 déc. 2016 18:38

Alors là... ça ne ressemble à rien de déjà vu, en tout cas pour moi. C'est vraiment une curiosité ton truc :shock:
Il y a des composants dessous? Sinon je doute fort que ça puisse fonctionner ainsi.

Attendons l'avis des spécialistes Thomson pour voir ce qu'ils en pensent.

Daniel
Messages : 10566
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Question MO5 CMS

Message par Daniel » 21 déc. 2016 18:47

C'est incroyable, je n'ai jamais vu cette carte mère de MO5. C'est une pièce unique, et probablement un prototype, car aucun MO5 de série n'avait deux ROMs, et encore moins de ROM sur support. Il serait extrêmement intéressant, pour la sauvegarde du patrimoine informatique, d'avoir une copie de ces deux ROMs et de bonnes photos recto/verso de la carte mère.

Une alimentation 12V/500mA permet en général de faire fonctionner le MO5, mais pas dans des conditions optimales. Pour un test c'est bon (attention de ne pas inverser la polarité), mais ensuite il vaut mieux une alimentation bien adaptée. Une alimentation à découpage de 15V/1A est parfaite. On en trouve en Chine pour quelques euros. Il y a un fil de discussion sur le sujet ici : http://forum.system-cfg.com/viewtopic.php?f=18&t=7074
Daniel
L'obstacle augmente mon ardeur.

__sam__
Messages : 4074
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Question MO5 CMS

Message par __sam__ » 21 déc. 2016 18:57

Whaaaa. Est-ce que par chance D27256-4 U6031945 S correspond à ceci : http://www.cpu-galaxy.at/cpu/ram%20rom% ... asheet.pdf, c'est à dire une EPROM de 32Ko ?

Comme il y en a 2 ca nous fait près de 64ko de ROM. Ca fait bcp pour un MO5, non ?
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Daniel
Messages : 10566
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Question MO5 CMS

Message par Daniel » 21 déc. 2016 19:03

Oui, c'est bien deux fois 32Ko. C'est pourquoi je suis extrêmement intéressé par leur contenu. J'en bave d'avance :wink:
Daniel
L'obstacle augmente mon ardeur.

__sam__
Messages : 4074
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Question MO5 CMS

Message par __sam__ » 21 déc. 2016 19:11

C'est moi qui ne voit peut-être pas clair, mais je vois aucun composants montés en surface sur la photo. S'ils sont sur la face du dessous, c'est curieux pour l'évacuation de la chaleur, non?
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Question MO5 CMS

Message par petitjd » 21 déc. 2016 19:30

C'est moi ou c'est la journée des MO5 qui n'existent pas?
Je serais curieux de voir ce qu'il y a sur l'autre côté de la carte mère!
Je serais curieux de savoir ce qui se cache dans les roms. OS9? :mrgreen:
Belle trouvaille!
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
6502man
Messages : 9009
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: Question MO5 CMS

Message par 6502man » 21 déc. 2016 20:55

Il nous faut la photo de l'autre face de la carte mère :shock:

Comme le dit Daniel une sauvegarde des EPROMS en priorité serait super :D
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 21 déc. 2016 21:09

Incroyable ! C'est spécialement pour Noël ?? Également impatient de voir l'autre face ! :P

Daniel
Messages : 10566
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Question MO5 CMS

Message par Daniel » 21 déc. 2016 21:59

petitjd a écrit :C'est moi ou c'est la journée des MO5 qui n'existent pas?
Reste à trouver le même en boîtier transparent...

Normalement la ROM du MO5 a une taille de 16K (4K pour le moniteur et 12K pour le Basic 1.0). La deuxième ROM pourrait être le BASIC 128 ? Mais le total ne fait pas encore 64K, il y a donc autre chose. C'est peut-être un prototype de MO5NR ? Mystère !
Le plus intrigant est de ne pas voir de trace de processeur 6809E. Je ne crois pas qu'il ait existé en boîtier carré. Le plus gros circuit carré est probablement un gate array, mais les petits c'est un autre mystère...
Daniel
L'obstacle augmente mon ardeur.

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Question MO5 CMS

Message par petitjd » 21 déc. 2016 23:09

Si c'était un prototype de MO5NR il y aurait le connecteur nanoreseau.
Ce qui pose soucis c'est effectivement que le microprocesseur semble ne pas être rectangulaire. Il y a bien eut le Z80 de forme carrée mais pas le 6809e à ma connaissance.
J'avance une hypothèse:
Le microprocesseur est un Motorola 68000. La rom embarque OS9 68k. Cette machine est le pendant MO du Théodor, TO à base de 68000.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Spoutnik
Messages : 153
Enregistré le : 12 déc. 2016 23:41
Localisation : Landes (40)

Re: Question MO5 CMS

Message par Spoutnik » 22 déc. 2016 19:58

Bonsoir!
fneck a écrit :Alors là... ça ne ressemble à rien de déjà vu, en tout cas pour moi. C'est vraiment une curiosité ton truc :shock:
Il y a des composants dessous? Sinon je doute fort que ça puisse fonctionner ainsi.
Alors oui il y a des composants dessous (j'ai juste à retourner l'appareil pour voir à travers les aérations pour la chaleur) qui semblent correspondre aux délimitations blanches du dessus.
Daniel a écrit :C'est incroyable, je n'ai jamais vu cette carte mère de MO5. C'est une pièce unique, et probablement un prototype, car aucun MO5 de série n'avait deux ROMs, et encore moins de ROM sur support. Il serait extrêmement intéressant, pour la sauvegarde du patrimoine informatique, d'avoir une copie de ces deux ROMs et de bonnes photos recto/verso de la carte mère.
L'étiquette comporte un numéro ce serait pas le numéro de série ? Par contre étant néophyte dans le domaine (j'ai juste quelques notions) je n'ai aucun moyen de sauvegarder ces ROMs, si on m'explique comment faire une interface je pourrai (après ça risque de prendre un peu de temps si sur le plan financier il faut mettre la main à la papatte!) les sauvegarder ou je ne suis pas contre arranger une entrevue avec quelqu'un qui a en une pas loin de chez moi.
Daniel a écrit :Une alimentation 12V/500mA permet en général de faire fonctionner le MO5, mais pas dans des conditions optimales. Pour un test c'est bon (attention de ne pas inverser la polarité), mais ensuite il vaut mieux une alimentation bien adaptée. Une alimentation à découpage de 15V/1A est parfaite. On en trouve en Chine pour quelques euros. Il y a un fil de discussion sur le sujet ici : viewtopic.php?f=18&t=7074
Merci pour tes infos, j'avais déjà parcouru rapidement ce topic. Alors pour info j'ai tenté après nettoyage l'alim de 12V et 500mA en faisant bien attention à la polarité. Seulement voilà, la télévision capte bien le signal et bascule sur la péritel quand je branche le Mo5 mais il y a juste un écran noir et rien d'autre (j'espère que c'est juste l'alim qui est faible). Je pense investir dans une alim chinoise, de toute manière je ne compte pas m'arrêter en si bon chemin!
__sam__ a écrit :Whaaaa. Est-ce que par chance D27256-4 U6031945 S correspond à ceci : http://www.cpu-galaxy.at/cpu/ram%20rom% ... asheet.pdf, c'est à dire une EPROM de 32Ko ?

Comme il y en a 2 ca nous fait près de 64ko de ROM. Ca fait bcp pour un MO5, non ?
En faisant des recherches je suis tombé sur le même document que toi et ça m'a paru impossible également vu les caractéristiques de la machine! Par contre je confirme qu'il y a bien des composants sous la carte mère. Je vais tenter un démontage mais j'ai peur pour les nappes du clavier, puisque je sais qu'elles sont fragiles, auriez vous une astuce pour les préserver au mieux ?

En tout cas je suis ravi de voir votre enthousiasme, je pensais que c'était un mo5 tout ce qu'il y a de plus banal (pour débuter la prog du coup c'est loupé, je me rabattrai sur l'émulateur en attendant :wink: ), par contre il est entre les mains d'un débutant... mais j'ai la patience nécessaire, si on m'explique ça fonctionnera!

Edit : En faisant quelques recherches sur le terme "CMS" sur internet j'ai pu voir qu'une version de l'Amstrad cpc avait été décliné en CMS également, ce qui revenait à l'époque à concentrer plusieurs composants dans une même puce : http://mo5.com/musee-machines-cpc464.html

Ils ont peut être expérimenté la chose chez Thomson ?

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: Question MO5 CMS

Message par petitjd » 22 déc. 2016 20:13

Est ce que tu peux faire une photo de l'autre côté de la carte. Pour les nappes ne t'inquiète pas trop, il faut les retirer délicatement en tirant doucement dessus. Pour les remettre il vaut mieux être deux: un qui tient la partie clavier au plus près des connecteurs et l'autre qui insère les connecteurs.

Perso je n'aurais pas tenté d'allumage avec une alim style MO5 car on ne sait pas à cent pour cent si c'est complètement un MO5 normal. Peut-être que ton MO5 a besoin d'une alimentation différente.
Les Thomson ont une polarité inversée par rapport au standard habituel. Chez Thomson, le - est au centre et le + est à l'extérieur.
Modifié en dernier par petitjd le 22 déc. 2016 20:13, modifié 1 fois.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 20:13

Spoutnik a écrit :Alors oui il y a des composants dessous (j'ai juste à retourner l'appareil pour voir à travers les aérations pour la chaleur) qui semblent correspondre aux délimitations blanches du dessus.
LA PHOTO !! LA PHOTO !! LA PHOTO !! LA PHOTO !! LA PHOTO !! LA PHOTO !! :D :D (en super haute résolution, bien sûr)
Par contre étant néophyte dans le domaine (j'ai juste quelques notions) je n'ai aucun moyen de sauvegarder ces ROMs
T'inquiètes, si ça s'allume, que t'as le basic et un magnéto, le Professeur va t'expliquer tout ça vite fait bien fait :)
En tout cas je suis ravi de voir votre enthousiasme, je pensais que c'était un mo5 tout ce qu'il y a de plus banal (pour débuter la prog du coup c'est loupé, je me rabattrai sur l'émulateur en attendant :wink: ), par contre il est entre les mains d'un débutant... mais j'ai la patience nécessaire, si on m'explique ça fonctionnera!
Bienvenue Spoutnik (bip bip.. bip bip..), je suis nouveau aussi. Tu avais un vieux MO5, d'apparence quelconque, qui prenait la poussière et finalement tu te décides à l'ouvrir pour y trouver... un OVNI ! On est ravi pour toi. Joyeux Noël à toi, et à nous ! 8)

Daniel
Messages : 10566
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Question MO5 CMS

Message par Daniel » 22 déc. 2016 20:22

Si l'écran reste noir avec l'alimentation 12V, c'est une panne ou un mauvais contact dans le câble péritel. Une alimentation 15V ne changera rien. A distance, avec une carte dont on n'a pas le schéma, il sera difficile de dépanner.

Pour dumper les ROMs, il y a des moyens hard, qui demandent du matériel que tu n'as pas, et des moyens soft, qui nécessitent le bon fonctionnement de la machine et d'un périphérique de stockage (cassette, disquette, carte SD etc.). Dans l'immédiat ça va être difficile, à moins de les confier à quelqu'un qui possède un lecteur d'EPROM.

Les nappes du clavier, on ne sait même pas si elles sont bonnes ou pas. Il ne faut pas trop les manipuler pour éviter de les endommager, alors je te conseille de les déconnecter délicatement, de bien ranger le clavier et de ne plus y toucher tant que l'ordinateur ne fonctionne pas. Il sera toujours temps plus tard de les réparer si elles sont abimées. De toutes façons, même si la machine est rarissime, le clavier est commun, tu pourras toujours le remplacer par un autre s'il ne fonctionne pas.

Sans le clavier il sera beaucoup plus facile d'intervenir sur la carte mère pour la réparer. Et de photographier la face cachée : il suffit de déconnecter le câble vidéo et d'enlever deux vis.
Daniel
L'obstacle augmente mon ardeur.

Répondre