Thomson MO5 N

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 20:29

Déjà, quand tu le mets sous tension, est-ce que les touches font "bip bip" :D ? Non, sérieusement.
edit: bon, en même temps, ça passe aussi par le câble péritel...

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 21:06

Avant que Spoutnik ne déconnecte son clavier, y'aurait pas des tests simples pour voir si la machine est correctement alimentée, voire "travaille du chapeau", même s'il n'y a pas d'affichage ? Personnellement, même sans l'ouvrir, j'aurais commencé par vérifier qu'il y a bien les les 5V sur les ports cassettes, crayon optique (et éventuellement sur le port d'extension).

Même si un souci plus sérieux qu'une panne d'affichage (ou mauvais câble péritel) est probable, il faudrait vérifier si la machine a le Basic chargé, et taper MOTORON pour voir si le niveau change sur la broche magnéto concernée, à l'aide d'un multimètre (ou d'une loupiotte branchée dessus).

petitjd
Messages : 1826
Enregistré le : 23 oct. 2007 11:50

Re: Question MO5 CMS

Message par petitjd » 22 déc. 2016 21:18

Normalement, avant de remettre sous tension une machine qui a séjourné dans un grenier depuis longtemps, on inspecte la carte mère et les composants visuellement pour s'assurer qu'il n'y ait pas de soucis visible comme l'oxydation, decollage de piste, composants qui on coulé...
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 21:30

Oui,tu as raison, mais à part ça ?? L'idée, c'est d'aider Schmilblik à faire avancer le Spoutnik. Qu'est qu'il pourrait faire avec les moyens du bord, en faisant les choses correctement bien sûr, mais sans attendre un mois, ou la visite d'un spécialiste avec sa caisse à outils ?..

petitjd
Messages : 1826
Enregistré le : 23 oct. 2007 11:50

Re: Question MO5 CMS

Message par petitjd » 22 déc. 2016 21:41

Les grands manitous du MO5 ont besoin des schemas pour réparer. Là non seulement il n'y a pas de schemas mais on ne sait même pas ce qui se cache de l'autre coté de la carte.
Je le répète et Daniel l'a aussi mentionné, à ma connaissance, il n'y a pas de 6809e au format cms "carré". Un MO5 sans 6809e n'est plus un MO5. En l'état on ne sait pas exactement ce que c'est.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 21:56

Oui, j'ai lu toute la conversation qui précède, et même si j'ai un grand respect pour le travail et l'expérience des "grands manitous", on a pas toujours besoin d'un schéma, ni de dogme. Il semblerait que ce soit quand même un MO5, avec tous les connecteurs standards et qui a déjà servi pour un usage normal. Ok pour faire les choses dans les règles de l'art, mais ça n'empêche pas d'effectuer des test simples.
Maintenant si vous craignez qu'une mauvaise manip' n'endommage ce qui est possiblement une pièce inestimable par sa valeur et son intérêt technique, ok, il suffit de le dire clairement, sans donnage de leçon. Bonne soirée.

Daniel
Messages : 11609
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Question MO5 CMS

Message par Daniel » 22 déc. 2016 22:07

Ca ressemble à un MO5, avec un boîtier de MO5, un clavier de MO5, une alimentation de MO5, des connecteurs de MO5. Mais avec 64K de ROM et pas de 6809E ça ne peut pas être un vrai MO5. Peut-être un simulateur de MO5, ou peut-être autre chose. Il faut commencer par voir la face cachée. Ensuite on pourra peut-être trouver des pistes.
Daniel
L'obstacle augmente mon ardeur.

Spoutnik
Messages : 153
Enregistré le : 12 déc. 2016 23:41
Localisation : Landes (40)

Re: Question MO5 CMS

Message par Spoutnik » 22 déc. 2016 22:33

Les photos arrivent! Joyeux noël!! :lol:

Ca y est, j'ai déconnecté les nappes du clavier en allant doucement c'est venu sans problème. Alors le dos de la carte mère à l'air plutôt sain, je n'ai pas aperçu de soudure en mauvais état, d'oxydation ou de pistes endommagées. Il y a un peu plus de composants que sur le dessus mais ça reste très épuré (je vous mets les vignettes cliquables le forum redimensionne toutes mes photos et vu qu'elles sont conséquentes..):

Image Image Image Image Image

Image Image Image Image Image

Quelques photos supplémentaires du dessus :

Image Image Image Image Image

Image

Voilà, à vos analyses!

Avatar du membre
Carl
Modérateur
Messages : 10541
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: Question MO5 CMS

Message par Carl » 22 déc. 2016 22:49

pas de 6809E ça ne peut pas être un vrai MO5
Daniel, je crois que c'est un 6809E... :roll:
IMG_20161222_212609.jpg
IMG_20161222_212609.jpg (62.06 Kio) Vu 1087 fois
une machine hybride TO8/TO9+ dans le corps d'un MO5 :roll:
0000.jpg
0000.jpg (166.16 Kio) Vu 1085 fois
cf74021.jpg
cf74021.jpg (183.16 Kio) Vu 1084 fois
9369.jpg
9369.jpg (140.54 Kio) Vu 1084 fois

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 22:54

Voilà :
https://www.usbid.com/assets/datasheets ... 35D6F8.pdf
http://matthieu.benoit.free.fr/cross/da ... EF6809.pdf
EF6809.png
EF6809.png (55.15 Kio) Vu 1084 fois
Au fait, merci beaucoup pour tous ces clichés !
Modifié en dernier par nicolho le 22 déc. 2016 23:37, modifié 2 fois.

Avatar du membre
Totor le Butor
Messages : 1507
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: Question MO5 CMS

Message par Totor le Butor » 22 déc. 2016 23:12

Carl = 1 point Vs Sherlock Holmes = 0 point :mrgreen:
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Spoutnik
Messages : 153
Enregistré le : 12 déc. 2016 23:41
Localisation : Landes (40)

Re: Question MO5 CMS

Message par Spoutnik » 22 déc. 2016 23:13

nicolho a écrit :Au fait, merci beaucoup pour tous ces clichés !
Y'a pas de quoi! C'est aussi un mystère pour moi autant en faire profiter tout le monde.

Par contre si j'en crois Carl, j'ai tout sauf un mo5 dans mon mo5... :shock:

nicolho
Messages : 346
Enregistré le : 10 nov. 2016 16:53

Re: Question MO5 CMS

Message par nicolho » 22 déc. 2016 23:23

En attendant le mot des vrais spécialistes, on dirait que ta machine reprend des composants utilisés dans des modèles ultérieurs au MO5 de base, comme le gate array CF74021, d'ailleurs Pulkomandy cite le MO5NR parmis les Thomson l'utilisant :
http://pulkomandy.tk/wiki/doku.php?id=d ... gate_array
Ce qui est sûr, c'est que ton MO5 (doté d'un 6809 pas courant, bien vu Carl!) est très spécial, et que le contenu de ses roms nous rend particulièrement curieux :D
Et puis ton processeur est un composant militaire et spatial, la classe intersidérale, quoi :P
Modifié en dernier par nicolho le 23 déc. 2016 01:58, modifié 3 fois.

__sam__
Messages : 4589
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Question MO5 CMS

Message par __sam__ » 22 déc. 2016 23:33

C'est l’ancêtre du MO6 ou du MO5NR cette machine ? En tout cas le 6809E PLCC ne court pas les rues. Google image n'a pas l'air d'en sortir des masses (ou alors j'ai pas posé la bonne requête). Par exemple ici il est fait mention de cette version "44-pin plastic LCC", mais pas de photos.
Modifié en dernier par __sam__ le 22 déc. 2016 23:37, modifié 1 fois.
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Avatar du membre
Carl
Modérateur
Messages : 10541
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: Question MO5 CMS

Message par Carl » 22 déc. 2016 23:36

6809.jpg
6809.jpg (122.25 Kio) Vu 1074 fois
Carl

Répondre