Redémarrage Apple ][e, 30 ans après...

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

jvernet
Messages : 1326
Enregistré le : 12 avr. 2007 10:59
Localisation : France 69

Re: Redémarrage Apple ][e, 30 ans après...

Message par jvernet » 19 janv. 2018 09:35

Et le netoyage de la tête de lecture ??

Avatar du membre
Totor le Butor
Messages : 1389
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: Redémarrage Apple ][e, 30 ans après...

Message par Totor le Butor » 19 janv. 2018 11:09

+ 1 :mrgreen:
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 19 janv. 2018 15:10

Totor et jvernet ont sans doute raison, la tête de lecture est peut-être encrassée. En cherchant vite fait, il y a cette vidéo en anglais sur comment y accéder sur un Disk II: https://www.youtube.com/watch?v=CMF3PL17kqg . Vois déjà ce que ça donne avant de poursuivre le diagnostic.

Comme tu as un IIGS avec un lecteur 5 pouces 1/4 fonctionnel, tu aurais aussi la possibilité de tester ce lecteur (un A9M0107 probablement) correctement câblé depuis son connecteur interne vers la carte, ou vice-versa, en branchant le lecteur Disk II sur le IIGS (en utilisant le câble démonté du lecteur externe), enfin à condition de prendre le temps de tout bien vérifier et d'avoir de quoi faire le recâblage (pas le connecteur 20 broches directement ! il y a quelques différences) ne serait-ce qu'avec de simples câbles Dupont (si tu n'en as pas , il suffit d'en demander à n'importe quel électronicien pré-pubère de ton entourage :D).

Avatar du membre
Eagle Protect II
Messages : 251
Enregistré le : 22 nov. 2017 22:17

Re: Redémarrage Apple ][e, 30 ans après...

Message par Eagle Protect II » 20 janv. 2018 18:18

Bonjour,


Suite du diagnostic :
- Tête de lecture nettoyée => pas de changement,
- Test de continuité sur les 20 brins de la nappe => le fil n°1 n'est pas passant.

Cependant, c'est une masse (GND) et une fois la nappe branchée des deux côtés, j'ai la continuité (probablement par le pont entre toutes les masses sur une carte ou sur l'autre).

J'ai bien envie de brancher le lecteur sur le connecteur "DRIVE2" de la carte contrôleur... ça aurait des chances de marcher avec un lecteur en bon état ?

(sinon je commence à regarder le câblage du 5,25" GS (effectivement un A9M0107), mais j'ai des scrupules à démonter un lecteur qui marche et à lui changer son câblage pour l'essayer sur une installation qui ne marche pas...).

Merci pour vos conseils,
EP2.

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 20 janv. 2018 19:17

TEST FLOPPY DISK EN BASIC 8)
Hier soir, je me suis amusé à créer un programme de diagnostic qui soit pas trop fatiguant à rentrer, en quelques lignes de Basic.
Après avoir démarré le lecteur 1 sur slot 6 en lecture, voilà ce que c'est censé faire normalement (sur du matériel qui fonctionne bien) :

- écran noir : si aucune donnée nouvelle n'arrive du lecteur vers le contrôleur : faux contact sur RD DATA, disque immobile, panne électronique

- des lignes de points qui défilent conclues par le mot "SYNC" qui apparaît très souvent : une disquette déjà écrite (ou formatée) est insérée ET enclenchée, lecteur fermé (que ses données soient correctement lues ou pas)

- seulement des lignes des point : disquette non formatée, lecteur ouvert (ou qui tourne à vide), ampli du lecteur qui ne reçoit rien

Code : Tout sélectionner

10 HOME : A=49376
20 Z=PEEK(A+14)=PEEK(A+10)=PEEK(A+9)
30 D=PEEK(A+12) : IF D=P THEN HOME : GOTO 50
40 PRINT ".";  :  IF D=255 THEN PRINT "SYNC"
50 P=D : GOTO 30
Ça ne déplace pas la tête, ça reste sur la même piste, donc piste 0 si on a obtenu juste avant la recalibration du lecteur habituelle au reboot.
Quand on arrête le programme avec un Control-C, le lecteur continue à tourner, c'est normal (on peut l'arrêter avec un Control-Reset).
On peut aussi sélectionner plutôt le disque 2 en remplaçant le nombre 10 par 11 à ligne 20.
( :!: en principe, ça ne risque rien, mais à n'utiliser qu'avec des disquettes sans importance)

Donc ça ne permet pas de savoir si les données sont invalides (tête de lecture encrassée, par exemple, enfin quand c'est cas, rien ne va...), mais au moins de voir si, erronées ou pas, elles transitent d'un bout à l'autre de la chaîne, et ça peut donner des indications en cas d'incohérence avec les 3 cas de figures mentionnés plus haut.

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 20 janv. 2018 20:00

Eagle, je comprends tes réticences à trafiquer le lecteur externe, c'était seulement pour évoquer cette possibilité. (si tu le faisais, il faut surtout bien repérer les différences, voir le premier schéma sur cette page : http://www.bigmessowires.com/2015/04/09 ... igs-disks/ )
EDIT : quelques liens vers des images du lecteur A9M0107 pour se faire une idée de sa connectique interne :
http://www.nightfallcrew.com/wp-content ... G_0974.jpg
http://www.nightfallcrew.com/wp-content ... G_0968.jpg
http://www.nightfallcrew.com/wp-content ... G_0971.jpg

Pour le fil 1, c'est bien ça , tu as aussi la masse sur 3, 5 et 7, sur mon lecteur les quatre lignes sont reliées entre elles.
Et oui, pourquoi pas tester sur le "drive 2", si ce n'est que le code de la carte n'essayera de booter que sur le premier lecteur.. mais au moins tu peux encore tester mon programme en BASIC ci-dessus :wink: (après la modification de la ligne 20 que j'ai indiquée, pour changer de lecteur).
EDIT : évidemment, les broches des connecteurs pour lecteur 1 et 2 sont toutes reliées entre elles, à l'exception de la ligne d'activation /EN respective de chaque lecteur.

Dans mes tests j'ai rencontré parfois le même phénomène (assez angoissant :? ) que toi quand l'alimentation ne délivrait pas suffisamment de courant (enfin je pense, parce que j'en utilisais une bricolée pour tester sans alimenter le lecteur par l'ordinateur, j'ai pas mesuré), et même si la tête de lecture/écriture (qui était bien nettoyée pourtant) se déplaçait correctement, ça devait avoir une influence sur son amplification.

Du coup, un test simple qui me vient à l'esprit serait que tu essayes le lecteur avec sa carte contrôleur enfichée dans le IIGS, à vérifier mais je crois bien que c'est possible (configuré pour qu'il soit vu en slot 6 ? enfin je crois,je connais très mal le IIGS, pas les moyens :D), histoire de voir ce que ça donne quand il est alimenté par autre chose. Des chances que ce soit pareil, mais ça ne mange pas de pain d'essayer.

Dans un cas récent, après avoir testé à la chaîne toute une série de disquettes, exactement la même situation que toi... pourtant bonnes, elles n'étaient plus lues correctement, et je ne pouvais rien booter si ce n'est, rarement, que quelques programmes qui tenaient sur une ou quelques pistes.. Premier nettoyage : rien, second (après inspection à la loupe), pareil... Après de nouveaux essais infructueux, j'ai finalement réussi à booter Locksmith 5.0.
Sans trop y croire, histoire de voir ce qui se passait, j'ai lancé une copie rapide avec ce seul lecteur, en passant d'une disquette à l'autre, puis j'ai rebooté la nouvelle disquette pour voir... et : problème réglé ! :shock: :?: Tout est redevenu normal.. enfin c'est probablement une coïncidence, peut-être le temps que les têtes sèchent, tout simplement... Palpitant, non ? :)

Avatar du membre
Eagle Protect II
Messages : 251
Enregistré le : 22 nov. 2017 22:17

Re: Redémarrage Apple ][e, 30 ans après...

Message par Eagle Protect II » 21 janv. 2018 13:01

Hello Guys,


Alors suite des investigations, j'ai tapé ton petit programme, et il donne ceci avec une "bonne" disquette :
(j'affiche "$FF" au lieu de "SYNC" mais c'est pareil)
Essai1.jpg
Essai1.jpg (46.01 Kio) Vu 558 fois

Puis avec une disquette à moitié démagnétisée :
(j'affiche la valeur qu'il trouve au lieu de ".")
Essai2.jpg
Essai2.jpg (92.59 Kio) Vu 558 fois

Puis lecteur ouvert :
(on constate qu'il lit quelques bits à 1 de temps en temps, mais ne trouve jamais de synchrobytes)
Essai3.jpg
Essai3.jpg (97.17 Kio) Vu 558 fois

Ensuite j'ai mis la carte contrôleur dans le slot 6 du GS => je te fais grâce des copies d'écran, mais le résultat est à peu près le même.

Ensuite j'ai booté une "bonne" disquette dans le Disk-II-par-lequel-le-malheur-arriva dans le slot 6 du GS => la disquette est lue, tout marche normalement ! Du coup j'ai remis la carte et le Disk-II-par-lequel-le-malheur-arriva dans le //E, et tout marche normalement.

En résumé : j'ai fait beaucoup de bruit pour rien !

Mais, mauvaise nouvelle, j'ai désormais beaucoup d'autres disquettes qui ne marchent pas sur //e, et lorsque j'ai fait une copie d'une qui marche sur une autre, l'autre ne marche pas. Si je fais la copie avec le lecteur du GS sur le GS, la copie marche.

Le Disk-II-par-lequel-le-malheur-arriva semble donc un peu "faiblard"...

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 21 janv. 2018 19:37

Ah bah voilà, c'est ça l'open source ! Tout de suite on modifie tout comme on veut sans respect pour la présentation originale :mrgreen: :) Si j'ai mis le mot "SYNC", c'est pas pour faire genre, c'est parce que quand on récupère des $FF c'est à cause des nibbles de synchronisation...

Enfin peu importe, sur tes copies d'écran, tout se passe normalement, ça confirme que les données transitent, bien ou mal (comme je prévenais, ça ne confirme pas la validité des données, impossibles à récupérer comme il faut en Basic). Tant mieux si ça fonctionne à nouveau, déjà globalement en lecture, c'est un peu comme mon histoire où ça finit par remarcher : les tête sèchent, les composants se "rodent", la mécanique coulisse mieux...
Alors maintenant si j'ai bien compris, le lecteur du IIGS écrit les disquettes correctement, mais pas ton Disk II (mais est-ce le lecteur du GS arrive à lire les copies qui ne marchent pas sur l'autre ?).

Là encore, c'est plus probablement un souci côté lecteur, au niveau de la tête ou de l'électronique qui la commande. Le Disk II a la grande chance d'avoir un excellent manuel de service, avec ses différentes procédures de test et de réglage : http://apple2online.com/web_documents/a ... edures.pdf , mais côté problème d'écriture, ils proposent un simple essai minimal sous DOS, et seulement de remplacer tous les circuits intégrés de la carte du lecteur, puis de faire une calibration du comparateur à l'oscillo (pas forcément nécessaire si la lecture marche bien), et si ça ne marche toujours pas... de "renvoyer la carte à Apple", pourquoi pas, pour le fun :D .

Il paraît nettement moins probable que le souci soit au niveau du contrôleur, bien que pour le confirmer il suffirait juste de brancher et tester un autre lecteur fonctionnel dessus (moins simple avec les lecteurs à connecteurs DB19 comme on le disait).
Modifié en dernier par nicolho le 21 janv. 2018 19:45, modifié 1 fois.

Avatar du membre
Eagle Protect II
Messages : 251
Enregistré le : 22 nov. 2017 22:17

Re: Redémarrage Apple ][e, 30 ans après...

Message par Eagle Protect II » 21 janv. 2018 19:44

nicolho a écrit :
21 janv. 2018 19:37
... (mais est-ce le lecteur du GS arrive à lire les copies qui ne marchent pas sur l'autre ?).
Oui !
nicolho a écrit :
21 janv. 2018 19:37
Ah bah voilà, c'est ça l'open source, tout de suite on modifie tout comme on veut sans respect pour la présentation originale :mrgreen: :)
Oui !

(déformation professionnelle, je passais mon temps à mettre mon nom partout où je pouvais sur les disquettes à coup de Diskfixer...)

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 21 janv. 2018 19:53

Eagle Protect II a écrit :
21 janv. 2018 19:44
nicolho a écrit :
21 janv. 2018 19:37
... (mais est-ce le lecteur du GS arrive à lire les copies qui ne marchent pas sur l'autre ?).
Oui !
Ah ça change tout ! Si tu as des disquettes qui passent dans l'un et pas dans l'autre, ça reste un problème de lecture sur le DISK II. Du coup la calibration peut jouer.
Sans matériel électronique, je commencerais par tester la vitesse de rotation du lecteur, il faut déjà un programme qui la mesure, il y a ça dans Locksmith 5.0 (par exemple je vérifie que c'est un peu moins que 300RPM et un peu plus que OPTIMUM) mais les vrais utilisateurs Apple du forum auront certainement de meilleures propositions pour ce type de test, ou pour ton problème.

Avatar du membre
Eagle Protect II
Messages : 251
Enregistré le : 22 nov. 2017 22:17

Re: Redémarrage Apple ][e, 30 ans après...

Message par Eagle Protect II » 21 janv. 2018 20:41

nicolho a écrit :
21 janv. 2018 19:53

Ah ça change tout ! Si tu as des disquettes qui passent dans l'un et pas dans l'autre, ça reste un problème de lecture sur le DISK II. Du coup la calibration peut jouer.
Sans matériel électronique,
J'ai un oscilloscope, si ça peut servir...
nicolho a écrit :
21 janv. 2018 19:53
je commencerais par tester la vitesse de rotation du lecteur, il faut déjà un programme qui la mesure, il y a ça dans Locksmith 5.0 (par exemple je vérifie que c'est un peu moins que 300RPM et un peu plus que OPTIMUM) mais les vrais utilisateurs Apple du forum auront certainement de meilleures propositions pour ce type de test, ou pour ton problème.
Datalife Disk Drive Analyser, qui m'a fait la grâce de démarrer sur le //e :
DDDA.jpg
DDDA.jpg (47.17 Kio) Vu 526 fois

(à savoir que "pass" ne veut pas dire "passable" mais "ça passe").

Bon, je me demande si ce n'est pas, comme tu l'évoquais plus haut, une tension un peu faible au niveau de l'alim, ou in fine au niveau de la tête d'écriture...

Avatar du membre
fneck
Site Admin
Messages : 12122
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Redémarrage Apple ][e, 30 ans après...

Message par fneck » 21 janv. 2018 20:47

Hello EP2, je dois avouer que je suis un peu largué là et je n'arrive plus du tout à suivre, pourrais-tu nous faire un résumé de ce qui va et ne va pas sur ton Apple IIe? 8)

nicolho
Messages : 237
Enregistré le : 10 nov. 2016 16:53

Re: Redémarrage Apple ][e, 30 ans après...

Message par nicolho » 21 janv. 2018 20:48

Eagle Protect II a écrit :
21 janv. 2018 20:41
J'ai un oscilloscope, si ça peut servir...
Alors à l'occasion, avec tu peux suivre les procédures du document Apple dont je viens de redonner le lien.
Eagle Protect II a écrit :Bon, je me demande si ce n'est pas, comme tu l'évoquais plus haut, une tension un peu faible au niveau de l'alim, ou in fine au niveau de la tête d'écriture...
Oui, pour avoir alimenté un lecteur de ce type avec diverses sources, ça peut jouer. Tu l'as peut-être déjà fait, mais du coup tu pourrais déjà tester le Disk II avec sa carte contrôleur dans le IIGS (au cas où le lecteur serait mieux alimenté comme ça) et refaire de tests de copie.

Avatar du membre
Eagle Protect II
Messages : 251
Enregistré le : 22 nov. 2017 22:17

Re: Redémarrage Apple ][e, 30 ans après...

Message par Eagle Protect II » 21 janv. 2018 21:23

fneck a écrit :
21 janv. 2018 20:47
Hello EP2, je dois avouer que je suis un peu largué là et je n'arrive plus du tout à suivre, pourrais-tu nous faire un résumé de ce qui va et ne va pas sur ton Apple IIe? 8)
Oui, excuse-moi, ça devient confus.

1) Mes disquettes marchent sur mon //e.
2) Mes disquettes ne marchent plus sur mon //e (là, j'appelle au secours).
3) Je déterre mon GS, les disquettes marchent dessus.
4) Je lance le petit programme BASIC de Nicolho sur le //e, et ça a l'air de vivre quand-même.
5) Je lance le petit programme BASIC de Nicolho sur le GS, et ça fait pareil.
6) Je mets la carte contrôleur dans le GS, le Disk II remarche (j'arrive à booter le GS, alors que le //e ne bootait pas)
7) Je remets la carte contrôleur dans le //e, le Disk II remarche (j'arrive à booter le //e qui ne bootait plus)

(Là, je dis "beaucoup de bruit pour rien", mais c'est quand-même bizarre toute cette histoire). Je crois être tiré d'affaire, mais :

8 ) Si j'ai certaines disquettes qui marchent, d'autres ne marchent plus (le lecteur a l'air caractériel), et
9) Si je fais une copie avec le Disk II sur le //e, la copie ne marche pas.

Bon, je n'ai pas fini de regarder toutes les infos données par Nicolho, je continue les investigations et on verra après.

Désolé de monopoliser le forum (surtout arrivé au point 7 ci-dessus, je suis un peu confus...)

Avatar du membre
fneck
Site Admin
Messages : 12122
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Redémarrage Apple ][e, 30 ans après...

Message par fneck » 21 janv. 2018 22:50

Merci pour le résumé.

En fait tu as peut-être simplement des mauvaises connexions... dans ces vieilles machines ça arrive. Et donc démonter, remonter, débrancher, rebrancher peut aider à résoudre des problèmes. En partant sur cette hypothèse, tu peux essayer d'appuyer sur tous les composants sur support dans ton Apple II et sur la carte Disk II s'il y en a (voire même légèrement les retirer de leur support puis les réinsérer à fond). Eventuellement regarder la propreté dans les slots de la carte mère voire utiliser un désoxydant genre KF F2 ou équivalent. Désoxyder le connecteur de la nappe de la même manière. A-t'il était stocké à l'humidité?

Et y a pas à être désolé 8)

Répondre