Panne démarrage To7

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Papy.G, fneck, Carl

Falkayn
Messages : 90
Enregistré le : 12 juin 2018 18:18

Panne démarrage To7

Message par Falkayn » 21 déc. 2018 11:27

Bonjour,

J'ai un TO7 (Pas 7/70) qui refuse de démarrer :

Ecran blanc/gris avec bordure noire. (Edit : L'écran est bien blanc, pas gris)
Lors de l'appuie sur reset : écran blanc. (Edit : L'écran est bien blanc, pas gris)

Une idée du circuit fautif ? Je soupçonnerai bien l'un des ic 74 liée a la partie graphique, Mais je ne trouve que très peu d'info.
Si des spécialistes Thomson ont des conseils ?
20181205_222640.jpg
20181205_222640.jpg (62.69 Kio) Vu 349 fois
20181205_222640-2.jpg
20181205_222640-2.jpg (29.93 Kio) Vu 349 fois
Modifié en dernier par Falkayn le 09 janv. 2019 10:05, modifié 1 fois.

__sam__
Messages : 4703
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Panne démarrage To7

Message par __sam__ » 21 déc. 2018 11:38

Bah déjà la couleur grise sur un TO7 (qui n'a pas cette couleur dans sa palette) indique que la prise peritel n'est pas la bonne. La TV affiche du composite au lieu du RVB. C'est un classique qui se produit quand le cordon peritel n'est pas complètement cablé ou qu'on a branché sur la mauvaise entrée peritel de la TV.
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Daniel
Messages : 11923
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne démarrage To7

Message par Daniel » 21 déc. 2018 11:44

On peut savoir si le processeur fonctionne grâce au son : y-a-t-il un beep en appuyant sur une touche ?
Sinon, la première chose à faire est de vérifier les trois tensions d'alimentation.
Les condensateurs tantale du TO7 se mettent souvent en court-circuit, dans ce cas le radiateur à l'arrière est généralement très chaud.
Après ces vérifications faciles, la suite nécessite un oscilloscope pour vérifier la présence du signal d'horloge.
Daniel
L'obstacle augmente mon ardeur.

Falkayn
Messages : 90
Enregistré le : 12 juin 2018 18:18

Re: Panne démarrage To7

Message par Falkayn » 21 déc. 2018 11:54

J'ai vérifié les 3 condo, ils ne sont pas en court circuits.

Mais bon je vais les retirer pour plus de tests.
Le radiateur arrière n'est pas très chaud. Par contre le bloc alu de refroidissement sous le clavier est lui assez chaud.
Les tests sont sans cartouches. Et il n'y a pas de beep des touches.


La Gris est assez clair. C'est pour ça que j’hésite a dire si c'est du blanc ou du gris.

Daniel
Messages : 11923
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne démarrage To7

Message par Daniel » 21 déc. 2018 12:55

Pas de beep de touche, alors le processeur ne fonctionne pas ou s'est planté au démarrage. Les causes possibles sont multiples, le diagnostic nécessite un oscilloscope et un analyseur logique. Sinon on peut remplacer des circuits au hasard, mais c'est une loterie avec peu de chances de gagner.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 12920
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Panne démarrage To7

Message par fneck » 21 déc. 2018 13:30

Le beep de touche passe par le haut-parleur de la télévision or, comme le disait Sam plus haut, on n'est peut-être pas certain du branchement correct...

Daniel
Messages : 11923
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne démarrage To7

Message par Daniel » 21 déc. 2018 20:04

Dans le TO7 et dans le TO7/70 il y a un buzzer sur la carte mère. On entend le beep des touches même sans connecter le câble péritel.

buzzer.png
buzzer.png (70.64 Kio) Vu 295 fois
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 12920
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Panne démarrage To7

Message par fneck » 21 déc. 2018 21:07

Ah OK... alors du coup je n'ai rien dit :oops:

Falkayn
Messages : 90
Enregistré le : 12 juin 2018 18:18

Re: Panne démarrage To7

Message par Falkayn » 09 janv. 2019 10:03

Suite des tests.

J'ai mis la main sur un deuxième TO 7 en panne. Malheureusement qui présente exactement les mêmes symptômes... J'ai vu que J Vernet avait eu les mêmes soucis il y a longtemps. (Je lui ai envoyé un MP pour savoir si il a résolu la panne.)

Donc ça semble un PB récurrents, mais je n'ai pas trouvé la solution dans les archives.

Donc,

Remplacement de tous les condensateurs Tantale (alim et autres) : Pas d'effets
Remplacement du 6809 par plusieurs autres processeurs 6809 que l'on m'a prêté : Pas d'effets

J'ai commencé une analyse à l'oscilloscope avec l'aide de quelqu'un (car pour l'instant je n'ai pas les compétences). Rien de concluant sur le temps passé. Mais nous n'avons pas été plus loin que qq tests sur le processeur. Je vais investigué plus profondément les analyses dans les semaines à venir. Le temps d’acquérir plus d’expériences.

Donc pour résumer : Semble une panne très courante, non lié aux condensateurs tantale ni le processeur.

Daniel
Messages : 11923
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne démarrage To7

Message par Daniel » 09 janv. 2019 10:47

Quelles sont les tensions d'alimentation mesurées sur la carte mère (5V, 12V et -5V) ?

Ce que l'on peut dire :
- Le processeur est planté avant l'affichage de l'écran d'accueil.
- C'est une panne courante qui a différentes variantes (écran blanc, motifs aléatoires, ou fixes ou animés).
- Les causes sont multiples : RAM, ROM, décodage d'adresse, mauvais contact, etc.

Le plus courant est une panne de RAM ou d'un circuit logique, mais toutes les autres causes sont aussi possibles.
Exemple : un 74LS139 - Voir ici --> viewtopic.php?f=18&t=5402
Daniel
L'obstacle augmente mon ardeur.

Falkayn
Messages : 90
Enregistré le : 12 juin 2018 18:18

Re: Panne démarrage To7

Message par Falkayn » 10 janv. 2019 13:57

Suite de mes investigations.
Bon, finalement mon graveur d'eprom TL866 vient d'être rentabilisé... La fonction test ic vient d'identifier un 74157n défectueux sur l'un des 2 To7... donc transfert du 74157 depuis l'autre TO ainsi que du clavier qui avait une piste oxydé...

Heureusement j'ai commencé avec les ic qui étaient déjà sur support... donc aucun dessoudage...

Si ce n'est le recapping que j'avais déjà effectué... Donc voici un TO 9000...
Quelques tests avec la megarom T2 , tous semble OK.

Me reste donc à dépanner l'autre TO7. Mais mon objectif d'au moins faire une machine fonctionnelle avec les composants des 2 est déjà atteint.
Fichiers joints
TO9000.jpg
TO9000.jpg (124.59 Kio) Vu 150 fois

__sam__
Messages : 4703
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Panne démarrage To7

Message par __sam__ » 10 janv. 2019 15:20

Félicitations!
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Daniel
Messages : 11923
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne démarrage To7

Message par Daniel » 10 janv. 2019 15:28

Un de plus de sauvé. Félicitations !

Pour ce genre de panne, c'est une preuve de plus qu'il faut éviter les diagnostics trop faciles. Du genre "Il y a un problème d'affichage donc c'est la RAM vidéo". Oui, ça peut être la RAM vidéo, mais aussi vingt autres causes tout aussi probables. Dans le TO7 on ne peut pas accuser le gate array (il n'y en a pas), par contre les circuits logiques (74LS157, 74LS239, etc.) sont parfois en panne. C'est au moins le troisième exemple à ma connaissance.
Daniel
L'obstacle augmente mon ardeur.

Patrick
Messages : 990
Enregistré le : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: Panne démarrage To7

Message par Patrick » 10 janv. 2019 15:37

Super ! Le TL866 est très pratique pour ça. Dommage qu'il ne fasse pas les RAMs.
Patrick

jasz
Messages : 717
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: Panne démarrage To7

Message par jasz » 10 janv. 2019 16:18

Bravo!

Cependant cette réparation a donné à ton Trinitron le pouvoir d'attirer tout les objets alentours :shock: :mrgreen:

Répondre