bras robot

C'est le lieu des discussions diverses et variées, mais toujours en rapport avec le thème général du forum et dans l'esprit de celui-ci.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
Papy.G
Modérateur
Messages : 1708
Enregistré le : 10 juin 2014 13:40
Localisation : Nantes/La Roche sur Yon

Re: bras robot

Message par Papy.G » 10 avr. 2018 13:44

La pince est double effet, orifices M5x0,8, probablement équipée déjà de raccords encliquetables pour tuyau de 4mm, il faut un distributeur ou 5/3 à centre fermé, si tu n'as pas de stockage et ne veux pas laisser le compresseur tourner en permanence, c'est chaud à trouver en pneumatique! Faudra bricoler avec une ev à l'alimentation, sauf si t'as un compresseur à cuve, et un 5/2 fera l'affaire.
laurel a écrit :
09 avr. 2018 21:09
ça? c'est petit !
https://www.ebay.fr/itm/AIR-POMPE-12V-5 ... SwQbhakSZU
Trop faible en pression. :wink:
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
laurel
Messages : 1449
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: bras robot

Message par laurel » 11 avr. 2018 20:48

Merci pour toutes ces infos. Il est arrivé au point relais...
J'essayerai d'aller le chercher demain!
Papy.g, c'est quoi un 5/3 ou 5/2??
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
Falkor
Messages : 583
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: bras robot

Message par Falkor » 12 avr. 2018 07:44

laurel a écrit :
11 avr. 2018 20:48
Papy.g, c'est quoi un 5/3 ou 5/2??
C'est une convention permettant de désigner un distributeur pneumatique ou hydraulique. Le premier chiffre (5) indique le nombre de connecteurs ou orifices, le second chiffre (3 ou 2) le nombre de positions que peut prendre le distributeur.

http://geea.org.pagesperso-orange.fr/PN ... uteurs.htm

Selon cette représentation, ton distributeur va pouvoir piloter un vérin simple (alimenté que d'un coté, avec rappel souvent par ressort) ou double effet (alimentation des deux cotés du piston).

Quelques photos du bestiau seront les bienvenues dès que tu pourras !!

Avatar du membre
laurel
Messages : 1449
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: bras robot

Message par laurel » 12 avr. 2018 21:07

Suis arrivé 5 min après la fermeture de mon point relay... ce sera pour samedi,
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
laurel
Messages : 1449
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: bras robot

Message par laurel » 14 avr. 2018 15:06

Juste quelques photos... je viens de le récupérer.
Première impressions :
Sale mais de super bonne qualité.
L'un des moteurs me semblait bloqué, mais je pense que c'est normal, c'est du au "couplage?" (Je ne sais pas comment on appel ça...)
Il y'a déjà l'electrovanne pour l'air il me semble.
J'ai pris une photo de l'encodeur du moteur. Il faudra trouver à quoi correspondent les sorties.
Aucune information sur le moteurs par contre...
Même pas de marque.
Fichiers joints
IMG_6092.JPG
IMG_6092.JPG (763.06 Kio) Vu 145 fois
IMG_6087.JPG
IMG_6087.JPG (456.96 Kio) Vu 145 fois
IMG_6076.JPG
IMG_6076.JPG (1.43 Mio) Vu 145 fois
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
Falkor
Messages : 583
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: bras robot

Message par Falkor » 14 avr. 2018 17:00

Chouette engin !
laurel a écrit :
14 avr. 2018 15:06
L'un des moteurs me semblait bloqué, mais je pense que c'est normal, c'est du au "couplage?" (Je ne sais pas comment on appel ça...)
Alors j'ai du mal à voir, mais s'il s'agit d'un moteur avec motoréducteur, normal qu'il y ait un peu de couple. Ou présence d'un frein !

laurel a écrit :
14 avr. 2018 15:06
Il y'a déjà l'electrovanne pour l'air il me semble.
Yep, sûrement alimentée en 24V. La pince doit donc être équipée d'un ressort de rappel.

laurel a écrit :
14 avr. 2018 15:06
J'ai pris une photo de l'encodeur du moteur. Il faudra trouver à quoi correspondent les sorties.
A 90% de chances tu as A, /A, B et /B d'un encodeur incrémental.

http://www.robotoid.com/appnotes/circui ... oding.html

On donne les complémentaires des signaux pour faire du filtrage et de la vérification. Un coup d'oscillo si tu en a un permet de déterminer les signaux. Sur ta 2eme photo à droite on voit un bout de texte d'un capot, certainement des infos sur le codeur (nombre d'impulsions par tour...)
laurel a écrit :
14 avr. 2018 15:06
Aucune information sur le moteurs par contre...
Même pas de marque.
Arffff. :( J'ai peur qu'il ne te faille en extraire un...


On aperçoit un capteur de fin de course sur ta dernière photo. Tu dois en avoir 2 par axes.

Avatar du membre
laurel
Messages : 1449
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: bras robot

Message par laurel » 14 avr. 2018 19:37

Falkor a écrit :
14 avr. 2018 17:00
Alors j'ai du mal à voir, mais s'il s'agit d'un moteur avec motoréducteur, normal qu'il y ait un peu de couple. Ou présence d'un frein !
Pas de frein je pense...
Falkor a écrit :
14 avr. 2018 17:00
A 90% de chances tu as A, /A, B et /B d'un encodeur incrémental.
A oui, je vois bien des sortes de roues dentées ! Parfait, j'ai compris le principe.
Falkor a écrit :
14 avr. 2018 17:00
Sur ta 2eme photo à droite on voit un bout de texte d'un capot, certainement des infos sur le codeur (nombre d'impulsions par tour...)
Non, aucun texte informatif! mais pas grave, je devrais pourvoir faire sans pour l'encodeur...
Falkor a écrit :
14 avr. 2018 17:00
Arffff. :( J'ai peur qu'il ne te faille en extraire un...
J'ai déjà démonté une bonne partie, je n'ai rien vu...
Sinon quelle serait la procédure pour le tester ? Augmenter progressivement la tension? Je peux l'alimenter avec une alim de labo...
L'idée c'est de définir sa tension maximum de fonctionnement c'est bien ça? (pwm à termes pour faire varier la vitesse)
Mais alors il faudrait que je démonte les motoreducteur avant de faire mes tests?
Falkor a écrit :
14 avr. 2018 17:00
On aperçoit un capteur de fin de course sur ta dernière photo. Tu dois en avoir 2 par axes.
Exactement!
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
Falkor
Messages : 583
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: bras robot

Message par Falkor » 14 avr. 2018 20:32

Aie, si aucune info sur les moteurs, ça ne va pas être facile... :)

Déjà et histoire d'être sûr, combien de fils sortent des moteurs ? Si l'arbre est libre en rotation, place un oscillo sur les éventuels fils pour vérifier que le moteur fait bien dynamo.

Après oui l'idée peut consister à monter progressivement la tension avec une alim de labo. Mais tu auras du mal à déterminer la puissance max et la tension max avec certitude.

Apparemment, une technique pour déterminer ces grandeurs consiste à faire tourner l'axe moteur avec une perceuse ou similaire et faire des relevés de tension en fonction de la vitesse de rotation. Jamais essayé... mais c'est la méthode qui revient souvent quand on fait des recherches sur le sujet.

https://electronics.stackexchange.com/q ... n-dc-motor

Avatar du membre
laurel
Messages : 1449
Enregistré le : 23 nov. 2009 16:04
Localisation : Nancy
Contact :

Re: bras robot

Message par laurel » 16 avr. 2018 14:56

Il n'y a que 2 fils qui sortent des moteurs.
J'ai essayé d'alimenter un des 2 plus gros (il y 2 type de moteurs) de 12v à 24v.
Ça tourne plus ou moins vite et l'alim annonce entre 0.7 et 1 ampere.
En tout cas à 24v ca me paraît déjà rapide. À contrôler avec le moteur Remonté dans Le Bras.
Il faudra je suppose que je contrôle l'amperage au démarrage avec l'oscillo et un petit montage.

Quels sont les risques à sur ou sous alimenter un moteur ? Sachant qu'il ne va pas tourner 24/24 !!
Apple 1: http://applethefirst.blogspot.com/
Recherche un boitier Color Classic, du Next, un DD apple SC20
Voir mes échanges

Avatar du membre
Falkor
Messages : 583
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: bras robot

Message par Falkor » 17 avr. 2018 07:41

Tu as bien avancé...!

Oui l'idéal est de contrôler à l'oscillo (résistance de 1 ohm en série avec ton moteur, oscillo à ses bornes).

Sous alimenter un moteur CC n'a pour conséquence de le faire tourner moins vite. Dans certains cas, le courant (image du couple) peut faire que le moteur cale et là il y a risque de le griller.

Sur alimenter : risque de griller le tout.

Après effectivement si ton but n'est que de le faire marcher de temps en temps à vitesse réduite, tu peux le sous alimenter.

Répondre