Problème d'affichage des images sur le forum

Ici c'est moi qui vous informe de la vie du site et du forum.

Modérateurs : Papy.G, fneck, Carl

Répondre
Avatar du membre
fneck
Site Admin
Messages : 13916
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Problème d'affichage des images sur le forum

Message par fneck » 14 nov. 2020 18:15

C'est que chez moi ou il y a de nouveau des problèmes avec l'affichage des photos hébergées chez Free, en fait je ne vois pas les photos du message précédent de Daniel (sous W10 avec Chome) ?

[topic divisé]
Exemple d'images ne passant pas :
Daniel a écrit :Image Image

Daniel
Messages : 13119
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Journée avec ma petite Colorpaint TO8

Message par Daniel » 14 nov. 2020 18:35

Ah oui, tu as raison. Je viens d'essayer avec Chrome et je ne les vois pas. Pourtant je suis chez Free.

Google a peut-être inventé un autre moyen pour me persécuter. J'ai réussi à échapper à la censure de Google Safe Browsing, mais ils ont du trouver autre chose. Pourtant je vous assure qu'il n'y a aucun virus dans ces copies d'écran. Vous pouvez les voir en cliquant sur les liens de mon message précédent.

Avec Firefox elles s'affichent sans problème.

Dans Chrome, avec un clic droit / afficher l'image dans un nouvel onglet, on peut les voir.

[Edit]
C'est un problème connu. Une solution a été trouvée, semble-t-il, mais sans aucune explication :
https://forum.forumactif.com/t400839-pr ... gle-chrome
Daniel
L'obstacle augmente mon ardeur.

sebastus
Messages : 136
Enregistré le : 21 janv. 2019 14:36

Re: Journée avec ma petite Colorpaint TO8

Message par sebastus » 14 nov. 2020 23:16

Firefox ici ça marche sans problème ;-)

Patrick
Messages : 1528
Enregistré le : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: Journée avec ma petite Colorpaint TO8

Message par Patrick » 15 nov. 2020 10:44

Sur Chrome, c'est lié au fait que le forum est en HTTPS et les images hébergées sur les sites personnels en HTTP chez Free.
Chrome bloque désormais par défaut le chargement de ressources non sécurisées à partir de site sécurisés.
Il faut changer les paramètres de site pour autoriser le contenu non sécurisé, en attendant que Free propose le HTTPS.
Patrick

Avatar du membre
Carl
Modérateur
Messages : 11391
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: Journée avec ma petite Colorpaint TO8

Message par Carl » 15 nov. 2020 11:09

Sous Mac OS big Sur avec Safari, je vois les images mais pas avec Chrome...

Carl

Avatar du membre
fneck
Site Admin
Messages : 13916
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Journée avec ma petite Colorpaint TO8

Message par fneck » 15 nov. 2020 11:14

Oui, c'est bien cela Patrick. Par défaut Chrome bloque l'affichage d'un contenu non sécurisé sur un site sécurisé. Il faut ajouter l'URL du forum en tant que site autorisé dans : Paramètres -> Confidentialité et sécurité -> Paramètre de sites -> Contenu non sécurisé

C'est lourd, et du coup je ne sais pas quoi faire dans mes options... Depuis le temps je ne comprends pas pourquoi Free ne passe pas en https :|

Zebulon
Messages : 58
Enregistré le : 02 nov. 2020 14:03

Re: Journée avec ma petite Colorpaint TO8

Message par Zebulon » 15 nov. 2020 11:15

Pas de problème non plus avec Edge sous Windows 10. Mais ça ne m'étonne pas que Chrome soit moins permissif pour des raisons de sécurité. Les autres s'y mettront aussi, cependant il faut trouver un moyen pour informer l'utilisateur non expert du pourquoi et comment rétablir la situation moins sécurisée en lui faisant prendre conscience des risques encourus...

Patrick
Messages : 1528
Enregistré le : 16 mai 2009 09:30
Localisation : Clermont-Ferrand

Re: Journée avec ma petite Colorpaint TO8

Message par Patrick » 15 nov. 2020 11:16

Petite précision, ce paramétrage est fait au niveau du site visité, pas globalement.
Personnellement, je l'ai fait pour le forum et celui de Silicium, sur lesquels je poste des liens dont le contenu est hébergé sur mon site personnel Free.
Patrick

Daniel
Messages : 13119
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Journée avec ma petite Colorpaint TO8

Message par Daniel » 15 nov. 2020 16:44

Je comprends l'intérêt du HTTPS quand un site reçoit des informations venant de l'utilisateur.
Mais pour un site comme dcmoto, avec uniquement des pages HTML statiques, le cryptage des informations n'a pas de sens.
Une copie d'écran de Graffiti ou d'Animatix a peu de chances de corrompre votre système et ne risque pas de vous dérober votre carte bancaire.
Daniel
L'obstacle augmente mon ardeur.

Zebulon
Messages : 58
Enregistré le : 02 nov. 2020 14:03

Re: Journée avec ma petite Colorpaint TO8

Message par Zebulon » 15 nov. 2020 22:00

HTTPS outre le fait de garantir le cryptage/confidentialité, l'authenticité et l'intégrité des données entre le Client et le Serveur qui établissent une communication point à point à l'aide de certificats, prévient aussi des attaques de type "man in the middle" dans laquelle un individu malveillant peut substituer un fichier contenant une charge virale en réponse à la simple demande d'image de votre navigateur. Là potentiellement ce n'est pas uniquement le numéro de carte bleue que vous lui communiquez mais bien plus.

Voilà ce qu'en dit mon navigateur à l'instant:
Capture d’écran 2020-11-15 220007.png
Capture d’écran 2020-11-15 220007.png (8.84 Kio) Vu 264 fois

C'est pour cela qu'il est risqué de combiner HTTP et HTTPS dans une même navigation. Ce n'est normalement pas très bien vu non plus de mixer des éléments provenant de domaines différents au sein d'une même page. En l'occurrence c'est le cas pour des images hébergées ailleurs que sur le forum mais des sites institutionnels évitent ce genre de pratique.

Avatar du membre
fneck
Site Admin
Messages : 13916
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Journée avec ma petite Colorpaint TO8

Message par fneck » 15 nov. 2020 23:08

Tu as l'air de connaitre le sujet Zebulon. Que faut-il faire alors dans le cas d'un forum?
Accepter ce que propose Chrome par défaut et ne plus afficher les éléments non sécurisé?

(nota: demain je vais séparer les messages n'ayant pas de rapport avec le sujet initial dans un nouveau topic).

Zebulon
Messages : 58
Enregistré le : 02 nov. 2020 14:03

Re: Journée avec ma petite Colorpaint TO8

Message par Zebulon » 15 nov. 2020 23:37

Si on veut se sécuriser au maximum oui mais les pages vont être tristounes. Il faut bien accepter une part résiduelle de risque. Disons que Chrome est radical par défaut. Edge est plus souple mais l'affichage "Non sécurisé" ne saute pas aux yeux et franchement je n'y avais même pas prêté attention avant de répondre à Daniel.

Donc accepter l'affichage du contenu externe non sécurisé (les images hébergées en HTTP) tout en ayant conscience d'un possible risque. Mais HTTPS et le navigateur ne sont pas les seuls remparts. Votre "antivirus" (c'est un abus de langage car les suites actuelles font bien plus) doit scanner le contenu en entrée/sortie et isoler un éventuel fichier "image" vérolé avant qu'il ne soit affiché par le navigateur.

Répondre