Page 1 sur 5

Déconnexion intempestive (ancien hébergement)

Posté : 23 juil. 2016 12:26
par Daniel
Dans le passé, j'ai eu parfois des déconnexions intempestives. Elles n'étaient pas provoquées par une inactivité prolongée, mais intervenaient immédiatement.

Par exemple je me connecte pour répondre dans un fil de discussion, je tape trois mots en 3 secondes, je clique sur aperçu et au lieu d'avoir l'aperçu je suis renvoyé à la page de connexion. Même problème pour l'envoi, ou pour l'édition d'un message. Même problème dans la messagerie personnelle.

Il y a quelques mois, le problème arrivait, mais très rarement. Depuis quelques jours c'est presque à chaque fois. Suis-je le seul ? Quelle peut être la cause ? Est-ce que ça peut avoir un rapport avec Addblock ou Ghostery ?

Re: Déconnexion intempestive

Posté : 23 juil. 2016 13:17
par __sam__
Perso, une fois connecté ca marche pour moi. Mais il est vrai que parfois quand je click sur le liens de mes favoris j'ai un message qui dit que le site est inaccessible.

Re: Déconnexion intempestive

Posté : 23 juil. 2016 13:52
par Zaxxon
Bonjour,

Je rencontre ce problème uniquement sur téléphone (Chrome sur android), mais le problème est le même que celui décrit Par Daniel.

Par contre pas d'adlbock (ad away mais par blocage pub par fichier host).

Quant à Adblock (j'utilise ublock origin, un fork d'adblock plus), sur mes pcs, aucun soucis.

Daniel, Ghostery ne bloquerait-il pas des cookies?

Re: Déconnexion intempestive

Posté : 23 juil. 2016 14:03
par Daniel
Normalement je n'ai bloqué les cookies nulle part, dans aucune option du navigateur ou des plugins (Firefox + Adblock Plus + Ghostery). D'ailleurs, à certains moment de la journée, il n'y a pas de problème. J'ai ouvert ce sujet parce que c'est arrivé une dizaine de fois ce matin, alors que je répondais à des messages personnels, et aussi deux ou trois fois dans des fils de discussions.

A cet instant même (14:04) tout fonctionne bien.

[Edit] A 14h40 nouvelle déconnexion non souhaitée, en répondant à un post dans la section bricolage. A ce moment précis, la réponse du serveur a été très longue (plus de 10 secondes).

Re: Déconnexion intempestive

Posté : 23 juil. 2016 14:41
par fneck
Pas de problème de mon coté.

Les seules fois où j'ai rencontré ce problème de déconnexion c'est dans un hôtel, dans lequel le signal wifi est de très mauvaise qualité (trop faible ou trop partagé je ne sais pas exactement).

Re: Déconnexion intempestive

Posté : 23 juil. 2016 15:55
par Daniel
Voici une preuve du problème de déconnexion :
- Je viens de me connecter. Il y a la mention "CONNECTE" en haut à droite.
- Mais en fait la connexion n'a pas marché, car je ne peux pas répondre ni éditer mon message. Les boutons n'apparaissent pas.

Quelquefois les boutons apparaissent, on peut rédiger une réponse, mais en lançant l'aperçu ou l'enregistrement ça ne marche pas, on retourne à l'écran de connexion. On perd tout ce qu'on a tapé, sauf en rusant par l'utilisation de la commande retour page précédente 5 ou 6 fois de suite. Au bout d'un moment ça devient très pénible.
deconnexion.png
deconnexion.png (64.58 Kio) Vu 2772 fois
Autre bug constaté depuis quelques jours seulement : après avoir cliqué sur Déconnexion en haut à droite de la page du forum, on a une réponse indiquant que l'on est déconnecté. Par contre, en bas de la page, on est toujours dans la liste des utilisateurs connectés, et dans les posts figure le bandeau "CONNECTE" en haut à droite. Et pourtant on est bel et bien déconnecté car on ne peut ni répondre ni éditer. Ca, c'est nouveau, je ne l'ai jamais eu auparavant.

Re: Déconnexion intempestive

Posté : 23 juil. 2016 16:29
par claudounet
Quel navigateur utilise tu Daniel?
Personnellement, je trouve qu'un certain navigateur (très populaire) pose pas mal de problèmes à cause de sa gestion du cache (firefox pour ne pas le nommer).

Essaie Opera et voit si ca fait la même chose.

Aussi, regarde ton anti-virus au cas où il efface les cookies. Après, il y a aussi la qualité du signal (mobile, wifi).

Re: Déconnexion intempestive

Posté : 23 juil. 2016 18:01
par Daniel
C'est peut-être effectivement un problème avec Firefox + Adblock Plus + Ghostery. Là je poste avec K-Meleon et (pour l'instant) je n'ai pas pu reproduire l'erreur, mais l'incident était aléatoire il n'y a donc pas de certitude. C'est le genre de problème difficile à cerner, il faudra du temps pour trouver une logique et une explication rationnelles. C'est l'inconvénient des systèmes modernes, beaucoup trop complexes à mon goût.

[Edit]
Je ne suis pas le seul à avoir ce problème, ce qui me rassure un peu : http://forums.phpbb-fr.com/support-util ... 61473.html
J'ai trouvé plus d'une dizaine de témoignages du même genre, avec Firefox mais aussi d'autres navigateurs.
C'est semble-t-il un problème de vieux cookies qui trainent, ou peut-être de cache, il est difficile d'en savoir plus. Je crois que je vais, moi aussi, effacer toutes mes traces, au moins à la fermeture du navigateur.

Re: Déconnexion intempestive

Posté : 24 juil. 2016 00:44
par claudounet
Le cache de Firefox nous a toujours posé un problème. On a eu pas des cas ou nos utilisateurs rafraichissent le contenu, puis rafraichissent la page, et celle ci n'est pas mise à jour. On a essayer de le configurer pour rafraichir à chaque fois, ca ne marche pas vraiment, du coup on a abandonné Firefox.

Regarde aussi si Firefox ne serait pas en mode 'private' par défaut, auquel cas, les cookies seraient effacés dès fermeture du navigateur.

J'utilise Opera avec Ghostery et je n'ai aucun problème, ni sur le forum, ni ailleurs. Et puis, avec le temps, j'ai remarqué que les bonnes idées d'amélioration de navigateur sont initiées par Opera: mode "clone page", "pin page" etc. Il intègre un gestionnaire de bookmarks par défaut.

Re: Déconnexion intempestive

Posté : 24 juil. 2016 14:07
par Daniel
Après avoir effacé tous les cookies et vidé le cache de Firefox, je retrouve le comportement d'avant : plus de déconnexions intempestives, sauf rares exceptions (une fois hier soir). Le problème n'est pas résolu pour autant, car la cause est toujours inconnue. On peut dire que le navigateur y est certainement pour quelque chose, comme l'a justement écrit Claudounet. Mais pourquoi exactement ?

Je me souviens d'un problème similaire : http://forum.system-cfg.com/viewtopic.php?f=14&t=7135
Il était lié aux cookies du forum system-cfg, mais pas au cache. Je l'avais résolu en effaçant les cookies. Je suis persuadé que le problème de déconnexion intempestive est de même nature. Je vais attendre que ça se reproduise et j'espère finir par trouver...

Re: Déconnexion intempestive

Posté : 24 juil. 2016 20:01
par frodon69
J'utilise Firefox + Adblock Plus + Ghostery et ne rencontre aucun problème ; je vide très rarement le cache et fait tout aussi rarement le ménage dans les cookies.

Par contre si je change d'ordinateur, même sur la même ip, je dois obligatoirement me ré-identifier.

Re: Déconnexion intempestive

Posté : 24 juil. 2016 20:49
par Daniel
J'étais exactement dans le même cas, et je n'avais pas de problème. Jusqu'à cette semaine. Je n'ai rien fait de spécial ni changé quoi que ce soit dans les paramètres de Firefox, et le problème est arrivé tout seul. Maintenant je sais que ça vient d'un cookie de system-cfg, mais je n'ai pas encore identifié lequel. J'en avais 7, et en supprimant les 7 tout est redevenu comme avant.

Re: Déconnexion intempestive

Posté : 24 juil. 2016 22:53
par fneck
Pour ce qui concerne les cookies, j'ai aussi remarqué que lorsqu'un site (en général, pas spécialement pour System-cfg) ne fonctionne pas comme à l'attendu, la suppression des cookies peut résoudre les problèmes. Actuellement ça me le fait avec ma banque en ligne, un comble!

Je ne sais pas si c'est le site qui est responsable du dysfonctionnement ou Firefox que j'utilise aussi.

Re: Déconnexion intempestive

Posté : 25 juil. 2016 09:27
par Daniel
Ce matin j'ai un peu progressé dans l'analyse :

Il semblerait que le cookie 60gp soit à l'origine du problème. Je suppose qu'il indique que l'on est connecté, et il a une date d'expiration (de l'ordre d'une heure). Dans certaines conditions, que je n'ai pas pu déterminer, il se crée un autre cookie nommé 60gpBAK. Je ne sais pas s'il est créé par Firefox ou par le forum. Il a aussi une date d'expiration, mais pas la même que le 60gp.

A partir de la création de ce deuxième cookie les ennuis commencent. Il est probable que les deux cookies donnent des informations contradictoires sur la connexion, et il n'y a plus aucune logique dans les contrôles effectués. Si on supprime le cookie 60gpBAK (ou les deux cookies), on rétablit la logique normale.

Reste à savoir qui est le coupable : Firefox ou le forum ? A suivre...

[Edit]
Il y a un troisième coupable possible : le serveur. Quand j'ai eu le problème les temps de réponse étaient anormalement longs, et peu de temps après le serveur s'est planté :
General Error
SQL ERROR [ mysql4 ]
Can't connect to MySQL server on 'mysql5-11.bdb' (4) [2003]
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
C'était le 25/07/2016 à 9h42.

[Edit 2]
L'étau se resserre. OVH est mon suspect n°1 depuis que j'ai lu ceci : https://forum.ovh.com/archive/index.php/t-102083.html
Je ne comprends pas tout, mais c'est une nouvelle piste. J'ai eu encore plusieurs fois des déconnexions intempestives ce matin, à des moments ou OVH était très long à répondre et m'imposait ce fameux cookie 60gpBAK.
J'ai tendance à penser que Firefox et le forum n'y sont pour rien, c'est un problème de l'hébergeur.

Re: Déconnexion intempestive

Posté : 25 juil. 2016 18:34
par claudounet
Certains cookies ne sont présent que pour identifier les sessions. Une fois authentifié par le serveur, le serveur établit une session, qui se traduit par l'envoi d'un cookie qui permet de lier le navigateur à cette session. PHP utilise aussi des cookies internes pour son bon fonctionnement.

Vu que le problème ne se pose pas avec tous les navigateurs, je ne suis pas convaincu que le problème vienne du serveur, mais bon, je peux me tromper. Pour le navigateur, cote client, il y a tout un ensemble qui va de: parametres du navigateur, bloqueurs de pub, puis les firewall/anti-virus, le réseau, et les bugs.

On a vu des cas ou l'anti-virus supprimait les cookies une fois la connection établie, ou sur IE 11, une drôle de gestion de cookies qui en détruit tu sais pas pourquoi.