[Vectrex] Réparation d'une console - son OK pas d'image (résolu)

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Avatar de l’utilisateur
fbr1969
Messages : 7
Inscription : 28 mai 2020 17:14
Localisation : Meudon (92)

[Vectrex] Réparation d'une console - son OK pas d'image (résolu)

Message par fbr1969 »

Bonjour,

Débutant sur ce forum (voir mon post de présentation).
Je cherche a remettre en fonction une vieille console Vectrex qui traînait dans le garage de mon père et que je souhaite réparer.
Réparer, car si elle fonctionnait très bien il y a 20 ans, ce n'est plus le cas.
Aujourd'hui, lorsque je la met en fonction :
- J'ai du son, la Vectrex s'initialise et a priori (au son), Asteroid fonctionne correctement
- Je n'ai pas d'image... Pas un point lumineux.

Par défaut, j'ai commencer par changer patiemment tous les condensateurs. A nettoyer un peux les deux cartes électroniques, mais j'attend la réception d'une bombe de "WD40 Contact" pour faire plus propre.

En lisant différents forums et celui-ci, j'ai vu que des personnes avaient eu des soucis avec les composants suivants :
Ci AY-3-8912
Ci 6550 ou 6502
Régulateur lm7505ct

Je ne suis pas électronicien et ne me sent pas trop de continuer à l'aveugle cette recherche de panne.
Est ce que l'un d'entre vous, pourrait me guider dans cette recherche ?
Je possède un multimètre, mais pas d'oscilloscope.

Merci pour votre aide,

Cordialement,
François
Dernière modification par fbr1969 le 31 mai 2020 07:42, modifié 1 fois.
Avatar de l’utilisateur
6502man
Messages : 10438
Inscription : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par 6502man »

Alors la si tu n'es pas électronicien je te conseille de pas toucher à l’électronique de l'écran (risque d'électrocution) ou de la platine d'alimentation (idem risque d’électrocution).

Après tu peux sans prendre de gros risque regarder du côté du 6522 (platine logic), si il est sur support essaye de le sortir et vérifier si il n'y à pas d'oxydation sur les pattes idem pour le AY-3 ;)
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.
Avatar de l’utilisateur
fneck
Site Admin
Messages : 14172
Inscription : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fneck »

Même pas un petit point blanc lorsque tu mets hors tension la console après quelques minutes d'allumage?
gotcha
Messages : 1064
Inscription : 30 mars 2017 11:39
Localisation : Isère

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par gotcha »

Il y a un potentiomètre de réglage de la luminosité à l’arrière du Vectrex vers le haut.

As tu essayé de changer la luminosité (la mettre au max par exemple) pour voir si quelque chose apparait (image ou point central fixe) ?
Amstrad CPC addict :mrgreen:
Avatar de l’utilisateur
6502man
Messages : 10438
Inscription : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par 6502man »

Oui le potentiomètre derrière la console est une bonne piste :wink:

Sinon comme je le disais le 6522 contrôle l'affichage et est accessible sur la carte logique (celle qui est à l'horizontale) :wink:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.
Avatar de l’utilisateur
fbr1969
Messages : 7
Inscription : 28 mai 2020 17:14
Localisation : Meudon (92)

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fbr1969 »

Bonjour a tous,

Merci pour vos réponses !

Ne vous inquiétez pas, j'ai bien sur déchargé le tube avant de mettre les mains dans ma Vectrex, pour tout démonter et changer les condensateurs. Et je referai de même après mes différentes essais.

Je vais suivre vos différents conseils et vous fait un retour aujourd'hui ou demain.

Bonne journée.
François
Avatar de l’utilisateur
fbr1969
Messages : 7
Inscription : 28 mai 2020 17:14
Localisation : Meudon (92)

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fbr1969 »

Re-bonjour a tous,

J'ai pu refaire des tests de bon matin :
- J'ai enlevé avec précautions tous les CI et ai nettoyé prudemment les pattes à la gomme et au vinaigre blanc avec de les sécher et de les remettre (je n'ai pas encore reçu ma bombe de WD40 contact).
- j'ai relancé et j'ai les mêmes résultat. Même en utilisant le potentiomètres pour faire varier la luminosité de l'écran, pas un seul point sur le tube, pendant mes tests ou après l'extinction. Pourtant, je vois une lumière orangé à l'arrière du tube (du coté du canon à électron je suppose).
- Sinon, le son est très bon et le jeux se lance.

Je vais continuer à chercher du coté des forums anglais, mais si vous avez d'autres idées, je suis à l'écoute.

Bonne journée,
François
Avatar de l’utilisateur
fneck
Site Admin
Messages : 14172
Inscription : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fneck »

La lumière orange à l'arrière du tube c'est le chauffage, c'est de la basse tension qui va chauffer le générateur d'électron donc ça c'est bon.

D'après ce que tu décris j'ai un doute sur la présence de la THT. Lorsque tu allumes la Vectrex, est-ce que tu constates la présence d'électricité statique devant l'écran? Théoriquement tu peux le voir en approchant doucement l'avant-bras vers l'écran. Si les poils se dressent c'est bon. Si rien ne se passe il y aura toujours ce doute car ce test n'est pas fiable à 100%.
(explication ici https://fr.wikipedia.org/wiki/Tube_cath ... 9_statique )
Avatar de l’utilisateur
fbr1969
Messages : 7
Inscription : 28 mai 2020 17:14
Localisation : Meudon (92)

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fbr1969 »

J'ai trouvé !

En cherchant sur internet, j'ai trouvé sur ce fil de discussion :
https://atariage.com/forums/topic/19782 ... o-picture/
Le post suivant ;
Update - I was able to fix it. With the help of the service manual, I traced things back to the power switch / volume knob. One of the two poles on the switch was working, the other wasn't. Took apart the switch, cleaned it with some tuner cleaner, reassembled, and all is well! I also shot some tuner cleaner into the volume pot part of the switch, so I have no scratchy sound when adjusting the volume.
J'ai regardé mon bouton de démarrage mais il ne me semble pas facilement démontable.
J'ai refait des tests et en tournant et tirant légèrement sur le bouton, l'image est apparue !

J'ai donc un soucis de contact sur le bouton de démarrage. Apres son activation, il faut que je tire légèrement dessus.
Savez vous comment le nettoyer ?

A+ François
Avatar de l’utilisateur
Falkor
Messages : 1349
Inscription : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par Falkor »

J'attaquerai déjà à la bombe contact...
Avatar de l’utilisateur
6502man
Messages : 10438
Inscription : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par 6502man »

Ca me parait bizarre que tu ais du son et pas d'image si le bouton d’allumage ne fonctionne pas correctement, le contraire à la rigueur aurait était plausible puisque le bouton d'allumage est aussi un potentiomètre pour le volume, mais une fois tourné le contact laisse passer le courant ou non pour toute la console pas une partie !!!!


Edit: j'avais réparé il n'y à pas longtemps une Vectrex ayant un problème justement avec le bouton d'allumage si ça peut t'aider :
viewtopic.php?f=18&t=10478&hilit=anti+buzz
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.
Avatar de l’utilisateur
fneck
Site Admin
Messages : 14172
Inscription : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fneck »

Alors ma première impression aurait été comme Phil, à savoir que si tu as le son comme par ailleurs le chauffage sur le culot du tube, c'est que le courant passe...

Mais en regardant le schéma de la Vectrex, on voit que l'interrupteur coupe les deux sorties du secondaire du transformateur mais le point milieu de ce dernier est relié en permanence au circuit. Donc avec un pôle de l'interrupteur HS il est possible que tu alimentes quand même une partie de la machine mais pas la totalité. Donc la piste est très plausible et sans doute bonne puisque tu l'as testée :)
Avatar de l’utilisateur
6502man
Messages : 10438
Inscription : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par 6502man »

Effectivement je n'avais pas pensé à cette possibilité les 2 pôles du switch :roll:
Car le switch à 3 poles dont 1 point milieu comme tu le signales :wink:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.
Lesarthois
Messages : 199
Inscription : 13 mai 2016 22:21

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par Lesarthois »

Puisque tu as changé des condensateurs, je me permet de rappeler une petite spécificité du Vectrex : si la PCB est double face, les composant traversants reliant des pistes ne sont pas équipés de vias. Il faut donc dans ce cas faire une soudure des deux côtés de la PCB pour assurer un bon contact!
Avatar de l’utilisateur
fbr1969
Messages : 7
Inscription : 28 mai 2020 17:14
Localisation : Meudon (92)

Re: [Vectrex] Réparation d'une console - son OK pas d'image

Message par fbr1969 »

Bonjour a tous,

Je pense que j'avais un problème de soudure sur le bouton. En effet, j'ai refait pour être certain les 3 soudures, puis un coup de bombe contact, et plus aucun problème. Ma console démarre au cars de tour.

Merci à tous pour votre aide. Je vais voir si je peu basculer mon poste en [résolu].
Sinon, est ce que un administrateur peut le faire ?

Bonne journée,

François
Répondre