[PET] vidéo externe ?

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
fneck
Site Admin
Messages : 13745
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PET] vidéo externe ?

Message par fneck » 13 déc. 2016 18:45

6502man a écrit :Par contre j'ai remarqué un composant RAM ayant les pattes oxydées, là aussi j'ai pu vérifier l'activité sur les broche IN et OUT (datas) ???
Le condensateur jaune à droite de la RAM n'aurait pas coulé? Pour ma part je commencerai par bien nettoyer cette zone potentiellement en défaut et aussi vérifier le condensateur.

[edit] Xavier a raison, ce n'est peut-être pas de l'oxydation en fait.

Avatar du membre
fneck
Site Admin
Messages : 13745
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PET] vidéo externe ?

Message par fneck » 13 déc. 2016 18:47

Xavier a écrit : Piquez le dissolvant à vernis à ongle de votre femme (ou mère!) et nettoyez le fondant au coton-tige!
ça mange pas de pain, et c'est pas un motif de divorce...
Sinon, tu peux aussi acheter un litre d'acétone et tu en auras assez pour toute ta vie sans risquer l'incident familial 8)

Avatar du membre
fneck
Site Admin
Messages : 13745
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PET] vidéo externe ?

Message par fneck » 13 déc. 2016 18:55

6502man a écrit :Ca correspond d'après la photo 8032089 à ces schémas
Tu es sûr, sur le lien on trouve les références 8032029 et pas 89

Je veux bien jeter un oeil pour les condensateurs dont tu as un doute pour la tension, mais si tu pouvais me préciser à chaque fois le folio du schéma :?

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [PET] vidéo externe ?

Message par 6502man » 13 déc. 2016 19:57

Je vérifierais le condensateur jaune ;)

@Fabien: les mesures concernent la partie voltage regulator PAGE 11

le gros condensateur jaune C7 est aussi sur cette page !
Quelle tension je doit trouver à la sortie de ce condensateur ?
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Daniel
Messages : 12884
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [PET] vidéo externe ?

Message par Daniel » 13 déc. 2016 22:42

Comme Fabien, je crois que les schémas ne correspondent pas à la carte photographiée.

Les composants n'ont pas les mêmes références. Prenons par exemple le 7400 référencé UF1. Dans le schéma ce n'est pas un 7400, mais un 74LS00, et il est référencé UE11. Pour les condensateurs aussi, la numérotation du schéma doit être différente de celle de la carte, c'est pourquoi tu ne trouves pas les tensions attendues.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [PET] vidéo externe ?

Message par 6502man » 13 déc. 2016 23:36

Bon, je n'ai pas trouvé de schéma référencé 8032089, le plus proche c'est la UNIV2 = 8032087 :? :(
Il y a bien UF1 sur celui la !

la c'est 8032090 et des pages avec 8032087 :roll:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Daniel
Messages : 12884
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [PET] vidéo externe ?

Message par Daniel » 14 déc. 2016 08:59

Ce nouveau schéma correspond un peu mieux à ta carte, mais rien ne prouve qu'il soit conforme.
Si on lui fait confiance, toutes les tensions que tu as mesurées aux bornes des condensateurs et à l'anode de la diode CR1 sont bonnes.

Aux bornes du gros condensateur de filtrage de la ligne +5V la tension n'est pas constante, elle ondule en fonction de la charge. En moyenne elle devrait être aux alentours de 9V, à 2 ou 3V près. Cette tension se retrouve sur la sortie 9V non régulée et à l'entrée du régulateur LM340-5.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [PET] vidéo externe ?

Message par 6502man » 14 déc. 2016 11:23

Merci Daniel :)

J'ai mesuré C7 = 12V

J'ai analysé le 6502 et voici ce que j'obtiens sur 20 secondes :
Image

En zoomant un peu :
Image


Et en zoomant encore plus :
Image

Que pensez vous de ces résultats ?
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
fneck
Site Admin
Messages : 13745
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PET] vidéo externe ?

Message par fneck » 14 déc. 2016 19:26

Je ne sais pas trop à quoi correspondent ces mesures mais déjà on voit qu'il y a de la vie la dedans. Donc il y a de l'espoir 8)
As-tu mesuré l'horloge ? Et éventuellement vérifié que le reset n'est pas activé en permanence ?

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [PET] vidéo externe ?

Message par 6502man » 14 déc. 2016 20:04

Oups j'ai pas précisé j'ai bêtement pensé que c'était logique en voyant la capture :oops: :roll:

Donc la légende :
- channel 1 = 00 (IN) {pin 37} => clock
- channel 2 = RDY {pin 2} => Ready
- channel 3 = SYNC {pin 7} => Sync
- channel 4 = RES {pin 40} => Reset
- channel 5-8 = non connectés
SYNC ( MCS6502 only)
This output line is provided to identify those cycles in which the microprocessor is doing an OP CODE
fetch. The SYNC line goes high during 0j of an OP CODE fetch and stays high for the remainder of that
cycle. If the RDY line is pulled low during the 0 clock pulse in which SYNC went high, the processor
will stop in its current state and will remain in i 'ne state until the RDY line goes high. In this
manner, the SYNC signal can be used to control RDY to cause single instruction execution.
Reset
This input is used to reset or start the microprocessor from a power down condition. During the time
that this line is held low, writing to or from the microprocessor is inhibited. When a positive edge
is detected on the input, the microprocessor will immediately begin the reset sequence.
After a system initialization time of six clock cycles, the mask interrupt flag will be set and the
microprocessor will load the program counter from the memory ve.ctor locations FFFC and FFFD. This is
the start location for program control.
After Vcc reaches 4.75 volts in a power up routine, reset must be held low for at least two clock cycles.
At this time the R/W and (SYNC) signal will become valid.
When the reset signal goes high following these two clock cycles, the microprocessor will proceed with
the normal reset procedure detailed above.
Ready (RDY)
This input signal allows the user to single cycle the microprocessor on all cycles except write cycles. A
negative transition to the low state during or coincident with phase one (0i) will halt the microprocessor
with the output address lines reflecting the current address being fetched. This condition will remain
through a subsequent phase two (02) in which the Ready signal is low . This feature allows microprocessor
interfacing with low speed PROMS as well as fast (max. 2 cycle) Direct Memory Access (DMA). If Ready is
low during a write cycle, it is ignored until the following read operation.
http://archive.6502.org/datasheets/mos_ ... g_1975.pdf

Donc le reset n'est pas activé en permanence et l'horloge j'ai mesuré que O0 donc peut être il faudrait aussi que je mesure O1 et O2 ???
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Totor le Butor
Messages : 1679
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [PET] vidéo externe ?

Message par Totor le Butor » 14 déc. 2016 21:42

Le signal de Reset n'est pas très orthodoxe, normalement il devrait passer son temps au niveau 1 sauf au démarrage.
Ici on voit plusieurs cycles de reset, puis le signal repasse et reste à 0 le proco est donc toujours inhibé.
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Daniel
Messages : 12884
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [PET] vidéo externe ?

Message par Daniel » 14 déc. 2016 22:21

Et l'horloge n'est pas régulière, bizarre :roll:
Il y a un gros doute sur les signaux mesurés.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 13745
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [PET] vidéo externe ?

Message par fneck » 14 déc. 2016 22:58

6502man a écrit :Oups j'ai pas précisé j'ai bêtement pensé que c'était logique en voyant la capture :oops: :roll:
Oui, j'avais bien vu la légende mais comme ça ne me paraissait pas très cohérent j'ai eu un doute :?

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [PET] vidéo externe ?

Message par 6502man » 14 déc. 2016 23:07

Bon donc il y a de la vie mais c'est le bazar :roll: :(

Demain je vais essayer d'analyser O1 et O2 et de me pencher sur la partie génération de l'horloge page6
Je vais essayer de vérifier le 7400 mais comment avec l'analyseur logique ?
Si j'ai bien compris le schémas et le datasheet, les entrées A1 et B1 sont connecté ensemble et le quartz 16Mhz et connecté en entrée et en sortie de la porte 1 pour ensuite rentrée en A2 et B2 pour ressortir en Y2 d'après la table de vérité la sortie est à 1 sauf si les 2 entrées sont à 0 dans ce cas la sortie est à zéro :roll: :roll: :roll: :lol:
Donc si je met une sonde sur la pin 6 je dois voir les créneaux de l'horloge en sortie du 7400.

Après c'est beaucoup trop compliqué pour moi :oops: malgrès tout si je comprends bien l'horloge passe ensuite par UD3 LS393 pour ressortir par la pin 6 et arrive enfin sur la pin 37 O0 du 6502 :lol:

Donc pour résumé il faut que je teste : UF1 (16 Mhz) et UD3 (~1Mhz) pour vérifier si l'horloge est bien générée et régulière :roll:

Après le reste du circuit de la page 6 c'est très très compliqué :oops: :(

Ensuite la partie reset sur la page 1 je vois qu'il y a un composant UD16 LM555 qui est connecté à la broche RESET du 6502, mais la j'ai rien compris au fonctionnement de ce composant :oops: :x hormis que la sortie de ce composant (pin 3) est relié à la pin RES du 6502 :wink:

Je sens que les profs vont me recadrer et que la note va pas être terrible :lol: :lol:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Xavier
Messages : 1000
Enregistré le : 03 avr. 2014 14:42

Re: [PET] vidéo externe ?

Message par Xavier » 15 déc. 2016 02:27

Tout comme le NE555, le LM555 est un multivibrateur astable.
En deux mots, c'est un composant à base d'ampli-Op, qui traite une tension pour créer un signal carré avec une base de temps donnée par la structure et la valeur des composants qui le contrôle.

Image

vérifie la tension VCC du composant, puis le signal de sortie sur le "output".
Si tu n'as rien, c'est soit que le reset est actif, soit qu'un condo qui donne sa base de temps est mort.
C'est à vérifier avec le schéma que tu as en ta possession...

Répondre