[ TRS80 model 1 ] problème vidéo et floppy

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

[ TRS80 model 1 ] problème vidéo et floppy

Message par 6502man » 30 nov. 2016 17:02

Lors de la dernière visu de novembre 2016, nous avions testé un ensemble TRS80 + Expansion + Floppy , nous n'avions pas réussi à booter sur une disquette, par contre le TRS80 seule fonctionnais mais présentais un problème avec l'affichage vidéo, l'image défilé de bas en haut comme un problème de synchro, sur un moniteur TRS80 d'origine on arrive à caler l'image en jouant avec les réglage à l'arrière (sans être parfait) mais avec un cable composite sur une TV impossible :?

J'ai testé un autre model 1 avec le même câble composite et l'image est parfaitement stable sur une TV LCD, donc cela ne vient ni du cable composite ni de la TV LCD :wink:

On m'a suggéré l'hypothèse que cela pouvais être un modèle 60Hz, j'ai essayé avec une TV NTSC mais même résultat :?

Demain je vais vérifier qu'une soudure de la sortie vidéo n'aurait pas lâché ....

Avait vous une idée pour diriger mes recherches ?

Et finalement j'arrive à booter sur le floppy ou un HXC, le problème venait de mauvais contact entre la nappe et le floppy :x :evil:


Question subsidiaire: connaissais vous les commandes des DOS TRS80 pour formater et copier des disquettes ???
Synchro.jpg
Synchro.jpg (291.38 Kio) Vu 1106 fois
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
gleike
Messages : 548
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [ TRS80 model 1 ] problème vidéo

Message par gleike » 30 nov. 2016 18:45

Sur la carte mére du TRS80 tu as 2 petites résistances ajustables,
R21 qui permet d'ajuster la synchro vertical
et R20 qui ajuste la synchro horizontal.

Sous Newdos la commande pour formater est : format :a
"a" est le numéro de ton drive.

Pour copier tu fait : copy :a to :b
"a" et" b" = numero de drive
La commande copy accepte plein d'option , il vaut mieux voir le manuel du DOS.

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 30 nov. 2016 20:23

Merci pour les commandes DOS ;)

Voila la carte mère en question :
Pascal m'avais aussi parlé de ces 2 résistances variables (les 2 du haut) mais je n'ai pas trop osé toucher et surtout dans quel mesure ont peut les régler ???
Parceque la l'ecran c'est la vrai samba donc est ce que je peux faire un tour complet ou plus et y a t'il des butés ??

Image
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
gleike
Messages : 548
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [ TRS80 model 1 ] problème vidéo

Message par gleike » 30 nov. 2016 20:31

Oui il y a des butées de fin de course, tu peut les tourner sans danger,seulement 1 tour,
de toutes façon ça ne peut pas être pire.

Mais attention de ne pas tourner les autres résistances ajustables (R10 et R5) qui elles, ajustes les tensions d'alimentations
R10=+12V
R5=+5V

Si le réglage ne donne pas de résultat probant, tu peut essayer de suivre le chemin du signal de synchro
en remontant depuis Q2 jusqu’à sa source, de composants en composants.
D'ailleurs Q2 me semble un bon candidat pour une panne eventuelle.
video TRS80.jpg
video TRS80.jpg (252.85 Kio) Vu 1053 fois

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 01 déc. 2016 15:56

Merci pour le schéma :D

Aujourd'hui après avoir démonté le dessous du TRS80 pour avoir accès à la carte mère, je le branche à la TV et la le signal est stable pas très bien centré mais stable :shock: :shock: :shock:
La seule chose qui est changè c'est que j'ai enlevé les alimentations qui étaient dans l'expansion (je l'avais eu comme ca), et j'ai donc rebranché mais pas avec la même alimentation le TRS80 :shock: :roll: :x :?

Du coup je ne vais pas toucher au réglage pour l'instant si jamais le problème venais à ce reproduire j'aviserais :wink:

En tout cas merci ;)

Dans l'expansion il y avait une carte d'extension : un doubleur de densité, belle surprise :

Image

Maintenant il me reste à faire fonctionner le HXC et un floppy réel sur la même chaine, je suppose qu'il faut mettre un en DS0 et l'autre en DS1, mais avec le floppy que j'ai je n'y suis pas arrivé en essayant toutes les positions des dipswitch, et de plus il mange mes disquettes :cry:
C'est un modèle comme celui la :
Image
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
gleike
Messages : 548
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [ TRS80 model 1 ] problème vidéo

Message par gleike » 01 déc. 2016 18:49

Normalement, avec le câble des drives d'origine, la sélection se fait dans le connecteur cote lecteur par des broches manquantes,
dans mes lecteurs je n'ai pas de dipswitch.

Apparemment les câbles plats on été soudes sur les connecteur de sorties :shock:
je trouve ce bricolage pas très heureux :(

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 01 déc. 2016 23:24

Oui j'ai eu le lot Model1 + Expansion avec les câbles soudés comme ca :roll:

J'essaierai de refaire des connecteurs et étamer les bords de cartes si j'y arrive ...
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Papy.G
Modérateur
Messages : 1779
Enregistré le : 10 juin 2014 13:40
Localisation : Haute-Garonne/Gers

Re: [ TRS80 model 1 ] problème vidéo

Message par Papy.G » 02 déc. 2016 06:05

Les soudures ont probablement été faites pour résoudre un problème de faux contacts. Il faut voir si ça vaut la peine de risquer de décoller les pistes et voir rapparaître une source potentielle de panne. :?

Le doubleur de densité permet de doubler la mémoire, ou l'écriture sur les disquettes?

Ton lecteur arrache la surface des disquettes?
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 02 déc. 2016 15:31

Doubleur de densité pour les disquettes :wink:

Pour les nappes je vais au moins désolidariser l'expansion car c'est vraiment pas pratique d'avoir les 2 retenus ensemble ...
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 06 déc. 2016 17:37

Ca y est j'ai dessoudé la nappe de l'expansion côté Model 1, et la nappe floppy côté expansion, j'ai mis des connecteurs 34 et 40 pins ça fonctionne très bien, pas de problèmes de contacts :D

C'est déjà plus agréable à manipuler avec l'expansion et le Model 1 dissocié :lol:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Daniel
Messages : 10890
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par Daniel » 06 déc. 2016 17:59

Peux-tu faire une petite photo pour voir la transformation ?

J'envisage de faire un bricolage du même type sur Thomson, pour remplacer les connecteurs "nez de carte" 2x19 broches, devenus assez difficiles à trouver. Avec un connecteur 40 broches standard on peut utiliser des nappes IDE (très courantes) pour connecter les périphériques. Une nappe IDE avec plusieurs connecteurs permet de connecter plusieurs périphériques sur le même port d'extension.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 07 déc. 2016 16:13

A mince je me suis mal expliqué :roll: :(

J'ai mis au bout des câbles que j'ai déssoudés des connecteur edge femelle :?
Image

j'avais pensais aussi à mettre un connecteur mal type IDE comme ca, mais je trouve que cela change trop l'esthétique de la machine :roll: :
Image

Sinon aujourd'hui j'ai essayé plusieurs lecteurs de disquette 5"1/4 mais aucun ne veux formater ou lire une disquette :evil: :twisted:
J'ai l'impression d'être maudit avec les TRS80 model 1 :twisted: :roll:
Pour un lecteur le dos me retourne un message "MOTOR SLOW" :shock: et pour un autre lecteur "MOTOR FAST" :shock:
:lol: :lol: :lol: :lol: :lol:
Dans tous les tests avec ou sans carte doubleur de densité le moteur du floppy démarre mais après ne veux pas formater ou lire :roll:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
meridian
Messages : 623
Enregistré le : 01 sept. 2014 13:10
Localisation : Seine-Saint-Denis

Re: [ TRS80 model 1 ] problème vidéo

Message par meridian » 09 déc. 2016 12:26

tu as essayé avec un HxC ou un Gotec pour être certain qu'il n'y avait pas de problème de nappe ou de contrôleur ?

Avatar du membre
6502man
Messages : 9139
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par 6502man » 09 déc. 2016 16:45

Je boot justement sur un HXC mais impossible d'utiliser un floppy en drive 1 :roll:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
fneck
Site Admin
Messages : 12270
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [ TRS80 model 1 ] problème vidéo

Message par fneck » 09 déc. 2016 19:20

Tu es sûr de la configuration des lecteurs 0 et 1 ?

Comme l'a dit Gleike plus haut, on l'avait aussi abordé rapidement lors de la dernière visu, la configuration peut se faire avec le câble et dans ce cas les lecteurs doivent être tous les deux en DS0 (ou toutes les positions strappées, j'ai un doute maintenant). De plus le dernier lecteur sur la chaine doit être terminé par un jeu de résistances (pas toujours nécessaire mais en théorie si).

Répondre