[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 03 juil. 2018 12:45

L'annonce pour la diffusion de la nouvelle version de SDDRIVE est en cours de préparation, avec toutes les précisions sur les options possibles et le montant de la participation. Je la posterai dans deux ou trois jours à la rubrique "Dons, ventes ou échanges". D'ici là patientez encore un peu...
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 04 juil. 2018 17:57

La diffusion de la nouvelle version de SDDRIVE (monté, testé, prêt à l'emploi) commence aujourd'hui.
Voir tous les détails dans la section "Dons, ventes ou échanges" -->
https://forum.system-cfg.com/viewtopic. ... 01#p140801 (fil de discussion réservé aux demandes de matériel et au suivi des expéditions).
Les discussions techniques et l'assistance à l'utilisation restent dans ce fil de discussion de la section "Bricolage et restauration".
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 455
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 10 juil. 2018 13:02

Daniel a écrit :
14 juin 2018 11:14
Garder celle-ci est possible, renvoyer l'autre non. J'en ai six exemplaires construits et jamais expédiés, un septième exemplaire m'encombrerait encore plus.
Il y avait pas mal de chose à récupérer tout même comme l'eprom, les circuits logiques 74L quelque chose et quelques broutilles ;)
Daniel a écrit :
14 juin 2018 11:14
Pour tous les utilisateurs du premier modèle ayant des difficultés avec certains ordinateurs, il y a une solution simple à tenter : raccourcir la nappe. Avec une nappe de 5 cm le contrôleur fonctionne bien dans presque tous les cas.
C'est ce que j'ai fait et effectivement le résultat est assez positif. :)

Par contre La Marque Jaune ne fonctionne pas en conversion SD et ce sur les deux versions de SDDrive :?

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 10 juil. 2018 15:53

Les Ripoux et La Marque Jaune sont assez particuliers. Je crois que leurs protections font des commandes directes du contrôleur de disquette Thomson, qui ne peuvent pas fonctionner avec SDDRIVE (ni avec le contrôleur CS91-280). Pour les Ripoux j'avais déjà essayé il y a quelques mois de trouver une parade, sans succès. Le problème doit être identique avec La Marque Jaune. Il faudra que je trouve un peu de temps pour chercher encore.

@jasz : paiement du SDDRIVE de test reçu aujourd'hui. Merci !
Daniel
L'obstacle augmente mon ardeur.

Giants
Messages : 24
Enregistré le : 19 avr. 2011 11:44

Re: [Thomson] SDDRIVE

Message par Giants » 12 juil. 2018 18:20

Par contre, le mien fonctionne 'aléatoirement'.
Je m'explique...

Mo5 (clavier a gomme) atteindre, sddrive inséré à l'arrière.
J'allume le Mo5, le LED verte du SDDrive s'allume ainsi que brièvement la led rouge (I/O Sd card)
et je me retrouve sous le basic standard du mo5.

Même en tapant DOS, il repart sur la séquence, refait un I/O SD (led verte rouge s'allume brièvement) mais tjs rien à l'écran.
On ne touche à rien, on éteins le mo5, on le re-allume, HOP, là ça fonctionne (pas tout le temps), j'arrive direct sous l'interface SDDrive.
Des fois, il faut que je m'y reprenne à plusieurs arrêt/relance du mo5

J'ai l'impression que l'initialisation et le check de la carte SD est trop rapide en faite.

Je précise que les contacts de la prise mo5 sont super nettoyé et super propre.
Juste que... un coup ça fonctionne, un coup ça ne fonctionne pas (sans raison et sans rien toucher).

Ca me donne vraiment l'impression que la routine de check et chargement du fichier sur la Sd card est trop rapide.
Et je précise que ma carte SD n'a rien de spécial. (d'origine, rien fait dessus).
(¯`·.¸¸¸¸.·´¯`·.¸¸Fondateur¸¸.·´¯`·.¸¸¸.·´¯)
( AmigaMOD - Ordinosaure - CPC-Hardware )
(
CPC300DPI - Abandon-Pub )
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

http://sasfepu78.fr

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 12 juil. 2018 18:43

Il y a des phénomènes transitoires au démarrage du MO5 (et de toutes les machines). Ils peuvent envoyer des parasites et empêcher l'initialisation correcte de la carte. Par contre, si l'initialisation n'a pas marché à la mise sous tension, après stabilisation la commande DOS devrait permettre de lancer le système (essayer de la taper plusieurs fois de suite).

L'alimentation de l'ordinateur peut aussi être fautive : tension hors normes, ondulations résiduelles, etc.

Si le contrôleur SDDRIVE a été modifié, par exemple en allongeant les connexions entre le circuit imprimé et le module de la carte SD, c'est aussi une source d'instabilité. Au cours de tests sur les machines de petitjd nous avons eu le cas : avec un connexion directe le système fonctionnait bien, en ajoutant des fils Dupont de quelques centimètres il ne s'initialisait plus.

Ou encore, et c'est le plus probable, il peut y avoir un problème avec les cartes microSD chinoises. Certaines ont des comportements pas très clairs à l'initialisation. On peut essayer d'insérer la carte après mise sous-tension de l'ordinateur, ou de la retirer et de la remettre si elle était déjà insérée, et ensuite de taper DOS pour l'initialiser. C'est ce que Thomson conseillait avec les disquettes : démarrer sans disquette, puis mettre la disquette, puis taper DOS.

Sinon essayer une autre carte de marque connue.
Daniel
L'obstacle augmente mon ardeur.

Giants
Messages : 24
Enregistré le : 19 avr. 2011 11:44

Re: [Thomson] SDDRIVE

Message par Giants » 13 juil. 2018 12:10

Merci, je vais regarder ça de plus prêt.
Je penche, pour l'instant sur la connections module sd pcb SDdrive.
je vous tiens au courant.


C'est bon, problème réglé, comme prévu ça venait de la qualité de ma nappe qui relie la carte sd au pcb.
Nape changée par des câbles récents et de bien meilleurs qualité, plus de problème.
(j'avais utilisé la vieille Nape papier que l'on trouve dans les cartouches nano réseaux)
(¯`·.¸¸¸¸.·´¯`·.¸¸Fondateur¸¸.·´¯`·.¸¸¸.·´¯)
( AmigaMOD - Ordinosaure - CPC-Hardware )
(
CPC300DPI - Abandon-Pub )
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

http://sasfepu78.fr

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 13 juil. 2018 14:45

J'aime bien les problèmes résolus, merci pour l'explication 8)

Avec la première version de SDDRIVE ce genre de mauvais fonctionnement arrivait parfois. Par contre, avec la nouvelle, tous les tests ont été bons, je n'ai plus trop d'inquiétude. D'autant plus que je teste systématiquement les contrôleurs avant de les envoyer, avec au minimum un MO5 et un TO8D.

Reste le problème des cartes SD chinoises bon marché, elles sont souvent capricieuses. Maintenant je préfère acheter des Sandisk d'occasion, elles sont un peu plus chères mais meilleures que les neuves sans marque. Je crois d'ailleurs que ces cartes de 128 Mo neuves à moins de deux euros sont des cartes de plus grande capacité déclassées. Les chinois savent modifier les registres internes de la carte pour changer la taille, et avec un petit remarquage "microSD 128MB" ils les vendent sans scrupules. Certaines sont utilisables, d'autres pas.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 22 juil. 2018 13:34

Le schéma de SDDRIVE a été légèrement modifié (par réaffectation de quelques portes logiques) pour permettre une simplification du circuit imprimé. Les prochains SDDRIVE vendus ici auront le nouveau circuit. Il est un peu moins haut que le précédent.

sddrive-schema_20180704.png
sddrive-schema_20180704.png (34.92 Kio) Vu 336 fois

Dès maintenant je prépare encore une autre version pour faciliter l'intégration dans un boîtier Thomson. Le circuit pourra être placé dans un boîtier nanoréseau ou autre sans aucun découpage. Cette nouvelle version sera diffusée après épuisement du stock actuel (10 exemplaires).

sddrive_201809.jpg
sddrive_201809.jpg (54.24 Kio) Vu 336 fois
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 08 août 2018 08:30

Cette information ne vous intéresse probablement pas, je la note ici pour mémoire et pour compléter le dossier SDDRIVE.

Les vingt derniers contrôleurs SDDRIVE construits fonctionnent (très bien et avec tous les ordinateurs) avec des circuits SN74LS133N de Texas Instruments, achetés chez Ali-Express.

Pour renouveler le stock j'ai acheté récemment des T74LS133B1 de STMicroelectronics, aux Pays-Bas. Avec ces circuits SDDRIVE fonctionne très bien avec un MO5 et un TO8, mais pas du tout avec un TO8D. Le phénomène est parfaitement reproductible avec plusieurs circuits : avec TI le programme de sélection SDDRIVE.SEL se lance bien à chaque fois sur TO8D, avec ST il ne se lance jamais. Avec le MO5 ou le TO8 il se lance toujours, aussi bien avec ST qu'avec TI.

C'est un mystère de plus à ajouter au dossier SDDRIVE. En attendant de trouver une raison rationnelle j'ai commandé à nouveau chez Ali-Express.
Daniel
L'obstacle augmente mon ardeur.

BDCIron
Messages : 57
Enregistré le : 24 juil. 2018 23:39
Localisation : Orne, région de Mortagne au Perche
Contact :

Re: [Thomson] SDDRIVE

Message par BDCIron » 08 août 2018 11:25

Merde c'est con j'aurai du attendre pour en avoir un qui tienne dans un boitier nanoreseau ^^ Tant pis j'en prendrai un autre ;)

Avatar du membre
irios
Messages : 3163
Enregistré le : 04 nov. 2007 19:47
Localisation : Rochefort du Gard (30)
Contact :

Re: [Thomson] SDDRIVE

Message par irios » 08 août 2018 12:30

Daniel, as tu comparé les data sheets?
http://irioslabs.over-blog.com/

La connaissance ne vaut que si elle est partagée par tout le monde.
I2C

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 08 août 2018 13:02

Oui, j'ai regardé. La plus grosse différence notable est le "Turn-On Delay, Input to Output"
ST: Typique 25ns, maxi 38ns
TI: Typique 40ns, maxi 59ns

ST est plus rapide que TI, mais la différence n'est pas énorme. Et pourquoi ça poserait un problème avec le TO8D et pas avec le TO8 ?
C'est seulement le TO8D qui a ce problème. J'ai essayé avec plusieurs TO8D, le résultat est le même : ne marche pas avec ST, OK avec TI.

@BDCIron : Le nouveau circuit imprimé est fabriqué, il est dans l'avion, je devrais le recevoir en début de semaine prochaine. Je donnerai des nouvelles dès que je l'aurai essayé.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 11 août 2018 14:44

Tout laisse penser que les circuits SN74LS133, avec leur délai de propagation plus long, filtrent plus ou moins les glitches sur le bus d'adresses.
Les T74LS133, plus rapides, les laissent passer jusqu'à la broche de commande des buffers 74LS125, ce qui cause le problème.

En ajoutant un petit délai à la sortie du T74LS133, avec une résistance de 100 ohms en série suivie d'un condensateur de 100 pF en parallèle, on retrouve un fonctionnement normal avec tous les ordinateurs, aussi bien avec les circuits ST qu'avec les circuits TI. Le schéma sera donc modifié avec le filtre R/C avant la prochaine commande de circuits imprimés.

Cette correction est d'autant plus nécessaire que, pour remplacer mes T74LS133 néerlandais, j'avais commandé en Allemagne des SN74LS133. Je les ai reçus aujourd'hui et, mauvaise surprise, ce ne sont pas des SN74LS133 mais des T74LS133. J'en ai maintenant 50 en stock. La modification du schéma permettra heureusement de les utiliser. En attendant je monterai des SN74LS133 chinois, ils fonctionnent parfaitement bien sans la modif.

[Edit]
Je viens de m'apercevoir que les contrôleurs SDDRIVE de la première série (celle qui a eu des problèmes chez quelques utilisateurs) étaient presque tous équipés de T74LS133. C'est probablement l'une des causes des anomalies constatées (mais pas la seule). Avec toutes les dernières améliorations la fiabilité s'améliore, et sur les vingt derniers exemplaires diffusés aucun utilisateur n'a signalé d'erreur.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 10685
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 17 août 2018 13:17

La dernière version du circuit imprimé permet, comme prévu, d'insérer le contrôleur SDDRIVE dans un boîtier Thomson. j'ai essayé un boîtier nanoréseau et une extension musique et jeux modèle 2.

L'EPROM avec son support a une hauteur d'environ 8 mm et ne permet pas de plaquer complètement le circuit contre les butées prévues, il est donc un peu en retrait de 2 mm par rapport au circuit imprimé Thomson qu'il remplace, mais il tient entièrement dans la coque avant du boîtier. On peut le fermer avec la coque arrière d'origine, en perçant deux trous pour les LEDs et une fente pour le module de la carte SD. On doit pouvoir loger entièrement dans la coque arrière le module de la carte SD, dans ce cas il faut prévoir de le relier au circuit imprimé principal par une nappe à six fils et le fixer par deux vis de 2 mm (je n'ai pas encore essayé).

On peut aussi remplacer la coque arrière par une plaque plate, pour avoir une version "slim" plus élégante, mais dans ce cas le module de la carte SD dépasse au-dessus.
Daniel
L'obstacle augmente mon ardeur.

Répondre