[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: [Thomson] SDDRIVE

Message par petitjd » 15 févr. 2018 20:16

Daniel a écrit :
15 févr. 2018 18:09
Ou encore brancher SDDRIVE sur le premier connecteur de la nappe en laissant le boîtier ouvert.
Je l'ai déjà fais, ca ne fonctionne pas.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
Carl
Modérateur
Messages : 10153
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 15 févr. 2018 20:22

Tests sur MO6...pas de soucis
Tests sur MO5...pas de soucis
Tests sur TO8 (2eme) ...pas de soucis

A tout hasard....

S/N du TO8 avec lequel aucun soucis
t08-ok.jpg
t08-ok.jpg (62.54 Kio) Vu 520 fois

S/N du TO8 avec lequel des soucis
t08-nok.jpg
t08-nok.jpg (61.6 Kio) Vu 520 fois

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: [Thomson] SDDRIVE

Message par petitjd » 15 févr. 2018 20:44

Daniel a écrit :
15 févr. 2018 18:09
Une expérience à faire avec les TO8D : sur la nappe entre l'ordinateur et SDDRIVE, mettre un contrôleur musique et jeu, ou contrôleur de communication, ou autre (mais pas un contrôleur de disquette ni un boîtier nanoréseau). Ce contrôleur externe est en doublon avec le contrôleur interne du TO8D, mais j'ai constaté que le fonctionnement n'est pas perturbé.
Ca ne fonctionne pas non plus.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: [Thomson] SDDRIVE

Message par petitjd » 15 févr. 2018 21:14

Un truc sans doute idiot:
Le connecteur 38 broches de sddrive coté TO8D n'est pas le même que celui utilisé pour le controleur CS91-280 non nanoreseau.
Il me semble que l'écartement entre les contacts de la rangé du haut et celle du bas est plus large sur celui de sddrive.
On dirait aussi que l'épaisseur du connecteur d'extension à l'arrière du TO8D est sensiblement plus fine que celle du MO5 et du TO7.
Les deux conditions réunies ne pourraient-elles pas favoriser un faux contact?
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Daniel
Messages : 10568
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 15 févr. 2018 21:32

irios a écrit :
15 févr. 2018 19:54
Daniel,
Insère une cellule RC entre CS/ et OE/ comme suit :
CS/-----[R=1K]------OE/------|C=100pF|------ GND

Afin de respecter le timing entre CS/ et OE/ :wink:
Merci pour le conseil. Il est judicieux, mais je ne peux pas savoir si ça change quelque chose, car chez moi SDDRIVE fonctionne avec tous les ordinateurs utilisés. C'est bien ça mon problème : tout marche parfaitement bien. Alors comment corriger une anomalie quand il n'y en a pas :roll:

Ce soir j'ai essayé une nappe de 5cm, mais elle doit avoir un problème car l'écran du TO8D reste noir. J'ai essayé aussi une nappe de 30 cm, tout marche bien, comme avec la nappe d'origine.

@petitjd : Les connecteurs du contrôleur CS91-280 (avant février 2018) étaient des modèles économiques, avec des contacts assez rigides et un peu difficiles à enfoncer. Les connecteurs de SDDRIVE (et de CS91-280 depuis ce mois-ci) sont des connecteurs BURNDY avec des contacts en or et des lamelles un peu plus souples. Thomson utilisait cette marque avec la plupart de ses contrôleurs. Je pense qu'ils sont de qualité largement supérieure, même s'ils sont un peu moins serrés. Toutefois un mauvais contact n'est pas exclu, et un bon nettoyage à la gomme du connecteur du TO8D suivi d'une pulvérisation de KF contact ne peux pas nuire.

J'ai remarqué qu'il y a souvent plus d'oxydation sur le connecteur d'extension du TO8 ou du TO8D, car il est rarement utilisé, contrairement à ceux du MO5 et du TO7 ou TO7/70.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Carl
Modérateur
Messages : 10153
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 16 févr. 2018 11:58

nouveaux tests

le TO8 qui fonctionne bien avec le SDDRIVE : fonctionne toujours bien
le TO8 qui fonctionne pas bien avec le SDDRIVE : fonctionne toujours pas bien...après nettoyage connecteur au KF mais fonctionne avec nappe à angle droit...

le TO8D....en panne plus de 12V

Space Project ne se lance pas sur aucune machine
space.jpg
space.jpg (81.65 Kio) Vu 462 fois
Carl

Daniel
Messages : 10568
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 févr. 2018 15:21

Quand le lecteur de disquette est connecté sur TO8D, je n'arrive pas à lancer Space Project. Je pense qu'il doit sélectionner automatiquement le lecteur interne s'il le détecte. De plus, en BASIC 1.0, Space Project ne fonctionne pas et affiche systématiquement "Erreur sur secteur".

Par contre, sur TO8 ou en débranchant le lecteur de disquette, voici la procédure de lancement :
- Après mise sous tension de l'ordinateur taper 1 pour accéder au BASIC 512
- Taper EXEC &HE007 pour afficher l'écran SDDRIVE
- Sélectionner Space Project. Normalement il devrait démarrer

D'autre part j'ai fait des essais de SDDRIVE sur TO8D avec des longueurs de nappe différentes, de 5cm, 10cm, 15cm, 25cm, 30cm. J'ai eu une fois un plantage de l'ordinateur au démarrage avec la nappe de 15cm. Par contre, après avoir essayé d'autres longueurs, je suis revenu à 15cm et je n'ai pas pu reproduire le plantage. Le test n'est donc pas concluant.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 426
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 16 févr. 2018 18:17

Bon! Je fais juste un passage pour dire que:
Sur mo6 Ecran menu figé
Sur to8 Il reconnait le lecteur mais pas le contenu
Photo dès que l’appareil est rechargé. Désolé

__sam__
Messages : 4077
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: [Thomson] SDDRIVE

Message par __sam__ » 16 févr. 2018 18:36

pour les soucis avec la nappe plate qui se résolvent avec la nappe à angle droit, ne serait-ce pas simplement un fil coupé qui referait contact quand on met la nappe à 90°?
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Daniel
Messages : 10568
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 févr. 2018 21:34

Tous ces phénomènes bizarres ont sûrement une explication, mais laquelle ?

Rappelons qu'avant expédition, tous les contrôleurs SDDRIVE sans exception ont été testés sur plusieurs ordinateurs et fonctionnaient parfaitement bien. Quelle peut être la différence entre votre matériel et le mien, je n'arrive pas à trouver. Et à distance pas facile d'échanger l'ordinateur, ou la nappe ou l'EPROM, pour tenter de trouver une piste. Je ne pensais pas qu'il y aurait de tels problèmes. Je mets le projet en pause et je ne diffuserai pas les six derniers SDDRIVE fabriqués tant qu'une solution fiable n'aura pas été trouvée.

Mon plus gros souci maintenant est l'incapacité de reproduire vos problèmes. Je ne peux rien trouver chez moi : les signaux sont bons à l'oscilloscope comme à l'analyseur logique et tous les SDDRIVE fonctionnent sans jamais la moindre erreur. Y compris les six derniers terminés hier. Alors comment faire ?
Daniel
L'obstacle augmente mon ardeur.

petitjd
Messages : 1817
Enregistré le : 23 oct. 2007 11:50

Re: [Thomson] SDDRIVE

Message par petitjd » 16 févr. 2018 21:42

Je peux passer par chez toi avec mon TO8D sous le bras?
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
Silou78
Messages : 182
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: [Thomson] SDDRIVE

Message par Silou78 » 17 févr. 2018 01:36

Daniel,
Ce week-end je vais tester :

1) Vérifier la valeur du +5V aux bornes du SDDRIVE,

2) Utiliser l'oscillo/analyseur que j'ai reçu et vérifier la forme des signaux (SCK en particulier),

3) Faire la manip indiquée par irios (cellule RC à insérer entre /CS et /OE). C'est vrai que sur l'EPROM du Moniteur Contrôleur de Disque (IW17) il y a cette cellule insérée. Par contre je vais être obligé de couper la piste entre /CS et /OE du PCB SDDRIVE :oops:
Edit: par contre faut que je vérifie : je ne suis pas sur d'avoir un 100pF en stock :?

4) Tenter d'abaisser un peu la valeur du +5V en court-circuitant RP03. De base j'avais mesuré 5,17V sur le fil d'alimentation qui arrive sur la carte-mère de mon TO8D => ceci-dit, vu les caractéristiques du circuit L4962, je doute qu'on puisse descendre beaucoup moins que 5V et des poussières. D'ailleurs comment est-ce possible que tu n'ai que 4,78V ? Certes aux bornes du SDDRIVE... mais il y aurait autant de perte entre l'arrivée de l'alim sur la carte mère et le connecteur d'extension ? Quand j'aurais fait la mesure aux bornes du SDDRIVE en 1), on pourra comparer.

En dernier recours je peux te renvoyer le SDDRIVE, m'enfin si petitjd t'amène son TO8D présentant aussi le problème, tu auras peut-être la "chance" de pouvoir investiguer. :wink:
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Daniel
Messages : 10568
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 17 févr. 2018 08:19

petitjd a écrit :
16 févr. 2018 21:42
Je peux passer par chez toi avec mon TO8D sous le bras?
Quand tu veux. Il faut rassembler le maximum d'expériences et de mesures pour arriver à trouver la cause (ou les causes multiples) de l'anomalie.

Silou78 a écrit :
17 févr. 2018 01:36
Par contre je vais être obligé de couper la piste entre /CS et /OE du PCB SDDRIVE :oops:
Tu peux aussi écarter la patte de l'EPROM pour qu'elle n'entre pas dans le support.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Silou78
Messages : 182
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: [Thomson] SDDRIVE

Message par Silou78 » 17 févr. 2018 09:09

Ah oui ! Bonne idée pour la patte de l'EPROM, merci :wink:
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Avatar du membre
Carl
Modérateur
Messages : 10153
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 17 févr. 2018 09:32

La tension est également de 5,17V sur mes 2 TO8 donc je ne crois pas que cela soit la source des soucis...car le SDDRIVE fonctionne parfaitement sur un de mes TO8...

Carl

Répondre