[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Daniel
Messages : 10683
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 01 avr. 2018 22:17

Je ne crois pas qu'il existe une extension mémoire de 16K pour TO7/70. A ma connaissance seule l'extension 64K est compatible.

Si la même configuration marchait et ne marche plus, c'est une preuve de plus de l'instabilité du schéma actuel de SDDRIVE. Il suffit d'une variation infime des tensions ou des capacités parasites pour que le système fonctionne ou pas. Les essais en cours, avec l'ajout de buffers sur les lignes d'adresse, permettront peut-être d'obtenir une bonne fiabilité. Du moins je l'espère...
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 02 avr. 2018 11:29

Je crois que j'ai fait une grosse erreur...
J'ai connecté ceci au T07-70
16k.jpg
16k.jpg (134.05 Kio) Vu 467 fois
test.jpg
test.jpg (74.87 Kio) Vu 467 fois
bref, je ne suis pas équipé pour tester SDDrive sur T07-70....

Carl

Avatar du membre
6502man
Messages : 9073
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Thomson] SDDRIVE

Message par 6502man » 02 avr. 2018 12:02

Si, ça fonctionne mais en Basic 1.0 sur To7-70.
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 02 avr. 2018 12:26

finalement sans l'extension 16Ko, SDDRIVE fonctionne à minima l'interface car je n'ai pas été plus loin...

en résumé les configurations à adopter seraient :
TO7-70 + Basic 1.0 + SDRIVE
TO7-70+ RAM 64K + Basic 128 + SDDRIVE

T07 + RAM 16K + BASIC 1.0 + SDRIVE

Daniel, Phil, ok ?

Carl

Avatar du membre
6502man
Messages : 9073
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Thomson] SDDRIVE

Message par 6502man » 02 avr. 2018 15:26

Carl je pense que ça me semble correcte :)
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 02 avr. 2018 22:25

Finalement, en respectant les bonnes configurations, SDDRIVE fonctionne parfaitement avec les TO7-70...
Carl

Daniel
Messages : 10683
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 29 avr. 2018 18:10

Quelques nouvelles de l'avancement du projet, et pour commencer un résumé des épisodes précédents :

1) Avec le schéma original, plusieurs utilisateurs ont constaté un mauvais fonctionnement avec quelques ordinateurs, en particulier TO8 et TO8D.
2) En ajoutant un filtre (R = 100 ohms, C = 100 nF) sur les lignes d'adresses il y a un petit mieux mais il y a encore des anomalies.
3) Avec un nouveau schéma utilisant le signal d'horloge E résultats mitigés. Il reste des cas à problème.

Globalement, SDDRIVE fonctionne avec la majorité des ordinateurs : 100% chez certains utilisateurs, 80% ou moins chez d'autres. Mais les quelques cas à problème ne permettent pas de garantir la fiabilité. Les causes probables de dysfonctionnement sont les interférences et rebonds dans le bus, mais aussi les différences de délai de propagation dans les circuits logiques. Normalement cette deuxième cause est éliminée par le nouveau schéma.

Reste donc les problèmes de bus, en particulier sur les lignes d'adresse. Pour les éliminer, j'ai repris exactement le même schéma que l'extension MO5, avec deux buffers 74LS244 sur les 14 lignes d'adresse et les 2 signaux E et R/W. Il y a aussi le filtre R/C décrit au point 2) ci-dessus sur les 16 entrées.

J'ai essayé cette solution avec les deux versions du schéma (avec et sans validation par le signal d'horloge E) sur plusieurs machines : MO5, MO6, TO7/70, TO8 et TO8D. Dans tous les cas ça fonctionne chez moi, mais ça fonctionnait aussi avant donc je ne peux rien conclure. J'attends que d'autres bricoleurs aient réalisé le même montage pour savoir s'il y a une amélioration.

sddrive_buffers.jpg
sddrive_buffers.jpg (83.36 Kio) Vu 388 fois
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 01 mai 2018 22:09

Daniel, si tu veux, je peux tester ton adaptateur sur mon T09...les frais d'envoi et de retour serait à ma charge....
Carl

Daniel
Messages : 10683
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 01 mai 2018 22:26

Je pense que tu veux tester sur TO9+ (le TO9 est incompatible avec SDDRIVE).
Si c'est le cas, je veux bien te prêter le filtre avec les buffers, mais à condition de payer les frais aller (et tu payes le retour).
En espérant que la poste ne le perdra pas, car la construction sur une plaquette d'essai avec tous les câblages faits manuellement m'a demandé plus de deux jours. Je n'aurai certainement pas le courage de recommencer.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 02 mai 2018 07:52

Ok Daniel, je vais avoir du temps entre le 8 et 20 mai pour effectuer les tests...
Pas : oui to9+
Carl

Daniel
Messages : 10683
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 02 mai 2018 09:12

Je vais t'envoyer dès que possible le module avec les buffers et les filtres. A la réception, vérifie que la Poste n'a pas écrasé l'enveloppe : les queues des résistances de la face inférieure ne doivent pas entrer en contact avec d'autres éléments, sinon il faut les redresser.

Pour recueillir le maximum d'informations il faudrait tester avec la première version de SDDRIVE que tu as actuellement, et ensuite essayer avec le nouveau schéma (attente du signal d'horloge E pour valider les adresses). Il a l'avantage du supprimer très efficacement les glitches. Le filtre avec la résistance en série et le condensateur en parallèle devient inutile, c'est beaucoup plus propre.

Si tu as le courage de modifier ton SDDRIVE, je donnerai ici ce nouveau schéma et les modifications à effectuer sur le circuit imprimé (deux ou trois pistes à couper et deux ou trois fils à ajouter).
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 02 mai 2018 13:27

Ok Daniel, on fait la phase 1 des tests.
Puis, ensuite nous passerons aux modifications....
ps : ce n’est plus le condensateur d’origine...

Carl

Avatar du membre
Carl
Modérateur
Messages : 10216
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 03 mai 2018 16:58

Daniel, j'ai reçu ton adaptateur...la poste en a pris soin :wink:
Je vais rapidement passer aux tests...
Carl

Daniel
Messages : 10683
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 03 mai 2018 17:46

La Poste est finalement pas trop mauvaise pour l'acheminement du courrier !

Je ne suis pas sûr que l'on puisse connecter le module quand SDDRIVE est dans son boîtier. Il faut vérifier que le bord du boîtier n'écrase pas les résistances de la face inférieure, ou alors sortir SDDRIVE du boîtier.

Bon test !
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
irios
Messages : 3163
Enregistré le : 04 nov. 2007 19:47
Localisation : Rochefort du Gard (30)
Contact :

Re: [Thomson] SDDRIVE

Message par irios » 03 mai 2018 19:51

6502man a écrit :
21 mars 2018 16:46
Oui c'est une bonne idée :D
Je prépare le TO8D et te contacte pour l’expédition ;) ...
Phil, Je pourrai t'expédier mon interface pour tester ton TO8D aussi non ? :mrgreen:
http://irioslabs.over-blog.com/

La connaissance ne vaut que si elle est partagée par tout le monde.
I2C

Répondre