[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 07 avr. 2019 17:24

J'utilise le même prolongateur pour carte microSD avec un PC, ça marche bien, et ça marche aussi avec SDDRIVE.
Mais la solution avec des fils Dupont est encore plus élégante car elle évite de faire dépasser le module Catalex à l'arrière de l'ordinateur.
Daniel
L'obstacle augmente mon ardeur.

p0ke
Messages : 65
Enregistré le : 20 mai 2018 20:29

Re: [Thomson] SDDRIVE

Message par p0ke » 25 avr. 2019 19:33

Bonjour,

Je n'ai plus de son avec le sddrive (je lance simon cat, bach imagine et les programmes fonctionnent sans problème).
Est-ce que le problème est connu ? (le buzzer sur le to7/70 marche très bien)

Merci d'avance pour votre aide

p0ke

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 25 avr. 2019 20:10

Aucune de ces démonstrations (sddrive music et sddrive video) n'utilise le buzzer.
Le son est produit par l'extension musique et jeux. C'est du côté de cette extension qu'il faut chercher l'origine du problème. Ca peut aussi être un problème en aval, dans le câble péritel ou dans le système audio du moniteur ou du téléviseur.
Daniel
L'obstacle augmente mon ardeur.

__sam__
Messages : 4621
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: [Thomson] SDDRIVE

Message par __sam__ » 25 avr. 2019 20:17

Oui tu n'aurais par hasard simplement retiré l'extension musique&jeux en te disant qu'avec le SDDrive ca n'était plus nécessaire pour mettre le module Catalex? C'est vrai que contrairement à SDMOTO le module catalex se met sur l'extension SDDrive. Mais pour du son par convertisseur numérique->analogique (cna), il faut conserver cette extension dans la machine. Sur TO7 tu as de la place à l'arrière, il ne faut pas s'en priver.
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

p0ke
Messages : 65
Enregistré le : 20 mai 2018 20:29

Re: [Thomson] SDDRIVE

Message par p0ke » 25 avr. 2019 20:43

raaaaaaaaa la honte, j'avais viré l'extension musique & jeux ....

honte à moi ....

(je l'enlève toujours si j'en ai pas besoin dans mes expériences !)

ça vaut une tournée

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 25 avr. 2019 21:00

Pour information, j'ai créé une extension musique et jeux qui peut se souder à l'arrière du contrôleur SDDRIVE :

Image Image

Je ne la propose pas en option car elle est un peu longue à fabriquer, et surtout elle est inutile pour les ordinateurs avec contrôleur musique et jeux intégré. Je croyais même qu'elle pourrait planter le système, puisque tous les circuits sont en double et en parallèle, mais l'expérience montre que ça marche.

http://dcmoto.free.fr/bricolage/sx90-2018/index.html
Image
Daniel
L'obstacle augmente mon ardeur.

p0ke
Messages : 65
Enregistré le : 20 mai 2018 20:29

Re: [Thomson] SDDRIVE

Message par p0ke » 25 avr. 2019 21:59

Yes, je me souviens de ça.
Bon disons que je me commanderais ça à Noël :)
Merci Sam et Daniel pour les réponses rapides et les suggestions.
Vous êtes vraiment adorable.

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 mai 2019 08:23

Copie des questions de Sylv1 postées dans le sujet [Vente] SDDRIVE pour Thomson
(Pour ne pas polluer les discussions de la catégorie "Dons, ventes ou échanges") :
Sylv1 a écrit :Bonsoir
Je reviens vers vous car je n'arrive plus à faire fonctionner le SDDRIVE... et c'est désespérant...
Je vais essayé d'être précis. Pour information j'ai débranché le lecteur de disquette, comme conseillé par Daniel, car celui-ci ne fonctionne plus.
Les premières fois le SDDRIVE fonctionnait uniquement en appuyant sur la touche 2 du menu (cat.sd, memphis.sd). Après cela fonctionnait en appuyant sur la touche 1 du menu mais après avoir tapé les codes donnés par Daniel.
Quand j'ai voulu faire du Basic et que j'ai essayé d'enregistrer un petit programme (SAVE «PROG.BAS») j'avais le message d'erreur : ? SN ERROR.
J'ai essayé aussi de jouer à des jeux au format .sd mais rien ne fonctionnait.
Entre chaque essai je coupais le TO8D plusieurs secondes. Au bout de plusieurs essais infructueux je me suis retrouvé avec un écran noir. Et au bout de 20 minutes de repos je me suis retrouvé avec l'écran ci dessous.

L'écran est bleu ciel et il y a le rectangle bleu plus foncé où est normalement affiché TO8D (désolé je n'ai pas d'URL pour envoyer les photos)

Pour information lorsque j'ai mis la carte SD dans mon ordinateur 1 fois sur 3 il ne la reconnaissait pas. Je ne dis pas que cela vient de la carte SD cela peut venir aussi de mon port USB (je cherche une solution). Au final j'ai formaté la carte SD au format FAT et j'ai recopié les programmes au format sd qu'il y avait à l'origine.
Au niveau des leds du SDDRIVE il n'y a que la led verte qui s'allume.
C'est tout ce que je peux dire à par que je suis un peu désespéré quand même:-(
Vos conseils sont les bienvenus car je ne sais vraiment pas quoi faire...
La photo ci dessous c'est le menu que j'ai quand j'allume le TO8D sans le SDDRIVE.

Il y a l'écran normal du TO8D avec uniquement les 3 premières lignes car j'ai débranché le lecteur de disquette

Comme précisé dans la documentation à http://dcmoto.free.fr/bricolage/sddrive/index.html , la carte SD n'est pas protégée en écriture et une fausse manœuvre ou un plantage de programme peut détruire son contenu, en particulier le MBR (master boot record) ou le secteur de boot de la partition. Dans ce cas le PC ne peut pas accéder aux fichiers et demande de reformater.

Il faut reformater la carte avec le PC en FAT ou FAT32. Le premier fichier à copier ensuite est sddrive.sel, mais pas n'importe quelle version : la version de sddrive.sel doit être compatible avec la version de l'EPROM. Le numéro de version est écrit sur l'étiquette, et le fichier sddrive.sel correspondant est dans l'archive de même numéro, disponible à la page officielle SDDRIVE du site dcmoto (lien ci-dessus) .

Ensuite on peut copier des fichiers .sd. S'ils doivent être lancés en BASIC 1.0 la disquette dans l'unité 0: doit être bootable, c'est à dire contenir un programme de lancement dans le secteur 1 de la piste 0. Dans tous les cas on peut utiliser le fichier basic-dos.sd. Il contient une version spéciale du DOS qui démarre aussi bien sur TO que sur MO.

Avec cette carte SD, le contrôleur SDDRIVE doit lancer automatiquement le programme sddrive.sel quand on tape 2 au menu d'accueil du TO8 ou du TO8D sans lecteur de disquette. A l'écran on doit voir le titre "S D D R I V E " suivi de la liste des fichiers du répertoire principal de la carte SD. Sinon il y a une panne matérielle, qui peut affecter le TO8, les connexions, le contrôleur SDDRIVE, le module de la carte SD, la carte SD etc. Il faudra tester chaque élément séparément si le problème n'est pas résolu par la restauration d'une carte SD correcte.

Sachant que le système a bien fonctionné la première fois lors du lancement des démonstrations de musique et de vidéo, le problème le plus probable est l'absence de la bonne version de sddrive.sel sur la carte. En postant le fichier zippé en pièce jointe dans un message je pourrais le vérifier en cas de doute.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 717
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 16 mai 2019 16:20

J'avais avant sa sortie fait des tests complet >> ICI << sur l'extension SDdrive V2.00 avec 4 autres personnes. Depuis elle a évolué et je pense que tout le monde en est content. Bien sûr cela n'exclus pas la panne comme tout matériel électronique mais cela n'exclus pas non plus la mauvaise utilisation.
jasz a écrit :
16 juin 2018 19:06

Code : Tout sélectionner

Machine  | SDDRIVE | Lecture | Ecriture | Reset | Commentaires          
---------|---------|---------|----------|-------|------------------------------------------------------
T9000    | Aucune  |         |         `|       | Pas d'extension 16ko
TO7/70   | V1      | Ok      |          | Non   | Impossible d'essayer l'ecriture
         |         |         |          |       | Le reset plante systématiquement
         | V2      | Ok      |          | Ok    | Ecriture impossible car Disk DOS impossible à charger
MO5 50001| V1      | Ok      | Ok       | Ok    |
         | V2      | Non     |          |       | Test à refaire sur une autre machine 50.001
MO5 Meca | V1      | Non     |          |       | 
         | V2      | Ok      | Ok       | Ok    |
MO6NR    | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC128
         |         |         |          |       | Taper CLEAR,&H4FFF:EXEC&HA025
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment
TO8      | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC512
         |         |         |          |       | Taper CLEAR,&H8FFF:EXEC&HE025
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment
TO8D     | V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC512 ou 1.0
         |         |         |          |       | Taper POKE&HE7E7,&HD4:EXEC&HE025
         |         |         |          |       | Après Disk chargé taper EXEC&HE007    
         |         |         |          |       | Le reset renvoie 3 erreurs 2 et bloque le retour au BASIC
         | V2      | Ok      | Ok       | Ok    | Même remarque que précédemment sauf
         |         |         |          |       | Le reset bloque le retour au BASIC directement
---------|---------|---------|----------|-------|------------------------------------------------------        
Je complèterai ce post avec d'autres tests mais déjà nous avons un bon comparatif entre les deux versions V1 et V2 de SDDRIVE ;)

[edit]

Code : Tout sélectionner

Machine  | SDDRIVE | Lecture | Ecriture | Reset | Commentaires          
---------|---------|---------|----------|-------|------------------------------------------------------
MO5 50001| V1      | Ok      | Ok       | Ok    | Pas de chargement direct en BASIC1.0 sur les deux UC test et contrôle 
         |         |         |          |       | Taper CLEAR,&H4FFF:EXEC&HA025
         |         |         |          |       | Après Disk chargé taper EXEC&HA007 
         | V2      | Ok      | Ok       | Ok    |
TO7/70   | V1      | Non     |          |       | ?IO Error in 0
         |         |         |          |       | Le reset ne plante plus
         | V2      | Ok      | Ok       |       | Erreur ?NE in 0 après chargement du DOS
         |         |         |          |       | DOS bien présent
         |         |         |          |       | Le reset ne retourne pas au DOS
---------|---------|---------|----------|-------|------------------------------------------------------        

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 16 mai 2019 17:56

A noter qu'au fil des versions le comportement du contrôleur SDDRIVE a très légèrement évolué : pour supporter le DOS LOGO, pour éviter l'écrasement de paramètres quand la pile système se remplit, pour démarrer automatiquement en BASIC 128 ou 512, pour ne plus se bloquer en cas de carte SD incompatible ou d'absence de carte SD. Les premières versions sont toutefois pleinement opérationnelles dans la très grande majorité des cas.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 02 juin 2019 19:00

Au cours de tests avec le TO7/70 je viens de constater un comportement anormal quand on utilise la version 2019.04.10 du contrôleur SDDRIVE avec le BASIC 128. Au premier lancement le programme de sélection sddrive.sel affiche le titre SDDRIVE et se bloque.

Bon, ce n'est pas grave, il suffit de réinitialiser le TO7/70 (par le bouton INIT PROG) et de relancer sddrive.sel par EXEC &HE007
Je n'ai pas encore trouvé la raison de cette anomalie, car le problème ne se produit pas avec l'émulateur dcmoto et il n'est pas facile de débuguer un programme avec la vraie machine. En attendant une prochaine correction il faudra utiliser la procédure ci-dessus (Initialisation + EXEC).
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 04 juin 2019 21:46

Le problème est identifié et corrigé :

Avec le TO7/70 en BASIC 128 la banque RAM sélectionnée par défaut est la dernière de l'extension mémoire. Si l'extension mémoire est absente, l'ancienne version du programme sddrive.sel ne fonctionne pas. Je crois qu'au cours des premiers tests Carl avait déjà signalé le problème.
Dans dcmoto ça marchait car l'extension mémoire est sélectionnée par défaut, mais si on l'enlève dans les options alors l'émulateur reproduit exactement l'erreur constatée avec la vraie machine.

J'ai ajouté dans le programme sddrive.sel la routine de sélection de la première banque de RAM si le BASIC 128 est détecté.
Le problème est résolu.

Code : Tout sélectionner

*------------------------------------------------------
* Initialisation banque memoire TO7/70 en BASIC 128
*------------------------------------------------------
INIT0
  LDB   #$38          caractere 8
  CMPB  >$0009        test du 8 de BASIC 128
  BNE   INIT1         ce n'est pas le BASIC 128 
  LDB   $E7CB         charger DDRB
  ANDB  #$FB          RAZ bit 2
  STB   $E7CB         modifier DDRB
  LDB   #$0F          valeur pour premiere banque RAM
  STB   $E7C9         stocker dans PORTB 
  LDB   $E7CB         charger DDRB
  ORB   #$04          positionner bit 2
  STB   $E7CB         modifier DDRB
  
La version corrigée de sddrive.sel est dans l'archive sddrive_20190410.zip à la page officielle de SDDRIVE :
http://dcmoto.free.fr/bricolage/sddrive/index.html

Cette version fonctionne avec les EPROMs 20190212, 20190410 et suivantes.
Elle comporte aussi une autre amélioration : les flèches droite et gauche permettent de passer à l'écran suivant et à l'écran précédent, pour éviter de parcourir la liste ligne à ligne avec les flèches bas et haut.
Daniel
L'obstacle augmente mon ardeur.

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 26 juin 2019 15:02

ATTENTION : BUG !
Je viens de découvrir un bug du contrôleur SDDRIVE qui affecte les versions 2019.03.03 et 2019.04.10 de l'EPROM, diffusées entre le 08/03/2019 et le 24/06/2019. Les huit derniers contrôleurs vendus sont impactés.

L'erreur concerne la fonction d'écriture d'un secteur : l'adresse du buffer est erronée et l'écriture peut corrompre le système de fichiers.
Par contre toutes les opérations de lecture fonctionnent parfaitement bien, c'est pourquoi ce bug n'a pas été découvert immédiatement.
Si on se contente de charger des programmes, tout est bon. Le problème se manifeste, par exemple, si on sauve un fichier.

Conduite à tenir si vous avez l'une des deux mauvaises versions de l'EPROM :
- Si vous êtes équipés pour reprogrammer l'EPROM, utilisez la version 2019.06.26 disponible ici --> http://dcmoto.free.fr/bricolage/sddrive/
- Si vous ne pouvez pas programmer l'EPROM vous-même, manifestez-vous dans ce fil de discussion, je vous enverrai l'EPROM de la version 2019.06.26 pour remplacer la mauvaise.

Désolé pour ce problème. Les informaticiens comprendrons que ce genre d'erreur échappe parfois aux contrôles.
Pour la petite histoire, le registre DP n'avait pas la bonne valeur lors d'un adressage direct : LDY <DK_BUF
Daniel
L'obstacle augmente mon ardeur.

Brochiman
Messages : 48
Enregistré le : 02 juin 2019 11:26

Re: [Thomson] SDDRIVE

Message par Brochiman » 26 juin 2019 15:53

@Daniel je pense être dans les 8 derniers a avoir acheté un sddrive et malheureusement je n'ai pas l'équipement et les connaissances pour reprogrammer l'EPROM 😕😕

Daniel
Messages : 11699
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 26 juin 2019 16:02

@Brochiman : Aucun problème, j'envoie la nouvelle EPROM demain.

Pour retirer l'ancienne EPROM de son support, l'outil le plus pratique est une lame de canif.
Pour insérer la nouvelle, il faut procéder avec beaucoup de précautions :
- Bien respecter le sens, l'encoche de l'EPROM doit être du côté de l'encoche du support et de la sérigraphie.
- Ne pas appuyer tant que toutes les broches ne sont pas parfaitement positionnées. Elles peuvent se tordre très facilement, attention !
Modifié en dernier par Daniel le 26 juin 2019 17:06, modifié 1 fois.
Daniel
L'obstacle augmente mon ardeur.

Répondre