Goupil G4: Restauration

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Goupil G4: Restauration

Message par gotcha » 12 oct. 2018 09:18

Hello,

J'essaie de faire redémarrer un Goupil G4 et mon premier problème se trouve comme je m'y attendais dans l'alim:
Elle fait un bruit assez important de tac-tac-tac (peut-être dans les 5-10hz) que je n'arrive pas bien à localiser.

Quand j'ai initialement mesuré le 12v en charge, il n’était pas stable. J'ai donc tout débranché.

J'ai ensuite inspecté le PCB de l'alim et j'ai détecté un pont de soudure qui court-circuitait des diodes près du régulateur 12v. De l'autre coté du PCB, il y a trace d'une forte chaleur (noirci). J'ai l'impression que le pont de soudure s'est crée par la fonte de la soudure du fait d'un problème en fonctionnement.

Pont de soudure à gauche.jpg
Pont de soudure à gauche.jpg (290.34 Kio) Vu 593 fois
Ca a chauffé.jpg
Ca a chauffé.jpg (251.47 Kio) Vu 593 fois

J'ai dessoudé les 3 composants autour du point de chauffe (une résistance, deux diodes) et étonnamment, ils sont toujours fonctionnels. Je les ai quand même remplacés par du neuf. Et j'ai enlevé le pont de soudure. Avec ça et aucune charge sur l'alim, le 12v est semble plus stable au multimetre (j'ai plutôt 11v) et j'ai aussi du 5v qui semble stable. Note: je n'ai pas encore branché l'oscillo pour voir la forme du signal sur le 5v et 12v.

Par contre, j'ai toujours ce bruit de tac-tac-tac régulier que je n'arrive pas à localiser à l'oreille.
Est-ce que quelqu'un a une idée d'où peut provenir ce bruit assez fort ?
J'imagine que c'est le signe qu'il y a toujours un problème.

Malheureusement, je n'ai trouvé strictement aucune info sur cette alim.

(je précise qu'avant de bricoler sur la carte, je vérifie au multimètre que les gros condos du primaire sont déchargés 8) )

Reference alim G4.jpg
Reference alim G4.jpg (190.75 Kio) Vu 593 fois
Alim Goupil G4.jpg
Alim Goupil G4.jpg (256.07 Kio) Vu 593 fois
Modifié en dernier par gotcha le 22 oct. 2018 22:56, modifié 1 fois.
Amstrad CPC addict :mrgreen:

Avatar du membre
fneck
Site Admin
Messages : 12821
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par fneck » 12 oct. 2018 09:36

Le claquement qu'on peut entendre dans une alimentation à découpage est généralement lié à la mise en protection de celle-ci. C'est à dire qu'elle doit fournir un courant supérieur à sa limite et déclenche, puis redémarre et re-déclenche... et ainsi de suite.

Donc, comme tu as débranché l'alimentation de ses consommateurs, c'est sur elle-même qu'il y a un problème. Il se situe sur la partie secondaire de l'alimentation ou sur la partie mesure de courant, on peut facilement soupçonner un des condensateurs chimiques du secondaire.

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 12 oct. 2018 09:38

fneck a écrit :
12 oct. 2018 09:36
Le claquement qu'on peut entendre dans une alimentation à découpage est généralement lié à la mise en protection de celle-ci.
Cette mise en protection est effectuée par quel composant ? Il y a une sorte de disjoncteur caché quelque part ?
Amstrad CPC addict :mrgreen:

Avatar du membre
fneck
Site Admin
Messages : 12821
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par fneck » 12 oct. 2018 09:43

Non, il n'y a rien de mécanique, tout est électronique. Le bruit est probablement dû à la coupure ou la remise sous tension dans le transformateur.

Je pense qu'avec un schéma on pourrait identifier le circuit de mesure. Il doit partir du secondaire pour arriver sur le transistor principal de coupure du primaire, comme pour la régulation de tension.

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 12 oct. 2018 09:47

Prochaine étape donc: vérification des condensateurs chimiques du secondaire.
A priori, de ce que je comprends, on cherche un composant en court-circuit.

S'il y avait un problème sur le primaire, cela se traduirait par le claquage du fusible ?
Amstrad CPC addict :mrgreen:

Daniel
Messages : 11697
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par Daniel » 12 oct. 2018 10:18

Une alimentation sans charge peut aussi se mettre en protection et faire le même bruit. Pour être sûr que la panne est toujours présente après la suppression du pont de soudure, il faudrait la faire débiter avec au minimum une résistance de puissance d'environ 5 ohms sur le 5V. Ce n'est qu'une hypothèse parmi d'autres, le court-circuit évoqué par Fabien est beaucoup plus probable à cause de la surchauffe des diodes et du régulateur.

Comme les diodes et le régulateur 12V ont beaucoup chauffé, le court-circuit est probablement dans les condensateurs de filtrage du 12V. S'il y en a un en court-circuit, il vaut mieux les changer tous. Sinon, si les condensateurs de l'alimentation sont tous bons, le court-circuit peut aussi être en aval sur la carte mère.

Au primaire, il y a deux types de pannes possibles : composant en court-circuit (transistor oscillateur ou condensateur) ou composant coupé (pont de diodes ou transistor oscillateur). Dans le premier cas le fusible fond, dans le deuxième cas il ne fond pas, c'est le composant qui a servi de fusible. Mais d'après la description de la panne le problème n'est pas là.
Daniel
L'obstacle augmente mon ardeur.

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 12 oct. 2018 12:50

Bon, ça se corse. Je viens de remarquer aussi qu'un autre composant a eu chaud sur une petite carte fille de l'alim.
Il s'agit d"un composant qui ressemble à un transistor mais qui à mon avis n'en ai pas un : 0100 TI8432

TI8432 abimé.jpg
TI8432 abimé.jpg (211.21 Kio) Vu 549 fois

De plus, il est inconnu sur google, sauf sur un site chinois où une personne cherche aussi à comprendre ce composant: https://translate.google.fr/translate?s ... t=&act=url

Une possibilité serait qu'il est en fait un TL432 (three-terminal voltage adjustable shunt regulator: http://www.ti.com/lit/ds/symlink/tl431.pdf) qui semble être utile dans les alims, mais rien n'est sûr. Aussi, c'est un composant qui semble introuvable en format TO-92.

Alors, je peux peut-être tenter de ressouder celui sur la carte: Il a une patte dessoudé et une patte cassée.

Mais bon, là, j'ai l'impression qu'il va falloir tenter une autre solution: mettre une autre alim. Je vais ouvrir un peu plus le G4 pour voir le connecteur d'alim sur la carte mère. La question est: est-ce un connecteur AT ? A priori, j'ai vu sur ce forum que le G5 est compatible AT, mais pour le G4, ce n'est pas clair.
Carte fille alim G4.jpg
Carte fille alim G4.jpg (229.14 Kio) Vu 549 fois
Amstrad CPC addict :mrgreen:

Daniel
Messages : 11697
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par Daniel » 12 oct. 2018 17:16

Le transistor défectueux ressemble à un 2SC0100 : TO-92 15W 40V 0.2A RF.SW
http://shop.cpu.com.tw/html/2231/2SC0100.html

8432 est la date de fabrication (année et semaine).
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 12821
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par fneck » 12 oct. 2018 19:06

Coté caractéristique ça ne doit pas être 15W, c'est beaucoup trop pour un boitier TO92.

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 12 oct. 2018 20:29

Bon, je viens de casser un élément de ma pompe à dessouder :evil: Il va falloir attendre quelques jours que je reçoive la pièce.
J'ai envie de tester ce 'transistor' sur un testeur, pour confirmer, ou pas, si c'est un transistor. Il va falloir être patient :?

Entre temps, je pense que je vais regarder le lecteur 5" 1/4 du goupil et voir si je peux en faire quelque chose avec la Kryoflux.
Sur le Goupil, c'est du DOS 2.11 en DF DD.
Amstrad CPC addict :mrgreen:

Daniel
Messages : 11697
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par Daniel » 12 oct. 2018 21:15

fneck a écrit :
12 oct. 2018 19:06
Coté caractéristique ça ne doit pas être 15W, c'est beaucoup trop pour un boitier TO92.
Oui, c'est bizarre. J'ai recopié bêtement les infos données sur la page citée.
Cette page contient aussi un lien vers un fichier .pdf, malheureusement le lien est invalide.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 12821
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par fneck » 12 oct. 2018 22:50

Sur cette page on trouve 0.15 W pour un 2SC0100
https://alltransistors.com/transistor.p ... stor=11287

[edit] Je l'ai trouvé dans un vieux bouquin d'équivalence de transistor
Si-NPN HF 40V 0.2A 400MHz

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 13 oct. 2018 23:45

Bon, malgré une patte cassée, j'ai réussi à obtenir quelque chose au testeur avec le 0100 TI8432. Il me dit transistor NPN, mais avec un gain étrange de 1 et une tension de seuil tout aussi étrange de 1.32v. Il me mets aussi une diode entre le collecteur et l’émetteur.

Ce composant a eu un coup de chaud, mais bon ... Du coup, je ne sais pas trop quoi penser. Est-ce vraiment un transistor ?

IMAG2097_small.jpg
IMAG2097_small.jpg (222.09 Kio) Vu 443 fois
Amstrad CPC addict :mrgreen:

Avatar du membre
fneck
Site Admin
Messages : 12821
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par fneck » 14 oct. 2018 09:46

L'as-tu testé au multimètre classique, position diode entre chaque patte ?
Car un gain de 1 me fait automatiquement penser à un court-circuit sur une jonction, mais bon, je suppose que le testeur devrait le voir :roll:

gotcha
Messages : 417
Enregistré le : 30 mars 2017 11:39
Localisation : Grenoble

Re: Goupil G4: bruit tac-tac-tac dans l'alim

Message par gotcha » 14 oct. 2018 10:58

fneck a écrit :
14 oct. 2018 09:46
L'as-tu testé au multimètre classique, position diode entre chaque patte ?
Je viens de le faire, et voici le résultat ... assez étonnant :o

IMAG2099_small.jpg
IMAG2099_small.jpg (141.77 Kio) Vu 415 fois

Ca ressemble plus à un transistor PNP :D


Image
Amstrad CPC addict :mrgreen:

Répondre