Trs80 qui chauffe

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Trs80 qui chauffe

Message par bubblefouasson » 16 oct. 2018 13:14

Bonjour, en faisant un peut de rangement, j'ai ressorti un de mes trs80 modèle 1. En le branchant, j'ai une image non stabilisée mais avec le bon demarrage de demande de choix de ram.
J'ai aussi une odeur de chaud. Après ouverture, la carte mère a ete pas mal bidouillé et le transitor à côté des gros condensateurs est brulant: cela me parait pas normal?
Qu'en pensez vous ?
Fichiers joints
EAB524AC-1B77-4CA4-981E-F866034B6564.jpeg
EAB524AC-1B77-4CA4-981E-F866034B6564.jpeg (243.24 Kio) Vu 272 fois
D23568A8-7984-46AF-8144-EE1E5340C8D5.jpeg
D23568A8-7984-46AF-8144-EE1E5340C8D5.jpeg (409.11 Kio) Vu 272 fois
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
gleike
Messages : 537
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: Trs80 qui chauffe

Message par gleike » 16 oct. 2018 14:05

J'ai eu le même problème sur mon model 1,

Si Q3 chauffe et que Q2 est froid ,c'est que Q2 est mort, dans ce cas Q3 absorbe toute la puissance.
J'ai changé les 2 par précaution et plus de chauffe.
Pour Q3 j'ai installé un TIP29A a la place du MJE29 installé d'origine
et pour Q2 un MJ2955 a la place de 2N6594 d'origine, normalement ça correspond.

Vérifie quand même avant de commander les composants Q2 et surtout les gros condensateur de filtrages

Dans les modifications je reconnais celle pour les caractères minuscule, et la deuxième doit être je pense pour l'horloge rapide, c'était les modifs les plus courantes a l'époque.

pour tester l'horloge : out254,1=rapide , out254,0=lente,
en chronométrant une boucle FOR NEXT tu vois la différence.

[Edit] Il faut lire Q4 à la place de Q2
Modifié en dernier par gleike le 19 oct. 2018 13:10, modifié 2 fois.

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 16 oct. 2018 21:10

Merci pour ce retour, q2 pourrais être hs et que la machine fonctionne ? Effectivement q2 est froid donc je vais suivre tes conseils et commander les composants.
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 16 oct. 2018 21:23

Pour les transistor, c'est plutôt q4 au lieu de q2, c'est bien un transistor de puissance avec son dissipateur de chaleur? celui que l'on voit sur la photo à gauche de q3.
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
gleike
Messages : 537
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: Trs80 qui chauffe

Message par gleike » 17 oct. 2018 11:13

Aie :roll: , oui c'est bien Q4, je me suis mélangé les idées, quand je pense que j'avais écrit Q4 au départ et que j'ai corrigé mon post pour Q2 :oops:

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 17 oct. 2018 16:06

Ok merci, je viens de commander les pièces , je ferai un retour dès remplacement.
A +
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

TRS-80

Trs80 qui chauffe

Message par TRS-80 » 19 oct. 2018 05:14

Bonjour,
Pour le transistor qui chauffe, c'est exact il faut changer les deux. Le TO3 2N6594 peut être remplacé par un 2N2955 (si ma mémoire est bonne) qui est beaucoup plus facile à trouver et moins cher!!!
Mais cette panne je la connais bien!!! C'est la graisse sous le transistor TO3 qui ne conduit plus la chaleur!!! Elle a 40 ans!!!
Donc il faut acheter de la graisse comme pour un Pentium!!!!!
Attention pour régler les tensions, Elles sont interactives!!!
Il faut d'abord régler le +12V puis le +5V (si ma mémoire est bonne)
Attention si tu attends trop, c'est le deuxième transistor qui brule et c'est la diode zener CR1 1N4735 de protection qui encaisse tout et donne du 6,75 à 7V!!! Puis lorsque la zener CR1 brule c'est toute la carte qui est H.S. car la limite de tension pour les C.I. TTL est de 7V à 7,5V
A+
Pascal

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 19 oct. 2018 19:24

ok merci, j'ai de toute manière tout arrêté rapidement, je suis en attente de pièces maintenant.
donc à suivre
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 25 oct. 2018 10:51

Bonjour,
pièces reçues et montées: c'est ok, seul le Q4 chauffe mais c'est normal je pense d'où la présence du radiateur thermique (je n'ai pas oublié la pate thermique).
Par contre, j'ai toujours un problème d'image, non stabilisée.
Je ferais des photos dans la journée.
Merci
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
gleike
Messages : 537
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: Trs80 qui chauffe

Message par gleike » 25 oct. 2018 11:46

Tu utilise quel type de moniteur, le moniteur d'origine Tandy Radio shack ou un autre ?

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 25 oct. 2018 13:52

Non, un sony kx14, mon moniteur d'origine est dans un carte au chaud.
Mais, j'ai un autre trs80 (celui sans clavier numérique à droite) cela fonctionne .
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
gleike
Messages : 537
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: Trs80 qui chauffe

Message par gleike » 25 oct. 2018 17:57

Sur la carte mére du TRS80 tu as 2 petites résistances ajustables,
R21 qui permet d'ajuster la synchro verticale
et R20 qui ajuste la synchro horizontale.
Si le réglage ne donne pas de résultat probant, tu peux essayer de suivre le chemin du signal de synchro
en remontant depuis Q2 jusqu’à sa source.
Image

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 25 oct. 2018 21:08

Merci, je fais le test demain soir.
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
bubblefouasson
Messages : 202
Enregistré le : 23 déc. 2014 12:54

Re: Trs80 qui chauffe

Message par bubblefouasson » 31 oct. 2018 09:26

Bonjour, donc j'ai fait le test, 1 seule résistance variable à l'air de fonctionner: le reglage agit sur l'image de droite à gauche, l'autre rien.
Un condensateur pourrait être la cause?
Merci
trop de trucs, trop de choses, des caltoches, des consoles, des jeux et surtout des vieux micros.

Avatar du membre
gleike
Messages : 537
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: Trs80 qui chauffe

Message par gleike » 31 oct. 2018 14:10

As-tu un oscilloscope ?
Si oui , il faut contrôler la présence du signal VDRV depuis la patte 9 de Z5 jusqu'à la patte 1 de Z57 (voire éventuellement plus loin sur le schéma) et trouver à quel endroit un signal apparaît si il n'est pas présent sur la patte 9 de Z5.

Répondre