Problème Apple II (e)

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Papy.G, fneck, Carl

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Problème Apple II (e)

Message par Clem » 12 juin 2019 21:43

Bonsoir,

Il y a environ quelques semaines un ancien prof de technologie du collège m'a très généreusement donné un Apple II ( "e" je pense ... c'est mon tout premier Apple et je n'y connais pas grand chose).

Cet ordinateur est un peu spécial car c'est mon prof qui l'a construit entièrement, même les PCB on été faits par lui a partir des schémas originaux de l'Apple IIe qu'il avait trouvés à l’époque.

Il possède 3 cartes d’extension fabriquées par la même personne:
-une carte d’extension mémoire (je ne connais pas sa capacité)
-une carte pour mettre 2 FDD
-et une carte graphique couleur.

Le seul accessoire que je possède est le lecteur de disquettes.

Il ne possède malheureusement plus son clavier (qui était aussi fabriqué maison d’après ce qu'il a pu me raconter à partir d'un clavier de machine à écrire numérique qu'il avait légèrement transformé afin de l’adapter.

Ma question est: donc : est-il normal que l’ordinateur se mette à "biper" sans arrêt et qu'il m'affiche des "@@@@@@@@@/" lorsque je l'allume sans la carte de lecteur de disquette et sans pontage entre STROBE et RESET(de la prise du clavier) ?

Et que lorsque cette carte est en place il ne "bipe" qu'une seule fois mais le lecteur se met à tourner et peut lancer des jeux, mais le pointiller blanc en haut à gauche n'est plus présent lorsque il n'y a pas de disquette insérée ?

Mais quand je relie STROBE et RESET et que la carte du lecteur de disquette n'est plus présente, l'ordinateur me parait normal et le point blanc en haut a gauche clignote comme s'il attendait des instructions.

J’espère que vous arriverez à comprendre mon problème malgré mes descriptions un peu vagues.

P-S: Je possède du matériel, donc si une de vos idées nécessite d'un oscilloscope, gbf, multimètre... (je n'ai juste plus d’alimentation de laboratoire, elles m'ont lâchées toutes les deux ;( ) n’hésitez pas à me l'exposer.

Les claviers Apple ][e sont des ASCII ou autre ?

Merci de votre participation pour m'aider.
Clément.

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 12 juin 2019 21:49

Les photos...
Fichiers joints
IMG_20190603_183942.jpg
Mais il charge très bien les jeux.
IMG_20190603_183942.jpg (1.33 Mio) Vu 370 fois
IMG_20190603_183927.jpg
Le FDD tournant dans le vide.
IMG_20190603_183927.jpg (938.61 Kio) Vu 370 fois
IMG_20190603_183920.jpg
Avec la carte du FDD.
Même avec et sans pontage c'est la même chose et le FDD tourne dans le vide sans disquette.
IMG_20190603_183920.jpg (996.72 Kio) Vu 370 fois
IMG_20190603_183648.jpg
Sans la carte du FDD et avec un pontage entre RESET et STROBE.
Le point blanc clignote.
IMG_20190603_183648.jpg (977.14 Kio) Vu 370 fois
IMG_20190309_134652.jpg
Vue d'ensemble.
IMG_20190309_134652.jpg (1.21 Mio) Vu 370 fois

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 12 juin 2019 21:50

Encore...
Fichiers joints
IMG_20190603_184047.jpg
Et la carte mère ainsi que l’alimentation.
IMG_20190603_184047.jpg (1.35 Mio) Vu 370 fois

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 12 juin 2019 21:59

et voila ce qu'il m'affiche lorsque il n’y a pas la carte du FDD et de pontage.
Fichiers joints
Screenshot_20190612-215500.png
Screenshot_20190612-215500.png (571.98 Kio) Vu 366 fois

jvernet
Messages : 1536
Enregistré le : 12 avr. 2007 10:59
Localisation : France 69

Re: Problème Apple II (e)

Message par jvernet » 12 juin 2019 22:06

Magnifique. Plus que magnifique, même !

Ce n'est pas un IIe, mais un clone "a la main" d'Apple II Europlus tout court.

je ne connais pas bien l'Apple II (beaucoup plus l'Apple IIe).

Sinon, le clavier d'Apple IIe n'est pas compatible avec l'Apple II, ce n'est pas non plus un clavier "ascii". Le pontage permet de démarrer la machine, sinon il plante pendant le boot (l'ecran de rempli de tas de trcus et il beep non stop, normalement).

La carte mémoire doit faire 16k, et il doit y avoir une ROM marqué F8 dessus, non ? C'est une Language Card, qui permet un Apple ][ de démarrer sur disquette. Si tu la retire, la machine ne boot plus sur disquette
Je ne sais pas trop ce que tu veux dire par "point blanc" en haut à gauche ? C'est l"invite du BASIC Integer: ]

Si tu ne met pas de disquette, la machine attend indéfiniment une disquette, avec Apple ][ en haut de l'écran, normal.

Le comportement de la machine me parait sinon tout a fait cohérente.

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 12 juin 2019 22:44

Merci pour le compliment et la reponse...

Il y'a effectivement 2 eprom (28c16 il me semble) qui sont marqué f8 une sur la carte mère et une autre sur la carte mémoire mais lorsque je retire l'une des 2 le pc plante a un moment et le lecteur tourne et charge quand même.(puis plante)

Pour moi ''point blanc’' est l'invite du Basic (j'avais juste oublié...) Merci pour la correction.
Du coup s'erait il possible d'adapter un clavier style commodore 64 ou autre sur l'Apple II auroplus avec entre les deux un pcb avec des ci?

Et oui il bipe en continus et l'affiche des @ sans arrêt si je ne ponte pas.mais il m'affiche quand même Apple ii

Mais comment faites vous la différence entre un IIe et IIeuroplus? Je suis curieux...

jvernet
Messages : 1536
Enregistré le : 12 avr. 2007 10:59
Localisation : France 69

Re: Problème Apple II (e)

Message par jvernet » 12 juin 2019 23:00

Le IIe par exemple, intégre la carte Langage et la ROM F8 sur la carte mére (et des ROM de 8K, 2 puces uniquement). Il ne dispose que de 7 slots plus un slot dit AUX, en face du lot 3 pour les versions européennes, contre 8 (ATTENTION, le slot 0 n'accepte que les cartes mémoires, rien d'autres) pour l'apple IIeuroplus.
Le IIe comporte beaucoup moins de composants, aussi.

Le IIe a 64k de RAM sur carte mére, le II europlus comme le tien 32k ou 48k (il manque d'ailleurs des RAM à ta machine, qui doit donc être en 32k+16k).

Pour le clavier, il existe des adaptateurs permettant -c'est pas joli- de mettre un clavier PS2: https://knzl.at/ps2-keyboard-for-apple-ii/ par exemple.

J'avais des cartes méres faites mains comme celle ci, je les ai refilées gratos, je regrette maintenant...

Il faudrait une photo meilleure de la carte mére. Certaines etaient bi cPU (6502 et Z80).

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 12 juin 2019 23:12

Merci bien pour le petit cours...

Je vous enverrai de meilleur photos demain matin mais je ne pourrait pas prendre en photo l'autre face de la carte -trop peur de la bousiller en la sortant- :|

Bonne soirée et a demain pour les photos.

Avatar du membre
F1FCO
Messages : 289
Enregistré le : 26 juin 2015 23:22
Localisation : NIMES

Re: Problème Apple II (e)

Message par F1FCO » 12 juin 2019 23:50

bonsoir à vous tous,
il y avait eu en fin d'année dernière une description d'interface clavier pour Apple II
viewtopic.php?f=18&t=9354
facile à réaliser sur un petit bout de plaquette pastillé
et avec l'accord de l'auteur, il est facile de programmer le composant actif

Pierre, de Nîmes.

Avatar du membre
Falkor
Messages : 863
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Problème Apple II (e)

Message par Falkor » 13 juin 2019 07:57

Je veux bien quelques photos de la carte graphique couleur...! :)

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 13 juin 2019 09:23

Merci bien pour le lien Pierre et jvernet(que j'ai oublier de remercié hier soir quelle honte pour moi :oops: )

Je ferais les photos de la carte mère se soir ...mon téléphone fais des photos trop médiocre, je prendrais celui de mon père qui est plus recent...

Bonne journée à tous et a ce soir...

Clem
Messages : 19
Enregistré le : 22 févr. 2019 11:35
Localisation : St Etienne

Re: Problème Apple II (e)

Message par Clem » 15 juin 2019 21:29

Bonsoir,

Pardonnez moi de ne pas avoir répondu avant mais entre temps j'ai récupéré le câble vidéo pour la carte graphique et je n’arrête pas d'essayer de retrouver le bon positionnement des fils ( c'est du péritel) à partir de pas grand chose mais je pense pouvoir réussir avec de la patience...
Voici les photos avec une qualité supérieur à celle de mon téléphone...(prendre en photo un Apple II avec un Ipad je trouve ça rigolo)
image2 (1).jpeg
carte graphique
image2 (1).jpeg (1.49 Mio) Vu 282 fois
La fiche rouge est relié a la sorti composite.
image2 (1).jpeg
carte graphique
image2 (1).jpeg (1.49 Mio) Vu 282 fois
image6.jpeg
carte mémoire
image6.jpeg (1.41 Mio) Vu 282 fois
J'aimerais beaucoup vous envoyez les autres photos mais elles sont trop lourde pour le forum, avez vous une technique ou astuce pour les mettre sans les retoucher????
Fichiers joints
image4.jpeg
carte lecteur de disquette
image4.jpeg (1.44 Mio) Vu 282 fois

Avatar du membre
fneck
Site Admin
Messages : 12900
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Problème Apple II (e)

Message par fneck » 15 juin 2019 23:18

Clem a écrit :
15 juin 2019 21:29
J'aimerais beaucoup vous envoyez les autres photos mais elles sont trop lourde pour le forum, avez vous une technique ou astuce pour les mettre sans les retoucher????
Heu... non justement je préférerais que tu les retouches. Je limite volontairement la taille des fichiers pour ne pas héberger des photos énormes. Pour mémoire, dans une fenêtre du forum ton image s'affiche à environ 900 pixels de large, pas plus. Donc sauf pour des cas particuliers ça ne sert à rien d'uploader une photo de 2500 x 1900 pixels.

Pour info le répertoire des photos hébergées du forum contient environ 9500 fichiers aujourd'hui, je te laisse calculer l'espace requis.

Avatar du membre
snsv6502
Messages : 77
Enregistré le : 12 oct. 2018 21:28
Localisation : Nantes

Re: Problème Apple II (e)

Message par snsv6502 » 16 juin 2019 09:45

Les différences entre le //e et le ][ europlus sont nombreuses et elles s'étendent aussi au clavier (pas la même disposition, absence des touches "pomme" etc...)

l'europlus :
Image

le //e
Image
call-151

Avatar du membre
Falkor
Messages : 863
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Problème Apple II (e)

Message par Falkor » 16 juin 2019 20:10

Merci pour les photos. Comme indiqué par Fabien, il n'est pas forcément pertinent d'uploader les photos en haute résolution. Utiliser une largeur d'image à peu près égale à la largeur du fil d'affichage est en général suffisant !

Toutes ces cartes sont très bien réalisées. As-tu pu tester la carte contrôleur graphique via la sortie composite ?

Répondre