Un Amiga 500 bien boosté

A partir de maintenant la course à l'armement est lancée.

Modérateurs : Papy.G, fneck, Carl

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Un Amiga 500 bien boosté

Message par Rodrik » 07 févr. 2020 20:01

Bonjour,

Vous avez peu-être vu un de mes Amiga 500 (j'en ai que 2 pas de panique) en confrontation avec un IBM 5150 sur la lecture de modules.
Cette fois c'est l'Amiga qui est à l'honneur.

Cette machine est boostée en mémoire à son maximum, mais là il est question de mettre plein de disques durs pour avoir facilement 3 workbenchs et préparer la suite.


Petite note: il n'est pas jaune comme la vignette le montre, il est en fait plutôt bien et le clavier un petit peu moins mais rien à voir avec mon second A500 qui est très jaune.

La carte dans la trapdoor est une carte actuelle disponible sur eBay. La Minimax qui faisait plus ou moins la même chose avec un peu moins de slow est en rade car le support Garry a été perdu par mes soins :cry:

La carte mère est une rev 6A que j'ai passée à 1Mo de Chip RAM il y a un bail.
Le HD8+, je l'ai depuis les années 90 et son 40Mo de base est rangé depuis longtemps (mais pas perdu lui). La carte PC286, je l'ai depuis 1 an mais on va l'utiliser prochainement :wink:

Bon visionnage et n'hésitez pas à commenter la vidéo.
Rodrik

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 08 févr. 2020 13:30

Bravo! Et dire qu'avec ma GVP530 je m'étais fait une tour externe qui contenait 4 ou 5 autres disks durs scsi + CDROM (chaine scsi quasi complète au final), pour un total cumulatif de même pas 4Go.. Il faut dire qu'à l'époque le prix des disques SCSI était loin d'être donné. Ca faisait un de ces boucans à comparer avec les solutions SD/CF actuelles.
Image

Tout pareil que toi je softkickais en 3.0 ou 1.3 (et même linux watchtower) suivant le disk-dur sur lequel je choisissais de booter dans l'early-startup. Par contre javais changé la ROM pour mettre une 2.04 physique car c'était l'os le mieux adapté pour A500 (rapide, "moderne", supporté par pleins d'applis, et pas trop gourmand en ram).
Image

Question typique de l'amigaiste qui voit un amiga upgradé: ca donne quel taux de transfert cet adaptateur SCSI? (utiliser l'outil sysinfo). J'ai souvenir que sur ma GVP530 on avait entre 800ko/sec et 1Mo/sec en taux de transfert (il y avaitr un 68030@40Mhz dans ma GVP).
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 08 févr. 2020 14:47

Alors le transfert, je l'ai mesuré à 1.3Mo/sec avec sysinfo.
C'est moins que le A1200 avec son 68030/50Mhz de l'époque sur CF qui lui fait le crois près de 2Mo/sec, mais bien suffisant je trouve pour un A500.

J'ai aussi eu par le passé des boîtiers externe SUN CD et HDD de récup sur le 500, mais je m'en suis séparé quelque temps après avoir acheté le 1200. Sur le 1200 j'ai une microbotics, j'aurais voulu une blizzard à l'époque avec son interface SCSI, mais je n'avais pas les moyens, d’où ma séparation des boîtiers SCSI SUN.

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 08 févr. 2020 17:20

1.3Mo/s c'est carrément énorme pour le 68000 de base. La GVP doit travailler en DMA directement dans sa mémoire interne sans utiliser le CPU. C'est super bien!
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 09 févr. 2020 10:06

J'ai re mesuré hier pour être sur, le commentaire que je t'ai mis sous la vidéo :
Le transfert avec cet adaptateur SCSI2SD est de 1220ko/sec. Valeur identique sur les 3 disques virtuels tous en PFS/3.
1140ko/sec sur une disquette ZIP 250Mo formatée en PFS/3 et 1360ko/sec sur une disquette ZIP 100Mo en Fat 95.
C'est pour moi très largement suffisant pour un Amiga avec un 68000. Cela fait quand même 1.5 disquette 3"5 par seconde :)
Il est bien ce contrôleur SCSI c'est clair. :D

Sinon pour l'écran, on en parle pas mais j'ai un 1085 et un 1803 mais c'est tellement mieux sur un PVM de 20" pour filmer et aussi pour jouer 8)

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 09 févr. 2020 18:12

Je continue avec mon Mega A500.

Cette fois je bataille un peu à faire le disque pour la partie PC (GVP PC286) et installe le DOS.
Et toute la puissance du A500 est démontré en utilisant l'Amiga et le 286 qui est dedans en même temps.

Filmer en contre jour, je ne ferais plus. Aussi puissant soit mon éclairage, il ne suffit pas.

J'attends avec impatience vos commentaires.
Rodrik

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 10 févr. 2020 13:31

Ben dis donc.. la mise en place d'un environnement PC fonctionnel semble être bien plus laborieuse que celui pour l'amiga :wink: Je dis ca, je ne dis rien... :roll:

L'affichage du GVP286 ne me semble pas être des plus rapides. J'ai comme l'impression que c'est le 68000 qui émule la carte graphique et dessine les caractères logiciellement dans un écran amiga standard. C'est une prouesse technologique, mais le pauvre 68000 se voit énormément ralenti quand il affiche du 640x200 (hires) en 16 couleurs car la puce d'affichage vole des canaux DMA au CPU pour pouvoir récupérer tous les bitplans à temps pour la mise en forme du signal video.
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 10 févr. 2020 18:26

Le problèmes du PC sur un A500, pour moi c'est le lecteur 720ko alors que sur PC on a des disquettes 1.44Mo ou des 5"1/4 en 360Ko. Il me faut toutes les copier, ziper le contenu, transférer l'archive avec le GVP286, puis pkunzip le tout. Et finalement découvrir que l'installeur du DOS 5.0 veut absolument que A: soit la source... donc expand les fichiers un à un :evil:

Et oui c'est vrai que l'affichage est plutôt lent, là peut-être que ton GVP avec 68030 ferait bien mieux, mais il sont dur à trouver, chère et pas ma priorité actuelle.
Difficile de voir la charge du 68000, tu as un outils à me conseiller pour voir ?

Avec cet affichage, faut que je test des jeux.

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 10 févr. 2020 20:57

Rodrik a écrit :
10 févr. 2020 18:26
Difficile de voir la charge du 68000, tu as un outils à me conseiller pour voir ?
Sur mon amiga 030 j'utilisais Executive qui en plus d’améliorer la fluidité de l'amiga en modifiant dynamiquement la priorité des taches fournissait aussi l'outil TOP comme sous linux. On le peut le voir sur ma photo au dessus. C'est la fenêtre avec le fond noir. On y lit que la commande "make" occupe 23% du CPU vient ensuite le volume "APPLI" (disk virtuel compressé avec xpk, bien obligé de compresser ADE ou EGS avec des disks SCSI aussi petits) puis le diskdur QDH0 (et oui le disk dur est une tache dans l'os) sur lequel je compile quake (fenêtre du bas.)

A propos de quake, sur cet amiga là il tourne à 1 image toutes les 3 secondes, et sur ma vampire actuelle, toujours sur a500, il fait du 30 images/secondes, ce qui me permet de dire que j'avais raison quand j'ai entamé le portage de quake sur amiga il y a 23ans en me disant qu'un jour les amigas seraient 100x plus rapides!!! (ceux qui sont patients finissent toujours par avoir raison de toute façon ;) )
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 11 févr. 2020 18:13

Ah oui executive, je l'ai eu des années sur mon 1200 en 68030, et oui il y avait un xload.
Mais je trouve ça un peu gros pour un 68000 et il faut être en 2.04 donc il faut que je change de roms.
Question con, j'ai jamais essayé, mais peut-on re-kick une rom 1.3 si on a une rom 2.04? J'ai toujours re-kick les versions d'après.

Ah quake :D bravo pour ce travail de titan. Pour moi la vampire si un jour j'ai un second 1200 je la mettrai, ou peut-être mon second A500.

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 11 févr. 2020 18:17

Oui avec ma rom2.04 dans mon A500 je pouvais SKick'er vers 1.3 aussi.
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 15 févr. 2020 14:57

J'ai commandé des ROM pour me faire un kickstart 2.05 et aussi la carte à monter pour stabiliser les ROM de 512ko et corriger le oops bug car la carte mère est une rev5. Mais comme les ROM viennent de Chine, je les aurai pas de sitôt.

En attendant, j'ai encore pousser plus loin avec l'Amiga 500 et sa GVP286 en installant Windows et WinWord :D


Bon visionnage et à vos commentaire + abonnement + pouce :mrgreen:

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 16 févr. 2020 02:43

Ahalala windows 3... toute une époque! Bravo pour la manip 8)

Perso, sans carte 286, mais avec un 68030@40mhz, sur ma GVP je faisais tourner shapeshifter, donc un macintosh pas trop pourri dans lequel j'avais accès à Word qui n'existait pas sur amiga autrement. Ca marchait pas mal vu que c'est même processeur. Seul l'affichage n'était pas tip-top car ca clignotait un max du 640x512 comme pour toi. Pour réduire le clignotement, je baissais la luminosité de l'écran. Ca faisait moins mal aux yeux. Puis plus tard j'ai fait une bidouille logicielle (>>ici<<) pour convertir l'écran monochrome entrelacé en hires gris 4 couls non entrelacé et c'était plus pratique.
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Rodrik
Messages : 93
Enregistré le : 25 oct. 2018 17:37
Localisation : Pays de Gex, Ain
Contact :

Re: Un Amiga 500 bien boosté

Message par Rodrik » 16 févr. 2020 12:29

Merci __sam__ pour ta petite bidouille.
Je l'ai essayée. J'ai du changer le nom de fenêtre car celle de la GPV286 est sans nom.
Cela fonctionne un petit peu, je veux dire pas là que cela créé bien un écran sans entrelacement en N&B mais cela me met la souris du workbench donc plus d'interaction possible avec le PC qui utilise sa propre souris en émulation. Et pas de clavier non plus.

__sam__
Messages : 5084
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Un Amiga 500 bien boosté

Message par __sam__ » 16 févr. 2020 14:10

Oui c'est une bidouille de quelques lignes. Il faudrait aller au delà pour faire un truc propre intégré à 100% qui ne vole pas la souris ou le clavier à l'application (quelqu'un a parlé de driver sur amiga-impact) mais ca n'a pas eu de suite.
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Répondre