Amiga 1200: probleme avec plus de 4mo de fast ram

A partir de maintenant la course à l'armement est lancée.

Modérateurs : Papy.G, fneck, Carl

Répondre
gotcha
Messages : 936
Enregistré le : 30 mars 2017 11:39
Localisation : Isère

Amiga 1200: probleme avec plus de 4mo de fast ram

Message par gotcha » 26 sept. 2020 13:55

Hello,

Sur mon A1200, J'ai en extension trapdoor une carte Amitek Hawk qui supporte 8Mo, mais avait juste jusqu'à présent une barrette de 4Mo.

Du coup, j'ai acheté des barrettes de 8Mo (double face FPM - non EDO - 60ns) et j'ai testé en configurant bien comme il faut les jumpers de la carte.

Le problème est qu'avec les 2 barrettes de 8mo que j'ai essayé, j'ai une erreur de test mémoire (Amiga Test Kit v1.12) sur les seconds 4mo de mémoire fast. J'ai systématiquement une erreur à partir de l'adresse 0x600000 (la fast ram est mappée sur la plage 0x200000-0x9FFFFF).

Du coup:
  • les 2 barrettes sont de la même marque, donc est-ce un problème d'incomparabilité (c'est une barrette ) ?
  • Ou y a t-il des choses à faire quand pn veut passer de 4mo à 8mo de fast ram ?
Modifié en dernier par gotcha le 26 sept. 2020 14:24, modifié 1 fois.
Amstrad CPC addict :mrgreen:

gotcha
Messages : 936
Enregistré le : 30 mars 2017 11:39
Localisation : Isère

Re: Amiga 1200: probleme avec plus de 4mo de fast ram

Message par gotcha » 26 sept. 2020 14:02

Hummmm, toujours avec Amiga Test Kit v1.12:
  • quand je fais un 'kickstart memory scan', il me détecte 8mo de fast ram
  • quand je fais un 'direct memory scan', il me détecte juste 4mo de fast ram
A mon avis, le problème vient de là ... mais pourquoi, c'est une autre question :?
Amstrad CPC addict :mrgreen:

gotcha
Messages : 936
Enregistré le : 30 mars 2017 11:39
Localisation : Isère

Re: Amiga 1200: probleme avec plus de 4mo de fast ram

Message par gotcha » 26 sept. 2020 18:37

Bon, apparemment, c'est un problème de la carte d'extension RAM. Ça semble être un problème reçurent avec certaines version:
http://eab.abime.net/showthread.php?t=64122
Amstrad CPC addict :mrgreen:

hlide
Messages : 1803
Enregistré le : 29 nov. 2017 10:23

Re: Amiga 1200: probleme avec plus de 4mo de fast ram

Message par hlide » 26 sept. 2020 22:18

Je suppose que tu n'as pas de PCMCIA de branché ou quelque chose de ce genre car ça te limite à 4 Mo.

Code : Tout sélectionner

200000-5FFFFF	4MB	Zorro-II space	Fast RAM
600000-9FFFFF	4MB	Zorro-II space	PCMCIA memory card / Fast RAM
Modifié en dernier par hlide le 27 sept. 2020 17:43, modifié 1 fois.

gotcha
Messages : 936
Enregistré le : 30 mars 2017 11:39
Localisation : Isère

Re: Amiga 1200: probleme avec plus de 4mo de fast ram

Message par gotcha » 26 sept. 2020 22:34

Non, pas encore d'extension PCMCIA.

A priori c'est la carte d'extension fast ram qui est buggée. Sur cette carte, il y a une sorte d'array programmable (un PEEL 18CV8) qui pourrait être le fautif.
Je vais donc me contenter de 4Mo de fast ram. De toute manière, comme tu l'as dit, si je veux ajouter une extension PCMCIA, je serai de toute manière limité à 4Mo de fast ram. J'ai juste acheté des SIMM de 8Mo pour rien :?

Il faudra aussi que j'ouvre un peu plus l'A1200 pour vérifier qu'il n'y a pas de bidouille sur la carte mère.
Amstrad CPC addict :mrgreen:

Répondre