AMIGA 500 rev6.A, upgrade kick start

A partir de maintenant la course à l'armement est lancée.

Modérateurs : Carl, Papy.G, fneck

Répondre
Avatar du membre
fabrice_035
Messages : 519
Enregistré le : 20 sept. 2011 20:24
Localisation : RENNES

AMIGA 500 rev6.A, upgrade kick start

Message par fabrice_035 » 11 sept. 2014 20:43

Bonjour,

Est-il possible de passer du kickstart d'origine d'un Amiga 500 au kickstart 3.1, sur le site ici http://amigakit.leamancomputing.com/cat ... cts_id=157 il est possible d'acheter une nouvelle rom, je suppose que cela doit se faire facilement mais autant demander avant de faire une connerie.

Merci

Avatar du membre
mandrake
Messages : 1167
Enregistré le : 13 avr. 2007 09:53

Re: AMIGA 500 rev6.A, upgrade kick start

Message par mandrake » 12 sept. 2014 22:31

c'est la première fois que je vois une rom 3.1 pour un Amiga 500 :roll:
Et pour quoi faire ? pas de disk dur IDE ni de puce AGA ni de port PCMCIA sur un A500 à mon avis aucun intérêt autant prendre directement un A1200 ou la rom 3.1 te servira à quelque chose :idea:
Un A500 est au top avec une rom 1.3 pas besoin de changer :wink:
Rien n'est jamais perdu, tant qu'il reste quelque chose à trouver. (pierre DAC)
Ressources pour TI-99/4A et 4 tout court

__sam__
Messages : 4074
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: AMIGA 500 rev6.A, upgrade kick start

Message par __sam__ » 12 sept. 2014 23:00

Moi je kickrom mon amiga 500, de la rom 2.1 (changée par rapport à l'origine) vers la rom 3.1. J'ai développé des années dans cette config avec mon extension GVP530 (68030 + 8Mo) et ses 5 diskdurs (SCSI 50broches). J'adore cette config au point que j'en délaisse mon A1200 "brut" de fonderie. Cette config m'a empêché de basculer sur PC pendant de longues années et juqu'en 2007 c'était d'ailleurs mon seul ordi permanent à l'appart.
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
fabrice_035
Messages : 519
Enregistré le : 20 sept. 2011 20:24
Localisation : RENNES

Re: AMIGA 500 rev6.A, upgrade kick start

Message par fabrice_035 » 13 sept. 2014 19:48

Sam, j'imagine que tu n'avais pas internet sur ton Amiga 500 gonflé à bloc ?

__sam__
Messages : 4074
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: AMIGA 500 rev6.A, upgrade kick start

Message par __sam__ » 13 sept. 2014 20:34

Sisi j'avais un modem usr-robotics 56K. Pile TCP/IP: Miami. Je faisais de l'AmIRC, du ftp, de la lecture de mail, du usenet etc. Pour le web, les browsers amiga étaient déjà à la ramasse à l'époque, je n'ai jamais été convaincu par eux.

Tout ca pendant que je développais UAE pour amiga... sur amiga :lol: ADE, GCC, EGCS n'avaient aucun secret pour moi. Le l'utilisais pour porter/adapter une version pirate de Quake récupérée via un pote sur IRC... un vrai Hacker ^^, je peux le dire il y a prescription.

Bon je dois avouer que les 8Mo de ram étaient limite, mais grace à VMM j'en avais beaucoup plus. L'amiga était une machine géniale qui forçait à être malin.

Mais avant ca je récupérais déjà pas mal de soft sur D7 (fred fish, bab micro-center sont des noms qui me reviennent à l'esprit), et plus tard à la fac je profitais des stations sun avec lecteur de D7 connectées au tout nouveau reseau reliant les centres de recherche entre eux pour récupérer (et publier) des trucs et bidules sur aminet (ahh funet.fi). Je te raconte pas le b*rdel pour installer ma 1ere version de ADE (i.e. gcc) sur amiga. J'étais horrifié par la taille de ce compilo moi qui avais l'habitude des petits trucs DICE, SAS/C ou SAXON-C, mais j'y suis passé car il permettait de développer des trucs sur amiga qui seraient plus tard utilisé dans mon travail de thèse sur des gros serveurs de calculs.

Parfois aussi je bootais aussi sur la distrib linux Watch-tower pour lancer Lyx ou faire du LaTeX à la maison.

Bref l'amiga était une vraie machine quoi. C'est seulement depuis que j'ai déménagé sur Brest il y a 7 ans que je l'ai remisé et ne l'utilise plus. Il faut dire qu'il est devenu capricieux et bien moins fiable qu'avant. Des gurus non documentés surgissent au hasard. Je crois que l'une des deux alim (A500 ou GVP) est en fin de vie, à moins que ce ne soit des faux-contacts dans la RAM-GVP, ou les deux :mrgreen: .
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
fabrice_035
Messages : 519
Enregistré le : 20 sept. 2011 20:24
Localisation : RENNES

Re: AMIGA 500 rev6.A, upgrade kick start

Message par fabrice_035 » 14 sept. 2014 14:44

Whaou, belle aventure avec cet Amiga, respect.

J'en profite pour te demander si tu penses qu'il est possible de faire un sélecteur de boot entre un Gotek (émulateur disquette vers USB) et le lecteur d'origine de l'Amiga de façon relativement simple pour pouvoir mettre les deux en DF0.

Je pensais pouvoir le faire avec de simples switch (sur les alimentations des disques) mais ça bug de trop, beaucoup de read error. La nappe que j'utilise a trois connecteurs (câble croisé), si le Gotek est en DF0 et le drive interne en DF1 (ou le contraire) ça boot mais il y a aussi régulièrement des read error et le lecteur de disquette interne n'est pas détecté.

Ceci dit en insistant, par exemple avec XCopy, j'ai pu copier un disque du Gotek (DF1) vers le lecteur interne (DF0) mais en utilisant la RAM pour le transfert. Si je démarre sur le Workbench, il voit bien le Gotek en DF1 mais je reste avec ces 'read error' régulièrement. En plus, l’éjection d'une disquette en DF0 n'est plus détectée.

J'ai déjà intégré le hard:

Image

Image

A+

__sam__
Messages : 4074
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: AMIGA 500 rev6.A, upgrade kick start

Message par __sam__ » 14 sept. 2014 15:05

Les read-errors sont problématiques.

Est-ce que si tu mets le gotek en DF0 seul (i.e. tu n'alimentes pas le drive mécanique) elle disparaissent ? Si c'est le cas c'est peut-être un pb de tension. Il faudrait essayer aussi de voir en activant les deux, mais en laissant une D7 dans le floppy mécanique. Mon hypothèse "comme ca" est que la detection de D7 faisant bouger régulièrement la tete de lecture pourrait influer sur les tensions.

Mais ca n'est qu'une hypothèse sans garantie...
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

Avatar du membre
fabrice_035
Messages : 519
Enregistré le : 20 sept. 2011 20:24
Localisation : RENNES

Re: AMIGA 500 rev6.A, upgrade kick start

Message par fabrice_035 » 14 sept. 2014 18:12

Dernières investigations, après correction de mes erreurs quant au sens de la nappe :evil: ... ce qu'il est possible de faire est:

-Drive Amiga DF0 / Gotek DF1 = Boot OK, exemple le Workbench voit bien le Gotek.

-Gotek DF0 / Drive Amiga DF1 = Book OK mais le drive amiga n'est jamais reconnu, quelque soit la position du switch au cul du lecteur, impossible de le monter, si quelqu'un a une idée ?

-Gotek DF0 / Drive Amiga DF0 = OK *uniquement* en alimentant l'un ou l'autre avec le +5v, sinon si les deux sont alimentés aucun boot.

Donc, je pense que je vais monter le Gotek en DF0 et le drive Amiga aussi en DF0 et installer un sélecteur pour l'alimentation sur le coté.

En fait l'alimentation est assez puissante, c'était bien d'y avoir pensé mais je pense que c'est moi qui ai merdé sur l'installation car cette fois je n'ai plus ce problème d'erreurs de lectures (donc le positionnement de la nappe était en cause)

A+

Répondre