Amiga 500 : écran rouge avec Prince of Persia

A partir de maintenant la course à l'armement est lancée.

Modérateurs : Carl, Papy.G, fneck

Répondre
gotcha
Messages : 368
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Amiga 500 : écran rouge avec Prince of Persia

Message par gotcha » 08 avr. 2019 13:31

Hello,

J'ai testé avec succès plusieurs jeux sur mon Amiga 500. Par contre, avec Prince of Persia, ça bloque sur un écran rouge au chargement.
J'ai testé plusieurs disquettes, plusieurs ADF (de plusieurs sources), et plusieurs méthodes de copie (X-Copy à partir d'un gotek et Kryoflux sur un PC) et j'ai le même résultat :evil: .

Des avis sur le problème ?
- Non compatibilité entre Prince of Persia et l'A500 ?
- Problème avec les ADF ?
- Symptôme d'un problème hardware sur mon Amiga (lecteur de disquette, carte mère, memoire etc..) ?
- Il faut 1Mo de mémoire pour le faire tourner ?

Est-ce que quelqu'un a ADF Prince of Persia qui tourne sur son A500 ?
Amstrad CPC addict :mrgreen:

__sam__
Messages : 4552
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par __sam__ » 08 avr. 2019 13:54

C'est pas le dispositif anti-copy cet écran-rouge ?

Bah sinon le mieux que tu puisse faire c'est tester tes ADF sur winuae avant de les matérialiser sur un support physique. Tu va gagner beaucoup de temps à avoir un WinUAE à coté pour faire des tests.

sam.
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

gotcha
Messages : 368
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par gotcha » 08 avr. 2019 14:47

Bon, l'ADF passe sur WinUAE. Donc il y a un autre problème.

Edit: bon j'ai parlé trop vite. Il marche avec une ROM Kickstart1.3 non standard. Mais quand j'essaie avec ce que je pense être la ROM standard (Kickstart-v1.3-rev34.5-1987), j'ai un bel écran rouge sur WinUAE comme sur l'ordinateur physique. Il me semble donc qu'il y a un problème de compatibilité entre le jeu (craqué me semble-t-il) et la ROM standard du A500.
Modifié en dernier par gotcha le 10 avr. 2019 10:45, modifié 1 fois.
Amstrad CPC addict :mrgreen:

__sam__
Messages : 4552
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par __sam__ » 08 avr. 2019 18:36

C'est quoi ta rom 1.3 non standard ?

A mon avis le cracker saute à des adresses en ROM inexistantes sous KS 1.3. Il lui faut probablement le 2.0+ (A500+, A600) voire le 3.0 (A1200).
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

gotcha
Messages : 368
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par gotcha » 08 avr. 2019 22:13

__sam__ a écrit :
08 avr. 2019 18:36
C'est quoi ta rom 1.3 non standard ?
Elle est donnée comme étant un kickstart 1.3, mais au boot, il a un fond noir avec des yeux. Je ne sais plus où je l'ai trouvé. Le kickstart officiel a un fond blanc et montre une disquette.
Modifié en dernier par gotcha le 08 avr. 2019 22:22, modifié 1 fois.
Amstrad CPC addict :mrgreen:

gotcha
Messages : 368
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par gotcha » 08 avr. 2019 22:17

__sam__ a écrit :
08 avr. 2019 18:36
A mon avis le cracker saute à des adresses en ROM inexistantes sous KS 1.3. Il lui faut probablement le 2.0+ (A500+, A600) voire le 3.0 (A1200).
C'est tout à fait possible que le crack soit à l'origine de mon problème étant donné que j'ai un amiga avec un kickstart assez ancien. J'ai aussi un problème avec R-Type qui bloque au démarrage. En fait, l'avantage de la Kryoflux est qu'on n'a plus besoin d'un crack car on peut recréer des disquettes avec les protections d'origine pour peu qu'on ait l'image IPF (et non l'ADF). Pour R-Type, je viens de copier la version originale sous forme d'IPF sur une disquette, et là, j'arrive à le faire booter sur mon A500 ! Il faut que je regarde si j'ai aussi Prince of Persia en IPF.
Amstrad CPC addict :mrgreen:

Avatar du membre
fneck
Site Admin
Messages : 12654
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par fneck » 09 avr. 2019 09:18

gotcha a écrit :
08 avr. 2019 22:17
(...) pour peu qu'on ait l'image IPF (et non l'ADF).
Je n'ai jamais compris comment on pouvait obtenir des images IPF, il faut faire partie du club "Kryoflux" ?

gotcha
Messages : 368
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Amiga 500 : écran rouge avec Prince of Persia

Message par gotcha » 09 avr. 2019 09:30

fneck a écrit :
09 avr. 2019 09:18
Je n'ai jamais compris comment on pouvait obtenir des images IPF, il faut faire partie du club "Kryoflux" ?
En fait, la SPS les garde jalousement :) Pour Amstrad, j'en ai aucun et il faut contacter la SPS avec j'imagine une preuve qu'on a bien l'original pour avoir accès à l'IPF. Concernant l'Amiga, en recherchant un set d'ADF, je suis tombé par hasard sur un set d'IPF, qui ont l'air de marcher:
https://ia800201.us.archive.org/7/items ... 0Amiga.zip
Amstrad CPC addict :mrgreen:

Répondre