[Thomson] Contrôleur CS91-280 pour carte SD

Cette catégorie traite de développements récents pour nos vieilles machines, applications, jeux ou démos... Amis programmeurs, c'est ici que vous pourrez enfin devenir célèbres!

Modérateurs : Papy.G, fneck, Carl

Daniel
Messages : 12869
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] Contrôleur CS91-280 pour carte SD

Message par Daniel » 28 déc. 2014 10:23

La mise au point du soft est difficile, les problèmes "hard" viennent s'y ajouter, ça ne facilite pas la tâche. Le bon fonctionnement du système est influencé par le sens de la prise, l'endroit où je pose le doigt, le type de carte SD, le contrôleur (avec différentes EPROM ou EEPROM j'ai la panne ou pas). Dans certains cas le MO6 reste figé au démarrage (bandes verticales alternées), mais l'appui sur le bouton Reset permet de le redémarrer. Pour éviter les parasites générés par le téléviseur, j'ai aussi essayé de démarrer en aveugle, prise péritel débranchée. Le comportement est identique, donc le téléviseur n'est pas en cause. Relier la masse du MO6 à la terre ne change rien.

Certains comportements sont aléatoires, d'autres sont reproductibles : par exemple, dans les mêmes conditions (même interface, même carte SD, même contrôleur CS91-280), une EPROM 27C64 fonctionne et une EEPROM 28C64 avec le même contenu ne fonctionne pas. Autre exemple, avec les mêmes conditions, le système ne démarre pas avec une carte micro SD et démarre avec une autre. Toutes les EPROMS et toutes les cartes SD utilisées pour les tests fonctionnent parfaitement avec un TO8.

Contrôle de l'alimentation : tout est bon, tension de 5,03V, pas d'ondulations résiduelles. Sur le condensateur de filtrage principal il y a des dents de scies bien propres, dont l'amplitude ne dépasse pas 400 mV. Après les régulateurs je ne détecte pas d'ondulation avec un calibre de 50mV/cm.

Il reste les condensateurs chimiques de la carte mère, les parasites, les mauvais contacts, les circuits logiques... Pas facile :|

[Edit]
Essai avec un autre MO6 : même comportement erratique.
Je suis maintenant sur une autre piste, après avoir constaté qu'en démarrant l'ordinateur sans initialiser la carte (carte enlevée), si on lance ensuite l'initialisation elle marche à tous les coups. Le problème se produit donc uniquement lors d'une initialisation à la mise sous tension. Une hypothèse serait que l'initialisation soit lancée trop tôt, alors que la tension d'alimentation n'est pas encore bien stabilisée. Je vais ajouter une temporisation pour vérifier cette hypothèse.

[Edit 2]
Après divers tests et essais, j'ai trouvé un contournement. Le MO6 appelle deux fois la routine d'initialisation du contrôleur :
- La première fois, à la mise sous tension. Celle-là pose problème, et provoque le blocage au lancement du Basic. Je n'en connais pas la cause (hard ou soft). Ca restera probablement encore longtemps un mystère.
- La deuxième pendant l'initialisation du Basic. Celle-là fonctionne toujours, à condition évidemment de ne pas avoir été bloqué avant.

J'ai modifié le programme de l'EPROM pour ne pas faire la première initialisation dans le cas du MO6, et maintenant tout fonctionne parfaitement bien. La nouvelle version 2014.12.28 est disponible à la page officielle : http://dcmoto.free.fr/bricolage/cs91-280
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Thomson] Contrôleur CS91-280 pour carte SD

Message par 6502man » 10 mars 2015 20:34

Aujourd'hui j'ai essayé de graver la nouvelle version de l'eprom, mais échec total :(

Programmateur TOP8xx connecté en USB (fonctionne très bien pour graver les eproms de la TRIPLEX).

1) avec une EEPROM AT28C64B, lecture et effacement okay, mais erreur au début de l'écriture bizarrement si j’essaie d'écrire que des $FF ou $00 ca fonctionne :roll: :twisted:
2) avec une EPROM 27xxx ecriture okay vérif okay mais une fois installé dans l'extension le TO8D fige après les 2 instructions POKE &He7e7,&Hd4 et EXEC &He025 :?
3) j'ai remis l'ancienne EPROM et ca fonctionne mais sans les nouveautés :(

En ce moment c'est difficile tous ce que j'essaie ne fonctionne pas :twisted:
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Daniel
Messages : 12869
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] Contrôleur CS91-280 pour carte SD

Message par Daniel » 10 mars 2015 21:28

- Utilises-tu la bonne version de l'EPROM : 2014.12.28 ?
- As-tu créé un fichier de 8K en mettant deux fois les 4K pour remplir complètement l'EEPROM 28C64 ?
- As-tu positionné l'interrupteur 7 du boîtier nanoréseau en fonction de l'interface utilisée (SDMO ou SDMOTO) ?
- As-tu bien préparé la carte SD avec le fichier boot.sd ?

Sinon, pour les erreurs d'écriture avec le programmateur TOP, il faut changer le paramètre Delay. La valeur par défaut n'est pas bonne pour toutes les EPROMs. En général, avec les 27Cxx, j'obtiens de bons résultats avec 1µs.
Modifié en dernier par Daniel le 10 mars 2015 21:31, modifié 2 fois.
Daniel
L'obstacle augmente mon ardeur.

__sam__
Messages : 5339
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: [Thomson] Contrôleur CS91-280 pour carte SD

Message par __sam__ » 10 mars 2015 21:29

6502man a écrit : 2) avec une EPROM 27xxx ecriture okay vérif okay mais une fois installé dans l'extension le TO8D fige après les 2 instructions POKE &He7e7,&Hd4 et EXEC &He025 :?
Ca ne serait pas un problème de switch comme chez moi ? Peux tu dumper le contenu mémoire à partir de $E000 ?
Samuel.
A500 Vampire V2+ ^8^, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.

Avatar du membre
6502man
Messages : 10098
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: [Thomson] Contrôleur CS91-280 pour carte SD

Message par 6502man » 10 mars 2015 22:18

Daniel:
- Oui j'ai bien copié 2 fois pour obtenir 8K !
- L’interrupteur du boitier nano je l'ai laissé comme il était auparavant puisque ca fonctionne avec la version plus ancienne de l'EPROM !!
- j'ai placé boot.sd sur la carte SD en premier après un formatage complet !!!

Sam: je ne sait pas mais ca fonctionne avec la même config et la version précédente de l'EPROM !!!
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Répondre