Mégarom T.2

Cette catégorie traite de développements récents pour nos vieilles machines, applications, jeux ou démos... Amis programmeurs, c'est ici que vous pourrez enfin devenir célèbres!

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
Kermitoo
Messages : 190
Enregistré le : 10 juil. 2013 19:21

Re: Mégarom T.2

Message par Kermitoo » 14 nov. 2018 22:39

Dites moi, à l'évidence, on perd un peu de vue le sujet principal: c'est la MEGAROM T2

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 14 nov. 2018 22:41

Bigre ! Il a raison ! :D

__sam__
Messages : 4218
Enregistré le : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: Mégarom T.2

Message par __sam__ » 14 nov. 2018 22:42

C'est pas ca justement être multitâches ? :lol:
Samuel.
A500 Vampire V2+, A1200(030@50mhz/fpu/64mb/cf 8go),
GVP530 (MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8. New Teo 1.8.4 8)

jasz
Messages : 516
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: Mégarom T.2

Message par jasz » 15 nov. 2018 09:06

:lol:

Mais désolé! Je plaide coupable :oops:

Pour revenir au sujet, c'est tout de même dingue de faire ce que l'on fait aujourd'hui, près de 40 ans après. C'est vrai, il y a l'avancé technologique qui facilite la tâche. En tout cas c'est une belle réalisation.

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 15 nov. 2018 10:19

Ce qui est épatant, ce sont les moyens à disposition du non-industriel. Il y a encore 15 ans, je gravais mes circuits moi-même, c'était une galère sans nom : alignement des couches, pas de trou métallisé, pas de vernis, précision aléatoire … Aujourd'hui, je fais du 6 couches qualité industrielle précision à 10 microns pour pas un rond. Une autre petite révolution, mais qui ne date pas d'hier celle-là, ce sont les logiques programmables et surtout les logiciels de simulation qui permettent de corriger les problèmes électriques ou de timing avant même d'avoir le circuit physiquement.

Avatar du membre
Kermitoo
Messages : 190
Enregistré le : 10 juil. 2013 19:21

Re: Mégarom T.2

Message par Kermitoo » 15 nov. 2018 18:09

Vivement que je teste un prototype de ce genre... (même en SLS, ça ira très bien !).

to-mini.jpg
to-mini.jpg (52.24 Kio) Vu 182 fois

Avatar du membre
Kermitoo
Messages : 190
Enregistré le : 10 juil. 2013 19:21

Re: Mégarom T.2

Message par Kermitoo » 16 nov. 2018 16:45

J'ai pu passer quelques heures sur mon problème de Basic128 sur la MEGAROM T2...
Difficile d'accéder directement au prompt du Basic128: le choix "7" freeze 1 coup sur 3.

Pour utiliser le basic128 avec le SDMOTO connecté, je choisis "2" (prog enregistré).
Le menu SDmoto s'affiche normalement ainsi que les disquettes.
Je peux surligner mon choix en me déplaçant avec les flêches mais dès lors que je valide, ça fige avec un contour d'écran qui devient soit bleu, soit jaune.

Bien entendu, le format des disques et les disquettes (.SD) fonctionnent TOUS sur DCmoto (configuré en mode SDmoto).
Alors, peut-être y a t'il une particularité que j'ignore concernant les .fd et leurs formats, pour le Basic128.

Par contre, sans contrôleur nanoréseau... Plus aucun problème, plus de freeze au choix "7" de la MEGAROM (Basic128).
Le Basic128 affiche désormais 45695 bytes

Alors, y'aurait'il un probleme de compatibilité entre la MEGAROM T.2, TO7/70 et le Boitier Nanoreseau?

Daniel
Messages : 10904
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mégarom T.2

Message par Daniel » 16 nov. 2018 17:25

Il faudrait étudier le soft de la Megarom. Si la Megarom et le contrôleur CS91-280 utilisent les mêmes zones en RAM ça peut expliquer le problème.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Kermitoo
Messages : 190
Enregistré le : 10 juil. 2013 19:21

Re: Mégarom T.2

Message par Kermitoo » 16 nov. 2018 18:49

Merci Daniel.

Je confirme donc un "conflit" avec le boitier nanoreseau (modifié pour les besoins du SDMOTO) et le Basic 128 de la Mégarom T2 du TO7/70.

Sur TO7/70, toujours, le SDMOTO fonctionne très bien avec le Basic 1.0 et la MEGAROM T2

Et sur le simple TO7 (T9000), aucun probleme constaté avec le SDMOTO et la MEGAROM T2 (Basic1.0)

C'est aussi ça, les prototypes...

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 16 nov. 2018 23:36

Non.

Que ce soit le BASIC 128 ou le BASIC 1.0, le soft de la Mégarom est le même et ne fait pas de distinction entre les MEMO7 qu'il lance. Corollaire, le soft de la Mégarom utilise les mêmes zones de RAM dans les deux cas.

Par contre, si la ROM SDDrive bidouille les registres disquette du moniteur de manière non standard, il est possible que la Mégarom pose problème. A noter que la Mégarom a été testée avec les lecteurs 3"1/2 et 5"1/4 sur TO7-70 et ne pose aucun problème dans ces cas-là. Mais si c'est ça le problème, je ne comprends pas pourquoi ca marche avec le basic 1.0 mais pas avec le basic 128.

Daniel, peut-on consulter le source de la rom quelque part ?

Daniel
Messages : 10904
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mégarom T.2

Message par Daniel » 17 nov. 2018 09:29

J'allais justement poser la même question pour le soft de la Megarom. Peut-on le consulter quelque part ?

Pour le contrôleur CS91-280 les sources ont été publiées, mais il y a eu plusieurs versions. Je vais rechercher dans mes archives celle utilisée par Kermitoo et je la posterai ici. De mémoire les zones utilisées par sa version du contrôleur sont dans la partie basse de la pile système. A partir de la version 2018.07.02 les six octets définissant le fichier .sd chargé ont été déplacés dans la zone de stockage de la position des têtes en $6051-$6057.

Une autre piste : le programme SDMOTO.SEL permettant de sélectionner le fichier .sd est chargé en RAM et utilise la zone $9000-$DFFF. Si le soft de la Megarom utilise la même zone c'est une cause possible du problème.

A noter aussi :
Avec le contrôleur SDDRIVE (différent mais néanmoins assez voisin de CS91-280) j'ai constaté un bug avec le BASIC 128 sur TO7/70 :
A noter un petit bug pas bien gênant : au premier lancement du BASIC 128 un écran SDDRIVE incorrect s'affiche. Il suffit d'appuyer sur le bouton d'initialisation et au second lancement tout fonctionne normalement. Avec l'émulateur dcmoto le bug ne se produit pas, et sur la vraie machine il n'est pas facile de déterminer la cause de l'anomalie. Donc pour l'instant il n'y a pas de correction prévue.
Il est donc possible que le problème soit lié au BASIC 128 et pas à la Mégarom. Il faudrait essayer le contrôleur CS91-280 de Kermitoo avec une vraie cartouche BASIC 128.
Daniel
L'obstacle augmente mon ardeur.

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 17 nov. 2018 10:05

Non, le code source de la Mégarom n'est pas disponible. A cela une raison très simple, il "n'existe pas" :o. Non, en fait, il y a un bout de code, mais ce dernier est hautement macro-isé et composé à l'assemblage avec d'autres includes et ressources (comme les graphismes du titre et la liste des ROM). Ce n'est pas très utile ni lisible pour quelqu'un qui n'a pas eu le nez dedans comme nous.

Mais je suis prêt à investiguer le problème et à en poster le détail ici si je trouve la solution.

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 17 nov. 2018 11:38

Si le soft de la Megarom utilise la même zone c'est une cause possible du problème.
Ce n'est pas le cas, pour autant que je sache. De manière générale, la Mégarom a été conçue pour être la plus transparente possible, elle rétablit les registres du moniteurs à leur valeur avant l'exécution et tout est exécuté depuis la ROM, sauf un tout petit bout de code pour la commutation de page et le saut au point d'entrée à froid de la MEMO7 fille.

Si tu me retrouves le source de la bonne version de ta ROM chez Kermitoo, je prends le temps nécessaire pour pister le problème.

Daniel
Messages : 10904
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mégarom T.2

Message par Daniel » 17 nov. 2018 11:40

Kermitoo a une version assez ancienne de l'EPROM du contrôleur CS91-280 : 20160902
Depuis cette date il y a eu beaucoup de mises à jour, et aujourd'hui les zones de travail en RAM ne sont plus les mêmes.
Voici le programme assembleur :
cs91280_20160902_kermitoo.zip
(13.08 Kio) Téléchargé 8 fois
Et le contenu binaire de l'EPROM :
cs91280_20160902_bin_kermitoo.zip
(1.73 Kio) Téléchargé 7 fois
Daniel
L'obstacle augmente mon ardeur.

Fool-DupleX
Messages : 1035
Enregistré le : 06 avr. 2009 12:07

Re: Mégarom T.2

Message par Fool-DupleX » 17 nov. 2018 12:39

Ce qui signifie que le bug a peut-être disparu depuis. Je vais quand même jeter un œil. Comment faire pour mettre à jour le hardware, tu envoies une nouvelle ROM par la poste ?

Répondre