Mon 1er ordi et ma collec... [Silou78]

Cette rubrique permet à celui qui le souhaite, de présenter sa collection au monde entier, voire plus.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 27 mars 2017 23:16

Ca c'est bien vrai. Je m'étais pas mal amusé avec mon TO8 (mais je débutais), et puis surtout avec mon premier PC (486DX33) en assembleur x86 (qq petites démos essayant de singer les grandes démos, scrolling en mode 0x13, routines de texturing, rendu 3d de surfaces concaves, ...). Amusement que je ne retrouve plus vraiment avec les PC modernes (trop puissants les CPU, plus beaucoup de challenge, ou alors il faudrait faire des projets de fou). J'ai un collègue qui s'amuse comme un fou en programmant pour son smartphone (il y a effectivement plus de challenge actuellement sur un smartphone que sur un PC).
Du coup je pense qu'en me remettant au TO8 (et avec un peu plus de background en informatique ça ne devrait rien gâcher), je devrais retrouver l'amusement d'antan. :D
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Tof
Messages : 12
Enregistré le : 17 avr. 2017 15:00

Re: Mon ordi [Silou78]

Message par Tof » 17 avr. 2017 22:05

Ben moi qu'est ce que j'aimerais en posséder un de TO8 (Celui là et pas un autre !).
Je suis militaire. Personne n'est parfait !

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 17 avr. 2017 23:43

Il y en a parfois à vendre sur lbc ou la bay :wink:

Un petit point d'avancement de mes bidouilles en cours et à venir : :mrgreen:

1) Extension 256K (schéma de Daniel) terminée :
ExtensionRAM256K-Forum2.jpg
ExtensionRAM256K-Forum2.jpg (75.16 Kio) Vu 833 fois
ExtensionRAM256K-Forum3.jpg
ExtensionRAM256K-Forum3.jpg (73.3 Kio) Vu 833 fois
2) Adaptateur souris PS/2-DB9 en cours (schéma et prog arduino de Phil) : électronique terminée, mise en boîte de luxe en cours (reste étiquette à imprimer et coller), en attente réception souris PS/2 pour tester (j'ai une souris USB avec adaptateur PS/2 mais qui fait partie de celles qui ne fonctionnent pas avec l'adaptateur sauf si mon câblage a un souci...)

3) Adaptateur DB9 manette Megadrive à venir (schéma que m'a fourni Gleike ci-dessus)

3) Floppy TEAC FD235HG externe à venir (montage dans boitier externe HDD + prise DIN14) + inverseur/désactivateur FDD

4) Projet BlueSD à venir (composants provisionnés, montage à faire et surtout toute la partie programmation)

5) Projet EmuTOstick à venir (schéma connectique en cours, 2 versions : une sur port parallèle, l'autre réutilisant l'adaptateur BlueSD, composants provisionnés, montage et programmation à faire)

6) Programmation ASM 6809 (démos ?)

Et en parallèle :
En cours :
- scan du guide utilisateur TO8D (version HQ)
Reste à faire :
- finir de sauvegarder mes disquettes physiques en .fd/.sd,
- scanner la doc assembleur et cours basic techos,
- remise en service de l'imprimante à aiguilles,
- etc... :wink:
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 01 mai 2017 16:28

Je viens de terminer la réalisation d'une 2ème interface SD-MOTO version Deluxe (2 Leds) :
SD-MOTO-2.jpg
SD-MOTO-2.jpg (33.76 Kio) Vu 802 fois
Pour celle-ci j'ai adopté le format SD et non-pas le micro-SD. Cela évite le risque de perdre la carte mémoire minuscule. Et le boitier est juste 1cm plus long. Pour comparer voici la version micro-SD :
SD-MOTO-1.jpg
SD-MOTO-1.jpg (29.86 Kio) Vu 802 fois
Et j'ai également terminé la réalisation de l'adaptateur souris PS/2-DB9 :
NM 90-122.jpg
NM 90-122.jpg (39.02 Kio) Vu 802 fois
Cela fonctionne impeccablement avec une souris PS/2 Microsoft (à boule), de consommation = 15mA.
En essayant d'autres souris PS/2, je m'aperçois que celles (optiques) demandant 100mA et + ne fonctionnent pas.
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Daniel
Messages : 10211
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mon ordi [Silou78]

Message par Daniel » 01 mai 2017 17:12

C'est bien d'avoir adopté le même style pour tous les périphériques, ça donne l'impression d'une gamme complète, qui pourra encore s'enrichir en fonction des nouvelles idées. S'il y avait un marché pour ces petits gadgets, tu pourrais, à partir de ces prototypes, commercialiser des modules de qualité professionnelle... Malheureusement ça n'intéresse que nous :wink:

Sur l'étiquette de l'adaptateur souris, il faut ajouter MO5NR et MO6. La souris doit aussi fonctionner aussi avec le MO5N, mais je crois qu'il n'a jamais été commercialisé et peu de thomsonistes le connaissent. Ca me fait penser qu'il faudrait écrire un driver de souris pour MO5 et TO7/70. J'ai déjà jeté un coup d’œil à celui du MO6, c'est compliqué mais probablement pas infaisable.

Bravo pour toutes ces réalisations !
Daniel
L'obstacle augmente mon ardeur.

Fool-DupleX
Messages : 985
Enregistré le : 06 avr. 2009 12:07

Re: Mon ordi [Silou78]

Message par Fool-DupleX » 01 mai 2017 18:33

Très jolies réalisations.

La souris fonctionne en effet sur MO5 et TO7/70 (moyennant driver), mais elle fait du bruit ... On ne peut pas muter le DAC sur l'extension musique et jeux.

Tiens ça me fait penser qu'on n'a toujours pas la doc cofadel du MO5E.

Daniel
Messages : 10211
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mon ordi [Silou78]

Message par Daniel » 01 mai 2017 18:36

Le driver de souris pour MO5 est-il disponible quelque part ? C'est juste pour m'éviter de passer des heures à le réécrire...
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 11952
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Mon ordi [Silou78]

Message par fneck » 01 mai 2017 19:06

Ils ont belle allure ces petits montages, j'aime bien quand ça fait pro, félicitations 8)

Fool-DupleX
Messages : 985
Enregistré le : 06 avr. 2009 12:07

Re: Mon ordi [Silou78]

Message par Fool-DupleX » 01 mai 2017 19:32

Daniel a écrit :Le driver de souris pour MO5 est-il disponible quelque part ? C'est juste pour m'éviter de passer des heures à le réécrire...
Pas que je sache. C'est juste qu'il y a des années de cela, j'avais écrit un petit bout de code perso pour faire un proof of concept. Je me souviens du bruit caractéristique quand la souris bougeait et c'est à cette occasion qu'en consultant les schémas, je m'étais aperçu qu'il n'y a pas de mute souris, ni sur l'extension, ni sur le megabus 2 (normal, il reproduit l'extension à l'identique). Pour l'anecdote, c'était dans le cadre du développement de Lemmings par Sam, car la routine souris du TO est très lourde. J'avais posté mon code sur mon wiki Thomatoes, mais comme j'ai tout perdu suite à un crash sans backup préalable ... Probablement que ce code se trouve encore quelque part sur une DISQUETTE :shock: mais laquelle :?:

La question reste posée pour le MO5E, mais mon petit doigt me dit que c'est la même chose.

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 01 mai 2017 20:11

Arf... pour l'étiquette il n'y a plus de place pour écrire MO5NR et MO6 :wink:
Pour info, j'ai repris l'étiquette du topic de Phil juste dans un format moins rectangulaire et plus carré.

Au truc du jour, je viens de réaliser l'adaptateur de manette Mega Drive pour le Thomson. Merci encore Gleike pour le schéma, ça fonctionne au poil ! :D
MJ 90-022.jpg
MJ 90-022.jpg (129.12 Kio) Vu 774 fois
Toujours en adoptant le même style pour le boitier/étiquette. Bien qu'ici pas besoin de leds. :wink:
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Avatar du membre
6502man
Messages : 8874
Enregistré le : 12 avr. 2007 22:46
Localisation : VAR
Contact :

Re: Mon ordi [Silou78]

Message par 6502man » 02 mai 2017 16:18

Sympa tous ces adaptateurs et avec les étiquettes ça fait très pro :D :D
Phil.

www.6502man.com

To bit or not to bit.
1 or 0.

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 04 févr. 2018 18:31

J'ai essayé d'utiliser SDDrive ce dimanche après-midi après l'avoir reçu en début de semaine.

Tout ne s'est malheureusement pas déroulé comme espéré (mais autant le dire tout de suite, cela n'a rien à voir avec SDDrive :wink:).

Au début, tout va bien, je lance SDDrive.sel, le menu s'affiche. :)

Ensuite, je sélectionne un .sd (TO8demoded), j'essaye de le lancer et... la led rouge SDDrive clignote... puis reste allumée... et plus rien ne se passe. :o

J'éteins tout, je désactive le contrôleur fdd interne, je déconnecte et reconnecte SDDrive, ... refait les manip pour lancer le .sd et là, TO8demoded fonctionne ! (Hourrah ! me suis-je dis, ce n'était qu'un mauvais contact et/ou problème avec le contrôleur interne). :)

J'essaye de lancer un autre .sd, et rebelote, ça ne charge pas comme il faut. :roll:

Bon, j'enlève SDDrive et je mets le contrôleur CS91-280 + SDMOTO. Après quelques nouvelles bizarreries (mais qu'est-ce que c'est que ce b..del, ça fonctionnait très bien avant :evil:), j'arrive à lancer un jeu. Il fallait une manette, je la branche, ça fonctionne. Je me fait donc une petite partie de La Mine au Diamants, ça marche. :?

Je décide alors de débrancher la manette et j'insère une souris (adaptateur + souris PS/2). Ca fonctionne dans le menu principal du TO8D. Je tente de lancer SDSel et là, horreur ! La led d'alim verte du TO8D se met à clignoter rapidement avec un petit tic tic tic. :cry:

J'éteints tout, j'enlève toutes les extensions (mémoire, contrôleur, SDMOTO, adaptateur souris PS/2), et remet en service le contrôleur interne. J'allume, insère une disquette, et tout semble bien fonctionner de nouveau (les programmes sur disquette se chargent et se lancent). Grrr....
Je branche la souris Thomson MM 90-120, elle fonctionne parfaitement.
Je remet l'adaptateur de souris PS/2, rebelotte ! A l'alumage du TO8D, clignotement rapide de la led verte (+ led rouge du contrôleur interne qui s'initialise) toujours avec un tic tic tic venant de l'intérieur du TO8D. :x

Bon, j'ai l'impression que c'est au niveau de l'alimentation du TO8D (mise en sécurité ?).
Il doit y avoir un composant qui fatigue (et qui semble fatiguer de plus en plus au fur et à mesure des manips d'aujourd'hui), et lorsque il y a trop d'extensions (ou bien adaptateur qui consomme un peu plus que les autres), ça merdouille.

L'après-midi touche à sa fin... je range tout, et je prends juste le temps pour écrire ce message.

Je suis bon, à l'occasion d'un prochain week-end, de démonter le TO8D, et de mesurer les tensions au niveau de l'alimentation. En espérant arriver à la dépanner (normalement je suis plutôt optimiste, mais là je sens que ce n'est pas gagné d'avance cette histoire).

Je vais parcourir le forum, pour voir s'il y a déjà des topics traitant de problèmes d'alimentation sur le TO8D...
Et si vous lisez ce message, toute idée ou expérience par rapport à l'alimentation du TO est la bienvenue :idea:
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Daniel
Messages : 10211
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mon ordi [Silou78]

Message par Daniel » 04 févr. 2018 19:02

Quand l'alimentation disjoncte, c'est généralement le signe d'une surconsommation. Pas facile à trouver quand la panne n'est pas franche.
La consommation de SDDRIVE est de l'ordre de 20mA, c'est insignifiant par rapport à la carte mère, et normalement les autres périphériques ne doivent pas consommer plus. Il faut chercher un composant défectueux. Peut-être un condensateur. Sinon un contact malencontreux quelque part dans les connecteurs (souris, manettes, port d'extension).
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Silou78
Messages : 159
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: Mon ordi [Silou78]

Message par Silou78 » 04 févr. 2018 20:51

Bonsoir Daniel,

Merci pour ces conseils.
J'ai bien l'impression que l'ordi arrive en limite de consommation et dès qu'une extension en réclame un peu plus, soit ça fait trop baisser la valeur du +5V et provoque des bizarreries, soit ça disjoncte carrément.

Je vais effectivement commencer par vérifier les connecteurs (DB9, ports d'extension) et les condensateurs chimiques sur la partie +5V (le +12V ne semble pas poser de problème, le moteur du lecteur de disquette interne fonctionne bien).
Après inspection visuelle des condensateurs (et changement de ceux qui auraient gonflé/fuit), et réfection des soudures sur les connecteurs , je vais mesurer la valeur du +5V pour vérifier si la valeur est acceptable et s'il n'y a pas de composante alternative.

J'espère que c'est bien un de ces éléments, condensateur ou connecteur, sinon si c'est un autre composant qui se met à trop consommer, cela ne va pas être facile à trouver à moins qu'il ne finisse par se mettre en court-circuit franc (en espérant que ça ne fasse pas d'autres dégats).
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

Daniel
Messages : 10211
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Mon ordi [Silou78]

Message par Daniel » 04 févr. 2018 21:14

Quand un composant consomme trop, on peut parfois s'en apercevoir à sa température excessive. Mais ce n'est pas toujours évident. Il serait pratique de mettre un ampèremètre entre l'alimentation et la carte mère pour observer l'intensité en fonction des périphériques branchés, ce qui permettrait de détecter une anomalie. Mais ça peut être aussi un défaut de l'alimentation (disjoncteur trop sensible).

Je me souviens d'un problème avec un TO8D : Dans le lecteur de disquette d'origine, l'alimentation du moteur est en 12V. Je l'avais remplacé par un lecteur de PC, dont le moteur est alimenté en 5V (il n'utilise pas le 12V). A chaque démarrage, il faisait disjoncter l'alimentation pendant quelques centièmes de seconde et le TO8D rebootait. J'ai mis très longtemps à comprendre pourquoi, car c'était imperceptible. C'est la preuve de la sensibilité du disjoncteur. Maintenant le lecteur de PC est alimenté par le 12V avec un régulateur 5V et il n'y a plus de problème.

Ca n'a certainement aucun rapport, mais j'ai constaté que SDDRIVE est relativement sensible à la tension d'alimentation. Si elle est hors normes c'est une explication possible de son fonctionnement aléatoire.
Daniel
L'obstacle augmente mon ardeur.

Répondre