Goupil G4: Restauration

Pour tout ce qui touche au PC d'IBM et ses nombreux descendants. Attention tout de même, au delà de quelques MHz la discussion devient vite hors sujet.

Modérateurs : Papy.G, fneck, Carl

gotcha
Messages : 2902
Inscription : 30 mars 2017 11:39
Localisation : Isère
Contact :

Re: Goupil G4: Restauration

Message par gotcha »

> Peut on savoir, avec le numéro de série par exemple, si tel ou tel G4 était livré avec quel dos?

C'est probable, mais cette information est à mon avis perdue.
La différence notable me semble être la version du moniteur : V1R<N> versus V2R<N> qui correspond peut-être aussi à une différence coté hardware.
Je n'ai eu de mon coté pour l'instant que des V1 entre mes mains.


> Il me semble même que cet ordi a eu droit à un windows 2 ...

C'est ce qu'affirme fneck sur son site. Pour sa part, Silicium indique Windows 1 avec le G4 et Windows 2 avec le Golf (http://silicium.org/site/index.php/28-c ... historique)

Pour l'instant, voici ce que j'ai retrouvé:
  • 2 versions de DOS 2.11
  • 1 ou 2 versions de DOS 3.1 (il faut que je vérifie)
  • 2 versions de Windows 1
  • Il y a apparemment une version multitâche de DOS 4 pour le G4 (prototype ?), mais qui plante dans mon cas (mon hardware est peut être trop ancien).
Mon but est de tout collecter ici: viewtopic.php?f=7&t=10578 (Il faut que je mette ceci à jour d'ailleurs)

Donc si quelqu'un a des ressources officielles pour Goupil G4 non encore publiées (en particulier Windows 2), merci de les partager :D
Amstrad CPC et Goupil power :mrgreen:
Bénévole à l'association pour un conservatoire de l’informatique et de la télématique (https://www.aconit.org)
Seb_A2
Messages : 461
Inscription : 11 nov. 2019 00:07
Localisation : Ile de France

Re: Goupil G4: Restauration

Message par Seb_A2 »

Hello,
j’ai récupéré un Goupil G4 avec 2 lecteurs disquettes 5”1/4 et un ecran couleur SM14
il y a une carte graphique couleur et une carte extension RAM (sans marque) sur le riser.
j’ai commencé par nettoyer la carte mère.
j’ai virer le condo rifa Y 2200pf’sur l’alim.
je branche l’alim Astec a vide, on entend un mini clic , et sur la molex 12v et 6v13
a priori, l’alim est ok

je branche l’alim sur la carte mère et rien d’autre.
aucun bip, mais la led DS2 cligote tout doucement, elle éclaire tŕès peu.
la led DS1 ne s’allume pas.
la réf sur la carte mère est
SMT - CPU 186 -8 G4 - 4770003-31-B 04 12 85 4770003-12-B

je ne vois aucune réf a V1 ou V2 ou V4..
il n’y a pas de pile
le proc intel 186 est quasiment au centre
sur certain CI, il y a une étiquette avec mention [ cpu 4.1 xx]
sur les éprom, il est indiqué IPL CODE V1

Questions:
- quel serait la version de la carte mère ?
- a quoi correspond la led DS2 clignotante ?
- je n’ai pas le clavier, il y a une prise tel sous la carte mère, peux t’on brancher un clavier XT avec un adaptateur ?
- est ce qu’il existe un manuel de ref pour le G4 ?

merci
20240510_143658~6.jpg
20240510_143658~6.jpg (902.6 Kio) Consulté 246 fois
gotcha
Messages : 2902
Inscription : 30 mars 2017 11:39
Localisation : Isère
Contact :

Re: Goupil G4: Restauration

Message par gotcha »

As tu vérifié les tensions avec la carte mère branchée ? J'ai déjà eu un problème de tantale sur la carte mère d'un G4.

La carte graphique est sur l'extension de port ISA a côté de la carte mère ? Elle n'est pas au dessus de la carte mère ?
Amstrad CPC et Goupil power :mrgreen:
Bénévole à l'association pour un conservatoire de l’informatique et de la télématique (https://www.aconit.org)
Seb_A2
Messages : 461
Inscription : 11 nov. 2019 00:07
Localisation : Ile de France

Re: Goupil G4: Restauration

Message par Seb_A2 »

il y a 2 emplacements pour les cartes au dessus de ma carte mère.
a gauche carte video
a droite c’est vide, normalement c’est dispo pour la xebec du disque dur

a coté de la carte mère, a gauche, j’ai un riser avec une carte extension RAM

j’ai regardé quelques points sur la carte, et j’ai du 5,1v ou 5,4v
est ce que tu aurais une idée où je dois tester ? ou bien il faut tester tous les condos tantale ?
sur mon IBM 5160, j’avais un tantale en court circuit, mais c’était facile car le tantale était fissuré. :-)
gotcha
Messages : 2902
Inscription : 30 mars 2017 11:39
Localisation : Isère
Contact :

Re: Goupil G4: Restauration

Message par gotcha »

Les cartes sont donc positionnées normalement.

Souvent, il y a plusieurs tantales sur un même rail d'alim. Du coup, il suffit de tester s'il y a un court circuit sur chacun des rails. Pas besoin de tester tous le tantales.
Tu peux même vérifier les court circuits pour les différents rails directement sur le connecteur branché a la carte mère je pense.

Si l'alim fait clic-clic, c'est je pense que soit la carte mère ne tire pas assez de courant, soit il y a un court-circuit au secondaire qui la met en sécurité
Amstrad CPC et Goupil power :mrgreen:
Bénévole à l'association pour un conservatoire de l’informatique et de la télématique (https://www.aconit.org)
Seb_A2
Messages : 461
Inscription : 11 nov. 2019 00:07
Localisation : Ile de France

Re: Goupil G4: Restauration

Message par Seb_A2 »

dans la foto, en haut a gauche, j’ai le connecteur de l’alim
les tensions sont les suivantes
de droite a gauche
JP6
jaune 5,11v
-
reset 5,10v
-
rouge -12,31v
noire 0v
jaune 13,67v
jaune 5,11v
noire 5,11v
rouge 0v
20240510_143658~7.jpg
20240510_143658~7.jpg (117.55 Kio) Consulté 228 fois
la comparaison se fait avec le point GND TP8 sur la carte mère
est ce que ces tensions sont correctes ?

le "rouge" a 0v??
Seb_A2
Messages : 461
Inscription : 11 nov. 2019 00:07
Localisation : Ile de France

Re: Goupil G4: Restauration

Message par Seb_A2 »

je débranche tout
voltmétre en position test de continuité entre TP5 Gnd et chaque pin de Jp6

Jp6 (de haut en bas)
- beep
- rien
- rien
- beep
- rien

- beep
- rien
- beep
- beep
- beep
20240510_172634~2.jpg
20240510_172634~2.jpg (655.49 Kio) Consulté 224 fois
gotcha
Messages : 2902
Inscription : 30 mars 2017 11:39
Localisation : Isère
Contact :

Re: Goupil G4: Restauration

Message par gotcha »

Seb_A2 a écrit : 10 mai 2024 17:14 dans la foto, en haut a gauche, j’ai le connecteur de l’alim
les tensions sont les suivantes
Tu prend quel point comme masse sur ton multimètre ? Vu les mesures que tu fais, tu ne dois pas avoir la bonne masse.
Prends un des fils noir du connecteur comme masse pour faire tes tests de voltage.

Ensuite, tu utilises TP5 pour les tests de continuité car c'est marqué GND en dessous ?
Là encore, je pense qu'il vaut mieux prendre un des fils noirs du connecteur comme masse de référence.
Amstrad CPC et Goupil power :mrgreen:
Bénévole à l'association pour un conservatoire de l’informatique et de la télématique (https://www.aconit.org)
gotcha
Messages : 2902
Inscription : 30 mars 2017 11:39
Localisation : Isère
Contact :

Re: Goupil G4: Restauration

Message par gotcha »

Pour info, sur le dernier G4 que j'ai remis en fonction, le tantale C58 avait explosé (il est sur ta dernière photo).

PXL_20230923_081554023_small.jpg
PXL_20230923_081554023_small.jpg (308.48 Kio) Consulté 129 fois
Amstrad CPC et Goupil power :mrgreen:
Bénévole à l'association pour un conservatoire de l’informatique et de la télématique (https://www.aconit.org)
Daniel
Messages : 17555
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Goupil G4: Restauration

Message par Daniel »

Il n'est pas très judicieux d'utiliser le mode "test de continuité" pour mesurer la résistance au connecteur d'alimentation d'une carte mère. C'est une mesure "tout ou rien" et on ne connait pas exactement la résistance de seuil. Donc ça ne veut rien dire. C'est juste utile pour détecter si un câble est coupé.

Par contre mesurer les résistances entre les différentes entrées et la masse permet de détecter des anomalies, en particulier les court-circuits mais aussi les résistances anormalement élevées.
Daniel
L'obstacle augmente mon ardeur.
Répondre