[Victor V86P] Remise en service

Pour tout ce qui touche au PC d'IBM et ses nombreux descendants. Attention tout de même, au delà de quelques MHz la discussion devient vite hors sujet.

Modérateurs : Papy.G, fneck, Carl

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

[Victor V86P] Remise en service

Message par fneck » 18 janv. 2020 21:46

J'ai fait l'acquisition de ce portable compatible PC suite à un don de jeff34 ici même viewtopic.php?f=10&t=10503
Merci encore Jeff 8)

N'ayant pas l'alimentation et vu la forme de la prise je me doutais que ça ne serait pas simple à bricoler. Et pourtant sur le coup, avec un peu de chance, je m'en tire plutôt bien. Le début de la discussion concernant l'alimentation se dans le topic ci-dessus, précisément trouve ici.

En particulier Carl m'avais posté la photo de l'alimentation et la forme de la prise ainsi qu'un schéma électrique. Et Totor m'a expliquer le fonctionnement de ce dernier.

Une photo du connecteur de l'ordinateur (prise sur internet, je vous expliquerai pourquoi plus loin):
Image

Et la prise de l'alimentation externe fournie par Carl:
Image

Les connexions sont assez profonde dans la prise, il est impossible de les atteindre directement sans une prise adéquate. Heureusement l'écartement des pinoches semble assez standard. En cherchant dans mon bazar (en particulier dans une boite à fils) je trouve un connecteur qui me semble pas trop mal adapté :
Image

Après un petit usinage ça donne ça:
Image

J'ai eu beaucoup de difficultés à insérer cette prise bien que l'écartement soit correct mais je pense que les broches venaient buter sur le bord des parties femelles un peu trop resserrées. Bref une dizaine de minutes plus tard, après avoir manipulé les fil dans tous les sens j'ai réussi à insérer la prise. Et voici pourquoi je n'ai plus fait de photo du connecteur car, maintenant qu'elle est en place, il n'est plus question de retirer la prise :D
Image

Je posterai le branchement électrique plus tard...

Et l'ordinateur démarre bien. Et même, au deuxième ou troisième essai après avoir déclaré la configuration dans le setup, le disque dur a fonctionné et boote sur un Ms-Dos 4.01a signé Victor:
Image

Image

Image

Il y avait déjà un topic de 2015 sur le forum consacré à cet ordinateur... malheureusement sont auteur a supprimé tous ses messages (je n'arrive pas à comprendre cette attitude :evil: ) mais on peut quand même y retirer quelques informations comme le fait que la pile de sauvegarde soit constituée d'un gros condensateur ou certaines commandes spécifiques à la machine :
CTRL-ALT-F7 pour un fonctionnement à 4.77MHz
CTRL-ALT-F8 pour un fonctionnement à 10MHz
CTRL-ALT-F9 pour inverser le LCD
CTRL-ALT-F10 pour commuter sur l'écran externe
CTRL-ALT-ESC pour un accès au "setup" de la machine

Avatar du membre
Pocket
Messages : 16
Enregistré le : 12 janv. 2020 20:58
Localisation : Toulouse
Contact :

Re: [Victor V86P] Remise en service

Message par Pocket » 19 janv. 2020 08:57

Salut,

La chance est avec toi (et la Wayback machine aussi) : https://web.archive.org/web/20150321223 ... f=3&t=6106

A+
Pocket
Image

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 19 janv. 2020 09:20

Eh, je ne pense jamais à ce truc, merci Pocket 8)
Je vais relire avec attention ce post et recopierai ici toute info intéressante.

jvernet
Messages : 1590
Enregistré le : 12 avr. 2007 10:59
Localisation : France 69

Re: [Victor V86P] Remise en service

Message par jvernet » 19 janv. 2020 10:09

J'en ai un aussi, sans alim du tout... Infos à suivre, donc

Avatar du membre
Carl
Modérateur
Messages : 10821
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Victor V86P] Remise en service

Message par Carl » 19 janv. 2020 11:57

Fabien, tu peux remettre le scan de la doc que j'ai proposé dans l'autre topic afin de tout centralisé...

Carl

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 19 janv. 2020 13:15

Je n'ai pas trop envie de déplacer les messages car chronologiquement ça va être compliqué et peu lisible. Ok, on aurait pas dû commencer à parler technique dans l'autre sujet. Je vais essayer de "quoter" ici l'essentiel de la partie technique...

Tout d'abord le manuel, posté par Carl et converti en .pdf -> https://system-cfg.com/scans/victor_V86P_manuel.pdf

Ensuite le schéma
Image
fneck a écrit :
18 janv. 2020 13:30
Je ne comprends pas trop le schéma posté plus haut, sur lequel on trouve 3 tensions, très proches... pas très cohérent, c'est probablement la même... mais sur quelle broche? l'une provient peut être de la batterie?
Sur cette vidéo on voit que la machine fonctionne avec une tension unique (le disque dur externe a été branché sur une autre alimentation).

Totor le Butor a écrit :
18 janv. 2020 15:00
A part la broche Vcc, toutes les autres (Va, Vb et Vc) servent à recharger et monitorer la batterie sauf que j'ai l'impression qu'il y a une erreur dans le schéma.

Le point test "Va" est directement relié à VCC, le point test "Vb" est relié à Vcc par une diode (D99) en série avec une résistance de 15 ohm (R99) jusque là tout va bien. Vb étant relié directement à la batterie le courant maximum est limité à environ 530 mA.

Par contre, quand il est déclenché, le transistor Q3 en série avec 1 résistance de 37,5 ohms (R30 en // sur R33) court-circuite la diode et la résistance de 15 ohms ce qui est équivalent grosso modo à mettre en // une résistance de 15 ohms et une de 37,5 ohms ce qui donne environ 10 ohms.
Dans ce cas, le courant maximum est d'environ 800 mA pour recharger la batterie à comparer aux 500 mA sans le transistor, la différence n'est pas très grande et la batterie serait en permanence rechargée par le courant de 500 mA.
Sans rentrer dans les détails Il y a une incohérence dans le rapport entre ces 2 courants pour la recharge et le courant d'entretien d'une batterie NI-CD.

A part ça, je pense que tu peux te contenter d'injecter du 8,5 V sur la broche Vcc du connecteur externe ou du 6V aux bornes de la batterie.
fneck a écrit :
18 janv. 2020 15:16
Merci Totor pour ton analyse du circuit 8)

J'ai réussi à brancher un connecteur sur la prise (je posterai des photos plus tard). Donc j'ai fait quelques mesure à l'ohmmètre et conformément au schéma les deux broches du bas à droite et à gauche sont bien reliées entre elles, et à droite c'est bien la masse. Donc tu me conseilles de brancher le 8,5V entre Vcc et la masse, d'après le schéma Vcc et Va sont reliés, donc entre Va et la masse de la prise (ce qui me semble logique vu qu'il y a deux broches à chaque fois pour passer la puissance).
Carl a écrit :
18 janv. 2020 15:29
Image
fneck a écrit :
18 janv. 2020 15:31
Ok j'ai réussi à démarrer l'ordinateur. Mais mon alimentation limitée à 2A s'écroule lorsque le disque dur démarre.
Est-ce que je pense brancher la batterie, pour essayer de la charger, sachant qu'il y n'y aura pas le monitoring de l'alimentation?
Totor le Butor a écrit :
18 janv. 2020 15:42
Euh... Brancher une batterie NI-CD d'une trentaine d'année :shock: !
Si elle marche je veux bien manger un transistor :lol: !
Tu ne risques pas grand chose, Face ça ne charge pas, Pile, tu écroules ton alimentation.
fneck a écrit :
18 janv. 2020 22:31
@ Totor, pour revenir sur le schéma, est-ce qu'il faut comprendre que la régulation de charge de la batterie est comprise dans l'alimentation externe? En fait je m’interroge sur la pertinence de refaire le module batterie, si la régulation est externe c'est inutile du coup.
Totor le Butor a écrit :
18 janv. 2020 23:19
Ben en fait, j'ai l'impression qu'il manque un bout de schéma parce que moduler le courant de charge au maximum à 500 ou 800 mA et éteindre une led (D1) ce n'est pas ce que j'appelle un contrôle de charge :evil:. Il doit y avoir autre chose à l'intérieur de la machine, a minima un circuit qui transforme le +8,63 en quelque chose d'acceptable pour les circuits logiques (5V), pareil pour la batterie, il est impossible qu'elle soit reliée tel que à la logique.
Sur le schéma on voit bien que la batterie est directement relié à Vb et reçoit donc en permanence un courant de 500 mA , en cas de perte de tension du chargeur, la batterie alimente le Vin par l'intermédiaire de la double diode D502 et on perd en plus 0,6 V dans la bataille :? .
Normalement une batterie NI-CD se charge à 1/10eme de sa capacité et le courant d'entretien est d'environ 1/20 à 1/30eme de la capacité. Quelle est la capacité de la batterie ?
D'autres schémas

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 19 janv. 2020 13:24

Concernant la batterie, elle ressemble à ceci:
Image

De plus près:
Image

Il y a 5 éléments de la taille d'une pile type C mais rien d'écrit visible dessus. Leanord286 nous écrivait dans l'autre topic:
Leanord286 a écrit :
04 mai 2015 00:14
A l'intérieur, il y a 5 cellules C NiCd 1800mAh avec en série un coupe circuit thermique 17AM203A5 et en parallèle avec une sonde thermique PEPI C

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 19 janv. 2020 14:12

Pour ce qui est de l'alimentation au stade actuel, conformément au schéma et aux mesures de continuité réalisées sur le connecteur, j'ai branché une alimentation stabilisée de 8,5V comme ceci:

Image

La consommation est de 0,9A en permanence et 1,2A avec le disque dur en fonctionnement.
Il faut un peu plus juste pour la mise en service, environ 1,8A.

Avatar du membre
Totor le Butor
Messages : 1577
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [mise en service] Victor V86P

Message par Totor le Butor » 19 janv. 2020 17:26

Si les accus ont une capacité de 1800 mA, la recharge doit s'effectuer à 180 mA et le courant d'entretien entre 60 et 90 mA donc il est absolument certain que la partie chargeur est dans la machine ou alors il y a de grosses erreurs dans le schéma dans les valeurs des résistances chutrices (R99=15 ohms et R30, R33 = 75ohms) de l'alim externe :? .
D'un autre point de vue, il vaut mieux retirer les accus de la machine avant qu'ils ne te bousillent tout :evil: et se contenter de faire fonctionner la bécane comme tu le fais actuellement.
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 19 janv. 2020 22:18

Alors, la batterie n'est pas totalement morte (Totor, je choisi le transistor :D )

Placée dans l'ordinateur il ne se passait rien. Je l'ai donc retirée et mise en charge avec un chargeur réglé à 500mA pendant 2 heures histoire de la réveiller et à ma grande surprise elle tient la tension (ça ne veut pas dire qu'elle est chargée). Puis remise dans l'ordinateur, rien de neuf... en fait j'espérais constater l'extinction du voyant "battery low" qui reste en permanence allumé (voir photo dans le premier message ci-dessus).

Et par chance, il n'y a pas d'autres mots, en touchant les fils au niveau du connecteur de la batterie je me rend compte que le voyant clignote. dans les fait il faut maintenir une traction sur les fils pour que ça fonctionne, je ne sais pas encore où se situe le mauvais contact mais il est bien réel. Et depuis le voyant "battery low" est éteint alors que "power" est allumé:
Image

Je me suis même permis de couper l'alimentation externe pour fonctionner sur batterie 30 secondes :o
Par contre je ne sais pas encore si elle se recharge sur la machine, à suivre.

[edit]
Totor le Butor a écrit :
19 janv. 2020 17:26
D'un autre point de vue, il vaut mieux retirer les accus de la machine avant qu'ils ne te bousillent tout :evil:
Je suis tout à fait d'accord avec toi, je ne vais pas la laisser dedans. Mais si elle se recharge via ma prise bricolée je vais peut être en refaire une neuve.

Avatar du membre
Papy.G
Modérateur
Messages : 2047
Enregistré le : 10 juin 2014 13:40
Localisation : Haute-Garonne/Gers

Re: [Victor V86P] Remise en service

Message par Papy.G » 20 janv. 2020 06:58

Fabien, est-tu sûr que l'écartement des broches de la prise que tu utilises n'est pas un peu trop important, et écarterait les broches de l'ordi une fois inséré, ou les broches sont trop petites dans l'ordi par rapport au serrage des lamelles de contact dans la prise.

A voir la première photo qui nous a été montrée, je croyais que c'était une prise au pas de 1/10è de pouce qui aurait pu recevoir un morceau de connecteur de disque dur, mais bon, on n'a pas forcément une idée de l'échelle quand on voit une photo de détail.
Soyez exigeants, ne vous contentez pas de ce que l'on vous vend.
Demandez-en plus, ou faites-le vous-même.

Avatar du membre
Totor le Butor
Messages : 1577
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [mise en service] Victor V86P

Message par Totor le Butor » 20 janv. 2020 10:58

fneck a écrit :
19 janv. 2020 22:18
(Totor, je choisi le transistor :D )
Même pas peur, j'ai avalé d'un seul coup (avec une petite pointe de sel) un petit transistor en boitier SOT23, je réserve le boitier TO3 pour une grande occasion :lol: !
boitier.png
boitier.png (67.48 Kio) Vu 222 fois
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 20 janv. 2020 19:50

Aller Totor, on efface l'ardoise pour le transistor 8)
Parce que de toute façon tu avais raison... le pack d'accus n'a probablement pas 30 ans, car ce soir il est toujours chargé (6,48V actuellement). Je le laisse comme ça pour voir sa décroissance.

Par contre du coup, je sais maintenant qu'il ne se recharge pas non plus, d'où probablement la présence des autres fils sur la prise d'alimentation non raccordés actuellement. Je reste sur mon idée que le chargeur est dans l'alimentation d'origine, ou du moins une partie, d'où également je suppose la tension présente sur la prise mesurée par Carl. Car sur cette broche (Vb) de la prise, non connectée chez moi, je lis la tension de la batterie.

Avatar du membre
fneck
Site Admin
Messages : 13105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Victor V86P] Remise en service

Message par fneck » 20 janv. 2020 20:55

J'ai réussi à trouver l'origine des schémas postés par Carl, c'est un gars comme moi qui possède un V86P sans son alimentation mais qui a pu en obtenir une pour l'étudier. C'est ici https://knm.org.uk/blog/2017/04/reverse ... /#more-203
Nota : pour garder le lien l'ensemble du blog consacré à la machine https://knm.org.uk/blog/tag/v86p/

Les photos de l'intérieur de l'alimentation sont ici https://knm.org.uk/blog/v86p-psu-internals/

Et enfin ça confirme ce qui me semblait de plus en plus sûr, le module de charge de la batterie est dans le bloc externe. Sur le schéma, la partie gauche et centrale (avec Q3 + Q4) est dans le chargeur. Dans l'ordinateur c'est uniquement le petit module de droite.

jeff34
Messages : 123
Enregistré le : 01 nov. 2019 11:15
Localisation : Montpellier

Re: [Victor V86P] Remise en service

Message par jeff34 » 21 janv. 2020 10:52

Hello à tous !

Je viens de découvrir ce post et je suis ravi que cette vieille rougne ai repris du service ! je ne le pensais pas :)
Mais les X86 ne m'ont jamais passionné (cela en est bien un hein ? :) )

Bravo en tous cas @fneck :) Il reste plus qu'à lui reblanchir les dents - pardon les touches :)

Jeff

Répondre