[OLIVETTI M240] Premier demarrage

Pour tout ce qui touche au PC d'IBM et ses nombreux descendants. Attention tout de même, au delà de quelques MHz la discussion devient vite hors sujet.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

[OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 15:03

Bonjour,

Je viens de procéder au premier démarrage de mon M240, avec les voltmètres branchés sur l’alimentation,
le +5 V est a 5,05 V et le +12 V est a 11,71 V, donc tout va bien. :D

Les tests de démarrage ont l'air corrects
les 2 drives tournes l'un après l'autre.
Ecran-M240.jpg
Ecran-M240.jpg (87.87 Kio) Vu 2661 fois
Mais une fois arrivé la que suis-je censé faire ?
"No ROM BASIC available - RESET"
Aucune touche du clavier ne fonctionne, (le clavier marche, les voyant s'allumes et réagissent ,NUM,CAPS LOCK etc...)

Je pensais qu'il allait booter sur le disque dur.


[Edit] Je viens de démarrer avec la disquette de TEST UTILISATEUR.
Le test carte system - echoue.
Le disque dur est marqué absent.
Le 2éme lecteur de disquette est absent aussi.
Tests M240.jpg
Tests M240.jpg (90.62 Kio) Vu 2652 fois
Tout le reste est bon.

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 16:15

Sur tes photos on voit une carte optionnelle en C800 et elle génère une erreur 1701 = erreur de contrôleur disque.
C'est pour ça que tu ne voies pas ton disque, le contrôleur fonctionne peut-être mais est mal paramétré, à un faux contact, est mal connecté au disque...
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 16:34

En réglant les switches sur la carte mère, le 2éme lecteur de disquette est reconnu.
J'ai retiré la carte avec le disque dur, mais le test carte system de la disquette test utilisateur échoue toujours.
Modifié en dernier par gleike le 25 janv. 2015 13:28, modifié 1 fois.

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 16:56

Appuie bien sur tous le circuits intégrés sur support sur la carte contrôleur, déconnecte le disque dur (nappe et alim) puis reconnecte le, c'est peut-être lui qui met la grouille.
Si l'erreur persiste, déconnecte complétement le disque ,sans lui la carte devrait te renvoyer une erreur 1780 signe quelle fonctionne mais qu'elle n'accède pas au disque.
Si les switchs étaient mal configurés pour le 2eme floppy il est fort possible qu'ils le soient également pour la carte contrôleur (conflit d'Irq ou d'adresse par exemple).

Quelles sont les références du contrôleur et du disque ?
Peux tu nous poster la signification des switchs de la carte mère, cela nous permettrait de te répondre plus facilement et nous éviterait d'aller chercher sur Internet.
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 17:12

Voila le lien pour la carte mère, avec la configuration des switches.
http://museum.ttrk.ee/th99/m/M-O/33374.htm

Pour le disque dur les ref sont: WDC 60-000227-01 rev x0 = carte controleur.
http://stason.org/TULARC/pc/hard-disk-f ... mbipBDNPQM
Ma config est W1=2-3 W2=1-2 W3=1-2
Disque = WD93028
http://stason.org/TULARC/pc/hard-drives ... DE-XT.html

[Edit]Il y a du changement.

Je viens de réinstaller le disque dur, appuyer sur tout les circuits sur support, débrancher et rebrancher les nappes,
maintenant a l'allumage le disque apparait
FIXED DISK 1 PRESENT

Mais reste bloqué sur le message
optional ROM at C800:0000
Sans code d'erreur.

[Edit] je viens de changer le switche n°5 de SWB
Le démarrage se poursuit jusqu'au bout avec la reconnaissance des floppy,
puis ça s'arrete sur

DISK BOOT FAILURE :(

[Edit]Quand je lance le test utilisateur du disque dur, la disquette tourne sans s’arrêter, obligé de faire RESET pour l’arrêter.
Modifié en dernier par gleike le 11 janv. 2015 18:13, modifié 2 fois.

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 17:59

Avec le disk failure, si tu boot sur une disquette DOS, as tu accès au disque C ?
Si non, que donne le FDISK ?
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 18:27

Effectivement, sous DOS j'ai accès au disque dur C, la commande DIR ma listé son contenu.

Un deuxième DIR me donne : erreur de recherche. erreur en cours de lecture de l'unité C.

[Edit]Je vais essayer de formater le disque dur et installer MS DOS dessus (jamais fait de ma vie) :oops:

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 19:21

Avant de formater assure toi bien que tu peux lire les disquettes et que le dos soit complet.

Pour bien faire les choses, il faudrait faire un formatage de bas niveau.

Boot sur une disquette, lance le programme DEBUG puis, au prompt, tape la commande :

G=C800:5
Ca va lancer le programme se trouvant dans l'Eprom de la carte contrôleur et qui va te permettre de formater le disque à bas niveau. Il suffit de suivre les instructions à l'écran.

Une fois fini tu reboot avec la disquette et tu lances la commande FDISK.
Fait une partition principale, suivant le dos il faudra choisir après Activer la partition.

Reboot avec la disquette DOS et tape la commande FORMAT C:/S

Reboot sur le disque qui doit fonctionner maintenant.

Il ne reste plus qu'à copier le contenu des disquettes dans le disque C, commande COPY A:*.* C:
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 20:55

Pas de problème pour lire les disquettes, il est équipé de 2 lecteurs un 5.25 et un 3.5.
J'ai plusieurs DOS,l'original fournit avec le M240 MS DOS 3.2 en 5.25,ou MS DOS 6.2 en 3.5

Merci pour tes précieux conseils, que je vais suivre a la lettre.

Je ne maîtrise pas trop le DOS, je suis passé directement du TRS80 en 1985 a Windows 98 en 2000,rien entre les 2.

Avatar du membre
fneck
Site Admin
Messages : 12245
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [OLIVETTI M240] Premier demarrage

Message par fneck » 11 janv. 2015 21:14

Attention, pas de formatage de bas niveau sur un disque IDE, ou éventuellement et en dernière tentative avec un outil du constructeur.

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 21:15

Je viens de voir la doc de la carte, suivant la position des switchs sur la carte controleur l'adresse DEBUG à utiliser peut-être :

Switch W1 = 1 et 2
DEBUG
G=CA00:5

Switch W1 = 2 et 3
DEBUG
G=C800:5

Si ça ne donne rien, remplace le 5 par 0 (zero), par exemple G=C800:0
Si ça ne donne toujours rien essaye 6 (G=C800:6).
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 11 janv. 2015 22:42

Cruel dilemme, je vois qu'il y a un conflit dans vos réponses, et ce n'est pas moi qui pourrai vous départager.
Alors formatage bas niveau ou pas ?

[Edit] Sur cette page,http://www.lo-tech.co.uk/wiki/Western_D ... tall_Guide
ils recommande,d’après ce que j'ai compris,
d'utiliser le programme SUPERBIOS inclus dans la carte WDXT150R pour le formatage de bas niveau.

Avatar du membre
fneck
Site Admin
Messages : 12245
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [OLIVETTI M240] Premier demarrage

Message par fneck » 11 janv. 2015 23:08

A priori, ma remarque très générale concernant les disques IDE ne s'applique pas sur les premiers disques dont fait partie le WD-9328. Dans la mesure où c'est écrit dans la documentation, effectivement tu peux y aller 8)

Avatar du membre
Totor le Butor
Messages : 1400
Enregistré le : 07 sept. 2011 16:14
Localisation : Paris

Re: [OLIVETTI M240] Premier demarrage

Message par Totor le Butor » 11 janv. 2015 23:22

Normalement le formatage bas niveau n'est pas nécessaire si l'on ne change pas de contrôleur.
C'est lors de ce formatage que l'on déclare les mauvaises pistes et secteurs indiquées sur l'étiquette du disque.
Il est vrai que l'on ne formate pas bas niveau les disques IDE moderne car ils comportent des informations de suivi de piste qui ne sont inscrites qu'en usine. D'ailleurs ce formatage est impossible, au mieux la commande ne fait rien, au pire elle efface les données du disque comme le ferait un soft de plus haut niveau. Mais dans tous les cas ce formatage n'affecte pas le fonctionnement du disque.

Il est vrai que sur un disque aussi vieux que le tien on peux se poser la question, à priori si la carte contrôleur le permet c'est que le disque accepte ce formatage.

D'un autre coté et si l'on veut jouer la sécurité, il suffit de faire un FDISK et un FORMAT sans passer par le bas niveau. Au pire tu auras des erreurs de lecture ou d'écriture, au mieux ça marchera correctement.

En résumé, fait simplement le FDISK et le FORMAT, si ça marche tant mieux autrement il faudra passer par l'étape formatage bas niveau
Born to bricole
[Rch] Vieux composants électroniques et circuits intégrés toute époque et vieilles cartes .

Avatar du membre
gleike
Messages : 539
Enregistré le : 16 oct. 2014 11:12
Localisation : Ludres (54710) Meurthe & Moselle

Re: [OLIVETTI M240] Premier demarrage

Message par gleike » 12 janv. 2015 11:38

D'accord, je vais dans un premier temps, faire un simple formatage classique.

Répondre