[SEGA Master System 1] En panne

Si vous n'avez pas trouvé de catégorie correspondante ci-dessus, regroupe les discussions plus générales et à l'occasion peut aussi abriter un fil sur les vieilles consoles de jeux.

Modérateurs : Papy.G, fneck, Carl

Répondre
petitjd
Messages : 1853
Enregistré le : 23 oct. 2007 11:50

[SEGA Master System 1] En panne

Message par petitjd » 06 août 2019 22:44

Bonjour,
j'ai dégotté sur la baie une Sega Master System 1 et une SMS 2 HS.
Pour la SMS2, la réparation a été simple: toutes les soudures du connecteur vidéo DIN avaient cassé. Quelques fils en guise de strap et c'est reparti.
Pour la SMS1, ca se complique: la pcb est fendue autour du connecteur cartouche coté composant et coté pistes.
D'après le vendeur, la console s'allumait, on pouvait jouer au jeu intégré en ROM mais elle ne lisait pas les cartouches. Le voyage a empiré la fissure de la carte mère en la fissurant coté composants (pistes à droite du cpu sectionnées), ce pourquoi je n'ai même pas tenté de l'allumer à sa réception.
J'ai refais les pistes avec des straps, mais visiblement, je me suis planté sur la zone proche du CPU côté composants, du coup j'ai eu un écran noir sans son à l'allumage.
J'ai revérifié mes straps et j'ai corrigé les erreurs (certaines des 11 pistes sectionnées sur la droite du cpu étaient recablées au mauvais endroit).
Je rallume, et là j'ai un superbe écran rose, stable, en plein écran et j'entend les hauts parleurs de la tv sortir un léger grésillement.
Je suppose que j'ai grillé un ou plusieurs composants.
J'ai fais un tours sur le net pour trouver de la doc, il y a un super site dédié à la SMS:
http://www.smspower.org/Development/RGB ... SC837-6700
http://www.smspower.org/Development/Seg ... otingGuide
Le service manual en pdf sur le deuxième lien est très intéressant.
A priori, si j'ai un affichage et un grésillement audio, la ROM, le vdp, la vram et la ram vivent encore (complètement ou pas, là est la question).
Le cpu en revanche me parait hs, du moins partiellement, sinon je suppose qu'il n'y aurait pas d'affichage aussi.
Qu'en pensez-vous?
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

petitjd
Messages : 1853
Enregistré le : 23 oct. 2007 11:50

Re: [SEGA Master System 1] En panne

Message par petitjd » 06 août 2019 22:53

Petite précision: les pins du cpu concernées par l'erreur de straps sont:
6, 16, 18, 19, 20, 22, 23, 24, 25, 27, 28
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
fneck
Site Admin
Messages : 12897
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [SEGA Master System 1] En panne

Message par fneck » 07 août 2019 09:37

Perso j'ai toujours du mal à dire avec certitude si le CPU fonctionne ou pas sur une machine plantée. Néanmoins je me dis que si l'affichage est présent, même s'il n'affiche qu'un écran rose, c'est que le CPU a démarré jusqu'à un stade où l'ensemble est resté bloqué.

Avatar du membre
gilles
Messages : 1858
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: [SEGA Master System 1] En panne

Message par gilles » 07 août 2019 10:21

c'est une machine à VDP avec VRAM donc c'est assez difficile de se prononcer.
Avec une image stable on peut supposer que le VDP et la VRAM sont au moins partiellement fonctionnels mais ça ne permet pas de dire grand chose sur le CPU, la RAM ou la ROM interne.
Le raisonnement concernant la ROM ne me semble pas cohérent par contre car il faut un CPU correct pour exploiter cette ROM. Perso j'irai regarder vers la RAM CPU avec ce genre de symptôme mais c'est un peu pifométrique.

petitjd
Messages : 1853
Enregistré le : 23 oct. 2007 11:50

Re: [SEGA Master System 1] En panne

Message par petitjd » 07 août 2019 19:42

Victoire!!! Ca remarche!!!
J’ai dessoudé le z80 et je me suis aperçu que j’avais encore une erreur de cablage.
J’ai remis le z80 sur un support tant qu’on y était et la console refonctionne!
Sega c’est du solide!
Bon reste à tester le port cartouche, sauf que je n’ai pas encore reçu Sonic.
A suivre...
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Avatar du membre
frodon69
Messages : 2475
Enregistré le : 24 juin 2007 10:55
Localisation : Lyon

Re: [SEGA Master System 1] En panne

Message par frodon69 » 08 août 2019 23:04

Bravo pour ta persévérance, tu peux nous faire une photo de ta réparation (pour nous inspirer au cas où) ?
Frodon69

petitjd
Messages : 1853
Enregistré le : 23 oct. 2007 11:50

Re: [SEGA Master System 1] En panne

Message par petitjd » 09 août 2019 21:46

Le port cartouche refonctionne, petit test ce soir avec Moonwalker.
Reste à tester les jeux au format carte.
Je suis heureux d’avoir sauvé cette console qui était dans un triste état.
@frodon: je mettrai une photo de ce qui se trouve en dessous du cpu, la réparation en elle même n’est qu’un sac de nouilles de soudures.
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

petitjd
Messages : 1853
Enregistré le : 23 oct. 2007 11:50

Re: [SEGA Master System 1] En panne

Message par petitjd » 10 août 2019 21:32

Voilà la photo de ce qui se trouve sous le cpu:
Image

Image en haute résolution:
http://nanoreseau.net/system-cfg/sega/s ... cpu-hr.jpg
PetitJD
Tortue Jeulin: www.tortue-jeulin.com
Nanoreseau: www.nanoreseau.net
Proteus III: www.proteus-international.fr

Répondre