Panne NES

Si vous n'avez pas trouvé de catégorie correspondante ci-dessus, regroupe les discussions plus générales et à l'occasion peut aussi abriter un fil sur les vieilles consoles de jeux.

Modérateurs : Carl, Papy.G, fneck

Répondre
Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Panne NES

Message par Falkor » 09 sept. 2018 15:17

Salut à tous,

J'ai récupéré une NES non fonctionnelle. Les premières investigations ont montré que l'alim de 5V s'effondre quand je connecte cette dernière à la carte mère, il y a donc un composant en CC quelque part. (L'alim, linéaire, montrant bien du 5V à vide).

Voici une photo de la CM :

Image

J'ai changé les 3 condos chimiques en bleu sur la photo, sans résultat. (A part celui d'avoir à priori flingué ceux de l'alim... Plus qu'à les changer aussi :cry: .).

De quel type sont les condensateurs restants ? Céramique ? Je ne vois pas de condensateurs tantale. Les céramiques sont-ils sujets au courts-circuits ?

Je préfère demander avant de me lancer dans le changement de la vingtaine de condensateurs... Il y a une majorité de 10nF et un ou deux 100 nF.

Qu'en pensez-vous ?

Daniel
Messages : 10904
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Panne NES

Message par Daniel » 09 sept. 2018 16:11

Je n'ai jamais vu de condensateur céramique en court-circuit, je ne sais pas si c'est possible.

Je commencerais par une inspection visuelle pour rechercher un court-circuit entre deux pistes (pont de soudure ou autre...). Ensuite, hors-tension, mesurer la résistance de chaque circuit intégré entre VCC et la masse. Mais sans dessouder ça ne localisera pas forcément le court-circuit. il faut alors employer d'autres moyens.

Une première technique : Utiliser une alimentation qui ne risque pas d'être endommagée par une consommation excessive, par exemple avec un limiteur d'intensité aux alentours de 500 mA. Au bout de quelques minutes le composant fautif doit être brûlant.

Une autre technique, plus violente : Utiliser une alimentation surpuissante (10 A ou plus), le composant fautif va se couper, il ne sera plus en court-circuit. Le risque est qu'il explose, ou que les pistes du circuit imprimé fassent office de fusible. Je crois que Fabien a déjà utilisé cette méthode avec succès.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 09 sept. 2018 18:37

Tu me confirmes donc que ces condensateurs sont de type céramique ?

Le précédent propriétaire m'a indiqué que la console a cessé de fonctionner pendant le jeu, j'avais pensé à un souci de condos d'alim dans un premier temps.

J'ai examiné le PCB, mais je n'ai pas trouvé de pont de soudure où autre explication mécanique au court-circuit.

J'ai une alim de labo, je vais l'utiliser pour les prochains tests. Et je vais voir au boulot si je trouve de la bombe givrante. La méthode du 10A m'effraie un peu, je vais d'abord tester l'autre méthode. :)

Avatar du membre
fneck
Site Admin
Messages : 12274
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: Panne NES

Message par fneck » 09 sept. 2018 18:46

Oui, les autres condensateurs sont des céramiques (les trucs jaunes/marrons).

gotcha
Messages : 199
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Panne NES

Message par gotcha » 10 sept. 2018 10:15

J'irais aussi voir du coté des diodes (je vois au moins D1 sur la carte mère et une plus grosse à droite). Si elles passent dans les deux sens, ça peut faire le court circuit. J'ai déjà eu des diodes défectueuses sur d'autres consoles.

D'ailleurs, as-tu utilisé un ohmmètre entre l'entrée + et la masse de la carte-mère pour valider la thèse du court circuit ?
Amstrad CPC addict :mrgreen:

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 11 sept. 2018 07:49

J'ai procédé à quelques essais hier soir... N'ayant pas de bombe givrante sous la main, j'ai emprunté une caméra thermique au boulot. :-)

Utilisation d'une alim de labo limitée en courant pour faire les essais.

Premiers essais de "mise en chauffe" sur la CM : le CPU et le PPU virent au rouge. Je coupe tout, mais constate que la température n'est que de 28° :
FLIR2691.jpg
FLIR2691.jpg (70.94 Kio) Vu 300 fois
Poursuite des essais. Je constate que le point chaud se déplace à coté des circuits, au niveau des plans de masse (?). Mais pas de surchauffe.
FLIR2697.jpg
FLIR2697.jpg (88.23 Kio) Vu 300 fois
Je pousse légèrement l'ampérage, pas d'évolution. J'ai un autre point chaud au niveau de l'endroit où je me suis repiqué sur la masse, sans doute à cause d'une soudure faite un peu trop rapidement.

J'observe malgré tout que l'alim ne chute pas... Je branche alors le connecteur auxiliaire reliant les boutons de power/reset et surtout la led témoin.

Après redémarrage, cette dernière se met à clignoter....! Un coup d'oeil au schéma montre que cette dernière est alimentée via la puce gérant la sécurité anti-copie, ce qui me laisse à penser qu'il y a un peu de vie là dedans.

J'ai donc l'impression pour conclure que la CM ne semble pas en si mauvais état que ça et que la panne de la console que je pensais être un court-circuit est probablement due à une alim défaillante (qui d'ailleurs m'a lâchée pendant les tests). En tout cas (je vais checker) mais le fait que la led clignote semble très bon signe.

Prochaine étape : trouver un câble vidéo (je n'ai pas le bon) remonter le connecteur de cartouches et faire un essai...

Pour répondre à gotcha, la résistance Vcc/Masse est de 1k9 ohms, ce qui semble confirmer l'absence de court-circuit sur la carte...! J'avais testé hier avec un autre multimètre en mode diode (avec signal sonore) mais j'ai l'impression que ce mode est défaillant... Il bipe un peu trop...?

A suivre !

gotcha
Messages : 199
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Panne NES

Message par gotcha » 11 sept. 2018 09:39

Sympa les photos du FLIR ! :D
Je pense aussi que le mieux maintenant est de trouver un câble vidéo, un jeu et un joystick de manière à tester tout ça 8)
Amstrad CPC addict :mrgreen:

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 05 nov. 2018 08:26

Suite des expérimentations... Un peu d'attente car j'avais des pistes pour me faire prêter un câble vidéo. N'ayant finalement pas eu de retour, je n'ai pas pu avancer tant que je n'avais pas reçu un câble commandé sur le net. :)

Coté électronique, changement de tout les chimiques du boîtier d'alim, pont de diodes (une liaison claquée) et le régulateur 5v. RAS, beau 5v en sortie.

Je remonte le tout sur la carte mère, clignotement led. (normal)

Mise en place d'un jeu avec câble vidéo : clignotement et écran blanc :cry:

Autre cartouche, pareil. Je google un peu et j'apprends que la puce de protection de la NES pose parfois problèmes. (Bon après mes jeux sont français...). Dans le doute je fais sauter la protection et là surprise : après quelques insertions le jeu démarre. Pareil pour ma seconde cartouche.

Je suppose donc un mauvais contact entre la cartouche et le slot. Ce dernier a reçu pourtant un bon nettoyage à l'alcool et un coup de bombe contact.

J'observe toutefois que la cartouche de jeu quand je l'insère va en butée très facilement (trop peut-être). Alors je ne sais pas trop vu le système d'insertion en biais suivi d'un verrouillage, mais contrairement aux autres machines à cartouche que je possède, je trouve que sur la NES le jeu rentre un peu trop facilement, alors que sur les autres il faut légèrement forcer.

J'ai vu sur certains forums qu'une reprise des broches pour les détordre était parfois nécessaire... voire un changement complet du système.

Qu'en pensent les utilisateurs de NES ? :?:

gotcha
Messages : 199
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Panne NES

Message par gotcha » 05 nov. 2018 08:44

Falkor a écrit :
05 nov. 2018 08:26
Je suppose donc un mauvais contact entre la cartouche et le slot. Ce dernier a reçu pourtant un bon nettoyage à l'alcool et un coup de bombe contact.
Tu l'as nettoyé comment le connecteur avec l'alcool ? Sur un autre type de console, j'avais nettoyé le connecteur au coton tige ce qui avait 'distendu' les connections métalliques du connecteur (car le coton tige est souvent trop large). Résultat: problèmes de contact ensuite et connecteur mort. Si tu y vas au coton tige, il faut bien écraser le bout avec un pince avant, de manière à avoir une largeur plus adaptée au connecteur.

Autre piste: sur une autre console aussi, certain jeux étaient tellement oxydés que j'ai du y aller au papier de verre :shock: (grain très fin)
L'alcool n' y faisait rien ...
Amstrad CPC addict :mrgreen:

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 05 nov. 2018 09:44

gotcha a écrit :
05 nov. 2018 08:44
Tu l'as nettoyé comment le connecteur avec l'alcool ?
Pour justement tenter de limiter les déformations, j’utilise une carte de fidélité de magasin sur laquelle je place une épaisseur d'un tissu fin imbibé d'alcool. Je pousse cet ensemble dans le slot et je déplace le tissu pour nettoyer les cochonneries.

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 11 nov. 2018 09:21

Suite (et fin ?) du dossier. J'ai (re)donné un coup de nettoyage aux cartouches (que je pensais avoir fait :roll:). Malgré le fait que les connecteurs semblaient propres, le coton-tige utilisé à bien retiré de la crasse. Depuis, mes deux cartouches fonctionnent sans problèmes du premier coup !

Bon après avoir refermé le bazar, je me suis rendu compte que j'ai oublié de remettre 4 vis à l'intérieur... Je suis bon pour tout ré-ouvrir :P

Merci pour vos conseils !

gotcha
Messages : 199
Enregistré le : 30 mars 2017 11:39
Localisation : Alpes (38)

Re: Panne NES

Message par gotcha » 11 nov. 2018 16:05

Super! :)

En fait, l'alcool marche plus ou moins bien selon les cartouches. En solution intermédiaire entre l'alcool et le papier de verre, il y a à priori la solution de la gomme. J'ai déjà essayé une gomme blanche sans succès. Peut-être que les gommes rose et bleues sont mieux.
Amstrad CPC addict :mrgreen:

Avatar du membre
Falkor
Messages : 649
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: Panne NES

Message par Falkor » 12 nov. 2018 15:35

Pour le nettoyage des cartouches, je commence par alcool + coton tige pour retirer la crasse. Je laisse évaporer et je pshitte un coup de bombe nettoyant contact qui laisse en plus "un film protecteur conducteur".

J'ai déjà entendu parler du coup de la gomme, a utiliser coté "bleu" (plus abrasif !!)

Répondre