[Thomson] MO5E - Préséries

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

[Thomson] MO5E - Préséries

Message par hadessuk » 01 mars 2018 02:42

Bonsoir,

J'ai fait l'achat d'un MOE5 sur eBay récemment:
https://www.ebay.fr/itm/312063238753

Je ne l'ai pas encore branché, il n'est sorti de son paquet qu'aujourd'hui, et je ne sais pas si il fonctionne. Mais j'ai vu une étiquette dessous qui lit "000006 PRESERIES".

Si je réussis à le faire fonctionner, je tenterai une dump de la ROM, comme dans le fil "MO5E bizarre":
https://forum.system-cfg.com/viewtopic.php?f=1&t=4589

Est-ce que c'est quelque chose que je peux faire avec un lecteur de cassette de MO5 "normal"? Ou mieux, avec un SDMOTO?
Voulez-vous des photos?

L'ordinateur partira bientôt à sa destination finale, chez un ami anglais, et je voudrais être sûr que la communauté ici puisse récuperer le plus d'informations possibles avant.

Comme vous avez pû le voir, je suis un peu occupé avec d'autres réparations parallèles, donc je mettrai surement un moment avant de répondre, mais n'hésitez pas.

Daniel
Messages : 10554
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] MO5E - Préséries

Message par Daniel » 01 mars 2018 11:39

C'est certainement l'un des tout premiers MO5E fabriqués. Il est bizarre qu'il ait un clavier QWERTY et pas de modulateur UHF.

Sa ROM est probablement la même que celle du MO5 QWERTY, mais la table des caractères accentués est peut-être différente. Il serait intéressant de la dumper. Avec le contrôleur CS91-280 et l'interface SDMOTO ou SDMO c'est le plus facile.

Une photo de la carte mère serait très intéressante.
Daniel
L'obstacle augmente mon ardeur.

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 17:06

Daniel a écrit :
01 mars 2018 11:39
C'est certainement l'un des tout premiers MO5E fabriqués. Il est bizarre qu'il ait un clavier QWERTY et pas de modulateur UHF.
On dirait qu'il y a un modulateur UHF, ajouté comme une carte fille, cf. la droite de la carte mère.
Daniel a écrit :
01 mars 2018 11:39
Sa ROM est probablement la même que celle du MO5 QWERTY, mais la table des caractères accentués est peut-être différente. Il serait intéressant de la dumper. Avec le contrôleur CS91-280 et l'interface SDMOTO ou SDMO c'est le plus facile.
Est-ce que tu aurais des instructions à ce propos quelque part?
Daniel a écrit :
01 mars 2018 11:39
Une photo de la carte mère serait très intéressante.
En voilà plusieurs dans les posts qui viennent.

Je les ai attachées à ce post, pour éviter qu'elles ne disparaissent, l'horreur du voyageur du futur. Des versions en taille originale sont aussi dispos sur:
https://www.dropbox.com/sh/j0lth4er2r4m ... Ak_oa?dl=0

Je vais commencer par nettoyer l'intérieur, et passer ensuite à un test, en espérant que je ne grille pas tout. Ça aurait été bien une alimentation interne séparée comme sur le TO8D :/

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 17:07

Photos, partie 1
Fichiers joints
IMG_resized_2462.JPG
IMG_resized_2462.JPG (687.97 Kio) Vu 559 fois
IMG_resized_2463.JPG
IMG_resized_2463.JPG (502.05 Kio) Vu 559 fois
IMG_resized_2464.JPG
IMG_resized_2464.JPG (633.41 Kio) Vu 559 fois
IMG_resized_2465.JPG
IMG_resized_2465.JPG (1.06 Mio) Vu 559 fois
IMG_resized_2466.JPG
IMG_resized_2466.JPG (1.06 Mio) Vu 559 fois

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 17:09

Photos, partie 2
Fichiers joints
IMG_resized_2467.JPG
IMG_resized_2467.JPG (665.85 Kio) Vu 559 fois
IMG_resized_2468.JPG
IMG_resized_2468.JPG (1.05 Mio) Vu 559 fois
IMG_resized_2469.JPG
IMG_resized_2469.JPG (1.04 Mio) Vu 559 fois
IMG_resized_2470.JPG
IMG_resized_2470.JPG (1000.55 Kio) Vu 559 fois

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 17:47

Et la face cachée de la carte mère.
Fichiers joints
IMG_resized_2471.JPG
IMG_resized_2471.JPG (1.02 Mio) Vu 554 fois
IMG_resized_2472.JPG
IMG_resized_2472.JPG (1.07 Mio) Vu 554 fois

Daniel
Messages : 10554
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] MO5E - Préséries

Message par Daniel » 14 avr. 2018 18:11

Ce MO5E de présérie, avec clavier QWERTY, connecteur Peritel et modulateur UHF, ressemble étrangement à un MO5 Export espagnol dont j'ai vu la photo récemment.

Pour dumper la ROM voir ici : http://dcmoto.free.fr/programmes/dump-rom/index.html
Daniel
L'obstacle augmente mon ardeur.

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 18:31

Daniel a écrit :
14 avr. 2018 18:11
Pour dumper la ROM voir ici : http://dcmoto.free.fr/programmes/dump-rom/index.html
Parfait. Mais ça sera pas pour tout de suite :/
Fichiers joints
IMG_2473.JPG
IMG_2473.JPG (491.37 Kio) Vu 545 fois

Daniel
Messages : 10554
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] MO5E - Préséries

Message par Daniel » 14 avr. 2018 19:11

Visiblement le processeur n'a pas démarré.
Les causes peuvent être tellement nombreuses et diverses que l'on ne peut rien dire sans tests plus précis.
Daniel
L'obstacle augmente mon ardeur.

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 19:47

Daniel a écrit :
14 avr. 2018 19:11
Visiblement le processeur n'a pas démarré.
Les causes peuvent être tellement nombreuses et diverses que l'on ne peut rien dire sans tests plus précis.
Oui, je suis en pleine recherche d'infos sur comment débugger ça.

J'aurais commencé par vérifier l'alimentation, mais comme elle n'est pas séparée et que le circuit est sur l'envers, ça rend les choses plus délicates. Et comme il n'y a pas de manuel de maintenance non plus...

Il semblerait que ça soit le même problème (écran orange, alternance orange/noir, et quelques "erreurs" ça et là) que:
https://forum.system-cfg.com/viewtopic. ... 0&p=124332

Par contre, est-ce que quelqu'un saurait me dire si les 2 chips socketés sont dans le bon sens? Ou si quelqu'un avait d'autres photos de MO5E déjà en ligne pour que je puisse le faire.

Je vais commencer par vérifier que le gate array soit bien soudé. Le circuit imprimé est énorme, et a tendance à se courber sous la pression.

Avatar du membre
fneck
Site Admin
Messages : 12105
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Thomson] MO5E - Préséries

Message par fneck » 14 avr. 2018 21:23

As-tu essayé de le démarrer plusieurs fois? J'ai déjà eu ce genre d'écran sur des MO5, et sans savoir pourquoi, la machine avait démarré au bout de quelques tentatives. Je sais que ce n'est pas très rationnel comme dépannage mais bon.... :|

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 21:36

Aprés avoir passer un peu de temps à essayer de vérifier certaines traces qui apparaissaient un peu moyenne (faudra que j'achète du vernis), je pense que je vais tenter ça.

À contrario des MO5 "normaux", le gate array est pas sur un socket, alors si il est mort, ça sera quelque chose à remplacer (et c'est pas tout à fait le même modèle que mentionné dans la doc technique du MO5v2).

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 22:15

hadessuk a écrit :
14 avr. 2018 21:36
Aprés avoir passer un peu de temps à essayer de vérifier certaines traces qui apparaissaient un peu moyenne (faudra que j'achète du vernis), je pense que je vais tenter ça.
J'ai eu des résultats légèrement différents, avec, à l'occasion, des pourtours noir, bleu proche du bleu Thomson, et jaune (plutôt que orange). J'ai testé à la fois avec des reset hard (éteindre et rallumer avec le bouton de marche-arrêt), et soft, avec le bouton reset, où je peux faire cycler les couleurs avec le bouton reset.

J'ai aussi mis du nettoyant contact dans les sockets, sans sortir les composants, mais sans succés. Je me demande si ces deux composants sont correctement montés.

Daniel
Messages : 10554
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] MO5E - Préséries

Message par Daniel » 14 avr. 2018 22:29

Les encoches du 6809 et du 6821 doivent correspondre à l'encoche de leurs supports respectifs, et/ou à la sérigraphie de la carte mère.
Tous les circuits intégrés doivent avoir la même orientation.
Daniel
L'obstacle augmente mon ardeur.

hadessuk
Messages : 126
Enregistré le : 15 déc. 2016 18:01

Re: [Thomson] MO5E - Préséries

Message par hadessuk » 14 avr. 2018 22:49

J'avais effectivement pas vu les sérigraphies sur le dessus (l'envers, vraiment) du circuit, et tout semble correspondre.

D'autres idées avant que je commande un analyseur logique? :)

Je vais sans doute faire des retouches de points de soudure demain, à tout hasard.

Répondre