[Thomson] SDDRIVE

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Carl, Papy.G, fneck

Avatar du membre
Carl
Modérateur
Messages : 10144
Enregistré le : 08 avr. 2007 13:21
Localisation : http://www.doledujura.fr
Contact :

Re: [Thomson] SDDRIVE

Message par Carl » 17 juin 2018 21:45

Désolé, j’ai été pas assez precis, effectivement, je lance le jeu depuis le sélecteur sddrive...

Carl

Avatar du membre
Silou78
Messages : 182
Enregistré le : 11 févr. 2017 14:54
Localisation : Yvelines (78)

Re: [Thomson] SDDRIVE

Message par Silou78 » 17 juin 2018 23:18

Suivant le logiciel, il y a des manières différentes de lancer les programmes. Certains effectivement ne veulent pas se lancer via basic 1.0 mais fonctionnent avec basic 512, d'autres c'est l'inverse… Et encore d'autres qui sont agnostiques au basic utilisé…

Jusqu'à présent le seul programme qui me pose problème et qui fonctionnait avec le CS91-280 (EPROM de fin 2017, je n'ai pas retesté avec EPROM de 2018), c'est la démo Space Project.
Elle se lance, la 1ère barre de progression "Loading…" va jusqu'à 100% et l'intro s'affiche bien. En revanche la 2ème barre de progression reste bloquée à 0 et aucune activité sur SDDRIVE (testé sur TO8 sans lecteur connecté, TO8D avec switch désactivant le lecteur interne, et TO9+ avec contrôleur interne désactivé par POKE).
Je me demande si le loader ne supporte pas les dernières versions d'EPROM (un peu comme TO8Demoded que je ne pouvais plus faire fonctionner sur TO8D+CS91-280 avant que Daniel ne corrige le loader après s'être arraché les cheveux :wink: )
Sylvain
Les + malins et les + chanceux sont au sommet, les autres grenouillent.
La vie est un éternel combat contre soi-même.

gti
Messages : 32
Enregistré le : 20 oct. 2013 09:09

Re: [Thomson] SDDRIVE

Message par gti » 19 juin 2018 20:44

Bonsoir,

Contrôleur bien reçu merci.

7 tests effectués

1) mo5 uc50001 (1)--> sans tripleur de nappe : Imagine, bach et cat fonctionnent sans son
--> avec tripleur et interface musique et jeu ne fonctionne pas

2) mo5 uc50001 ( 2) --> sans tripleur de nappe : Imagine, bach et cat fonctionnent sans son

3)mo5 clavier mécanique --> sans tripleur de nappe : Imagine, bach et cat fonctionnent sans son

4) mo5 platini--> sans tripleur de nappe : Imagine, bach et cat fonctionnent sans son

5) mo6-->Imagine, bach et cat fonctionnent

6) to8 (1) : Problème avec fiche si enfoncée à fond ne fonctionne pas, si jeu de 2 mm fonctionne à merveille.

7)to8 (2) : Pas de problème avec fiche, fonctionne à merveille.


Daniel, veux tu que j essaye sur d autres machines ( il me reste un to7/70, deux to7 mais j ai pas d extension memoire et deux to9 sur lesquels cela ne devrait pas fonctionner.

Cordialement...
Modifié en dernier par gti le 30 juin 2018 16:57, modifié 1 fois.

jasz
Messages : 420
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 20 juin 2018 22:16

Effectue les tests sur le plus de machines possible ;)

Attention! Sur TO7 il faut impérativement l'extension mémoire 16ko

Daniel
Messages : 10552
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 01 juil. 2018 10:17

Résultats des tests de juin 2018
Ces résultats concernent uniquement le fonctionnement de l'interface avec la carte SD.
Le lancement des applications sur disquette au format .sd est un autre sujet, il sera traité séparément.

Code : Tout sélectionner

         |T07+16|T07/70| T08  | T08D | T09+ | MO5  | MO5E | MO5NR| MO6  | PC128|
---------+------+------+------+------+------+------+------+------+------+------|                        
Daniel   |      |  OK  |  OK  |  OK  |  OK  |  OK  |      |      |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|                        
jasz     |      |  OK  |  OK  |  OK  |      |  OK  |      |  OK  |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|                        
Silou78  |      |  OK  |  OK  |  OK  |  OK  |  OK  |      |      |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|                        
Carl     |  OK  |  OK  |  OK  |  OK  |  OK  |  OK  |  OK  |      |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|                        
irios    |      |      |      |  OK  |      |  OK  |      |      |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|                        
gti      |      |      |  OK  |      |      |  OK  |      |      |  OK  |      | 
---------+------+------+------+------+------+------+------+------+------+------|

Il y a deux points à préciser :
- jasz : D'après le post du 16 juin le premier essai sur MO5 n'a pas fonctionné. Serait-il possible de le refaire, pour s'assurer qu'il n'y a pas eu une erreur de manipulation ?
- gti : Sur le premier TO8 le connecteur doit être légèrement déplacé pour que SDDRIVE fonctionne. Il peut s'agir d'une anomalie sur le bus, ou d'un mauvais contact. Il faudrait vérifier l'état de la sortie du bus, éventuellement nettoyer les pistes avec une gomme ou un produit désoxydant, et refaire un essai.
Modifié en dernier par Daniel le 02 juil. 2018 15:57, modifié 3 fois.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 420
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 01 juil. 2018 16:16

Daniel a écrit :
01 juil. 2018 10:17
D'après le post du 16 juin le premier essai sur MO5 n'a pas fonctionné. Serait-il possible de le refaire, pour s'assurer qu'il n'y a pas eu une erreur de manipulation ?
Si si, j'ai justement réédité ce post avant ton départ. Cependant les tests ne sont pas terminés de mon côté avec MO5 car je ne comprends pas pourquoi le premier refuse SDDrive et pas les deux autres et pourquoi le clavier MECA refuse la V1 et pas les autres :shock: :?:

gti
Messages : 32
Enregistré le : 20 oct. 2013 09:09

Re: [Thomson] SDDRIVE

Message par gti » 01 juil. 2018 16:49

L interface marche bien sur le premier to8, en fait cela venait d un léger décalage latérale de la cm dans le boitier. J ai due mal la remettre lorsque j ai changer les mémoires défectueuses sur ce to8. Donc tu peux considérer que c est ok pour moi sur les deux to8. Veux tu que je teste sur mon to7/70?

Guillaume

Daniel
Messages : 10552
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 01 juil. 2018 20:32

@gti : Merci pour l'explication. C'était simplement un mauvais contact. Je marque "OK" dans la case TO8. Sur TO7/70 tous les tests ont été positifs jusqu'à maintenant. A l'occasion tu pourras essayer avec le tien, mais je suis pratiquement sûr que ça va marcher.

@jasz : Tu dis qu'il faut marquer OK pour le MO5 ? Pourtant SDDRIVE ne fonctionne pas avec l'un des MO5 c'est pourquoi j'avais laissé les points d'interrogation.

Si on trouve une explication le taux de réussite sera de 100%. On peut dire que la mise au point est terminée, ce qui n'exclut pas d'autres améliorations futures.

Comme convenu les testeurs ayant reçu le contrôleur SDDRIVE tout monté peuvent me le renvoyer (je rembourse les frais d'affranchissement en lettre verte) ou le garder en échange d'une participation de 30€. Le bouton "faire un don" tout en bas de la page SDDRIVE du site dcmoto donne accès au formulaire paypal : http://dcmoto.free.fr/bricolage/sddrive/index.html
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 420
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 01 juil. 2018 21:08

Daniel a écrit :
01 juil. 2018 20:32
@jasz : Tu dis qu'il faut marquer OK pour le MO5 ? Pourtant SDDRIVE ne fonctionne pas avec l'un des MO5 c'est pourquoi j'avais laissé les points d'interrogation.
V2. Oui en effet mais il faut que je retrouve son frère pour voir ça d'un peu plus près car en toute franchise ça me turlupine :roll:
Je donnerais mon compte rendu ci courant :wink:

Daniel
Messages : 10552
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 02 juil. 2018 11:27

Silou78 a écrit :
17 juin 2018 23:18
Jusqu'à présent le seul programme qui me pose problème et qui fonctionnait avec le CS91-280 (EPROM de fin 2017, je n'ai pas retesté avec EPROM de 2018), c'est la démo Space Project.
Elle se lance, la 1ère barre de progression "Loading…" va jusqu'à 100% et l'intro s'affiche bien. En revanche la 2ème barre de progression reste bloquée à 0 et aucune activité sur SDDRIVE (testé sur TO8 sans lecteur connecté, TO8D avec switch désactivant le lecteur interne, et TO9+ avec contrôleur interne désactivé par POKE).
J'ai testé avec l'émulateur dcmoto, le comportement est identique. A noter qu'en appuyant sur la barre d'espace pendant l'intro (avant le début de la musique), le deuxième programme se charge bien. Si on laisse l'intro se dérouler entièrement le deuxième programme ne se charge pas.

Donc c'est un problème purement soft : écrasement de pile (comme to8-demoded) ou appel direct au contrôleur, ou autre. Je vais chercher une parade. Parallèlement je prépare une documentation donnant toutes les procédures de lancement des applications sur disquette au format .sd, pour faciliter l'utilisation du système.
Daniel
L'obstacle augmente mon ardeur.

jasz
Messages : 420
Enregistré le : 05 oct. 2016 20:05
Localisation : Quelque part dans le 31

Re: [Thomson] SDDRIVE

Message par jasz » 02 juil. 2018 13:08

Daniel a écrit :
01 juil. 2018 20:32
@jasz : Tu dis qu'il faut marquer OK pour le MO5 ?
Tu peux oui. Je viens de reprendre les tests et tous mes MO5 réagissent comme il faut à SDD2. Y compris le premier (sans doute une erreur de ma part). Donc 100% de mon côté. Sur MO6 aussi :D

Daniel
Messages : 10552
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 02 juil. 2018 15:54

Résultats définitifs des tests :
100% de réussite sur une cinquantaine de tests par six testeurs sur des machines différentes.

Merci à tous les testeurs 8)
Le schéma actuel est validé, et la diffusion de SDDRIVE pourra reprendre dans quelques jours.

Par ailleurs le souci dans Space Project est identifié : écrasement de zones de travail de SDDRIVE par la pile système. Cette anomalie est corrigée par une nouvelle version de l'EPROM, elle est en cours de test et sera bientôt disponible.

Rappel aux testeurs : le contrôleur de test peut être renvoyé sans frais, ou gardé en échange d'une participation de 30 €.
Daniel
L'obstacle augmente mon ardeur.

gti
Messages : 32
Enregistré le : 20 oct. 2013 09:09

Re: [Thomson] SDDRIVE

Message par gti » 02 juil. 2018 19:56

Bonsoir,

Don fait avec un petit plus pour les différents frais.

Cordialement

Guillaume

Daniel
Messages : 10552
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: [Thomson] SDDRIVE

Message par Daniel » 02 juil. 2018 20:26

@gti : Merci beaucoup ! Le petit plus n'était pas nécessaire, je ne fais pas ces bricolages pour gagner des sous. Pour te remercier je t'enverrai la prochaine version de l'EPROM lorsqu'elle sera opérationnelle, dans quelques semaines.
Daniel
L'obstacle augmente mon ardeur.

Giants
Messages : 24
Enregistré le : 19 avr. 2011 11:44

Re: [Thomson] SDDRIVE

Message par Giants » 03 juil. 2018 12:25

Daniel a écrit :
02 juil. 2018 15:54
Résultats définitifs des tests :
100% de réussite sur une cinquantaine de tests par six testeurs sur des machines différentes.
Super !
Tu as déjà commencé les pré-commandes ? Si c'est le cas, il m'en faudrait une.
merci
(¯`·.¸¸¸¸.·´¯`·.¸¸Fondateur¸¸.·´¯`·.¸¸¸.·´¯)
( AmigaMOD - Ordinosaure - CPC-Hardware )
(
CPC300DPI - Abandon-Pub )
¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

http://sasfepu78.fr

Répondre