Thomson TO8 - bad video output

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

Répondre
Avatar de l’utilisateur
TrainingForUtopia
Messages : 141
Inscription : 12 mai 2015 04:44

Thomson TO8 - bad video output

Message par TrainingForUtopia »

Got a TO8 some days ago and i wonder, what could be wrong with this one.

The power LED is on, but i only get a bad video output.

I tried some different scart leads, but the problem is always the same.

I've added a short video. I've some TO8 parts for spare, so i can try some things. What could be wrong?

Thanks in advance.

https://streamable.com/5y5n5
Avatar de l’utilisateur
gilles
Messages : 2230
Inscription : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Thomson TO8 - bad video output

Message par gilles »

Let's start with the worst case : unstable image can be a bad gate array...

But I also had the same symptom with a very simple problem : a missing or broken main oscillator (the 16MHz one, not the other that is just for keyboard controler).

So check your clock signal with an oscilloscope (you can check on the pin34&35 of CPU respectively E and Q).
Avatar de l’utilisateur
TrainingForUtopia
Messages : 141
Inscription : 12 mai 2015 04:44

Re: Thomson TO8 - bad video output

Message par TrainingForUtopia »

Thanks, but i don't have an osci, so i have to find alternative & more ordinary ways to solve this problem.
Avatar de l’utilisateur
hlide
Messages : 2033
Inscription : 29 nov. 2017 10:23

Re: Thomson TO8 - bad video output

Message par hlide »

Or to buy a "cheap" USB oscilloscope that you can connect on a PC - for instance, an Hantek 6022BE (2 analog channels, 16 logical channels) which can be found around €60. BE, not BL. Or a standalone DSO138 with its LCD and 1 analog channel as cheaper but more limited solution.
Avatar de l’utilisateur
TrainingForUtopia
Messages : 141
Inscription : 12 mai 2015 04:44

Re: Thomson TO8 - bad video output

Message par TrainingForUtopia »

I would prefer other methods, but thanks anyway. I never used oscis in the past and i don't want to use one now or in the future.

I'll replace the 16MHz with a new one to check, if this solves the problem. I'll check other things too and report, when i solved the Problem. Hey, i revived a completely messed up Acorn A3000 without an osci, so this problem should be solved easily. I only asked, 'cause i don't know the Thomson internals that much. I think, i've to check some shematics first.
Avatar de l’utilisateur
gilles
Messages : 2230
Inscription : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: Thomson TO8 - bad video output

Message par gilles »

Make it your own style but to me an oscilloscope (I use a very old one, probably older than the to8) is just a way to see what happens instead of just guessing. It saves a lot of time.
Avatar de l’utilisateur
hlide
Messages : 2033
Inscription : 29 nov. 2017 10:23

Re: Thomson TO8 - bad video output

Message par hlide »

I agree with Gilles. I had to buy a DSO138 to make improvement with SDLEP-reader, especially when I need to mod its hardware and software to check the signals: it makes things easier and faster. Later, I also decided to buy an Hantek so I can have a better sight of signals in the long run.
Daniel
Messages : 13384
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: Thomson TO8 - bad video output

Message par Daniel »

I agree too. In addition repairing a TO7/70 is not as easy as you can believe without good skills and good equipment.
Daniel
L'obstacle augmente mon ardeur.
Avatar de l’utilisateur
TrainingForUtopia
Messages : 141
Inscription : 12 mai 2015 04:44

Re: Thomson TO8 - bad video output

Message par TrainingForUtopia »

Well, i only wanted to know, what COULD cause this screen. Some screens should be usually 'caused by common faulty ics.

Received infos so far:

- the 16MHz Oscillator
- Gate-Array

My thoughts:

- RAM?
- CPU?
- one of the 3 ROMs?

And i'm after some old Hamegs, so you don't have to bother me with such suggestions anymore :wink: :wink: :wink:
Avatar de l’utilisateur
TrainingForUtopia
Messages : 141
Inscription : 12 mai 2015 04:44

Re: Thomson TO8 - bad video output

Message par TrainingForUtopia »

Replaced the 16Mhz Osci und the ROMs... the same problem.
Répondre