TO7 écran accueil bugué

C'est la catégorie reine de l'ordinophile, 8 bits et pas un de plus!
Single board ou bus S-100 acceptés.

Modérateurs : Carl, Papy.G, fneck

Répondre
duduche87
Messages : 5
Enregistré le : 21 déc. 2018 12:10

TO7 écran accueil bugué

Message par duduche87 » 14 avr. 2019 17:44

Bonjour,

L'écran d'accueil du T07 est bugué. Une solution est-elle possible afin de le sauver ?

Merci. Cordialement.
Fichiers joints
TO7.jpg
TO7.jpg (949.41 Kio) Vu 232 fois

Daniel
Messages : 11606
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: TO7 écran accueil bugué

Message par Daniel » 14 avr. 2019 18:03

Comme d'autres fils de discussion l'ont montré, la RAM des TO7 est fragile, tombe souvent en panne et peut expliquer cet affichage.
Sinon il y a aussi beaucoup d'autres causes possibles, en particulier la défaillance d'un circuit logique TTL.
Avant toute intervention, il faut être sûr d'avoir les bonnes tensions d'alimentation, donc commencer par les mesurer.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
fneck
Site Admin
Messages : 12705
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: TO7 écran accueil bugué

Message par fneck » 14 avr. 2019 18:27

Dans le cas présent peut-être aussi vérifier la propreté des contacts de la cartouche (si une cartouche est insérée bien sûr).

Daniel
Messages : 11606
Enregistré le : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: TO7 écran accueil bugué

Message par Daniel » 14 avr. 2019 18:46

Bonne remarque ! Il y a une solution simple pour vérifier si le problème vient de la cartouche BASIC : démarrer sans cartouche. Si on a le même écran la cartouche est hors de cause.
Daniel
L'obstacle augmente mon ardeur.

Avatar du membre
gilles
Messages : 1754
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: TO7 écran accueil bugué

Message par gilles » 14 avr. 2019 19:02

On peut déjà se dire que la ram video forme et couleur sont ok, le cpu aussi car il va assez loin il lit donc la partie rom du 6846. Il semble ne pas aller lire la police de caractere correctement mais possible qu’il se soit planté qq part. La ram non video est une possibilité dans tous les cas la panne ne semble pas tres grave, je suis assez confiant sur le fait qu’il puisse être remis en route.

duduche87
Messages : 5
Enregistré le : 21 déc. 2018 12:10

Re: TO7 écran accueil bugué

Message par duduche87 » 14 avr. 2019 20:56

Ok merci. Je regarde de ce coté. (Pas de cartouche)

Avatar du membre
gilles
Messages : 1754
Enregistré le : 07 août 2008 13:44
Localisation : Nantes
Contact :

Re: TO7 écran accueil bugué

Message par gilles » 14 avr. 2019 22:04

Le to7 a 6ko de rom interne mais en fait il y en a 2k dans le 6846 et 4ko dans une eprom. Il faudrait chercher de ce coté là, plutot sur les ttl de decodage d’adresse.

duduche87
Messages : 5
Enregistré le : 21 déc. 2018 12:10

Re: TO7 écran accueil bugué

Message par duduche87 » 27 avr. 2019 16:43

Bon apparemment ce devait être l'eprom, j'ai retiré tout les CI et je les ai remis à leur place et tout est revenu dans l'ordre enfin presque, le haut du clavier gauche ne fonctionne pas donc pas de lancement de cartouche pour l’instant.
Merci.

Avatar du membre
Falkor
Messages : 813
Enregistré le : 28 juin 2010 12:09
Localisation : Cluny, Saône et Loire

Re: TO7 écran accueil bugué

Message par Falkor » 27 avr. 2019 18:29

Pour le souci de clavier, voir le tuto proposé par Daniel : http://dcmoto.free.fr/bricolage/clavier ... index.html

duduche87
Messages : 5
Enregistré le : 21 déc. 2018 12:10

Re: TO7 écran accueil bugué

Message par duduche87 » 27 avr. 2019 18:33

Une piste de la nappe est oxydé (le bas au contact est inexistant), j'ai mis un fil pour tester ça marche. je commande un stylo à encre conductrice pour refaire ça proprement. Merci.

Répondre