SDLEP-READER MO5 : problème de chargement !

Placez ici vos trucs et astuces, étalez sans retenue votre savoir-faire et votre science qui va nous permettre de redonner une apparence neuve et fonctionnelle à nos bouzes.

Modérateurs : Papy.G, fneck, Carl

p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Bonjour,

Mon "burgerelp" alias SDLEP-READER fonctionne très bien sur zx81.
Je voulais le faire tourner sur mon TO9 avec S D L E P - T F T - 2 0 2 2 de Daniel mais impossible.
Je me suis dit, vu les caractéristiques du to9 qu'il fallait peut être commencer par un mo5, mais cela ne fonctionne pas.
je prends saphir lep mo5 loadm"cass:", le démarrage moteur est bien détecté par l'arduino.
Il lit bien le fichier et semble envoyer quelque chose au mo5 (j'ai des tensions sur TX), et la led clignotte assez vite.
Le mo5 de son côté semble rester sur "Searching" pour toujours comme freezé.

Pour le montage de la din je me suis inspiré du schémas "côté soudure".
Image

Je ne sais plus trop quoi tester ni comment, j'ai revérifié le cablage, les pins utilisées dans le programme (A5 pour la led et D0 & D1 pour rx tx).

Si vous avez des pistes à vérifier je suis preneur !

merci d'avance,

p0ke
Daniel
Messages : 15441
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: SDLEP-READER MO5 : problème de chargement !

Message par Daniel »

Le diagnostic à distance n'est pas facile.
Je commencerais par bien vérifier le câblage, en particulier la continuité entre la sortie des données de l'Arduino (TX) et l'entrée du 6821 (PA7 broche 9).
Dernière modification par Daniel le 30 juin 2022 13:26, modifié 1 fois.
Daniel
L'obstacle augmente mon ardeur.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Lorsque tout est cablé, en dénudant la fiche DIN,
sur la pin motor j'ai environ 4.5v qui tombe au démarrage de la commande LOADM (normal).
Par contre sur Data in je suis à 4.4v même après démarrage.
Cela me paraît beaucoup non ?
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Est-ce que le curseur doit clignoter pendant le chargement de la cassette sur MO5 via le SDLEP READER ?
Daniel
Messages : 15441
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: SDLEP-READER MO5 : problème de chargement !

Message par Daniel »

Pendant le chargement d'une cassette, le clignotement du curseur est aléatoire. Il peut parfois apparaître ou disparaître mais jamais de façon régulière. Le clignotement du curseur est piloté par les interruptions, et la lecture de la cassette masque les interruptions, ce qui explique ce phénomène. Entre deux lectures de fichiers, si l'intervalle est assez long, le curseur peut changer d'état.

La lecture de la cassette par l'Arduino est indiquée par la diode d'activité.
Extrait de la documentation :
... [la diode d'activité] reste éteinte jusqu'au chargement d'un programme.

Pendant le chargement, elle clignote au rythme des transferts de données. Si l'ordinateur cherche à lire après la fin du fichier, la LED émet un flash toutes les deux secondes pour signaler l'erreur "lecture après la fin de la cassette".
Je répète mon conseil :
Je commencerais par bien vérifier le câblage, en particulier la continuité entre la sortie des données de l'Arduino (TX) et l'entrée du 6821 (PA7 broche 9).
Autre moyen pour savoir si le MO5 reçoit des données : Sur la fiche DIN connectée au port magnétophone, relier les broches 3 (Entrée de la voie audio) et 4 (Entrée des données). Si l'Arduino envoie des données le MO5 émettra le son caractéristique de la piste de données.
Dernière modification par Daniel le 30 juin 2022 13:26, modifié 1 fois.
Daniel
L'obstacle augmente mon ardeur.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

En fait j'ai branché l'arduino sur l'usb A à mon PC et scruté le moniteur du port série et je vois bien passer des datas.
(mais je ne manquerais pas de passer la broche 3 dessus j'adore le bruit du lecteur de cassettet).
J'ai aussi refais le cablage de la fiche DIN. Je n'ai mis QUE le moteur et data in.
Après plusieurs tentative j'ai eu un "LOADEUR!" en chargeant le lep de sorcery.
Mais cela ne va pas plus loin. A la fin l'arduino redémarre et il ne se passe rien.

Je remarque un comportement différent quand je branche l'arduino sur un powerbank via l'USB A, le moteur n'est pas détecté.
Alors que si je le branche sur un PC, il est détecté.

Je me demande si rx&tx ne sont pas parasité par l'utilisation du cable usb.
J'essayerais de me plugger sur le raw pour voir.

Je note aussi que l'arduino doit être booté avant le mo5 (je crois qu'on me le disait déjà au collège ça!!!)

Merci Daniel pour les pistes ça m'aide bien.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Je viens d'essayer avec saphir, et pareil, j'ai un début de changement d'écran, on voit qu'il trouve un fichier Mais après plus rien.

Est-ce obligatoire de brancher l'arduino sur le 12v du mo5 ?
Daniel
Messages : 15441
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: SDLEP-READER MO5 : problème de chargement !

Message par Daniel »

p0ke a écrit : 29 juin 2022 16:22 J'ai aussi refais le cablage de la fiche DIN. Je n'ai mis QUE le moteur et data in.
Et la masse ? Sans masse il n'y a aucune chance de lire les données.

Pour l'alimentation de l'Arduino, le plus naturel et le plus simple est de connecter VCC au +5V du MO5, par exemple sur le connecteur du crayon optique.

Sinon on peut utiliser une source extérieure entre 7V et 12V à connecter sur l'entrée RAW de l'Arduino. Il vaut mieux éviter 12V car c'est l'extrême limite pour le régulateur. Il est préférable de rester au-dessous, par exemple 9V. Il ne faut pas que l'alimentation génère des parasites pouvant perturber la transmission.

Il vaut mieux éviter d'utiliser le 12V du MO5 car les premiers modèles n'en disposaient pas et ne pourraient donc pas alimenter l'Arduino.
Daniel
L'obstacle augmente mon ardeur.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Ah en fait je pensais naivement que, comme j'alimentais par l'extérieur, je n'avais pas besoin de cabler la masse + le 12v.

J'ai testé avec la broche 3 pour sortir le son, j'ai bien du son, mais c'est très très faible.
Daniel
Messages : 15441
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: SDLEP-READER MO5 : problème de chargement !

Message par Daniel »

Si on pouvait transporter l'énergie électrique avec un seul fil, l'EDF économiserait des milliards d'euros sur le cuivre. Malheureusement c'est impossible.
Il suffit donc de connecter la masse et le montage fonctionnera.
Daniel
L'obstacle augmente mon ardeur.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

hahahaha, non mais Daniel, il est alimenté par un powerbank l'arduino, il n'a pas besoin de l'alim du mo5.
C'est pour ça que je n'ai pas câblé la masse dessus en fait.
Sinon pour EDF Tesla avait prévu la livraison d'électricité sans fil mais le lobby du pétrole ne l'a pas laissé faire !
__sam__
Messages : 6795
Inscription : 18 sept. 2010 12:08
Localisation : Brest et parfois les Flandres

Re: SDLEP-READER MO5 : problème de chargement !

Message par __sam__ »

Heu... je pige pas. Il faut que l'arduino, le mo5 et la powerbank aient la même référence 0v (masse ou commun) pour que ca marche. Donc si tu n'as branché qu'un seul fil +12v, et laissé le 0V flottant, ca ne marchera pas bien: le 0v ne sera pas le même entre toutes les portions du circuit et les tensions stables deviennent fluctuantes.

C'est d'une évidence que même moi je pige. Du coup je ne pige pas ta réponse p0ke. Il y a quelque chose de pas cohérent dans ce que je comprends de ce que tu dis. Ce sont les limites du langage naturel. Ne pourrais-tu pas poster un petit schéma de principe du montage pour voir si on comprends bien ce que tu as fais ?
Samuel.
A500 Vampire V2+ ^8^, A1200 (030@50mhz/fpu/64mb/cf 8go),
A500 GVP530(MMU/FPU) h.s., R-Pi, TO9, TO8D, TO8.Démos
Daniel
Messages : 15441
Inscription : 01 mai 2007 18:30
Localisation : Vaucluse
Contact :

Re: SDLEP-READER MO5 : problème de chargement !

Message par Daniel »

p0ke n'a pas compris que la règle des deux fils pour le transport de l'énergie électrique ne s'applique pas seulement à l'alimentation, mais aussi au signal audio du magnétophone ou de SDLEP READER. Il est vrai que c'est tellement évident qu'on oublie de le signaler.
J'espère que maintenant, avec la masse connectée, tout fonctionne bien.

Et je ne vois pas l'intérêt d'utiliser une batterie externe alors que le MO5 fournit directement le 5V par le connecteur du crayon optique. Je crois que le schéma de câblage donné dans la documentation est clair :

cable.png
cable.png (3.59 Kio) Consulté 557 fois
Daniel
L'obstacle augmente mon ardeur.
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

Cette fois n'ayant plus aucun résultat sur le mo5, je suis repassé sur le TO9.
Le son ressemble pas du tout au lecteur de cassette que je connais. Au lieu d'avoir des bips stridents, là j'ai plutôt un crachin.
J'ai connecté la masse de la prise din à l'arduino même si je suis alimenté par le port USB de l'arduino.
L'USB est branché directement à l'ordinateur (qui fournit souvent un meilleurs 5v, plus stable, que certaines sources).
J'ai lancé saphir version TO7, à la fin j'ai eu le jeu complet sans problème :D
Incroyable !! :P
Le son du lecteur de cassette est plus fort et plus soutenu, alors que sur mo5 il avait l'air très affaibli :(.
Je pencherais vraiment pour un problème de câble, peut être pas assez de bonne qualité.

Je vais concentrer mes efforts sur cet aspect, et ressortir ma pince à sertir dupont !!!!

Autres pistes peut être aussi Il y a peut être des parasites liés à mon horrible burger lep !
p0ke
Messages : 153
Inscription : 20 mai 2018 20:29

Re: SDLEP-READER MO5 : problème de chargement !

Message par p0ke »

ça ressemble à ça grosso modo :
lepreader.png
lepreader.png (18.71 Kio) Consulté 543 fois
Répondre