[Apple II] ADTPro - Tester une liaison série

Tout ce qui concerne le logiciel original et sa sauvegarde avec entre autre la régénération des disquettes ou autres supports physiques.

Modérateurs : Carl, Papy.G, fneck

Répondre
Avatar du membre
fneck
Site Admin
Messages : 12781
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

[Apple II] ADTPro - Tester une liaison série

Message par fneck » 28 févr. 2011 18:42

En complément du tuto sur l'utilisation d'ADTPro, j'ai profité d'une journée de congés pour faire des essais avec un Apple IIe et deux cartes séries.

Les cartes utilisées sont d'une part une Apple Serial Interface Card:
Image

... et d'autre part une MID S2 (dont je n'ai pas la documentation):
Image

Comme je le craignais, ADTPro ne fonctionne pas avec ces cartes ou bien je n'ai pas réussi à les faire fonctionner? La documentation d'ADTPro est assez vague la dessus, elle dit que ça fonctionne avec une Super Sérial Card et rien d'autre... ah si, que ça peut fonctionner avec une autre, mais sans plus.
Miscellaneous serial devices that do not otherwise have direct support may work with the "GENERIC SLOT 2" setting
Bref, en attendant j'ai quand même fait des essais qui permettent de valider le bon fonctionnement du câble et le fait qu'il faille en prendre un croisé (null-modem) ou non. Ceci permet au moins en cas de dysfonctionnement d'ADTPro de tester son matériel afin de le dédouaner ou justement de l'incriminer. Pour cela il faut simplement utiliser un émulateur de Terminal sur le PC (ou Mac si vous préférez) genre Terminal, Hyper Terminal ou Tera Term (je viens de le découvrir celui-là, il a l'air très puissant). Une fois les paramètres de communication réglés sur la carte Apple et placés à l'identique dans l'émulateur on peut démarrer.

Après le boot sur l'écran de l'Apple IIe faire <CTRL><RESET> pour calmer le drive (celui-ci n'est pas nécessaire, il n'y a pas besoin de DOS) puis tapez IN#2 (sachant que le 2 est fonction du slot dans lequel se trouve la carte et que le # se trouve sur la touche £ du clavier AZERTY):
Image

Sur le PC établir la connexion avec le port COM correspondant et tout ce qui est tapé sur ce dernier doit apparaître sur l'écran de l'Apple II:
Image
Le PRINT I <ENTER> ci-dessus a bien été tapé sur le PC.

On peut aller plus loin en redirigeant la sortie de l'Apple vers la carte série à l'aide de la commande PR#2 cette fois:
Image
Et maintenant on se retrouve avec le résultat de l'opération sur l'écran du terminal. En jouant avec l'option "Echo local" de l'émulateur on arrive à piloter l'Apple II complètement à distance.

Ah oui, une information quand même, avec les deux cartes séries Apple Serial Interface Card et MID S2 il faut utiliser un câble droit pour ces différentes opérations.

Avatar du membre
Stigma
Messages : 44
Enregistré le : 05 févr. 2010 16:38
Localisation : Oise
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par Stigma » 01 mars 2011 07:24

On avance on avance, mais on a pas assez d'essence (Alain Souchon) :)
Si tu es incinéré, ce sera ta dernière cuite.
Si tu es enterré, tu as encore une chance d'avoir un dernier ver dans le nez.

Avatar du membre
Stigma
Messages : 44
Enregistré le : 05 févr. 2010 16:38
Localisation : Oise
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par Stigma » 02 mars 2011 18:47

Je n'ai jamais utilisé Hyper Terminal. J'ai installé HyperTerm mais rien ne s'affiche dans la fenêtre sur le PC quand je tape sur le clavier. Pareil avec Hyperterminal.
Si tu es incinéré, ce sera ta dernière cuite.
Si tu es enterré, tu as encore une chance d'avoir un dernier ver dans le nez.

Avatar du membre
fneck
Site Admin
Messages : 12781
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par fneck » 02 mars 2011 23:09

C'est normal, si dans les paramètres de la connexion tu n'as pas validé le mode "Echo local", car par défaut un terminal affiche uniquement les caractères qui viennent du périphérique distant.

Pour HyperTerminal c'est l'option "Echo typed characters locally" :

Image

Avatar du membre
Stigma
Messages : 44
Enregistré le : 05 févr. 2010 16:38
Localisation : Oise
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par Stigma » 04 mars 2011 19:35

rien ne s'affiche sur l'Apple :(
Si tu es incinéré, ce sera ta dernière cuite.
Si tu es enterré, tu as encore une chance d'avoir un dernier ver dans le nez.

Avatar du membre
fneck
Site Admin
Messages : 12781
Enregistré le : 01 avr. 2007 12:03
Localisation : Drôme Provençale (26)
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par fneck » 06 mars 2011 09:05

Ca signifie, soit que ton câble n'est pas bon, soit que la carte dans l'Apple ne fonctionne pas, soit que la configuration logicielle (ou switch sur la carte) n'est pas bonne.

Avatar du membre
Stigma
Messages : 44
Enregistré le : 05 févr. 2010 16:38
Localisation : Oise
Contact :

Re: [Apple II] ADTPro - Tester une liaison série

Message par Stigma » 06 mars 2011 17:32

Mon câble est comme celui que tu m'avais conseillé dans ce post. http://forum.system-cfg.com/viewtopic.p ... 8&start=30
Quand à la carte, c'est celle avec laquelle je pilote l'imprimante. Donc elle est bonne à priori. Bien sûr je la configure différemment suivant une liaison série ou imprimante.
Je suis en 300 bauds des 2 côtés.
Si tu es incinéré, ce sera ta dernière cuite.
Si tu es enterré, tu as encore une chance d'avoir un dernier ver dans le nez.

Répondre